Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[banshee] ne se lance pas complètement
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Pixys
l33t
l33t


Joined: 23 May 2005
Posts: 669

PostPosted: Mon Feb 16, 2009 9:54 pm    Post subject: [banshee] ne se lance pas complètement Reply with quote

Bonsoir,
j'ai installé banshee avec ces flags sur une ~AMD64 :
Code:
media-sound/banshee-1.4.2  USE="aac encode flac ipod mad podcast vorbis -boo -daap -doc -mtp -test"

mais il ne se lance pas complètement.
En console en root j'ai ceci :
Code:
localhost pixys # banshee-1

Unhandled Exception: System.Exception: Unable to open the session message bus. ---> System.Exception: Relais brisé (pipe)
  at NDesk.DBus.Transports.UnixSocket.Write (System.Byte[] buf, Int32 offset, Int32 count) [0x00000]
  at NDesk.DBus.Transports.UnixStream.Write (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000]
  at NDesk.DBus.Connection.WriteMessage (NDesk.DBus.Message msg) [0x00000]
  at NDesk.DBus.Connection.SendWithReply (NDesk.DBus.Message msg) [0x00000]
  at NDesk.DBus.Connection.SendWithReplyAndBlock (NDesk.DBus.Message msg) [0x00000]
  at NDesk.DBus.BusObject.SendMethodCall (System.String iface, System.String member, System.String inSigStr, NDesk.DBus.MessageWriter writer, System.Type retType, System.Exception& exception) [0x00000]
  at IBusProxy.Hello () [0x00000]
  at NDesk.DBus.Bus.Register () [0x00000]
  at NDesk.DBus.Bus..ctor (System.String address) [0x00000]
  at NDesk.DBus.Bus.Open (System.String address) [0x00000]
  at NDesk.DBus.Bus.get_Session () [0x00000]
  --- End of inner exception stack trace ---
  at NDesk.DBus.Bus.get_Session () [0x00000]
  at Banshee.ServiceStack.DBusConnection.get_ApplicationInstanceAlreadyRunning () [0x00000]
  at Booter.Booter.Main () [0x00000]

et en user j'ai ça :
Code:
pixys@localhost ~ $ banshee-1

Unhandled Exception: System.Exception: org.freedesktop.DBus.Error.UnknownMethod: Method "Present" with signature "" on interface "org.bansheeproject.Banshee.ClientWindow" doesn't exist
  at IClientWindowProxy.Present () [0x00000]
  at Halie.Client.HandleWindowCommands (Boolean present) [0x00000]
  at Halie.Client.Main () [0x00000]
  at (wrapper managed-to-native) System.AppDomain:ExecuteAssembly (System.Reflection.Assembly,string[])
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly a, System.String[] args) [0x00000]
  at System.AppDomain.ExecuteAssembly (System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args) [0x00000]
  at (wrapper remoting-invoke-with-check) System.AppDomain:ExecuteAssembly (string,System.Security.Policy.Evidence,string[])
  at System.AppDomain.ExecuteAssembly (System.String assemblyFile) [0x00000]
  at (wrapper remoting-invoke-with-check) System.AppDomain:ExecuteAssembly (string)
  at Booter.Booter.BootClient (System.String clientName) [0x00000]
  at Booter.Booter.Main () [0x00000]

l'emerge c'est passé sans problème
j'ai cherché sur le forum principal mais je n'ai rien trouvé de très concluant...
si vous aviez une piste.
merci
Back to top
View user's profile Send private message
Pierre.R
n00b
n00b


Joined: 06 Aug 2012
Posts: 2

PostPosted: Mon Aug 06, 2012 9:41 am    Post subject: Reply with quote

J'ai le même bug de mon côté avec Banshee 2.4.1 (l'erreur se manifestait aussi avec le 2.2.x) , la trace complète:
Code:

[pounard@guinevere] ~
 >  banshee

Unhandled Exception: System.Exception: org.freedesktop.DBus.Error.UnknownMethod: Method "Present" with signature "" on interface "org.bansheeproject.Banshee.ClientWindow" doesn't exist
  at Halie.Client+IClientWindowProxy.Present () [0x00000] in <filename unknown>:0
  at Halie.Client.HandleWindowCommands (Boolean present) [0x00000] in <filename unknown>:0
  at Halie.Client.Main () [0x00000] in <filename unknown>:0
  at (wrapper managed-to-native) System.AppDomain:ExecuteAssembly (System.AppDomain,System.Reflection.Assembly,string[])
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly a, System.String[] args) [0x00000] in <filename unknown>:0
  at System.AppDomain.ExecuteAssembly (System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.AppDomain:ExecuteAssembly (string,System.Security.Policy.Evidence,string[])
  at System.AppDomain.ExecuteAssembly (System.String assemblyFile) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.AppDomain:ExecuteAssembly (string)
  at Booter.Booter.BootClient (System.String clientName) [0x00000] in <filename unknown>:0
  at Booter.Booter.Main () [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.Exception: org.freedesktop.DBus.Error.UnknownMethod: Method "Present" with signature "" on interface "org.bansheeproject.Banshee.ClientWindow" doesn't exist
  at Halie.Client+IClientWindowProxy.Present () [0x00000] in <filename unknown>:0
  at Halie.Client.HandleWindowCommands (Boolean present) [0x00000] in <filename unknown>:0
  at Halie.Client.Main () [0x00000] in <filename unknown>:0
  at (wrapper managed-to-native) System.AppDomain:ExecuteAssembly (System.AppDomain,System.Reflection.Assembly,string[])
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly a, System.String[] args) [0x00000] in <filename unknown>:0
  at System.AppDomain.ExecuteAssembly (System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.AppDomain:ExecuteAssembly (string,System.Security.Policy.Evidence,string[])
  at System.AppDomain.ExecuteAssembly (System.String assemblyFile) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.AppDomain:ExecuteAssembly (string)
  at Booter.Booter.BootClient (System.String clientName) [0x00000] in <filename unknown>:0
  at Booter.Booter.Main () [0x00000] in <filename unknown>:0
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3322
Location: Paris - France

PostPosted: Mon Aug 06, 2012 1:02 pm    Post subject: Reply with quote

Ça c'est du déterrage de sujet :lol:

dbus est bien lancé au démarrage ? => rc-update add dbus default
Ta session X démarre bien une session dbus pour ton utilisateur ? quel environnement graphique ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum