Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed Patch: 65_all_binutils-2.20-amd64-32bit-path.patch
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
zasdfgbnm
n00b
n00b


Joined: 06 Apr 2012
Posts: 43

PostPosted: Sat Jul 28, 2012 2:26 am    Post subject: Failed Patch: 65_all_binutils-2.20-amd64-32bit-path.patch Reply with quote

I'm using ACCEPT_KEYWORDS="~amd64". I got the error while updating system:
Code:
>>> Emerging (1 of 77) sys-devel/binutils-2.22.90
 * binutils-2.22.90.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...         [ ok ]
 * binutils-2.22.90-patches-1.0.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...  [ ok ]
>>> Unpacking source...
>>> Unpacking binutils-2.22.90.tar.bz2 to /var/tmp/portage/sys-devel/binutils-2.22.90/work
>>> Unpacking binutils-2.22.90-patches-1.0.tar.xz to /var/tmp/portage/sys-devel/binutils-2.22.90/work
 * Applying various patches (bugfixes/updates) ...
 *   03_all_binutils-2.15.92.0.2-ppc64-pie.patch ...                     [ ok ]
 *   08_all_binutils-RPATH_ENVVAR-smack.patch ...                        [ ok ]
 *   12_all_sh-targets.patch ...                                         [ ok ]
 *   20_all_ld-sysroot.patch ...                                         [ ok ]
 *   30_all_binutils-2.22.52.0.2-flexible-tests.patch ...                [ ok ]
 *   62_all_binutils-2.22-hardened-crtbegin.patch ...                    [ ok ]
 *   63_all_binutils-2.22.90-pt-pax-flags-20120727.patch ...             [ ok ]
 *   65_all_binutils-2.20-amd64-32bit-path.patch ...

 * Failed Patch: 65_all_binutils-2.20-amd64-32bit-path.patch !
 *  ( /var/tmp/portage/sys-devel/binutils-2.22.90/work/patch/65_all_binutils-2.20-amd64-32bit-path.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/sys-devel/binutils-2.22.90/temp/65_all_binutils-2.20-amd64-32bit-path.patch.out

 * ERROR: sys-devel/binutils-2.22.90 failed (unpack phase):
 *   Failed Patch: 65_all_binutils-2.20-amd64-32bit-path.patch!
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_unpack
 *   environment, line 2998:  Called toolchain-binutils_src_unpack
 *   environment, line 3786:  Called tc-binutils_apply_patches
 *   environment, line 3095:  Called epatch
 *   environment, line 1531:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 *
 * If you need support, post the output of `emerge --info '=sys-devel/binutils-2.22.90'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/binutils-2.22.90'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/binutils-2.22.90/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/binutils-2.22.90/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/binutils-2.22.90/work/binutils-2.22.90'
 * S: '/var/tmp/portage/sys-devel/binutils-2.22.90/work/binutils-2.22.90'

>>> Failed to emerge sys-devel/binutils-2.22.90, Log file:

>>>  '/var/tmp/portage/sys-devel/binutils-2.22.90/temp/build.log'

 * Messages for package sys-devel/binutils-2.22.90:

 * Failed Patch: 65_all_binutils-2.20-amd64-32bit-path.patch !
 *  ( /var/tmp/portage/sys-devel/binutils-2.22.90/work/patch/65_all_binutils-2.20-amd64-32bit-path.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/sys-devel/binutils-2.22.90/temp/65_all_binutils-2.20-amd64-32bit-path.patch.out
 * ERROR: sys-devel/binutils-2.22.90 failed (unpack phase):
 *   Failed Patch: 65_all_binutils-2.20-amd64-32bit-path.patch!
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_unpack
 *   environment, line 2998:  Called toolchain-binutils_src_unpack
 *   environment, line 3786:  Called tc-binutils_apply_patches
 *   environment, line 3095:  Called epatch
 *   environment, line 1531:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 *
 * If you need support, post the output of `emerge --info '=sys-devel/binutils-2.22.90'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/binutils-2.22.90'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/binutils-2.22.90/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/binutils-2.22.90/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/binutils-2.22.90/work/binutils-2.22.90'
 * S: '/var/tmp/portage/sys-devel/binutils-2.22.90/work/binutils-2.22.90'
Back to top
View user's profile Send private message
nicodarious
n00b
n00b


Joined: 16 Sep 2010
Posts: 7

PostPosted: Sat Jul 28, 2012 6:08 am    Post subject: Reply with quote

same issue. Just tried updating my system last night and came home to this same error. Never seen anything like it before. Anyone have any clues on to what would cause binutils to fail like this?
_________________
ugh. another n00b......
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 164

PostPosted: Sat Jul 28, 2012 8:30 am    Post subject: Reply with quote

It's fixed: https://bugs.gentoo.org/show_bug.cgi?id=428366

Sync (emerge --sync or eix-sync or . . .) and try again.
Back to top
View user's profile Send private message
nicodarious
n00b
n00b


Joined: 16 Sep 2010
Posts: 7

PostPosted: Tue Jul 31, 2012 12:09 am    Post subject: Reply with quote

Sweet! Now it works again! And here i was thinking it was because i had CCACHE enabled (tried with it off also, just to be sure). Thanks for the update!
_________________
ugh. another n00b......
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum