Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pylotro
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 185
Location: Cleebronn, Germany

PostPosted: Sun Apr 29, 2012 8:44 am    Post subject: pylotro Reply with quote

Ich benutze den PyLOTRO Client für mein Gentoo. Seit kurzem startet er nicht mehr, es kommt noch der Fehler
Code:
Checking account details...
und dann bleibt er stehen. Wenn ich es unter der Konsole starte kommt folgendes:
Code:
Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.48: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)"
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/MainWindow.py", line 295, in txtPasswordEnter
    self.btnLoginClicked()
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/MainWindow.py", line 289, in btnLoginClicked
    self.AuthAccount();
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/MainWindow.py", line 306, in AuthAccount
    self.uiMain.txtPassword.text(), self.baseConfig.gameName, self.valHomeDir, self.osType)
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/PyLotROUtils.py", line 532, in __init__
    if webresp.status == 500:
AttributeError: 'NoneType' object has no attribute 'status'


eselect python list
Code:
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.2


Hat jemand eine Idee das Problem zu fixen? portage ist aktuell, revdep-rebuild lief auch schon durch.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2296
Location: Germany

PostPosted: Sun Apr 29, 2012 10:30 am    Post subject: Reply with quote

Schau doch mal ob du hier ein paar hilfreiche Ansätze findest --> https://bugs.gentoo.org/show_bug.cgi?id=413541

Alternativ könntest du auf die aktuell stable dev-libs/icu-4.8* Version zurück gehen, und hoffen das es nach einem revdep-rebuild soweit wieder passt.
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 185
Location: Cleebronn, Germany

PostPosted: Sun Apr 29, 2012 4:47 pm    Post subject: Reply with quote

nach einem downgrade der icu Verson und einem emerge --oneshot qt-core fehlt nur die Zeile wegen icui18n, der Rest ist noch da:
Code:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/MainWindow.py", line 295, in txtPasswordEnter
    self.btnLoginClicked()
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/MainWindow.py", line 289, in btnLoginClicked
    self.AuthAccount();
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/MainWindow.py", line 306, in AuthAccount
    self.uiMain.txtPassword.text(), self.baseConfig.gameName, self.valHomeDir, self.osType)
  File "/usr/lib64/python2.7/site-packages/PyLotROLauncher/PyLotROUtils.py", line 532, in __init__
    if webresp.status == 500:
AttributeError: 'NoneType' object has no attribute 'status'


Denn das passiert jedesmal wenn ich auf "Login" klicke und der Timeout kommt. Danach blint der Cursor im Passwortfeld wieder auf.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2296
Location: Germany

PostPosted: Sun Apr 29, 2012 6:24 pm    Post subject: Reply with quote

Puh keine Ahnung, ich kenne pylotro nicht..
Aber,
hier würde es etwas so ausschauen:
Code:
emerge -pv games-rpg/pylotro

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/pyxml-0.8.4-r2  USE="-doc -examples" 718 kB
[ebuild  N     ] dev-python/dbus-python-1.0.0  USE="-doc -examples -test" 0 kB
[ebuild  N     ] dev-python/sip-4.13.2-r1  USE="-debug -doc" 716 kB
[ebuild  N     ] dev-python/PyQt4-4.9.1  USE="X dbus declarative kde multimedia opengl phonon sql svg webkit -assistant -debug -doc -examples -xmlpatterns" 9,514 kB
[ebuild  N     ] dev-python/4suite-1.0.2-r2  USE="-doc" 1,257 kB
[ebuild  N     ] games-rpg/pylotro-0.1.14::sunrise  673 kB

Total: 6 packages (6 new), Size of downloads: 12,877 kB

Und bei sip und PyQt4 sollte immer die richtige Reihenfolge beim bauen beachtet werden - also erst sip und dann PyQt4
und wenn ich mich recht erinnere gibt es nach dem bauen von PyQt4 eine postinstall-message mit dem Hinweis alle von PyQt4 abhängigen Pakete bitte neu zu mergen, also etwa die ein
Code:
equery d PyQt4
auflistet.
Hattest du diese postinstall-Message eventuell übersehen, und die Abhängigen Pakete noch nicht neu übersetzt?
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 185
Location: Cleebronn, Germany

PostPosted: Mon Apr 30, 2012 10:42 am    Post subject: Reply with quote

Ich habe pylotro manuell installiert. In meinem portage ist er nicht drin, gibt es ein gutes Tutorial für Portage overlays?

Zum Fehler, ich habe versucht die Packete zu installieren, bei 4sute kommt ein Fehler der mir sehr bekannt vorkommt:
Code:
 * Package:    dev-python/4suite-1.0.2-r2
 * Repository: gentoo
 * Maintainer: python@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking 4Suite-XML-1.0.2.tar.bz2 to /var/tmp/portage/dev-python/4suite-1.0.2-r2/work
>>> Source unpacked in /var/tmp/portage/dev-python/4suite-1.0.2-r2/work
>>> Preparing source in /var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2 ...
 * Applying 4suite-1.0.2-amd64_python2.5.patch ...
 [ ok ]
 * Applying 4suite-1.0.2-config.patch ...
 [ ok ]
 * Applying 4suite-1.0.2-version_parsing.patch ...
 [ ok ]
 * Applying 4suite-1.0.2-pyxml.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2 ...
 * Configuration of dev-python/4suite-1.0.2-r2 with CPython 2.7...
/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/Version.py:62: Warning: invalid version number: "make[3]: Leaving directory `/var/tmp/portage/sci-geosciences/gpsd-2.95-r1/work/gpsd-2.95'", treating it as '0'
  warnings.warn("invalid version number: %r, treating it as '0'" % vstring, Warning)
Traceback (most recent call last):
  File "setup.py", line 88, in <module>
    requires_python=['>=2.2.1'],
  File "/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/__init__.py", line 48, in setup
    return _setup(**attrs)
  File "/usr/lib64/python2.7/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/PackageManager.py", line 546, in run_commands
    for dist in self.get_distributions():
  File "/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/PackageManager.py", line 420, in get_distributions
    distributions = self._sort_distributions(distributions)
  File "/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/PackageManager.py", line 477, in _sort_distributions
    installed_provides.update(get_provides(package))
  File "/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/PackageManager.py", line 467, in get_provides
    package_version = Version.CommonVersion(package.get_version())
  File "/usr/lib64/python2.7/distutils/version.py", line 40, in __init__
    self.parse(vstring)
  File "/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/Version.py", line 67, in parse
    start = match.end()
AttributeError: 'NoneType' object has no attribute 'end'
 * ERROR: dev-python/4suite-1.0.2-r2 failed (configure phase):
 *   setup.py config failed with Python 2.7
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_configure
 *   environment, line 4895:  Called python_execute_function 'configuration'
 *   environment, line 3241:  Called configuration
 *   environment, line 4893:  Called die
 * The specific snippet of code:
 *           "$(PYTHON)" setup.py config --prefix=/usr --docdir=/usr/share/doc/${PF} --datadir=/usr/share/${PN} --libdir="$(python_get_sitedir)" || die "setup.py config failed with Python ${PYTHON_ABI}"
 *
 * If you need support, post the output of 'emerge --info =dev-python/4suite-1.0.2-r2',
 * the complete build log and the output of 'emerge -pqv =dev-python/4suite-1.0.2-r2'.
 * The complete build log is located at '/var/tmp/portage/dev-python/4suite-1.0.2-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/4suite-1.0.2-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2'
 * S: '/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2'



EDIT: Anscheinend hat noch jemand das Problem, aber schon seit einem Jahr: http://forums.gentoo.org/viewtopic-p-6725581.html
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2296
Location: Germany

PostPosted: Sun May 06, 2012 1:58 pm    Post subject: Reply with quote

Gladdle wrote:
Ich habe pylotro manuell installiert. In meinem portage ist er nicht drin, gibt es ein gutes Tutorial für Portage overlays?
Huh, i.d.R ist es keine gute Idee manuell am Paketmanager (portage) vorbei zu installieren - nutze am besten immer ein Ebuild.
Für die nutzung von Overlays siehe zb auch in der Gentoo-Dokumentation --> Gentoo Overlays: Users' Guide
Wahrscheinlich ist es das beste das manuell ins System geschossene pylotro wieder restlos zu entfernen - du wirst es vermutlich eh neu bauen müssen. Nutze dafür am besten ein Ebuild, so wie es unter Gentoo üblich ist (das macht vieles einfacher) :)

Zu dem fehlschlagenden dev-python/4suite
Quote:
Code:
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2 ...
 * Configuration of dev-python/4suite-1.0.2-r2 with CPython 2.7...
/var/tmp/portage/dev-python/4suite-1.0.2-r2/work/4Suite-XML-1.0.2/Ft/Lib/DistExt/Version.py:62: Warning: invalid version number: "make[3]: Leaving directory `/var/tmp/portage/sci-geosciences/gpsd-2.95-r1/work/gpsd-2.95'", treating it as '0'
  warnings.warn("invalid version number: %r, treating it as '0'" % vstring, Warning)
Traceback (most recent call last):
....

Nur ein Schuss ins Blaue:
Hast du eventuell sci-geosciences/gpsd installiert? Wenn ja, versuche doch mal ein rebuild

/edit:
Hab es hier grad mal getestet, ein rebuild von gpsd hilft leider nicht. (es schlägt hier mit dem selben Error fehl sofern gpsd-2.95-r1 installiert ist)
Ein Workaround könnte sein gpsd kurzfristig zu deinstallieren, dann dev-python/4suite mergen, und dann gpsd wieder zu mergen. (Eine saubere Lösung ist das natürlich nicht...)
Oder teste es (sofern möglich) auch mal mit einer aktuelleren gpsd Version - wenn das auch fehlschlägt erstelle für dev-python/4suite ggf einen Bugreport
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2296
Location: Germany

PostPosted: Tue May 08, 2012 1:01 pm    Post subject: Reply with quote

Bezüglich dev-python/4suite ist es wohl auch ein altbekanntes Problem - siehe zb
https://bugs.gentoo.org/show_bug.cgi?id=368089
und
https://bugs.gentoo.org/show_bug.cgi?id=246683
Back to top
View user's profile Send private message
nightmarez
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2004
Posts: 111
Location: FSV Mainz 05 ;)

PostPosted: Wed May 09, 2012 2:12 pm    Post subject: Reply with quote

Huhu,

ich benutze pylotro.exe direkt mit wine, so wie es der Hersteller dokumentiert hat:
"PyLotRO can now be installed directly inside your Wine/Crossover setup, this method is ideal for people using OS X as the installation of Qt4 & PyQt4 can be awkward. Download pylotro-setup.exe and install it directly inside the Wine/Crossover bottle containing LotRO"
_________________
Ecce quomodo moritur iustus
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2296
Location: Germany

PostPosted: Fri May 18, 2012 3:35 pm    Post subject: Reply with quote

nightmarez wrote:
Huhu,

ich benutze pylotro.exe direkt mit wine, so wie es der Hersteller dokumentiert hat:
"PyLotRO can now be installed directly inside your Wine/Crossover setup, this method is ideal for people using OS X as the installation of Qt4 & PyQt4 can be awkward. Download pylotro-setup.exe and install it directly inside the Wine/Crossover bottle containing LotRO"

Naja, solche Stolpersteine haben wir unter Gentoo ja normal nicht. Qt4 & PyQt4 funktioniert unter Gentoo i.d.R ja einwandfrei, von daher sehe ich eigentlich keinen Grund zu so einer "Notlösung" wie pylotro-setup.exe unter wine greifen zu müssen ;)

@Gladdle
woran scheitert es denn nun noch?
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 185
Location: Cleebronn, Germany

PostPosted: Sun Jul 22, 2012 1:16 pm    Post subject: Reply with quote

Daran das mein tolles Acer Aspire 9920G den Geist (oder genauer gesagt die Grafikkarte) aufgegeben hat. Ich durfte die Grafikkarte ausbauen und den Chip neu "verballen". Scheiss Acer -.-

Derzeitig scheitert es daran das "dev-python/4suite" nicht mehr im Portage ist? Gibt es einen Nachfolger? Oder ist es in einem Overlay noch existent?
Code:
emerge --pretend pylotro

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/4suite-1.0.2-r2  USE="-doc"
[ebuild  N     ] games-rpg/pylotro-0.1.15


Per eBuild habe ich das ganze gelöst, aber woher bekomme ich die Datei PyLotRO-0.1.15.zip her? Die ehemalige WebSite funktioniert NICHT MEHR :(
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
shortyno1
n00b
n00b


Joined: 25 Aug 2012
Posts: 45
Location: Bremen

PostPosted: Tue Dec 11, 2012 4:44 pm    Post subject: re: Reply with quote

http://lotr.linuxweb.net/PyLotRO-0.1.15.zip :roll:
_________________
core i7 3610qm, 16 GB , SSD, GTX 670M : hp
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum