Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
install intel-ocl-sdk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 2:58 pm    Post subject: install intel-ocl-sdk Reply with quote

I can not install intel-ocl-sdk, followed the guide to unmask by adding dev-util/intel-ocl-sdk in /etc/portage/package.unmask

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3&chap=3#doc_chap3

but it did not help


Last edited by zuoshulu on Thu Jul 19, 2012 5:04 pm; edited 2 times in total
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2395

PostPosted: Thu Jul 19, 2012 4:56 pm    Post subject: Reply with quote

zuoshulu,

please rethink what you posted. Nobody can help you, because you did not provide any useful information.
Paste the content of your /etc/portage/package.unmask in a code block.
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 5:05 pm    Post subject: Reply with quote

alex.blackbit wrote:
zuoshulu,

please rethink what you posted. Nobody can help you, because you did not provide any useful information.
Paste the content of your /etc/portage/package.unmask in a code block.


my /etc/portage/package.unmask
Code:

>=dev-java/sun-jdk-1.5
~dev-java/sun-jdk-1.5.0
=dev-java/sun-jdk-1.5.0.01
>=dev-java/java-sdk-docs-1.5.0
dev-java/sun-jdk
dev-java/java-sdk-docs
>=dev-java/sun-jdk-1.5
dev-util/android-sdk-update-manager
dev-util/intel-ocl-sdk
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2395

PostPosted: Thu Jul 19, 2012 5:35 pm    Post subject: Reply with quote

That looks good.
Could it be that you are on a x86 box?
That package only works on amd64.
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 5:50 pm    Post subject: Reply with quote

alex.blackbit wrote:
That looks good.
Could it be that you are on a x86 box?
That package only works on amd64.


I actually installing gnome on my x86 mini gentoo with x server, it asked me to get intel-ocl-sdk package, i manually added many keywords in USE in make.conf . can you post a completed USE for gnome here?
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2395

PostPosted: Thu Jul 19, 2012 6:15 pm    Post subject: Reply with quote

zuoshulu wrote:
can you post a completed USE for gnome here?

That does not make sense.
You have to define yourself which USE flags you want.
There shouldn't be any special flags needed to get a basic, usable gnome installation anyway.
I don't use gnome, much too bloated.
My X11 desktop is managed by x11-wm/dwm.
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 6:29 pm    Post subject: Reply with quote

oh dear, I did

Code:
emerge -C sys-libs/zlib


now my emerge stop working at all. it says ImportError: libz.so.1: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2395

PostPosted: Thu Jul 19, 2012 10:05 pm    Post subject: Reply with quote

That was not a very good idea.
You can extract this archive in your / directory.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum