Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solucionado] Lector de tarjeta SD no funciona
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
yio643
n00b
n00b


Joined: 25 Apr 2012
Posts: 16

PostPosted: Thu Jul 19, 2012 6:25 pm    Post subject: [Solucionado] Lector de tarjeta SD no funciona Reply with quote

Que tal compañeros sucede que mi lector no funciona como debe, aparece un sdb pero a la hora de montarlo "No medium found on /dev/sdb"

he seguido este tutorial http://en.gentoo-wiki.com/wiki/SD_and_MMC_card_readers#Multi_USB_Card_Readers
he activado luns en el kernel solo que a la hora de configurar lo siguiente
Code:

Device Drivers  --->
    <*> MMC/SD/SDIO card support  --->
        -*- MMC/SD card support
        <*>   MMC block device driver
        [*]     Use bounce buffer for simple hosts


la opcion
Code:
  -*- MMC/SD card support
queda asi y no puedo cambiarla
Code:
 --- MMC/SD card support


creo que no se esta incluyendo el soporte alguien podria decirme como incluirla en el kernel o como configurar correctamente este lector de tarjeta
Code:

Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader

_________________
.::Yio::. ==Life is measuredin beats==


Last edited by yio643 on Sun Jul 22, 2012 5:36 am; edited 1 time in total
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Thu Jul 19, 2012 8:13 pm    Post subject: Reply with quote

Has compilado y cargado el modulo usb-storage ?????? En mi caso no lo carga directamente y debe cargarlo en el script de inicio.

Y en SCSI compila esta opcion directamente:

Code:
Probe all LUNs on each SCSI device



En cualquier caso revisa esta guia :

http://en.gentoo-wiki.com/wiki/SD_and_MMC_card_readers

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
yio643
n00b
n00b


Joined: 25 Apr 2012
Posts: 16

PostPosted: Thu Jul 19, 2012 9:57 pm    Post subject: Reply with quote

Arctic wrote:
Has compilado y cargado el modulo usb-storage ?????? En mi caso no lo carga directamente y debe cargarlo en el script de inicio.

Y en SCSI compila esta opcion directamente:

Code:
Probe all LUNs on each SCSI device



En cualquier caso revisa esta guia :

http://en.gentoo-wiki.com/wiki/SD_and_MMC_card_readers

Salu2


tengo cargado usb-storage y de hecho he seguido esa guia y veo que en la parte
Code:
-*- MMC/SD card support


me queda asi
Code:
--- MMC/SD card support
no hallo como dejarlo
Quote:
-*-


siento que si corrijo esa parte quedara oluconado el problema
_________________
.::Yio::. ==Life is measuredin beats==
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Fri Jul 20, 2012 1:07 am    Post subject: Reply with quote

Cuando insertas una tarjeta , el dmesg muestra algun cambio ????? Se crean los dev ????? Algunas lectoras incorporan una contraladora que hay que cargar adicionalmente , los has comporbado ????? Sino quieres andar dando muchas vueltas carga un livecd de ubuntu y fijate que modulos carga para hacer funcionar la lectora y los resultados del dmesg.

Yo uso una lectora generica y tengo todo compilado como modulo , y funciona correctamente ,salvo la particularidad que te he comentado de cargar usb-storage a mano el resto lo tengo como en la guia.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
yio643
n00b
n00b


Joined: 25 Apr 2012
Posts: 16

PostPosted: Sun Jul 22, 2012 5:35 am    Post subject: Reply with quote

Arctic wrote:
Cuando insertas una tarjeta , el dmesg muestra algun cambio ????? Se crean los dev ????? Algunas lectoras incorporan una contraladora que hay que cargar adicionalmente , los has comporbado ????? Sino quieres andar dando muchas vueltas carga un livecd de ubuntu y fijate que modulos carga para hacer funcionar la lectora y los resultados del dmesg.

Yo uso una lectora generica y tengo todo compilado como modulo , y funciona correctamente ,salvo la particularidad que te he comentado de cargar usb-storage a mano el resto lo tengo como en la guia.

Salu2


Amigo muchas gracias por tu ayuda acabo de darme cuenta que un pin no esta haciendo contacto asi que asumo que no funciona por falla de hardware, lo checare en estos dias igual si alguien sabe como checarlo con multimetro se lo agradeceria
_________________
.::Yio::. ==Life is measuredin beats==
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum