Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Thu Jul 19, 2012 5:35 am    Post subject: [overlay] unity-gentoo Reply with quote

Hi all, firing off this quick post to put it out there that we now have the Unity desktop working on Gentoo.
Yes Arch have had this for a couple of years already so why can't Gentoo right ?

The overlay can be added by doing 'layman -a unity-gentoo' or browsed at https://github.com/shiznix/unity-gentoo
Everything works and it also comes with UbuntuOne cloud storage services.

The usual disclaimer, it's experimental, comes with no guarantees...etc. etc.
Enjoy!

Video of Unity desktop in action -> https://www.youtube.com/watch?v=ySJhFCtVTUQ

It is necessary to mask certain packages that would normally be emerged from the main portage tree:
Code:

ln -s /var/lib/layman/unity-gentoo/unity-portage.pmask /etc/portage/package.mask/unity-portage.pmask

All packages are keyword masked and can be unmasked by entering the following into your package.keywords file:
Code:

*/*::unity-gentoo

A package keywords file containing a base set of packages for Unity installation is maintained for convenience at /var/lib/layman/unity-gentoo/unity-portage.pkeywords:
Code:

ln -s /var/lib/layman/unity-gentoo/unity-portage.pkeywords /etc/portage/package.keywords/unity-portage.pkeywords

A package unmask file is maintained at /var/lib/layman/unity-gentoo/unity-portage.punmask:
Code:

ln -s /var/lib/layman/unity-gentoo/unity-portage.punmask /etc/portage/package.unmask/unity-portage.punmask

A package USE file is maintained at /var/lib/layman/unity-gentoo/unity-portage.puse:
Code:

ln -s /var/lib/layman/unity-gentoo/unity-portage.puse /etc/portage/package.use/unity-portage.puse

IMPORTANT
As of the Saucy release, Unity uses Gnome 3.8 and so this requires you enable systemd.
While systemd is not strictly needed for Gnome 3.8 to build, it is needed at runtime.
From http://wiki.gentoo.org/wiki/GNOME/3.8-upgrade-guide ...
Quote:
GNOME 3.8 requires systemd to be running to get it working properly, otherwise, you will get broken power management and multiseat handling, and also some more problems because upstream has moved away from the obsolete consolekit to logind (that needs systemd to be running to work).
It is highly recommended you get the system working with systemd before proceeding with the Unity desktop installation (see http://wiki.gentoo.org/wiki/Systemd).

QT5 packages are now included in the overlay due to Unity relying on stable QT versions which can disappear from the 'qt' overlay.
If you are already using QT5 packages from the 'qt' overlay, then you'll need to perform the following to downgrade back to the overlay's QT5 packages.
Code:
layman -d qt
emerge -1av $(qlist -ISC dev-qt/ | grep \:5)
emerge -1av $(qdepends -CNQ dev-qt/qtcore:5 2> /dev/null)

If you need support or would like to report an issue, you can post on this forum or chat on Freenode's #unity-gentoo IRC channel.
Issues can also be reported on the overlay's github page.


Last edited by shiznix on Sat Nov 30, 2013 8:21 am; edited 16 times in total
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Fri Jul 20, 2012 6:09 am    Post subject: Reply with quote

today is my birthday... nice gift!! i was wating it for years, now i will try to install it...
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Fri Jul 20, 2012 8:43 pm    Post subject: Reply with quote

nice one! Thanks for your work i think this will be valuable in the commmunityl :D I will try it.
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Fri Jul 20, 2012 9:59 pm    Post subject: Reply with quote

I added the unity-gentoo overlay, but i can't find the unity-meta package.... when i type "emerge --search unity" i only get this:
* app-xemacs/latin-unity
* dev-libs/libunity [ Masked ]
* dev-libs/libunity-misc [ Masked ]
* media-plugins/banshee-community-extensions
* x11-themes/unity-asset-pool [ Masked ]

but when i run layman -S i get:

* Successfully synchronized overlay "unity-gentoo".

What is happening?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Jul 21, 2012 3:10 am    Post subject: Reply with quote

Seems that only a few packages are in the unity-gentoo overlay... Is there the possibility of make a local overlay cloning the git repository? I guess yes, but i guess i will need some ebuild files for it, can someone help me with this??
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sat Jul 21, 2012 4:40 am    Post subject: Reply with quote

Happy Birthday!!

An odd issue lacking the ebuilds. I just tried fetching the overlay and it works OK here.

It's like layman or git hasn't fetched the overlay properly.
You might try to delete the overlay and then re-add it, 'layman -d unity-gentoo && layman -a unity-gentoo'.
Or a sync may even do the trick, 'layman -s unity-gentoo'.

And if all that still leaves no joy, you could verify that the files actually exist in /var/lib/layman/unity-gentoo/

Oh and another possibility, the overlay has package categories that are not used by the main portage tree that you'll need to let portage know about by adding them in /etc/portage/categories
Doing the following should fix that:
Code:
echo "unity-base" >> /etc/portage/categories
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Jul 21, 2012 4:58 am    Post subject: Reply with quote

shiznix wrote:
Happy Birthday!!

You might try to delete the overlay and then re-add it, 'layman -d unity-gentoo && layman -a unity-gentoo'.
Or a sync may even do the trick, 'layman -s unity-gentoo'.
didn't work...

shiznix wrote:

And if all that still leaves no joy, you could verify that the files actually exist in /var/lib/layman/unity-gentoo/
YES!! all the files really exists... but emerge cannot find them...

shiznix wrote:

Oh and another possibility, the overlay has package categories that are not used by the main portage tree that you'll need to let portage know about by adding them in /etc/portage/categories
Doing the following should fix that:
Code:
echo "unity-base" >> /etc/portage/categories"

I will try it now, thank you!
edit: it works, now i'm compiling!! thank you very much!
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Jul 21, 2012 5:24 pm    Post subject: Reply with quote

Actually, my idea is to install only the appmenu. BUT, i want to use it on gnome 2, with the gnome panel indicator-applet (appmenu). When i try to install indicator-applet i get a lot of dependencies and slots conflits:

Code:


ah@ah-1201n ~ $ sudo emerge -avt indicator-applet
Senha:

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!


[nomerge       ] gnome-base/gnome-light-2.32.1-r2  USE="automount"
[nomerge       ]  gnome-base/gnome-control-center-99.3.4.2::unity-gentoo [2.32.1-r1::gentoo] USE="bluetooth%* cheese%* colord%* cups%* gnome-online-accounts%* networkmanager%* socialweb%* -debug -systemd% -wacom% (-eds%*)"
[nomerge       ]   gnome-extra/nm-applet-99.0.9.4.1::unity-gentoo [0.8.4::gentoo] USE="bluetooth -debug%"
[nomerge       ]    dev-libs/libappindicator-0.4.92::unity-gentoo  USE="-vala"
[nomerge       ]     gnome-extra/zeitgeist-0.9.0.1  USE="dbus extensions fts nls passiv plugins -icu -sql-debug"
[ebuild  N    ~]      gnome-extra/zeitgeist-datahub-0.8.2::unity-gentoo  USE="-download" 199 kB
[ebuild     U ~]  gnome-base/gnome-control-center-99.3.4.2::unity-gentoo [2.32.1-r1::gentoo] USE="bluetooth%* cheese%* colord%* cups%* gnome-online-accounts%* networkmanager%* socialweb%* -debug -systemd% -wacom% (-eds%*)" 4,381 kB
[ebuild     U ~]   gnome-extra/nm-applet-99.0.9.4.1::unity-gentoo [0.8.4::gentoo] USE="bluetooth -debug%" 1,143 kB
[ebuild  N    ~]    dev-libs/libappindicator-0.4.92::unity-gentoo  USE="-vala" 515 kB
[ebuild  N    ~]     gnome-extra/zeitgeist-datasources-0.8.0.1  USE="telepathy -bzr -chromium -emacs -eog -geany -gedit -rhythmbox -static-libs -tomboy -totem -vim -xchat" 473 kB
[ebuild  N    ~]      dev-libs/libzeitgeist-0.3.18::unity-gentoo  USE="-static-libs" 521 kB
[ebuild  N    ~]       gnome-extra/zeitgeist-0.9.0.1  USE="dbus extensions fts nls passiv plugins -icu -sql-debug" 808 kB

Total: 7 packages (2 upgrades, 5 new), Size of downloads: 8,039 kB

 * Error: circular dependencies:

(dev-libs/libzeitgeist-0.3.18::unity-gentoo, ebuild scheduled for merge) depends on
 (gnome-extra/zeitgeist-0.9.0.1::gentoo, ebuild scheduled for merge) (runtime)
  (gnome-extra/zeitgeist-datasources-0.8.0.1::gentoo, ebuild scheduled for merge) (buildtime)
   (dev-libs/libzeitgeist-0.3.18::unity-gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-misc/networkmanager:0

  (net-misc/networkmanager-0.8.4.0-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-misc/networkmanager-0.9.4.0-r5::gentoo, ebuild scheduled for merge) pulled in by
    >=net-misc/networkmanager-0.9.4 required by (gnome-extra/nm-applet-99.0.9.4.1::unity-gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

gnome-base/gsettings-desktop-schemas:0

  (gnome-base/gsettings-desktop-schemas-3.2.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-base/gsettings-desktop-schemas-99.3.4.1::unity-gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gsettings-desktop-schemas-3.3.0 required by (gnome-base/gnome-settings-daemon-99.3.4.2::unity-gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-libs/libgweather:2

  (dev-libs/libgweather-2.30.3::gentoo, installed) pulled in by
    <dev-libs/libgweather-2.90.1:2 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
    (and 1 more with the same problem)

  (dev-libs/libgweather-3.4.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgweather-2.91:2 required by (gnome-base/gnome-panel-3.4.1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

gnome-base/gnome-panel:0

  (gnome-base/gnome-panel-3.4.1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-panel-3.4.1 required by (unity-base/indicator-applet-0.5.0::unity-gentoo, ebuild scheduled for merge)

  (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed) pulled in by
    gnome-base/gnome-panel[bonobo] required by (gnome-extra/gnome-power-manager-2.32.0-r3::gentoo, installed)
    >=gnome-base/gnome-panel-2.31.2[bonobo] required by (gnome-base/gnome-applets-2.32.1.1::gentoo, installed)

dev-lang/python:2.7

  (dev-lang/python-2.7.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/python-2*[sqlite] required by (gnome-extra/zeitgeist-extensions-0.0.13-r1::gentoo, ebuild scheduled for merge)

  (dev-lang/python-2.7.3-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/gnome-desktop:3

  (gnome-base/gnome-desktop-3.2.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-base/gnome-desktop-3.4.2::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-desktop-3.3.92:3 required by (gnome-base/gnome-settings-daemon-99.3.4.2::unity-gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
#required by gnome-extra/zeitgeist-0.9.0.1[passiv], required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-extra/zeitgeist-datahub-0.8.2 ~amd64
#required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/libindicator-0.5.0 ~amd64
#required by gnome-base/gnome-panel-3.4.1, required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-desktop-3.2.1 ~amd64
#required by indicator-applet (argument)
=unity-base/indicator-applet-0.5.0 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/atk-2.4.0 ~amd64
#required by gnome-extra/gnome-media-2.32.0-r1, required by @selected, required by @world (argument)
=dev-libs/glib-99.2.32.3 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=x11-libs/pango-1.30.1 ~amd64
#required by app-accessibility/at-spi2-atk-2.5.3, required by x11-libs/gtk+-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=app-accessibility/at-spi2-core-2.4.2 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/libgnomekbd-3.2.0-r1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[colord], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-extra/gnome-color-manager-3.2.4 ~amd64
#required by gnome-base/gnome-settings-daemon-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/libwacom-0.5 ~amd64
#required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/libappindicator-0.4.92 ~amd64
#required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=net-libs/gnome-online-accounts-3.2.1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-settings-daemon-99.3.4.2 ~amd64
#required by gnome-extra/zeitgeist-0.9.0.1[plugins], required by gnome-extra/zeitgeist-datahub-0.8.2
=gnome-extra/zeitgeist-datasources-0.8.0.1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-menus-99.3.4.0 ~amd64
#required by gnome-base/gnome-desktop-3.2.1, required by media-video/cheese-3.4.2, required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=x11-libs/gtk+-99.3.4.2 ~amd64
#required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-panel-3.4.1 ~amd64
#required by x11-libs/gtk+-99.3.4.2[introspection], required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/gobject-introspection-1.32.1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=media-sound/pulseaudio-2.1 ~amd64
#required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-extra/zeitgeist-extensions-0.0.13-r1 ~amd64
#required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-control-center-99.3.4.2 ~amd64
#required by gnome-base/gnome-panel-3.4.1, required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-desktop-3.4.2 ~amd64
#required by gnome-base/gnome-panel-3.4.1, required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/libgweather-3.4.1 ~amd64
#required by net-wireless/gnome-bluetooth-99.3.5.4, required by gnome-extra/nm-applet-99.0.9.4.1[bluetooth], required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=net-wireless/blueman-1.23-r2 ~amd64
#required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=net-misc/networkmanager-0.9.4.0-r5 ~amd64
#required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=net-libs/liboauth-0.9.7 ~amd64
#required by dev-libs/gobject-introspection-1.32.1, required by net-libs/libsocialweb-0.25.20[introspection,vala], required by gnome-base/gnome-control-center-99.3.4.2[socialweb], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/gobject-introspection-common-1.32.1 ~amd64
#required by gnome-extra/evolution-data-server-3.2.3-r2, required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/libgdata-0.10.2 ~amd64
#required by media-sound/pulseaudio-2.1[webrtc-aec], required by gnome-base/gnome-settings-daemon-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=media-libs/webrtc-audio-processing-0.1 ~amd64
#required by gnome-extra/nm-applet-99.0.9.4.1[bluetooth], required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=net-wireless/gnome-bluetooth-99.3.5.4 ~amd64
#required by gnome-extra/zeitgeist-0.9.0.1, required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-python/rdflib-3.2.1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=media-video/cheese-3.4.2 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gsettings-desktop-schemas-99.3.4.1 ~amd64
#required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/libzeitgeist-0.3.18 ~amd64
#required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-extra/evolution-data-server-3.2.3-r2 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=app-accessibility/at-spi2-atk-2.5.3 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[cups], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=net-print/cups-pk-helper-0.2.2 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-base/gnome-session-99.3.2.1 ~amd64
#required by dev-libs/libindicator-0.5.0, required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=x11-libs/libXfixes-5.0-r9999 ~amd64
#required by x11-libs/libXfixes-5.0-r9999, required by gnome-base/gnome-settings-daemon-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=x11-proto/fixesproto-5.0-r9999 ~amd64
#required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-extra/zeitgeist-0.9.0.1 ~amd64
#required by gnome-base/gnome-light-2.32.1-r2, required by @selected, required by @world (argument)
=x11-libs/gdk-pixbuf-2.26.1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=gnome-extra/nm-applet-99.0.9.4.1 ~amd64
#required by media-video/cheese-3.4.2, required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=x11-libs/mx-1.4.2 ~amd64
#required by gnome-extra/zeitgeist-extensions-0.0.13-r1[geolocation], required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-python/python-geoclue-0.1.0 ~amd64
#required by dev-python/rdflib-3.2.1, required by gnome-extra/zeitgeist-0.9.0.1, required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-python/isodate-0.4.8 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=gnome-base/gnome-panel-3.4.1
#required by gnome-base/gnome-panel-3.4.1, required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=gnome-base/gnome-desktop-3.4.2
#required by app-accessibility/at-spi2-atk-2.5.3, required by x11-libs/gtk+-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=app-accessibility/at-spi2-core-2.4.2
#required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=media-video/cheese-3.4.2

The following USE changes are necessary to proceed:
#required by gnome-extra/zeitgeist-extensions-0.0.13-r1, required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
>=dev-lang/python-2.7.3-r2:2.7 sqlite
#required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
>=gnome-extra/zeitgeist-0.9.0.1 passiv extensions plugins
#required by media-sound/pulseaudio-2.1[alsa], required by gnome-base/gnome-settings-daemon-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by gnome-base/gnome-control-center-99.3.4.2, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
>=media-plugins/alsa-plugins-1.0.25-r1 pulseaudio
#required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
>=gnome-extra/zeitgeist-datasources-0.8.0.1 telepathy
#required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
=dev-libs/xapian-bindings-1.2.8 python
#required by dev-libs/libappindicator-0.4.92, required by gnome-extra/nm-applet-99.0.9.4.1, required by gnome-base/gnome-control-center-99.3.4.2[networkmanager], required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts], required by gnome-base/gnome-panel-3.4.1[eds], required by unity-base/indicator-applet-0.5.0, required by indicator-applet (argument)
>=gnome-extra/zeitgeist-extensions-0.0.13-r1 geolocation

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).




Is there a way to get it working on gnome 2 / gtk2 ?? I really don't like gnome3 /gtk3, but if they are really needed, i think it will be more easy to me make a new instalation of gentoo (with gnome3).


if i try to install the unity-meta package, i get even more errors...
If i try to upgrade my system, i get this:

Code:

ah@ah-1201n ~ $ sudo emerge --update --deep --newuse --with-bdeps=y -avt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] gnome-extra/gnome-power-manager-2.32.0-r3  USE="applet policykit -doc -test"
[ebuild     U  ]  gnome-extra/polkit-gnome-99.0.105::unity-gentoo [0.105::gentoo] 0 kB
[nomerge       ] media-gfx/gimp-2.6.12-r2  USE="alsa dbus exif gnome jpeg lcms mmx mng pdf png sse svg tiff -aalib (-altivec) -curl -debug -doc -python -smp -webkit -wmf" LINGUAS="pt_BR -am -ar -ast -az -be -bg -ca -ca@valencia -cs -da -de -dz -el -en_CA -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -lt -lv -mk -ml -mr -ms -my -nb -nds -ne -nl -nn -oc -or -pa -pl -pt -ro -ru -rw -si -sk -sl -sr -sr@latin -sv -ta -th -tr -tt -uk -vi -xh -yi -zh_CN -zh_HK -zh_TW"
[nomerge       ]  gnome-base/gvfs-1.10.1  USE="bluetooth cdda gdu gnome-keyring http udev -afp -archive -avahi -bluray -doc -fuse -gphoto2 -ios -samba"
[nomerge       ]   sys-apps/gnome-disk-utility-3.0.2-r200  USE="gnome-keyring nautilus -avahi -doc -fat -remote-access"
[nomerge       ]    x11-libs/gtk+-3.2.4-r1  USE="colord cups introspection (-aqua) -debug -doc -examples (-packagekit) -test -vim-syntax -xinerama"
[nomerge       ]     net-print/cups-1.5.2-r4  USE="X acl dbus filters jpeg ldap pam png ssl threads tiff usb -avahi -debug -gnutls -java -kerberos -perl -python -slp -static-libs -xinetd" LINGUAS="pt_BR -da -de -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -ru -sv -zh -zh_TW"
[ebuild     U  ]      net-print/foomatic-filters-4.0.16 [4.0.15] USE="cups dbus" 261 kB
[ebuild     U  ]     x11-libs/gtk+-99.2.24.10::unity-gentoo [2.24.10-r1::gentoo] USE="cups introspection (-aqua) -debug -doc -examples -test -vim-syntax -xinerama" 13,074 kB
[nomerge       ] dev-vcs/git-1.7.8.6  USE="blksha1 curl gtk iconv perl python threads webdav -cgi -cvs -doc -emacs (-ppcsha1) -subversion -tk -xinetd"
[ebuild   R    ]  net-misc/curl-7.25.0-r1  USE="ipv6 ldap ssl -ares -idn -kerberos -ssh -static-libs -test -threads" CURL_SSL="nss -axtls -gnutls -openssl -polarssl (-cyassl%)" 0 kB
[nomerge       ] net-print/hplip-3.12.4  USE="X acl hpcups libnotify policykit qt4 scanner -doc -fax -hpijs -kde -minimal -parport -snmp -static-ppds"
[nomerge       ]  dev-python/imaging-1.1.7-r1  USE="X lcms scanner -doc -examples -tk"
[nomerge       ]   virtual/jpeg-0  USE="-static-libs"
[ebuild     U  ]    media-libs/libjpeg-turbo-1.2.1 [1.2.0-r1] USE="-java -static-libs" 1,715 kB
[ebuild     U  ]     dev-lang/nasm-2.10.01 [2.10] USE="-doc" 795 kB
[nomerge       ] sys-apps/baselayout-2.1-r1  USE="-build"
[nomerge       ]  sys-apps/openrc-0.9.8.4  USE="ncurses pam unicode -debug (-selinux) -static-libs"
[nomerge       ]   sys-libs/glibc-2.14.1-r3  USE="(multilib) -debug -gd (-hardened) -profile (-selinux) -vanilla"
[ebuild     U  ]    sys-kernel/linux-headers-3.4-r1 [3.1] 4 kB
[blocks B      ] dev-util/gtk-builder-convert ("dev-util/gtk-builder-convert" is blocking x11-libs/gtk+-99.2.24.10)

Total: 7 packages (6 upgrades, 1 reinstall), Size of downloads: 15,847 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-kernel/linux-headers:0

  (sys-kernel/linux-headers-3.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-kernel/linux-headers-3.1::gentoo, installed) pulled in by
    <sys-kernel/linux-headers-3.4 required by (sys-boot/syslinux-4.05::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



ps: how do you do for put a scrollbar in these longs logs?
Back to top
View user's profile Send private message
sera
Developer
Developer


Joined: 29 Feb 2008
Posts: 992
Location: CET

PostPosted: Sat Jul 21, 2012 5:48 pm    Post subject: Reply with quote

shiznix wrote:
Oh and another possibility, the overlay has package categories that are not used by the main portage tree that you'll need to let portage know about by adding them in /etc/portage/categories
Doing the following should fix that:
Code:
echo "unity-base" >> /etc/portage/categories


Then you should create a file gentoo-unity/profiles/categories listing the categories of your overlay.
You might also want a file gentoo-unity/metadata/layout.conf and at least set a master. See 'man 5 portage' for the format and an explanation of layout.conf.

Nice initiative btw.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Jul 21, 2012 5:56 pm    Post subject: Reply with quote

sera wrote:
shiznix wrote:
Oh and another possibility, the overlay has package categories that are not used by the main portage tree that you'll need to let portage know about by adding them in /etc/portage/categories
Doing the following should fix that:
Code:
echo "unity-base" >> /etc/portage/categories


Then you should create a file gentoo-unity/profiles/categories listing the categories of your overlay.
You might also want a file gentoo-unity/metadata/layout.conf and at least set a master. See 'man 5 portage' for the format and an explanation of layout.conf.

Nice initiative btw.


Can you explain me better? I can see all packages now, but i'm having a lot of dependencies / slots conflicts errors (see my last post)...

Is this procedure really necessary? It will avoid these dependencies errors?

thank you all for the help...
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2594
Location: The Peanut Gallery

PostPosted: Sat Jul 21, 2012 10:00 pm    Post subject: Reply with quote

ahgblopes wrote:
Is this procedure really necessary? It will avoid these dependencies errors?

No, that's for the overlay maintainer to do at the repo-side.

(Don't ask me about the packages, I don't use them: I only clicked on this thread as I thought it was about unity unit-testing ;)
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Jul 21, 2012 11:02 pm    Post subject: Reply with quote

i give upe... :(

Is impossible to install it on gnome2, i guess...
Back to top
View user's profile Send private message
danilkutkevich
n00b
n00b


Joined: 22 Jul 2012
Posts: 2

PostPosted: Sun Jul 22, 2012 9:08 am    Post subject: Reply with quote

Thank you for the overlay!

I am having an error:

On this

Code:
emerge -1a $(qlist -IC x11-libs/qt)


I got

Code:
....
>>> Downloading 'http://distfiles.gentoo.org/distfiles/qt4-x11_4.8.2-0ubuntu2.debian.tar.gz'
...
2012-07-22 12:31:09 ERROR 404: Not Found.
....
>>> Downloading 'http://archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/qt4-x11_4.8.2-0ubuntu2.debian.tar.gz'
...
2012-07-22 12:31:09 ERROR 404: Not Found.


I changed `UVER="0ubuntu2"` on `UVER="0ubuntu4"`
in the file eclass/qt4-build.eclass in my overlay.
But when `layman --sync-all` I got

Code:
error: Your local changes to the following files would be overwritten by merge:
       eclass/qt4-build.eclass
Please, commit your changes or stash them before you can merge.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sun Jul 22, 2012 11:29 pm    Post subject: Reply with quote

@ahgblopes: I don't think that it will work with gnome2.
Indicator-applet relies on gnome-panel >=2.91.93 (ie. gnome3).
That doesn't mean you can't have it look and feel like Gnome2, use either the 'unity-2d' or 'gnome-classic' sessions.

Zeitgeist circular deps. should be fixed now.
dev-util/gtk-builder-convert block should also be fixed now.
The other error messages look like normal messages due to the need for keyword unmasking.
There is a list of packages contained in the file /var/lib/layman/unity-gentoo/PACKAGES that you can use to help ease the process of unmasking.

@sera: thanks for the good word on putting the categories in overlay's profiles/categories - now fixed :)

@danilkutkevich: this should be fixed now.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Jul 23, 2012 2:52 am    Post subject: Reply with quote

shiznix wrote:
@ahgblopes: I don't think that it will work with gnome2.
Indicator-applet relies on gnome-panel >=2.91.93 (ie. gnome3).
That doesn't mean you can't have it look and feel like Gnome2, use either the 'unity-2d' or 'gnome-classic' sessions.

Zeitgeist circular deps. should be fixed now.
dev-util/gtk-builder-convert block should also be fixed now.
The other error messages look like normal messages due to the need for keyword unmasking.
There is a list of packages contained in the file /var/lib/layman/unity-gentoo/PACKAGES that you can use to help ease the process of unmasking.

@sera: thanks for the good word on putting the categories in overlay's profiles/categories - now fixed :)

@danilkutkevich: this should be fixed now.



Thank you!!

Now i'm installing the appmenu from stuff overlay. The indicator applet works with my gnome2-panel, but to install the server i need to install libdbusmenu. I cannot install it from stuff overlay, so i'm trying to install libdbusmenu from unity-gentoo overlay.

Everything compiles fine, but when i try to compile gtk, i also get an 404 error:

Code:



>>> Emerging (10 of 11) x11-libs/gtk+-99.3.4.2 from unity-gentoo
 * gtk+3.0_3.4.2.orig.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                              [ ok ]
>>> Downloading 'http://distfiles.gentoo.org/distfiles/gtk+3.0_3.4.2-0ubuntu0.3.debian.tar.gz'
--2012-07-22 23:40:17--  http://distfiles.gentoo.org/distfiles/gtk+3.0_3.4.2-0ubuntu0.3.debian.tar.gz
Resolvendo distfiles.gentoo.org... 216.165.129.135, 64.50.233.100, 64.50.236.52, ...
Conectando-se a distfiles.gentoo.org|216.165.129.135|:80... conectado.
A requisição HTTP foi enviada, aguardando resposta... 404 Not Found
2012-07-22 23:40:18 ERRO 404: Not Found.

>>> Downloading 'http://archive.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_3.4.2-0ubuntu0.3.debian.tar.gz'
--2012-07-22 23:40:18--  http://archive.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_3.4.2-0ubuntu0.3.debian.tar.gz
Resolvendo archive.ubuntu.com... 91.189.92.192, 91.189.92.193, 91.189.91.13, ...
Conectando-se a archive.ubuntu.com|91.189.92.192|:80... conectado.
A requisição HTTP foi enviada, aguardando resposta... 404 Not Found
2012-07-22 23:40:19 ERRO 404: Not Found.

!!! Couldn't download 'gtk+3.0_3.4.2-0ubuntu0.3.debian.tar.gz'. Aborting.
 * Fetch failed for 'x11-libs/gtk+-99.3.4.2', Log file:
 *  '/var/tmp/portage/x11-libs/gtk+-99.3.4.2/temp/build.log'

Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Mon Jul 23, 2012 3:14 am    Post subject: Reply with quote

Should be fixed now, thanks for reporting :)
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Fri Jul 27, 2012 3:24 am    Post subject: Reply with quote

I decide to upgrade to gnome 3.... so i will try again...

But now i'm getting this error:


emerge: there are no ebuilds to satisfy ">=99.dev-libs/libappindicator-0.4.92"


echo "99.dev-lib"s >> /etc/portage/categories didn't help me...

edit: SOLVED ... i just edited the indicator-appmenu-0.3.97.ebuild file (at /var/lib/layman/unity-gentoo/unity-base/indicator-appmenu/) and changed the 99.dev-libs/libappindicator-0.4.92 to dev-libs/libappindicator-99.0.4.92 !!(please fix the ebuild!!!)

Now i'm getting other problems, but i'm trying tho solve them...

edit2:
now i get this error:

[ebuild N ] app-text/docbook-dsssl-stylesheets-1.79 0 kB
[ebuild N ] app-text/docbook-sgml-dtd-3.0-r3 0 kB
[blocks B ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-99.3.4.2)

Total: 246 packages (6 upgrades, 1 downgrade, 226 new, 12 in new slots, 1 reinstall), Size of downloads: 328,746 kB
Conflict: 1 block (1 unsatisfied)

How do i fix this???
Thank you...
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Jul 27, 2012 7:01 am    Post subject: Reply with quote

Oops that's what I get for being half asleep.
Should be fixed now and thanks :)

You'll have to keyword unmask x11-libs/vte to resolve that block.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Jul 28, 2012 3:24 am    Post subject: Reply with quote

shiznix wrote:

You'll have to keyword unmask x11-libs/vte to resolve that block.


How do you do it??


edit: Ok, i added x11-libs/vte ** to package.unmask and x11-libs/vte ~amd64 to package.keywords, trying again!!


edit2:

Now the problem is:

sys-apps/dbus:0

(sys-apps/dbus-1.6.2::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/dbus-1.6.2 required by (dev-libs/dbus-glib-0.100::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(sys-apps/dbus-1.4.16::gentoo, ebuild scheduled for merge) pulled in by
<sys-apps/dbus-1.6 required by (dev-python/dbus-python-99.1.0.0::unity-gentoo, ebuild scheduled for merge)
(and 3 more with the same problem)

x11-base/xorg-server:0

(x11-base/xorg-server-1.12.2::gentoo, installed) pulled in by
<x11-base/xorg-server-1.12.99 required by (x11-drivers/nvidia-drivers-295.59::gentoo, installed)

(x11-base/xorg-server-99.1.12.3::unity-gentoo, ebuild scheduled for merge) pulled in by
>=x11-base/xorg-server-99.1.12.3 required by (unity-base/unity-5.12.0::unity-gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

dev-libs/dbus-glib:0

(dev-libs/dbus-glib-0.98::gentoo, ebuild scheduled for merge) pulled in by
<dev-libs/dbus-glib-0.100 required by (dev-python/dbus-python-99.1.0.0::unity-gentoo, ebuild scheduled for merge)
(and 3 more with the same problem)

(dev-libs/dbus-glib-0.100::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)



I have no idea how to solve this...

edit3: OK, i solve the conflicts adding some packages to package.mask, but for the xorg-xserver, i do it in a dirty way.... i changed the nvidia-driver ebuild to accept the xorg-xserver-99.... now i will let my pc compile it, i guess it will be done only tomorow (i will sleep now)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sat Jul 28, 2012 7:59 am    Post subject: Reply with quote

You'll need to package.mask >=dbus-1.6 as it does not work with any version of libindicate yet (the indicator panel won't refresh and indicators don't initialise properly):
Add the following to your package.mask:
Code:
>=dev-libs/dbus-glib-0.100
>=sys-apps/dbus-1.6.0

Xorg-server versioning should be fixed now too.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Jul 29, 2012 5:23 am    Post subject: Reply with quote

I broke my system!!! (i guess) when i try to compile glib, i get this:


Code:

>>> Emerging (1 of 208) dev-libs/glib-99.2.32.3 from unity-gentoo
 * glib2.0_2.32.3.orig.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                         
[ ok ]
 * glib2.0_2.32.3-0ubuntu1.debian.tar.gz SHA256 SHA512 WHIRLPOOL size
;-) ...                                                                                                                                               
[ ok ]
 * pkg-config-0.26.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                             
[ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.3.8-gentoo/build
 * Found sources for kernel version:
 *     3.3.8-gentoo
 * Checking for suitable kernel configuration options...                                                                                                                                                                   
[ ok ]
>>> Unpacking source...
>>> Unpacking glib2.0_2.32.3.orig.tar.xz to
/var/tmp/portage/dev-libs/glib-99.2.32.3/work
>>> Unpacking glib2.0_2.32.3-0ubuntu1.debian.tar.gz to
/var/tmp/portage/dev-libs/glib-99.2.32.3/work
>>> Unpacking pkg-config-0.26.tar.gz to
/var/tmp/portage/dev-libs/glib-99.2.32.3/work
>>> Source unpacked in /var/tmp/portage/dev-libs/glib-99.2.32.3/work
>>> Preparing source in
/var/tmp/portage/dev-libs/glib-99.2.32.3/work/glib-2.32.3 ...
 * Applying 0001-Run-gio-tests-with-a-dbus-session.patch ...                                                                                                                                                               
[ ok ]
 * Applying 01_gettext-desktopfiles.patch ...                                                                                                                                                                               
[ ok ]
 * Applying 02_gettext-desktopfiles-ubuntu.patch ...                                                                                                                                                                       
[ ok ]
 * Applying 03_revert_git_single_include_error.patch ...                                                                                                                                                                   
[ ok ]
 * Applying 04_homedir_env.patch ...                                                                                                                                                                                       
[ ok ]
 * Applying 61_glib-compile-binaries-path.patch ...                                                                                                                                                                         
[ ok ]
 * Applying revert_schema_path_warning.patch ...                                                                                                                                                                           
[ ok ]
 * Applying gnetworkmonitor_dont_leak_networks.patch ...                                                                                                                                                                   
[ ok ]
"/var/tmp/portage/dev-libs/glib-99.2.32.3/work/pkg-config-0.26/pkg.m4"
-> "/var/tmp/portage/dev-libs/glib-99.2.32.3/work/pkg.m4"
 * Applying glib-2.12.12-fbsd.patch ...                                                                                                                                                                                     
[ ok ]
 * Applying glib-2.31.x-external-gdbus-codegen.patch ...                                                                                                                                                                   
[ ok ]
 * Running eautoreconf in
'/var/tmp/portage/dev-libs/glib-99.2.32.3/work/glib-2.32.3' ...
 * Skipping 'gtkdocize --copy' due gtkdocize not installed
 * Running libtoolize --install --copy --force --automake ...                                                                                                                                                               
[ ok ]
 * Running aclocal -I /var/tmp/portage/dev-libs/glib-99.2.32.3/work -I
m4macros ...                                                                                                                                         
[ ok ]
 * Running autoconf -I /var/tmp/portage/dev-libs/glib-99.2.32.3/work ...                                                                                                                                                   
[ ok ]
 * Running autoheader -I /var/tmp/portage/dev-libs/glib-99.2.32.3/work
...                                                                                                                                                 
[ ok ]
 * Running automake --add-missing --copy ...                                                                                                                                                                               
[ ok ]
 * Running elibtoolize in: glib-2.32.3/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 * Removing useless C++ checks ...                                                                                                                                                                                         
[ ok ]
>>> Source prepared.
>>> Configuring source in
/var/tmp/portage/dev-libs/glib-99.2.32.3/work/glib-2.32.3 ...
 * econf: updating glib-2.32.3/config.sub with
/usr/share/gnuconfig/config.sub
 * econf: updating glib-2.32.3/config.guess with
/usr/share/gnuconfig/config.guess
 * econf: updating pkg-config-0.26/config.sub with
/usr/share/gnuconfig/config.sub
 * econf: updating pkg-config-0.26/config.guess with
/usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=x86_64-pc-linux-gnu
--host=x86_64-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --libdir=/usr/lib64
--disable-dependency-tracking --disable-xattr --disable-man
--disable-gtk-doc --enable-fam --disable-selinux --disable-static
--disable-dtrace --disable-systemtap --with-pcre=internal
--with-threads=posix
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to disable maintainer-specific portions of Makefiles...
yes
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none
needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for the BeOS... no
checking for Win32... no
checking for Mac OS X Carbon support... no
checking for Mac OS X Cocoa support... no
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking whether we are using the GNU C Library 2.1 or newer... yes
checking whether to enable garbage collector friendliness... no
checking whether to disable memory pools... no
checking for x86_64-pc-linux-gnu-c++... x86_64-pc-linux-gnu-c++
checking whether we are using the GNU C++ compiler... yes
checking whether x86_64-pc-linux-gnu-c++ accepts -g... yes
checking dependency style of x86_64-pc-linux-gnu-c++... none
checking for x86_64-pc-linux-gnu-gcc... (cached) x86_64-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89...
(cached) none needed
checking dependency style of x86_64-pc-linux-gnu-gcc... (cached) none
checking whether x86_64-pc-linux-gnu-gcc and cc understand -c and -o
together... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for x86_64-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... /usr/bin/pkg-config:
error while loading shared libraries: libglib-2.0.so.0: cannot open
shared object file: No such file or directory
no
checking for gawk... (cached) gawk
checking for perl5... no
checking for perl... perl
checking for indent... no
checking for perl... /usr/bin/perl
checking for iconv_open... yes
checking whether to cache iconv descriptors... no
checking for ZLIB... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for inflate in -lz... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for LIBFFI... no
configure: error: in
`/var/tmp/portage/dev-libs/glib-99.2.32.3/work/glib-2.32.3':
configure: error: The pkg-config script could not be found or is too
old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables LIBFFI_CFLAGS
and LIBFFI_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sun Jul 29, 2012 7:45 am    Post subject: Reply with quote

Don't panic this is Gentoo, everything is repairable ;)

As root, try a 'revdep-rebuild' (part of the 'gentoolkit' package if you don't have it already).
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Sun Jul 29, 2012 2:08 pm    Post subject: Reply with quote

Had the same problem, this patched glib::unity-gnome configure script require pkg-config, which is linked against glib, so make sure You have any glib installed (for example glib::gentoo) prior to installing patched version.

BTW. I'm in the middle of emerging unity, I'll let You know results later.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Jul 29, 2012 4:41 pm    Post subject: Reply with quote

shiznix wrote:
Don't panic this is Gentoo, everything is repairable ;)

As root, try a 'revdep-rebuild' (part of the 'gentoolkit' package if you don't have it already).


thank you, but i already did it, but i will try re-run rev-dep rebuild...

^marcs wrote:

Had the same problem, this patched glib::unity-gnome configure script require pkg-config, which is linked against glib, so make sure You have any glib installed (for example glib::gentoo) prior to installing patched version.

BTW. I'm in the middle of emerging unity, I'll let You know results later.


i will try it too, thank you...
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Jul 30, 2012 1:34 am    Post subject: Reply with quote

^marcs wrote:

make sure You have any glib installed (for example glib::gentoo) prior to installing patched version.


i will try it too, thank you...[/quote]


The glib from gentoo repositories also failed to compile, except the unstable version (i forgot the version, but it worked!...) Thank you all, now i'm compiling, everything fine until now....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 24, 25, 26  Next
Page 1 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum