Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Welche Useflags für Mesa 8.0.3? [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Wed Jul 18, 2012 1:09 pm    Post subject: Welche Useflags für Mesa 8.0.3? [solved] Reply with quote

Also ich möchte media-libs/mesa updaten. Habe aus Verzweiflung eselect-opengl entfernt.

Code:
[blocks B      ] <x11-proto/glproto-1.4.15-r1 ("<x11-proto/glproto-1.4.15-r1" is blocking app-admin/eselect-opengl-1.2.6.1)
[blocks B      ] <media-libs/mesa-8.0.3-r1 ("<media-libs/mesa-8.0.3-r1" is blocking app-admin/eselect-opengl-1.2.6.1)



Ich habe eine Nvidia-Karte mit nvidia-drivers 302.17. Nutzen möchte ich media-libs/mesa wenn möglich mit vdpau. Leider hängt das mit dem gallium zusammen zieht einen Rattenschwanz hinter sich her.

So komme ich nicht weiter? Soll ich jetzt mesa-8.0.3 entfernen und die ältere Version wieder installieren?

Code:
eix media-libs/mesa
[I] media-libs/mesa
     Available versions:  7.10.3 7.11 7.11.2 8.0.3 ~8.0.3-r1 {bindist +classic d3d debug +egl g3dvl +gallium gbm gles gles1 gles2 hardened kernel_FreeBSD (+)llvm motif +nptl openvg osmesa pax_kernel pic selinux shared-dricore +shared-glapi vdpau video_cards_i915 video_cards_i965 video_cards_intel video_cards_mach64 video_cards_mga video_cards_nouveau video_cards_r100 video_cards_r128 video_cards_r200 video_cards_r300 video_cards_r600 video_cards_radeon video_cards_savage video_cards_sis video_cards_tdfx video_cards_via video_cards_vmware wayland xa xvmc}
     Installed versions:  8.0.3(14:11:33 18.07.2012)(classic egl g3dvl gallium llvm nptl shared-glapi vdpau -bindist -d3d -debug -gbm -gles1 -gles2 -kernel_FreeBSD -openvg -osmesa -pax_kernel -pic -selinux -shared-dricore -video_cards_i915 -video_cards_i965 -video_cards_intel -video_cards_nouveau -video_cards_r100 -video_cards_r200 -video_cards_r300 -video_cards_r600 -video_cards_radeon -video_cards_vmware -wayland -xa -xvmc)
     Homepage:            http://mesa3d.sourceforge.net/
     Description:         OpenGL-like graphic library for Linux


Last edited by ChrisJumper on Fri Jul 27, 2012 6:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 426

PostPosted: Wed Jul 18, 2012 1:32 pm    Post subject: Reply with quote

Die aktuellste app-admin/eselect-opengl-1.2.6.1 verträgt sich nicht mit "älteren" glproto und mesa Versionen, wie es aus den Blocks rauszulesen ist. Also entweder musst Du älteres "eselect-opengl" nehmen oder neuere glproto und mesa.
Mir gefällt die Möglichkeit 2 besser (nach vorne gehen).
Installiere also mindestens
Code:
emerge -1a =x11-proto/glproto-1.4.15-r1 =media-libs/mesa-8.0.3-r1
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Wed Jul 18, 2012 1:53 pm    Post subject: Reply with quote

ChrisJumper wrote:
Ich habe eine Nvidia-Karte mit nvidia-drivers 302.17. Nutzen möchte ich media-libs/mesa wenn möglich mit vdpau. Leider hängt das mit dem gallium zusammen zieht einen Rattenschwanz hinter sich her.

Hm, ist es wirklich nötig im mesa die galium vdpau Erweiterung einzubauen wenn du eh den proprietären nvidia Treiber nutzt?
Soweit mir bekannt ist diese Möglichkeit eher für den freien nouveau Treiber vorgesehen.
Sprich, normal wirst du media-libs/mesa[vdpau] vermutlich gar nicht benötigen wenn du den nvidia-blob Treiber nutzt.
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Wed Jul 18, 2012 2:02 pm    Post subject: Reply with quote

:)

Danke das hat mir schon sehr weitergeholfen. Jetzt weiß ich was ich machen muss, den xserver-aktuallisieren das neue glproto verwenden und mesa ohne vdpau bauen. Und auf eselect-opengl verzichten.

Josef.95
Ich dachte vdpau ist eben DAS Useflag für die Hardwarebeschleunigung bei Nvidia-Karten. In Zusammenhang mit medial-libs/mesa dachte ich eben das hier auch die Proprietären Nvidia-Treiber genutzt werden.

In dem Ebuild zieht "vdpau? ( g3dvl)" also g3dvl hinzu und "g3dvl? (gallium)". Dazu hat es mich sehr verwirrt das das neue glproto eselect-opengl ersetzt. Denn selbst ohne den neuen Server schon installiert zu haben führt dieser Block aktuell dazu das ich mesa nicht mehr installieren konnte.

Ich habe mich jetzt kurzfristig damit gerettet erstmal ältere Versionen von eselect-opengl, mesa und glproto zu installieren.

Vielen Dank für die schnelle Hilfe!
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1001

PostPosted: Wed Jul 18, 2012 5:35 pm    Post subject: Reply with quote

Nein, vdpau ist nicht DAS useflag für die hardwarebeschleunigung. vdpau ist nur eine api, die es video dekodern ermöglicht die grafikkarte zu verwenden.
Aber josef95 hat auch nicht ganz recht. mit nouveau lässt sich kein vdpau nutzen, nur mit dem nvidia-blob. nouveau hat das (noch?) nicht implementiert.
Zugegebenermaßen weiß ich auch nicht so ganz, für was mesa das braucht. üblicherweiße verwenden videoanwendungen sowas (vlc, mplayer(2), ffmpeg/libav glaub ich)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Wed Jul 18, 2012 7:32 pm    Post subject: Reply with quote

Christian99 wrote:
Aber josef95 hat auch nicht ganz recht. mit nouveau lässt sich kein vdpau nutzen, nur mit dem nvidia-blob. nouveau hat das (noch?) nicht implementiert.
Zugegebenermaßen weiß ich auch nicht so ganz, für was mesa das braucht. üblicherweiße verwenden videoanwendungen sowas (vlc, mplayer(2), ffmpeg/libav glaub ich)

Chrischan99! :)
Schau dir doch mal equery u mesa
+ + vdpau : Enable the VDPAU acceleration interface for the Gallium3D Video Layer.
an.
Das läuft prima mit dem nouveau Treiber, inklusive vdpau Support (hier tut es das schon seit längerem)
Zugegeben, es werden hier zZt mit nouveau noch nicht alle Features unterstützt, und die Performance ist auch noch nicht die die der nvidia-blob liefern könnte, aber grundsätzlicher VDPAU Support ist da.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1001

PostPosted: Wed Jul 18, 2012 7:53 pm    Post subject: Reply with quote

ah sorry. da für den nouveau treiber in der feature matrix unter video acceleration bestenfalls "wip" steht dachte ich , dass das noch nicht so wirklich geht. im gegensatz zum nvidia blob. aber bei mesa wird das anders verwendet, deswegen machts dann wohl keinen sinn mit dem blob.
Also mein irrtum :)
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Wed Jul 18, 2012 7:55 pm    Post subject: Reply with quote

Also je länger ich darüber Nachdenke je weniger Sinn macht es das ich mich da so vertan habe.

Den equery u muss ich mir unbedingt merken und mir den equery-Befehl auch mal genauer ansehen, habe es bisher immer nur bentzt um Dateien einem Paket zuzuordnen mit dem Parameter b.

Es ist aber gut zu hören das die Treiberalternative mittlerweile auch schon teilweise VDPAU unterstützt.
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Thu Jul 26, 2012 2:24 pm    Post subject: Reply with quote

Seltsam. Bin leider aktuell draußen in der Sonne und nicht an meinem Rechner, aber bei meinem letzten Versuch hat es nicht geklappt. selbst die neueste Stable Version von glproto wollte sich nicht zusammen mit eselect-opengl installieren lassen. eselect-opengl benötigen aber die nvidia-drivers, als auch mesa-8.0.3.

Bisher muss ich wohl auf eselect-opengl-1.2.6.1 verzichten.

Definitiv zu warm.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Thu Jul 26, 2012 6:29 pm    Post subject: Reply with quote

ChrisJumper wrote:
... selbst die neueste Stable Version von glproto wollte sich nicht zusammen mit eselect-opengl installieren lassen.
...
Bisher muss ich wohl auf eselect-opengl-1.2.6.1 verzichten.

Ja, selbst die neuste Stable Version von glproto (aktuell 1.4.15) ist zu alt für deine (gewünschte?) eselect-opengl-1.2.6.1 Version aus dem testing Zweig.
Muss es denn wirklich eselect-opengl aus dem testing Zweig sein?
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Fri Jul 27, 2012 6:32 pm    Post subject: Reply with quote

Stupid me!

Natürlich ich habe jetzt eselect-opengl aus der keywords Datei genommen. Ich muss mir unbedingt hinter jedem Keyword-Eintrag in Zukunft eine Notiz machen warum ich diesen Eintrag dort machte.

Nochmals vielen Dank Josef! Wenn ich dir mal ein paar Euro per Flattr zukommen lassen kann sag bescheid (z.b. pm). Hast mir jetzt schon so oft geholfen. Es ist schrecklich wenn man sich mit einem Problem nur Stundenweise beschäftigt und sich dazu keine Notizen macht.

Solved!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum