Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enemy-territory will not start.[solved]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Mon Jul 16, 2012 8:41 pm    Post subject: Enemy-territory will not start.[solved] Reply with quote

Just updated system and :



Code:
earthy@vomit ~ $ et
/usr/games/bin/et: line 10: /opt/enemy-territory/et.x86: No such file or directory

earthy@vomit ~ $    /opt/enemy-territory/et.x86
bash: /opt/enemy-territory/et.x86: No such file or directory

 ls    /opt/enemy-territory/       
Docs  et.x86  etmain  openurl.sh  pb  pbcl.db


My system is lying.Can anyone tell my system to stop lying?


Last edited by earthy on Tue Jul 17, 2012 9:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Mon Jul 16, 2012 8:59 pm    Post subject: Reply with quote

ls -l /opt/enemy-territory/ would probably give some more valuable information.

Blind guess: usermod -a -G games earthy (as root)
Second blind guess: chmod a+rx /opt/enemy-territory/et.x86 (as root also)
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Mon Jul 16, 2012 9:04 pm    Post subject: Reply with quote

Thank you for a quick answer,your guess however did not work.

# ls -l /opt/enemy-territory
total 1578
drwxr-x--- 3 earthy users 248 Jul 15 23:34 Docs
-rwxr-xr-x 1 earthy users 1604328 Jul 15 23:34 et.x86
drwxrwx--- 3 earthy users 560 Jul 15 23:34 etmain
-rwxr-x--- 1 earthy users 287 Jul 15 23:34 openurl.sh
drwxr-x--- 3 earthy users 304 Jul 15 23:34 pb
-rw-r--r-- 1 earthy users 206 Jan 21 18:26 pbcl.db
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon Jul 16, 2012 9:07 pm    Post subject: Reply with quote

the ownership looks wrong - it should be root:games. try unmerging and remerging it again.

and after the usermod command, you need to logout and login again.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Mon Jul 16, 2012 9:09 pm    Post subject: Reply with quote

Uh, ET wasn't installed from a portage ebuild? I think those files should belong to root:games (although I do not have ET installed).
Have you tried runnning et.x86 directly from its directory? I still suspect a trouble with permissions, maybe with a directory above?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Mon Jul 16, 2012 9:19 pm    Post subject: Reply with quote

I am sorry I forgot to mention that et was working before update.

@ Veldrin: unmerge/emerge fixed ownership but nothing more
Code:

earthy@vomit ~ $ ls -l  /opt/enemy-territory/     
total 1578
drwxr-x--- 3 root   games     248 Jul 16 21:12 Docs
-rwxr-x--- 1 root   games 1604328 Jul 16 21:12 et.x86
drwxrwx--- 3 root   games     560 Jul 16 21:12 etmain
-rwxrgorkypl-x--- 1 root   games     287 Jul 16 21:12 openurl.sh
drwxr-x--- 3 root   games     304 Jul 16 21:12 pb
-rw-r--r-- 1 earthy users     206 Jan 21 18:26 pbcl.db


@gorkypl I was trying to change the permissions to start et so that explains why they are like that.
"Have you tried runnning et.x86 directly from its directory?"
Yes as I said before.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon Jul 16, 2012 9:29 pm    Post subject: Reply with quote

yes, and it also states, that the normal user has to be in the games group for it to work.
post the output of groups; id

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Mon Jul 16, 2012 9:34 pm    Post subject: Reply with quote

Code:
groups; id
wheel audio video games users vboxusers earthy
uid=1000(earthy) gid=1000(earthy) groups=1000(earthy),10(wheel),18(audio),27(video),35(games),100(users),241(vboxusers)
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Mon Jul 16, 2012 10:13 pm    Post subject: Reply with quote

I am trying now
Code:
emerge emul-linux-x86-baselibs emul-linux-x86-compat emul-linux-x86-gtklibs emul-linux-x86-medialibs emul-linux-x86-qtlibs  emul-linux-x86-sdl emul-linux-x86-soundlibs emul-linux-x86-xlibs -av

cause I have seen on other forums that this might be a problem with 32bit emulation.
I enabled ia32 a.out support in kernel and rebooted but that changed nothing.I didn't use that option before but ET worked before.
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Mon Jul 16, 2012 10:28 pm    Post subject: Reply with quote

That did nothing OFC.I have googled around and found I had a similar problem 5 years ago > solution reinstall.
Also found an 8 year old unanswered post.I can't wait 8 years,by then I think noone will still be playing ET,but who could have guessed in 2003,that people would still be trying to play it in 2012? It is for times like this that I keep a Windows 7 on a partition.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 6:22 am    Post subject: Reply with quote

earthy wrote:

"Have you tried runnning et.x86 directly from its directory?"
Yes as I said before.

No, you haven't done it from the directory itself.
Code:

cd /opt/enemy-territory/
./et.x86


Quote:

I enabled ia32 a.out support in kernel and rebooted

Don't get me wrong, but I just have seen too many silly errors that I have to ask: 'enabled ia32 support in kernel' means you have rebuilt the kernel, copied vmlinuz to /boot and then rebooted, yes?

earthy wrote:
I am trying now
Code:
emerge emul-linux-x86-baselibs emul-linux-x86-compat emul-linux-x86-gtklibs emul-linux-x86-medialibs emul-linux-x86-qtlibs  emul-linux-x86-sdl emul-linux-x86-soundlibs emul-linux-x86-xlibs -av


It does not matter here, but I'd suggest to use '--oneshot' option when emerging such things.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 12:17 pm    Post subject: Reply with quote

I thought
Code:
cd /opt/enemy-territory/
./et.x86

was same as
Code:
/opt/enemy-territory/et.x86

It least it gives the same resaults.
I have compiled a kernel perhaps 1000 times and it always worked.
I was taught to :
Code:
cd /usr/src/linux && make menuconfig
(change options)
mount /boot
 make && make modules && make modules_install && make install
umount /boot

Is there any way to check IA32 support?
Some small program I can install?
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 4:17 pm    Post subject: Reply with quote

earthy wrote:

Is there any way to check IA32 support?
Some small program I can install?

You can enable CONFIG_IKCONFIG_PROC and check /proc/config.gz

Anyway, I'd like to see the output of following commands
Code:

emerge -pqv glibc
file /opt/enemy-territory/et.x86

Also please post the result of emerge --info

I suspect you have something wrong with your multilib environment.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 4:27 pm    Post subject: Reply with quote

Thanks for your help
Code:

emerge -pqv glibc
--- Invalid atom in /etc/portage/package.use: =media-video/ffmpeg
--- Invalid atom in /etc/portage/package.use: =virtual/ffmpeg
[ebuild   R   ] sys-libs/glibc-2.14.1-r3  USE="gd (multilib) -debug (-hardened) -profile (-selinux) -vanilla"

!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.1.102.55::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


How to enable CONFIG_IKCONFIG_PROC ?
You mean in kernel ?
Code:
file /opt/enemy-territory/et.x86
/opt/enemy-territory/et.x86: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 2.0.30, stripped



Code:
emerge --info
--- Invalid atom in /etc/portage/package.use: =media-video/ffmpeg
--- Invalid atom in /etc/portage/package.use: =virtual/ffmpeg
Portage 2.1.10.65 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2 x86_64)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-AMD_FX-tm-4100_Quad-Core_Processor-with-gentoo-2.1
Timestamp of tree: Tue, 17 Jul 2012 02:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.3-r2, 3.1.4-r3, 3.2.3-r1
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4-r1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo proaudio wavilen alice zugaina aluco
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=amdfam10 -mtune=amdfam10 -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.bytemark.co.uk/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/pro-audio /var/lib/layman/wavilen /var/lib/layman/alice /var/lib/layman/zugaina /var/lib/layman/aluco"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X \ a52 aac acl acpi alsa amd64 amr apache2 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt curl cxx dba dbus dri dts dvd dvdr emboss encode examples exif expat fam ffmpeg firefox flac fortran fpm gd gdbm gif gpm gtk iconv imagemagick innodb ipv6 jpeg ladspa lash lcms ldap libnotify libsamplerate lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl ntlm ogg openexr opengl openmp oss pam pango pcre pdf png policykit ppds pppd qt3support qt4 quicktime readline reiserfs sdl server session soundtouch spell sse sse2 sse3 sse4 ssl startup-notification svg symlinks tcpd tiff truetype twolame udev udisks unicode upower usb vhosts vorbis wxwidgets x264 xcb xml xml2 xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTAB
LES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 4:34 pm    Post subject: Reply with quote

Code:
cat /proc/config.gz
cat: /proc/config.gz: No such file or directory
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 4:46 pm    Post subject: Reply with quote

CONFIG_IKCONFIG_PROC=y must be set in kernel to make /proc/config.gz appear. You will also need CONFIG_BINFMT_ELF=y, and I'd set CONFIG_X86_X32=n just to be safe.
Please also paste the result of
Code:

ls -l /lib/ld-linux.so.2

and then the same with the files that are symlinked to ld, probably:
Code:

ls -l /lib32/ld-linux.so.2
ls -l /lib32/ld-2.14.so


Please also try doing
Code:

ldd /opt/enemy-territory/et.x86.bin

_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 5:28 pm    Post subject: Reply with quote

under CONFIG_IKCONFIG_PROC=y there is an option :
Code:
Enable access to .config through /proc/config.gz (NEW)

I presume I must set that one too.
there is no
Code:
CONFIG_X86_X32

in my kernel (Linux/x86_64 3.2.1-gentoo-r2)

Are you sure I have to change my kernel config.ET worked before on that kernel?

Code:
ls -l /lib/ld-linux.so.2
ls: cannot access /lib/ld-linux.so.2: No such file or directory

Code:


ls -l /lib32/ld-linux.so.2
lrwxrwxrwx 1 root root 12 Jul  3 22:33 /lib32/ld-linux.so.2 -> ld-2.14.1.so



Code:
ls -l /lib32/ld-2.14.so
ls: cannot access /lib32/ld-2.14.so: No such file or directory


Code:
ldd /opt/enemy-territory/et.x86.bin
ldd: /opt/enemy-territory/et.x86.bin: No such file or directory
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 6:03 pm    Post subject: Reply with quote

Code:
ls -l /lib/ld-linux.so.2
ls: cannot access /lib/ld-linux.so.2: No such file or directory

This is the reason. re-emerge glibc and check again.
If this will not help, do
Code:

emerge wgetpaste
wgetpaste -c "equery -N files glibc | grep lib32"

and paste the link you get as result

Code:
ls -l /lib32/ld-2.14.so
ls: cannot access /lib32/ld-2.14.so: No such file or directory

You were supposed to do 'ls -l /lib32/ld-2.14-1.so', but I suspect it is there anyway :)
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 6:33 pm    Post subject: Reply with quote

ET still gives the same results.Even after re-emerge
Code:
wgetpaste -c "equery -N files glibc | grep lib32"
Your paste can be seen here: http://bpaste.net/show/35466/


Last edited by earthy on Tue Jul 17, 2012 6:35 pm; edited 2 times in total
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 6:33 pm    Post subject: Reply with quote

ls -l /lib32/ld-2.14-1.so
ls: cannot access /lib32/ld-2.14-1.so: No such file or directory
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 6:42 pm    Post subject: Reply with quote

It was meant to be 2.14.1.so, but nevermind, I see it is there from the wgetpaste content.
Please do
Code:

ls -l /

and paste the result.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 6:47 pm    Post subject: Reply with quote

Code:
ls -l /
total 196036
drwxr-xr-x   2 root root      2560 Jul 17 16:05 bin
drwxr-xr-x   2 root root        48 Jan 17 18:37 boot
drwxr-xr-x  15 root root      3920 Jul 17 02:00 dev
drwxr-xr-x  94 root root      5616 Jul 17 18:45 etc
drwxr-xr-x   4 root root       144 Jul 15 22:17 home
drwxr-xr-x   4 root root       120 Jul 17 16:03 lib
lrwxrwxrwx   1 root root         5 Jul 17 18:24 lib.backup.0000 -> lib64
drwxr-xr-x   3 root root      3728 Jul 17 18:24 lib32
drwxr-xr-x  10 root root      4504 Jul 17 18:24 lib64
drwxr-xr-x   6 root root       216 Jul 17 15:43 media
drwxr-xr-x   2 root root        72 Jan 12  2012 mnt
drwxr-xr-x  11 root root       320 Jul 16 21:53 opt
-rw-r--r--   1 root root  43440164 Jan 16  2012 portage-latest.tar.bz2
dr-xr-xr-x 146 root root         0 Jul 17 02:00 proc
drwx------  18 root root      1176 Jul 17 15:37 root
drwxr-xr-x   4 root root        80 Jul 17 02:00 run
drwxr-xr-x   2 root root      4792 Jul 17 18:24 sbin
-rw-r--r--   1 root root 157080992 Jan 16  2012 stage3-amd64-20120112.tar.bz2
drwxr-xr-x  12 root root         0 Jul 17 02:00 sys
drwxrwxrwt   8 root root       320 Jul 17 18:45 tmp
drwxr-xr-x  15 root root       424 Mar  9 13:23 usr
drwxr-xr-x  14 root root       368 Apr  5 20:21 var
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 6:53 pm    Post subject: Reply with quote

So it is clear now. What is 'lib.backup.0000'? Did you have a disk failure perhaps? Anyway, just remove the backup symlink, as it is absolutely not needed.
Next, do you have anything in /lib?
If not, just remove this directory and do 'ln -s /lib64 /lib'. It will fix the issue.
If yes, then your system is a bit broken and will need further repair. You can post the output of 'equery belongs /lib/*' if there are any files there.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
earthy
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2006
Posts: 145

PostPosted: Tue Jul 17, 2012 7:14 pm    Post subject: Reply with quote

No disk failure that I know of and I did reiserfsck without errors yesterday.I have no idea what lib.backup.0000 is.never saw it before.
Code:

equery belongs /lib/*
 * Searching for /lib/cpp,/lib/modules,/lib/udev ...
app-emulation/virtualbox-4.1.12 (/lib/udev)
app-emulation/virtualbox-guest-additions-4.1.12 (/lib/modules)
app-emulation/virtualbox-guest-additions-4.1.12 (/lib/udev)
app-emulation/virtualbox-modules-4.1.12 (/lib/modules)
app-pda/synce-core-0.16 (/lib/udev)
media-sound/alsa-utils-1.0.25-r1 (/lib/udev)
net-wireless/bluez-4.99 (/lib/udev)
sys-auth/consolekit-0.4.5_p20120320 (/lib/udev)
sys-fs/fuse-2.8.6 (/lib/udev)
sys-fs/lvm2-2.02.88 (/lib/udev)
sys-fs/ntfs3g-2012.1.15-r1 (/lib/udev)
sys-fs/udev-171-r6 (/lib/udev)
sys-fs/udisks-1.0.4-r2 (/lib/udev)
sys-power/upower-0.9.16 (/lib/udev)
x11-drivers/nvidia-drivers-295.59 (/lib/modules)
x11-drivers/nvidia-drivers-295.59 (/lib/udev)
x11-drivers/xf86-video-virtualbox-4.1.12 (/lib/modules)
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Jul 17, 2012 7:42 pm    Post subject: Reply with quote

Yeah, exactly as I have expected, and very unfortunately, your system is b0rked.

Quick explanation what have happened:
The /lib should be just a symlink to /lib64. Some time ago on your system it became a standalone directory, and applications that were emerged after this point put their files into /lib instead of /lib64. So now you have some files in /lib and some in /lib64, while they should all be in /lib64.

Here is a solution that *should* work, but be prepared that your system may as well become unresponsive and will need to be restarted from install CD to proceed, so don't do it if you need to rely on your machine now.
Code:

cp -a /lib/* /lib64/
rm -rf /lib
ln -s /lib64 /lib


If it works you may want to reinstall the most critical packages (udev, lvm2, glibc). ET should also work after this :)
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum