Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] Pro audio production applications, Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Sat Jun 02, 2012 12:42 am    Post subject: Reply with quote

I'm going to take a look at mixxx myself. I'll let you know what happens.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
wol
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2002
Posts: 107

PostPosted: Sat Jun 02, 2012 10:23 pm    Post subject: Lash-0.6.0_rc2 fails to emerge (Partially solved) Reply with quote

Lash fails to emerge for me with an error regarding texi2html. I got it to emerge by temporarily deleting texi2html.

This is on a general purpose box, just trying to get it to emerge before playing with seed kernels et al. Any pointers would be appreciated.

Error message as follows.

Code:


make[3]: Entering directory `/var/tmp/portage/media-sound/lash-0.6.0_rc2/work/lash-0.6.0.594/docs'
if test ! -d lash-manual-html-one-page; then \
  mkdir lash-manual-html-one-page; \
fi
if test ! -d lash-manual-html-split; then \
  mkdir -lash-manual-html-split; \
fi
cd lash-manual-html-one-page && \
  texi2html --number ../../docs/lash-manual.texi
Option number is ambiguous (number-footnotes, number-sections)
Try `texi2html --help' for more information.
make[3]: *** [html-manual-stamp] Error 2
make[3]: Leaving directory `/var/tmp/portage/media-sound/lash-0.6.0_rc2/work/lash-0.6.0.594/docs'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-sound/lash-0.6.0_rc2/work/lash-0.6.0.594/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-sound/lash-0.6.0_rc2/work/lash-0.6.0.594'
make: *** [all] Error 2
emake failed
 * ERROR: media-sound/lash-0.6.0_rc2 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 2304:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *
 * If you need support, post the output of `emerge --info '=media-sound/lash-0.6.0_rc2'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/lash-0.6.0_rc2'`.
 * This ebuild is from an overlay named 'proaudio': '/var/lib/layman/pro-audio/'
 * The complete build log is located at '/var/tmp/portage/media-sound/lash-0.6.0_rc2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/lash-0.6.0_rc2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/lash-0.6.0_rc2/work/lash-0.6.0.594'
 * S: '/var/tmp/portage/media-sound/lash-0.6.0_rc2/work/lash-0.6.0.594'

>>> Failed to emerge media-sound/lash-0.6.0_rc2, Log file:


emerge --info as follows:

Code:

Portage 2.1.10.64 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.15-r2, 3.4.0-gentoo x86_64)
=================================================================
System uname: Linux-3.4.0-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_6400_@_2.13GHz-with-gentoo-2.1
Timestamp of tree: Sat, 02 Jun 2012 16:00:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.8, 2.7.3, 3.1.4-r4, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.5-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo lisp cj-overlay gentoo-haskell proaudio
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1, AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="rsync://gentoo.mirrors.tds.net/gentoo http://gentoo.wetzlmayr.com/ ftp://mirror.datapipe.net/gentoo http://gentoo.mirrors.tds.net/gentoo http://mirrors.rit.edu/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/cj-overlay /var/lib/layman/haskell /var/lib/layman/pro-audio"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="256-color X a52 aac access accessibility acl acpi alsa amd64 apache2 apng arts asf aspell avi bbdb berkdb big-tables bitmap-fonts bluetooth branding bzip2 cairo calendar cdda cddax cdio cdr cgi classic cleartype cli clucene consolekit corefonts cracklib crypt css ctype cups curl cxx dba dbus declarative dri dso dssi dts dv dvd dvdnav dvdr dvdread dvdx4linux emacs embedded emboss encode exif extensions extra extraengine extras fam fame fastcgi ffmpeg firefox flac fontconfig force-cgi-redirect fortran fpm fts3 gcj gd gdbm gif gimp git glib glibc-compat glitz gnome gnuplot gpg gpm graphviz gstreamer gtk gtk2 gtkhtml hash hbci hfs hfsplus hpfs iconv icu id3 id3tag ieee1394 imagemagick imap imlib innodb ipod ipv6 ithreads jack jackmidi java jpeg jpeg2k jpg json kde kpathsea ladspa lame lash latex lcms ldap libffi libgcrypt libgda libnotify logitech-mouse logrotate lv2 mad maildir melt mhash midi minizip mmx mmx2 mmxext mng modules mono mozdevelop mozilla mozilla-firefox mp3 mp4 mpeg mpeg2 mudflap multilib mysql ncurses nls nptl nsplugin nsplugins nss nv nvidia ofx ogg opengl openmp pam pango pcre pdf pdflib pdo pdo-external pear pecl perl pg-intdatetime phonon php php5 plasma png policy policykit postgres postgresql ppds pppd pulseaudio python qt qt3support qt4 qtalsa quicktime quotes rar readline reflection samba sasl sbcl scanner sdl secure-delete semantic-desktop session simplexml sip slang slp smbclient smime smtp sndfile snmp sockets spell spl sql sqlite sqlite3 sse sse2 ssl startup-notification subtitles subversion svg svn syslog taglib tcl tcltk tcpd tetex threads tiff timidity tk tokenizer tordns truetype truetype-fonts type1 udev udisks unicode upower usb usb2 utf8 video virtuoso vorbis vst wav weather webdav webkit wxwidgets x x264 xcb xcomposite xetex xft xine xinerama xinetd xml xml2 xmlreader xmp xorg xsl xterm-color xulrunner xv xvid zlib" ALSA_CARDS="intel8x10" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
Intellectual dishonesty is a mortal sin.


Last edited by wol on Sat Jun 02, 2012 10:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Sat Jun 02, 2012 10:39 pm    Post subject: Reply with quote

I prefer jack session.
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Sun Jun 03, 2012 3:09 am    Post subject: Re: Lash-0.6.0_rc2 fails to emerge (Partially solved) Reply with quote

wol wrote:
Lash fails to emerge for me with an error regarding texi2html. I got it to emerge by temporarily deleting texi2html.
This is on a general purpose box, just trying to get it to emerge before playing with seed kernels et al. Any pointers would be appreciated.

Hi, wol. I created a patch to fix texi2html related failure, in proaudio overlay. Please sync the overlay and try lash. It should be working now.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Sun Jul 15, 2012 2:05 pm    Post subject: Reply with quote

When trying to emerge psychosynth, I get this error:

Code:

# emerge --ask media-sound/psychosynth

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-games/ois-1.3  USE="-static-libs"
[ebuild  N     ] media-libs/devil-1.7.8-r1  USE="X gif jpeg lcms mng opengl png sdl sse sse2 tiff xpm -allegro -glut -nvtt -openexr -sse3 -static-libs"
[ebuild  N     ] dev-games/ogre-1.7.4-r1  USE="boost freeimage opengl zip -cg -doc -double-precision -examples -ois -poco -profile -tbb -threads -tools"
[ebuild  N     ] dev-games/cegui-0.7.6-r1  USE="devil gtk lua ogre opengl pcre truetype xml -bidi -debug -doc -examples -expat -irrlicht -static-libs -tinyxml -xerces-c -zip"
[ebuild  N     ] dev-games/ogre-1.6.5  USE="cegui devil gtk -cg -doc -double-precision -examples -threads"
[ebuild  N    ~] media-sound/psychosynth-0.2.0  USE="alsa jack psynth3d sndfile vorbis xml -osc -oss -static-libs -test"
[blocks B      ] >dev-games/cegui-0.6.3 (">dev-games/cegui-0.6.3" is blocking dev-games/ogre-1.6.5)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-games/ogre:0

  (dev-games/ogre-1.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/ogre-1.7 required by (dev-games/cegui-0.7.6-r1::gentoo, ebuild scheduled for merge)

  (dev-games/ogre-1.6.5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/ogre-1.4.7[cegui,devil] required by (media-sound/psychosynth-0.2.0::proaudio, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Then, I tried emerging again with the --backtrack=30 option, as advised in the above message, and it didn't help.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Mon Jul 16, 2012 1:15 pm    Post subject: Reply with quote

noosphere wrote:
When trying to emerge psychosynth, I get this error:

Code:

# emerge --ask media-sound/psychosynth

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-games/ois-1.3  USE="-static-libs"
[ebuild  N     ] media-libs/devil-1.7.8-r1  USE="X gif jpeg lcms mng opengl png sdl sse sse2 tiff xpm -allegro -glut -nvtt -openexr -sse3 -static-libs"
[ebuild  N     ] dev-games/ogre-1.7.4-r1  USE="boost freeimage opengl zip -cg -doc -double-precision -examples -ois -poco -profile -tbb -threads -tools"
[ebuild  N     ] dev-games/cegui-0.7.6-r1  USE="devil gtk lua ogre opengl pcre truetype xml -bidi -debug -doc -examples -expat -irrlicht -static-libs -tinyxml -xerces-c -zip"
[ebuild  N     ] dev-games/ogre-1.6.5  USE="cegui devil gtk -cg -doc -double-precision -examples -threads"
[ebuild  N    ~] media-sound/psychosynth-0.2.0  USE="alsa jack psynth3d sndfile vorbis xml -osc -oss -static-libs -test"
[blocks B      ] >dev-games/cegui-0.6.3 (">dev-games/cegui-0.6.3" is blocking dev-games/ogre-1.6.5)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-games/ogre:0

  (dev-games/ogre-1.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/ogre-1.7 required by (dev-games/cegui-0.7.6-r1::gentoo, ebuild scheduled for merge)

  (dev-games/ogre-1.6.5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/ogre-1.4.7[cegui,devil] required by (media-sound/psychosynth-0.2.0::proaudio, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Then, I tried emerging again with the --backtrack=30 option, as advised in the above message, and it didn't help.


What is the output of emerge --info?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Mon Jul 16, 2012 1:56 pm    Post subject: Reply with quote

audiodef wrote:

What is the output of emerge --info?


Code:

% emerge --info
Portage 2.1.10.65 (default/linux/amd64/10.0/desktop, gcc-4.5.3, unavailable, 3.3.8-gentoo x86_64)
=================================================================
System uname: Linux-3.3.8-gentoo-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-gentoo-2.0.3
Timestamp of tree: Thu, 12 Jul 2012 12:45:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.8
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6::<unknown repository>, 1.5, 1.6.3::<unknown repository>, 1.7.9-r1, 1.8.5-r3::<unknown repository>, 1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.1.2, 4.3.4, 4.4.4-r2, 4.5.3-r1
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo proaudio kde-sunset sunrise lisp gentoo-haskell local-repo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL IBM-J1.5 IBM-J1.6 sun-bcla-java-vm Q3AEULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -falign-functions=64 -fomit-frame-pointer -ftracer -funit-at-a-time -fweb -fforce-addr -fpeel-loops -funswitch-loops -frename-registers -msse"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -falign-functions=64 -fomit-frame-pointer -ftracer -funit-at-a-time -fweb -fforce-addr -fpeel-loops -funswitch-loops -frename-registers -msse"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch parse-eapi-ebuild-head protect-owned sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.netnitco.net"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/pro-audio /var/lib/layman/kde-sunset /var/lib/layman/sunrise /var/lib/layman/lisp /var/lib/layman/haskell /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi alsa amd64 apache2 apm avi bash-completion bcmath berkdb branding bzip2 bzlib cairo cdda cdparanoia cdr cli consolekit cracklib crypt cscope ctype cups curl curlwrappers cxx dbm dbus djvu dri dts dvd dvdr dvdread dvi emboss emul-linux-x86 encode exif fam fbcon ffmpeg firefox flac flatfile fortran ftp gdbm gif gimp gimpprint gpm gstreamer gtk gtk2 iconv imagemagick imap imlib jack jpeg jpeg2k kde kdexdeltas lash lcms ldap lesstif libedit libnotify lirc lm_sensors loop-aes lua mad midi mime mmap mmx mng modules mozilla mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nptlonly offensive ogg opengl openmp pam pango pcntl pcre pdf perl plotutils png policykit posix postgres ppds pppd qt qt3support qt4 readline sdl session sharedmem slang sndfile sockets spamassassin spell sql sqlite sse sse2 ssl startup-notification svg sysvipc t1lib tcltk tcpd tiff truetype udev udisks unicode upower usb vim vim-syntax vorbis wma wxwidgets x264 xattr xcb xml xml2 xmms xorg xosd xpm xv xvid zlib zsh-completion" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias actions alias asis auth auth_anon auth_basic auth_dbm auth_digest autoindex cache case-filter-in case_filter cern-meta cgi cgid charset-lite dav dav-fs deflate dir disk-cache echo env expires expires ext-filter file-cache headers imap include info log_config logio mem-cache mime mime-magic negotiation proxy proxy-connect proxy-ftp proxy-http rewrite s setenvif speling status unique-id userdir usertrack vhost-alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" LIRC_DEVICES="irman devinput userspace" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="snapscan" USERLAND="GNU" VIDEO_CARDS="fbdev radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Mon Jul 16, 2012 10:53 pm    Post subject: Reply with quote

noosphere: What else are you using that requires ogre? When I try to compile psychosynth, the ebuild doesn't require higher than ogre-1.6.5. I see in your use flags you don't have "ogre".
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Sat Jul 21, 2012 10:19 pm    Post subject: Reply with quote

audiodef wrote:
noosphere: What else are you using that requires ogre? When I try to compile psychosynth, the ebuild doesn't require higher than ogre-1.6.5. I see in your use flags you don't have "ogre".


Looks like when I was trying to get this working, I put the following line in to /etc/portage/package.use:

Code:

  dev-games/cegui devil ogre


I just tried taking that line out, and now the error I get when trying to emerge psychosynth is:

Code:

# emerge --ask media-sound/psychosynth

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-games/ois-1.3  USE="-static-libs"
[ebuild  N     ] dev-games/cegui-0.7.6-r1  USE="gtk lua opengl pcre truetype xml -bidi -debug -devil -doc -examples -expat -irrlicht -ogre -static-libs -tinyxml -xerces-c -zip"
[ebuild  N     ] media-libs/devil-1.7.8-r1  USE="X gif jpeg lcms mng opengl png sdl sse sse2 tiff xpm -allegro -glut -nvtt -openexr -sse3 -static-libs"
[ebuild  N     ] dev-games/ogre-1.6.5  USE="cegui devil gtk -cg -doc -double-precision -examples -threads"
[ebuild  N    ~] media-sound/psychosynth-0.2.0  USE="alsa jack psynth3d sndfile vorbis xml -osc -oss -static-libs -test"
[blocks B      ] >dev-games/cegui-0.6.3 (">dev-games/cegui-0.6.3" is blocking dev-games/ogre-1.6.5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-games/ogre-1.6.5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/ogre-1.4.7[cegui,devil] required by (media-sound/psychosynth-0.2.0::proaudio, ebuild scheduled for merge)

  (dev-games/cegui-0.7.6-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/cegui-0.5.0b-r3 required by (media-sound/psychosynth-0.2.0::proaudio, ebuild scheduled for merge)
    >=dev-games/cegui-0.5 required by (dev-games/ogre-1.6.5::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Mon Jul 23, 2012 12:00 am    Post subject: Reply with quote

When trying to emerge hydrogen, I get the following warning:

Code:

# emerge --ask media-sound/hydrogen

These are the packages that would be merged, in order:

Calculating dependencies... done!
 * EAPI assignment in ebuild 'media-sound/hydrogen-0.9.3-r1::proaudio'
 * does not conform with PMS section 7.3.1 (see bug #402167):
 *      valid EAPI assignment must occur on or before line: 5
 * NOTE: This error will soon become unconditionally fatal in a future
 * version of Portage, but at this time, it can by made non-fatal by
 * setting FEATURES=-parse-eapi-ebuild-head in make.conf.
[ebuild  N     ] media-sound/hydrogen-0.9.5  USE="alsa archive jack ladspa lash -oss -portaudio"

Would you like to merge these packages? [Yes/No]


Despite the warning, it does build fine, however. But I thought you might want to know about this so that it can be fixed in future ebuilds.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Mon Jul 23, 2012 1:42 pm    Post subject: Reply with quote

noosphere wrote:

Code:

[blocks B      ] >dev-games/cegui-0.6.3 (">dev-games/cegui-0.6.3" is blocking dev-games/ogre-1.6.5)


That would make me unmerge cegui and try again. Let me know if that works.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Mon Jul 23, 2012 1:44 pm    Post subject: Reply with quote

noosphere wrote:
When trying to emerge hydrogen, I get the following warning:

Code:

# emerge --ask media-sound/hydrogen

These are the packages that would be merged, in order:

Calculating dependencies... done!
 * EAPI assignment in ebuild 'media-sound/hydrogen-0.9.3-r1::proaudio'
 * does not conform with PMS section 7.3.1 (see bug #402167):
 *      valid EAPI assignment must occur on or before line: 5
 * NOTE: This error will soon become unconditionally fatal in a future
 * version of Portage, but at this time, it can by made non-fatal by
 * setting FEATURES=-parse-eapi-ebuild-head in make.conf.
[ebuild  N     ] media-sound/hydrogen-0.9.5  USE="alsa archive jack ladspa lash -oss -portaudio"

Would you like to merge these packages? [Yes/No]


Despite the warning, it does build fine, however. But I thought you might want to know about this so that it can be fixed in future ebuilds.


I started noticing that recently. I'm not really crazy that no backward compatibility is being done, as it will cause a lot of stuff to break.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Mon Jul 23, 2012 5:03 pm    Post subject: Reply with quote

audiodef wrote:
noosphere wrote:

Code:

[blocks B      ] >dev-games/cegui-0.6.3 (">dev-games/cegui-0.6.3" is blocking dev-games/ogre-1.6.5)


That would make me unmerge cegui and try again. Let me know if that works.


I didn't have cegui installed when I got that error.

However, looking back at all the error messages I got before, I just noticed that the the following lines explain why cegui was required at all:

Code:

(dev-games/cegui-0.7.6-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-games/cegui-0.5.0b-r3 required by (media-sound/psychosynth-0.2.0::proaudio, ebuild scheduled for merge)
    >=dev-games/cegui-0.5 required by (dev-games/ogre-1.6.5::gentoo, ebuild scheduled for merge)


So that says that I need cegui version 0.5.0b-r3 or greater, while the error message we were discussing earlier was complaining that cegui version 0.6.3 or greater was blocking ogre 1.6.5.

I just noticed that the following versions of cegui are available in portage: 0.6.2b 0.7.5-r1 0.7.6-r1 ~0.7.7

I guess that because cegui 0.7.6-r1 was the highest numbered available version in portage, portage chose it to emerge when emerging psychosynth. However, cegui 0.6.2b would fit the 0.5.0b-r3 or greater requirement, and yet would be smaller than 0.6.3 and therefore not block ogre 1.6.5

So, I manually emerge cegui 0.6.2b, and tried emerging psychosynth. This time it started emerging without complaint.

I don't know why portage couldn't have automatically tried resolve the block by trying to emerge cegui 0.6.2b itself. Oh well, as long as the manual process works..
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Mon Jul 23, 2012 9:05 pm    Post subject: Reply with quote

Well, I just tried to emerge psychosynth 0.2.0 and got a bunch of errors (see below).

The full build log can be seen here:

http://pastie.org/4308434

Code:

libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../.. -Wall -I/usr/include -I../../src -I../../src -DPSYNTH_DATA_DIR=\"/usr/share/psychosynth\" -I/usr/include/soundtouch -I/usr/include/libxml2 -I/usr/include/alsa -O2 -march=native -pipe -falign-functions=64 -fomit-frame-pointer -ftracer -funit-at-a-time -fweb -fforce-addr -fpeel-loops -funswitch-loops -frename-registers -msse -std=c++0x -DNDEBUG -c app/psynth_app.cpp  -fPIC -DPIC -o app/.libs/libpsynth_la-psynth_app.o
In file included from ../../src/psynth/base/file_manager.hpp:34:0,
                 from ../../src/psynth/app/file_manager_director.hpp:27,
                 from ../../src/psynth/app/director.hpp:39,
                 from ./app/psynth_app.hpp:34,
                 from app/psynth_app.cpp:44:
../../src/psynth/base/file_finder.hpp:40:0: warning: "BOOST_FILESYSTEM_VERSION" redefined
/usr/include/boost/filesystem.hpp:24:0: note: this is the location of the previous definition
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4/memory:101:0,
                 from ../../src/psynth/base/pointer.hpp:34,
                 from ../../src/psynth/base/iterator.hpp:38,
                 from ../../src/psynth/base/tree.hpp:39,
                 from ./base/logger.hpp:42,
                 from app/psynth_app.cpp:28:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4/bits/shared_ptr.h: In function ‘std::shared_ptr<_Tp1> std::make_shared(_Args&& ...) [with _Tp = psynth::io::buffered_async_output<psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >, psynth::io::alsa_output<psynth::sound::buffer_range<const psynth::sound::frame<short int, psynth::sound::layout<boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >*> > >, _Args = {std::basic_string<char>&, int, int}]’:
../../src/psynth/io/output_fwd.hpp:48:796:   instantiated from ‘psynth::io::buffered_async_output_ptr<Par__0, Par__1> psynth::io::new_buffered_async_output(Args&& ...) [with Par__0 = psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >, Par__1 = psynth::io::alsa_output<psynth::sound::buffer_range<const psynth::sound::frame<short int, psynth::sound::layout<boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >*> >, Args = {std::basic_string<char>&, int, int}]’
./app/output_director_alsa.hpp:68:75:   instantiated from here
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4/bits/shared_ptr.h:471:37: error: conversion from ‘boost::shared_ptr<psynth::io::buffered_async_output<psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >, psynth::io::alsa_output<psynth::sound::buffer_range<const psynth::sound::frame<short int, psynth::sound::layout<boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >*> > > >’ to non-scalar type ‘std::shared_ptr<psynth::io::buffered_async_output<psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >, psynth::io::alsa_output<psynth::sound::buffer_range<const psynth::sound::frame<short int, psynth::sound::layout<boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >*> > > >’ requested
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4/bits/shared_ptr.h: In function ‘std::shared_ptr<_Tp1> std::make_shared(_Args&& ...) [with _Tp = psynth::io::jack_output<psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > > >, _Args = {std::basic_string<char>&, int}]’:
../../src/psynth/io/output_fwd.hpp:61:633:   instantiated from ‘psynth::io::jack_output_ptr<Par__0> psynth::io::new_jack_output(Args&& ...) [with Par__0 = psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > >, Args = {std::basic_string<char>&, int}]’
./app/output_director_jack.hpp:65:72:   instantiated from here
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/include/g++-v4/bits/shared_ptr.h:471:37: error: conversion from ‘boost::shared_ptr<psynth::io::jack_output<psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > > > >’ to non-scalar type ‘std::shared_ptr<psynth::io::jack_output<psynth::sound::buffer_range<psynth::sound::planar_frame_iterator<const psynth::sound::scoped_sample_value<float, psynth::sound::float_minus_one, psynth::sound::float_one, psynth::sound::float_zero>*, boost::mpl::vector2<psynth::sound::left_channel, psynth::sound::right_channel> > > > >’ requested
make[3]: *** [app/libpsynth_la-psynth_app.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-sound/psychosynth-0.2.0/work/psychosynth-0.2.0/src/psynth'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-sound/psychosynth-0.2.0/work/psychosynth-0.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-sound/psychosynth-0.2.0/work/psychosynth-0.2.0'
make: *** [all] Error 2
emake failed
Back to top
View user's profile Send private message
noosphere
n00b
n00b


Joined: 09 Dec 2007
Posts: 11

PostPosted: Tue Jul 24, 2012 5:43 am    Post subject: Reply with quote

When trying to emerge media-sound/specimen-0.5.2_rc3 I get the following errors:

Code:

jackdriver.c: In function ‘process’:
jackdriver.c:84:6: error: too many arguments to function ‘jack_midi_get_event_count’
/usr/include/jack/midiport.h:57:1: note: declared here
jackdriver.c:126:10: error: too many arguments to function ‘jack_midi_event_get’
/usr/include/jack/midiport.h:72:1: note: declared here


Full emerge log can be seen here:

http://pastie.org/4312475
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Tue Jul 24, 2012 7:35 pm    Post subject: Reply with quote

noosphere wrote:

I don't know why portage couldn't have automatically tried resolve the block by trying to emerge cegui 0.6.2b itself. Oh well, as long as the manual process works..


I suspect it has to do with your using "amd64". I'm on "~amd64" and I didn't have that issue. Switching to ~arch is something I encourage for anyone trying to do serious audio stuff on Gentoo - see my Gentoo Studio guide linked in my sig.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Tue Jul 24, 2012 7:37 pm    Post subject: Reply with quote

noosphere wrote:
Well, I just tried to emerge psychosynth 0.2.0 and got a bunch of errors (see below).



I have never been able to successfully compile psychosynth on any machine - and I've tried several. :(

If someone figures it out, please let me know so I can document it in my Gentoo Studio guide.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Sun Aug 05, 2012 11:26 pm    Post subject: Reply with quote

Museseq's ebuild is out of date. Muse is up to 2.0.1 (stable) and the ebuild has to be re-written, because I was able to manually compile it, but was not able to simply copy the 1.0.1 ebuild to 2.0.1. Also, the 2.9999 ebuild isn't able to fetch - at least, it wasn't when I tried it. Either way, it's better to include an ebuild for the latest stable release.

EDIT: I've modified an existing ebuild to install MusE 2.0.1: http://audiodef.com/projects.php?project_id=8 (search the page for "muse").
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 788
Location: Greece

PostPosted: Wed Sep 12, 2012 6:13 am    Post subject: Reply with quote

Is there anyone here also having problems emerging media-sound/jack-audio-connection-kit-1.9.8 from proaudio?

I get the following:
Code:
◢ perjanus ◣ ~ $  emerge jack-audio-connection-kit

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-sound/jack-audio-connection-kit-1.9.8::proaudio [0.121.3::gentoo] USE="alsa dbus%* -32bit% -debug -doc -freebob% -ieee1394% (-3dnow%*) (-altivec%) (-coreaudio%) (-cpudetection%) (-examples%) (-mmx%*) (-oss%) (-pam%*) (-sse%*)" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

>>> Verifying ebuild manifests
>>> Emerging (1 of 1) media-sound/jack-audio-connection-kit-1.9.8 from proaudio
>>> Failed to emerge media-sound/jack-audio-connection-kit-1.9.8, Log file:
>>>  '/var/log/portage/media-sound:jack-audio-connection-kit-1.9.8:20120912-060243.log'
>>> Jobs: 0 of 1 complete, 1 failed                 Load avg: 1.56, 1.56, 1.25
 * Package:    media-sound/jack-audio-connection-kit-1.9.8
 * Repository: proaudio
 * Maintainer: proaudio@tuxfamily.org
 * USE:        alsa amd64 consolekit dbus elibc_glibc kernel_linux multilib policykit userland_GNU
 * FEATURES:   preserve-libs sandbox




>>> Unpacking source...
>>> Unpacking jack-1.9.8.tgz to /var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work
>>> Source unpacked in /var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work


>>> Preparing source in /var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8 ...
 * Tweaking common/wscript for python2...
 * Tweaking dbus/wscript for python2...
 * Tweaking example-clients/jack_control for python2...
 * Tweaking example-clients/wscript for python2...
 * Tweaking linux/wscript for python2...
 * Tweaking macosx/wscript for python2...
 * Tweaking man/wscript for python2...
 * Tweaking solaris/wscript for python2...
 * Tweaking tests/wscript for python2...
 * Tweaking Binary for python2...
sed: can't read Binary: No such file or directory
 * Tweaking file for python2...
sed: can't read file: No such file or directory
 * Tweaking waf for python2...
 * Tweaking matches for python2...
sed: can't read matches: No such file or directory
 * Tweaking wscript for python2...
>>> Source prepared.


>>> Configuring source in /var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8 ...
 * Running "./waf configure --prefix=/usr --destdir=/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/image/ --alsa --dbus" ...
Linux detected
Checking for program g++                 : ok /usr/bin/g++
Checking for compiler version            : ok 4.5.3
Checking for program cpp                 : ok /usr/bin/cpp
Checking for program ar                  : ok /usr/bin/ar
Checking for program ranlib              : ok /usr/bin/ranlib
Checking for g++                         : ok 
Checking for program gcc                 : ok /usr/bin/gcc
Checking for compiler version            : ok 4.5.3
Checking for program ar                  : ok /usr/bin/ar
Checking for program ranlib              : ok /usr/bin/ranlib
Checking for gcc                         : ok 
Checking for header samplerate.h         : ok
Checking for alsa >= 1.0.18              : ok
Checking for libfreebob >= 1.0.0         : Package "libfreebob (>= 1.0.0)" could not be found or the found version is too old.
Checking for libffado >= 1.999.17        : Package "libffado (>= 1.999.17)" could not be found or the found version is too old.
Checking for dbus-1 >= 1.0.0             : ok
Checking for dbus-1 flags                : ok
Checking for header expat.h              : ok
Checking for header samplerate.h         : ok
Checking for header sndfile.h            : ok
Checking for celt >= 0.5.0               : Package "celt (>= 0.5.0)" could not be found or the found version is too old.
Checking for header ncurses.h            : ok
Checking for library readline            : ok
Checking for celt >= 0.11.0              : Package "celt (>= 0.11.0)" could not be found or the found version is too old.
Checking for celt >= 0.8.0               : Package "celt (>= 0.8.0)" could not be found or the found version is too old.
Checking for celt >= 0.7.0               : Package "celt (>= 0.7.0)" could not be found or the found version is too old.
Checking for celt >= 0.5.0               : Package "celt (>= 0.5.0)" could not be found or the found version is too old.

==================                     
JACK 1.9.8 exported from r4653
Build with a maximum of 64 JACK clients
Build with a maximum of 768 ports per application
Install prefix                           : /usr
Library directory                        : /usr/lib
Drivers directory                        : /usr/lib/jack
Build debuggable binaries                : no
C compiler flags                         : ['-march=core2 -msse4 -mcx16 -msahf -O2 -pipe', '-Wall']
C++ compiler flags                       : ['-march=core2 -msse4 -mcx16 -msahf -O2 -pipe', '-Wall']
Linker flags                             : ['-lm -lstdc++']
Build doxygen documentation              : no
Build with engine profiling              : no
Build with 32/64 bits mixed mode         : no
Build standard JACK (jackd)              : no
Build D-Bus JACK (jackdbus)              : yes
Build with ALSA support                  : yes
Build with FireWire (FreeBob) support    : no
Build with FireWire (FFADO) support      : no
D-Bus service install directory          : /usr/share/dbus-1/services

Configuration finished successfully (00:00:00); project is now ready to build.
>>> Source configured.


>>> Compiling source in /var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8 ...
Usage: waf [options] [commands ...]

* Main commands: configure build install clean dist distclean uninstall distcheck
* Example: ./waf build -j4

waf: error: no such option: -l
 * ERROR: media-sound/jack-audio-connection-kit-1.9.8 failed (compile phase):
 *   waf build failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 713:  Called die
 * The specific snippet of code:
 *       ./waf build ${MAKEOPTS} || die "waf build failed"
 *
 * If you need support, post the output of `emerge --info '=media-sound/jack-audio-connection-kit-1.9.8'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/jack-audio-connection-kit-1.9.8'`.
 * This ebuild is from an overlay named 'proaudio': '/var/lib/layman/pro-audio/'
 * The complete build log is located at '/var/log/portage/media-sound:jack-audio-connection-kit-1.9.8:20120912-060243.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8'
 * S: '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8'



 * Messages for package media-sound/jack-audio-connection-kit-1.9.8:

 * Package:    media-sound/jack-audio-connection-kit-1.9.8
 * Repository: proaudio
 * Maintainer: proaudio@tuxfamily.org
 * USE:        alsa amd64 consolekit dbus elibc_glibc kernel_linux multilib policykit userland_GNU
 * FEATURES:   preserve-libs sandbox
 * Tweaking common/wscript for python2...
 * Tweaking dbus/wscript for python2...
 * Tweaking example-clients/jack_control for python2...
 * Tweaking example-clients/wscript for python2...
 * Tweaking linux/wscript for python2...
 * Tweaking macosx/wscript for python2...
 * Tweaking man/wscript for python2...
 * Tweaking solaris/wscript for python2...
 * Tweaking tests/wscript for python2...
 * Tweaking Binary for python2...
 * Tweaking file for python2...
 * Tweaking waf for python2...
 * Tweaking matches for python2...
 * Tweaking wscript for python2...
 * Running "./waf configure --prefix=/usr --destdir=/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/image/ --alsa --dbus" ...
 * ERROR: media-sound/jack-audio-connection-kit-1.9.8 failed (compile phase):
 *   waf build failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 713:  Called die
 * The specific snippet of code:
 *       ./waf build ${MAKEOPTS} || die "waf build failed"
 *
 * If you need support, post the output of `emerge --info '=media-sound/jack-audio-connection-kit-1.9.8'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/jack-audio-connection-kit-1.9.8'`.
 * This ebuild is from an overlay named 'proaudio': '/var/lib/layman/pro-audio/'
 * The complete build log is located at '/var/log/portage/media-sound:jack-audio-connection-kit-1.9.8:20120912-060243.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8'
 * S: '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.8/work/jack-1.9.8/jack-1.9.8'
 *
 * The following package has failed to build or install:
 *
 *  (media-sound/jack-audio-connection-kit-1.9.8::proaudio, ebuild scheduled for merge), Log file:
 *   '/var/log/portage/media-sound:jack-audio-connection-kit-1.9.8:20120912-060243.log'


Couldn't find anything googling the error...
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Sep 12, 2012 7:39 am    Post subject: Reply with quote

@Holysword : Check your MAKEOPTS if you get a -l (lowercase L) option. If you get one : Remove it.
_________________
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 788
Location: Greece

PostPosted: Wed Sep 12, 2012 8:24 am    Post subject: Reply with quote

aCOSwt wrote:
@Holysword : Check your MAKEOPTS if you get a -l (lowercase L) option. If you get one : Remove it.

That works, thank you.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Wed Nov 07, 2012 4:16 pm    Post subject: qt-xml patterns required Reply with quote

qt-xmlpatterns is required for qjackctl-9999. Here's an ebuild that includes it as a dependency, without which qjackctl will fail to start: http://forums.gentoo.org/viewtopic-p-7184634.html#7184634
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org


Last edited by audiodef on Thu Nov 15, 2012 2:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Thu Nov 08, 2012 4:56 pm    Post subject: jack-audio-connection-kit-1.9.8.ebuild - update Reply with quote

Updated working ebuild for jack-audio-connection-kit-1.9.8: http://forums.gentoo.org/viewtopic-p-7184630.html#7184630
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org


Last edited by audiodef on Thu Nov 15, 2012 2:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Thu Nov 08, 2012 8:52 pm    Post subject: foo-plugins ebuild update Reply with quote

Updated working ebuild for foo-plugins-1.2: http://forums.gentoo.org/viewtopic-p-7184626.html#7184626
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org


Last edited by audiodef on Thu Nov 15, 2012 2:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Fri Nov 09, 2012 3:34 pm    Post subject: lv2vocoder-1.tar.bz2 missing Reply with quote

If anyone still has the lv2vocoder-1.tar.bz2 tarball, I will host it and a modified ebuild. The source tarball is no longer available from its home page and I haven't found it lying around somewhere so far.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 15, 16, 17  Next
Page 16 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum