Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skype 4.0 for Linux
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Tue Jun 19, 2012 9:31 am    Post subject: Reply with quote

Did you look at the settings? There is an option to use the old style in chats.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Tue Jun 19, 2012 10:35 am    Post subject: Reply with quote

fiddled with that a bit. Still not quite as nice as the way it was - possibly some limitation or quirk in fluxbox? Dunno

not a significant nit, just a bit clunkier than it was before
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
aceFruchtsaft
Guru
Guru


Joined: 16 May 2004
Posts: 438
Location: Vienna, Austria

PostPosted: Thu Jun 21, 2012 12:28 pm    Post subject: Reply with quote

Has anyone of you had segfault issues with skype 4.0?

I already observed twice that Skype segfaults on startup every time, but then it works after I re-emerge it. I find this to be very strange.
I experimented with deleting ~/.Skype as was suggested in some other thread on skype-4.0 issues, but that did not help.

I am running everything on ~amd64.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Thu Jun 21, 2012 12:38 pm    Post subject: Reply with quote

Yes I had a segfault once and re-emerging helped. I had actually upgraded world before the segfault. Did you upgrade world both the times before the segfault?
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Jun 21, 2012 3:53 pm    Post subject: Reply with quote

aceFruchtsaft wrote:
it works after I re-emerge it

Wild guess: running prelink?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Thu Jun 21, 2012 4:57 pm    Post subject: Reply with quote

PaulBredbury wrote:
aceFruchtsaft wrote:
it works after I re-emerge it

Wild guess: running prelink?
Yes. Indeed.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
dc0m
n00b
n00b


Joined: 15 May 2010
Posts: 22

PostPosted: Tue Jun 26, 2012 8:03 pm    Post subject: Reply with quote

My USB microphone stopped working after upgrade. I use Logitech Quickcam Pro 9000. The USB microphone device is listed under audio settings but for some reason microphone is not working. I tried each setting and no luck.

Does anyone else have the same problem?

EDIT:

Problem fixed. I went ahead and tried to enable mic boost as one previously posted earlier, and that fixed the issue. Not sure why this works since that setting was for different sound device.
Back to top
View user's profile Send private message
Chaos Engine
n00b
n00b


Joined: 13 Jun 2003
Posts: 32
Location: Poland

PostPosted: Fri Jul 06, 2012 8:43 am    Post subject: Reply with quote

ppurka wrote:
PaulBredbury wrote:
aceFruchtsaft wrote:
it works after I re-emerge it

Wild guess: running prelink?
Yes. Indeed.


Bingo. I did run prelink on my system and after that skype have borked.
Re-emerging helped in my case - SOLVED :-)
_________________
In the beginning there was Chaos
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1740
Location: Mannheim, Germany

PostPosted: Thu Jul 12, 2012 9:31 am    Post subject: Reply with quote

I have that prelink issue with Skype too. Is there a fix? I like prelink too :)
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Jul 12, 2012 2:32 pm    Post subject: Reply with quote

Martux wrote:
Is there a fix?

Edit the prelinking script so it ignores /usr/bin/skype :?:
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Thu Jul 12, 2012 7:07 pm    Post subject: Reply with quote

PaulBredbury wrote:
Martux wrote:
Is there a fix?

Edit the prelinking script so it ignores /usr/bin/skype :?:
Yes. the exact thing to do is make an env file /etc/env.d/99skype and add the following line to it
Code:
PRELINK_PATH_MASK="/opt/bin/skype"
Then run env-update.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1740
Location: Mannheim, Germany

PostPosted: Thu Jul 12, 2012 10:43 pm    Post subject: Reply with quote

Thanks guys, that was a good idea!
@naveed047: LOL :roll:
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Kaste
Guru
Guru


Joined: 21 Dec 2005
Posts: 537
Location: /home Sweet /home

PostPosted: Wed Jul 18, 2012 3:19 pm    Post subject: Reply with quote

We are seeing a problem with Skype4 and homes on NFS4, I think it's due to 413119 but i can't really tell. The problem is that it doesn't login anymore. Is anyone else seeing something like this?
_________________
I'm a membar of Mesnar and me scull contains wakky secrets!
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Thu Aug 02, 2012 5:14 pm    Post subject: Reply with quote

At the end of the day skype-4.0 is not working for me. Calls are very choppy, often the other side loosing large chunks of what I am saying (interestingly, it usually starts after 20-30 second of conversation). skype-2.1.89 on the neightbouring machine on the same network seems working as fine as it ever did. with skype-2.2 crashing on login 2 out of 3 times, I am looking for a way to downgrade to 2.1.89 - does anybody still have and ebuild ?
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Fri Aug 03, 2012 7:15 pm    Post subject: Reply with quote

Trying to make sense of all this and just getting more confused. I added the ACCEPT_LICENSE line in make.conf for skype-4.0.0.7-copyright, and it came back with
Code:
 # emerge skype

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-4.0.0.7-r2::gentoo (masked by: ~amd64 keyword)
- net-im/skype-2.2.0.35-r99::gentoo (masked by: skype-eula license(s), ~amd64 keyword)
A copy of the 'skype-eula' license is located at '/usr/portage/licenses/skype-eula'.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


So then I changed the line to skype-eula and I got this:
Code:
 # emerge skype

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-4.0.0.7-r2::gentoo (masked by: skype-4.0.0.7-copyright license(s), ~amd64 keyword)
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

- net-im/skype-2.2.0.35-r99::gentoo (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


So then I used both lines in there and it does this:
Code:
# emerge skype

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-4.0.0.7-r2::gentoo (masked by: skype-4.0.0.7-copyright license(s), ~amd64 keyword)
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

- net-im/skype-2.2.0.35-r99::gentoo (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Can anyone shed some light on this?

Thanks,
~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1740
Location: Mannheim, Germany

PostPosted: Tue Aug 07, 2012 8:07 am    Post subject: Reply with quote

Personally, not giving a damn about licenses, I use
Code:

ACCEPT_LICENSE="*"

in /etc/make.conf

Also you could just put the Skype version you want to emerge into /etc/portage/package.unmask (create it if non-existant).
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
cord
Apprentice
Apprentice


Joined: 28 Apr 2007
Posts: 204

PostPosted: Tue Aug 07, 2012 10:11 am    Post subject: Reply with quote

Is there any open source alternative?
sorry for offtop
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2867
Location: Omnipresent

PostPosted: Tue Aug 07, 2012 10:38 am    Post subject: Reply with quote

cord wrote:
Is there any open source alternative?
sorry for offtop

There's Jitsi. (Gentoo bug with ebuild)

Try it out, let us know!

I would love to have an open source alternative for placing calls to and receiving calls from normal phones, that Just Works.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
cord
Apprentice
Apprentice


Joined: 28 Apr 2007
Posts: 204

PostPosted: Wed Aug 08, 2012 5:10 am    Post subject: Reply with quote

Hypnos wrote:
cord wrote:
Is there any open source alternative?
sorry for offtop

There's Jitsi. (Gentoo bug with ebuild)

Try it out, let us know!

I would love to have an open source alternative for placing calls to and receiving calls from normal phones, that Just Works.

All right, thank you. I'll try it.
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Wed Aug 08, 2012 7:33 am    Post subject: Reply with quote

dmpogo wrote:
I am looking for a way to downgrade to 2.1.89 - does anybody still have and ebuild ?


http://sources2.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-im/skype/?hideattic=0
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Sat Aug 11, 2012 9:29 pm    Post subject: Reply with quote

Marktux, thanks for your suggestions. I am having trouble, however, when I put the version I want in /etc/portage/package.unmask.

I emerge Skype and get:
Code:
 # emerge skype
--- Invalid atom in /etc/portage/package.unmask: net-im/skype-4.0.0.8-r1

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-4.0.0.8-r1::gentoo (masked by: ~amd64 keyword)
- net-im/skype-2.2.0.35-r99::gentoo (masked by: ~amd64 keyword


Can't seem to figure out a way around this.

Thanks.
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4929

PostPosted: Sun Aug 12, 2012 5:52 am    Post subject: Reply with quote

mark2 wrote:
Marktux, thanks for your suggestions. I am having trouble, however, when I put the version I want in /etc/portage/package.unmask.

I emerge Skype and get:
Code:
 # emerge skype
--- Invalid atom in /etc/portage/package.unmask: net-im/skype-4.0.0.8-r1

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-4.0.0.8-r1::gentoo (masked by: ~amd64 keyword)
- net-im/skype-2.2.0.35-r99::gentoo (masked by: ~amd64 keyword


Can't seem to figure out a way around this.

Thanks.

your entry in /etc/portage/package.unmask is invalid, if you wanted to mask skype-4.0.0.8-r1 you need to add the following line in /etc/portage/package.mask:
Code:
<net-im/skype-2.2.0.35-r99

also, you need to unkeyword net-im/skype-2.2.0.35-r99, for how to do that, google it.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Mon Aug 13, 2012 3:02 am    Post subject: Reply with quote

cach0rr0 wrote:
dmpogo wrote:
I am looking for a way to downgrade to 2.1.89 - does anybody still have and ebuild ?


http://sources2.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-im/skype/?hideattic=0


Thanks !
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1740
Location: Mannheim, Germany

PostPosted: Mon Aug 13, 2012 3:30 am    Post subject: Reply with quote

@mark2:

You can do it like DaggyStyle said, also this should work:

Code:

=net-im/skype-4.0.0.8-r1

in /etc/portage/package.mask. See the = to mask a specific version.
Did not really try it, because here skype-4.0.0.8-r1 runs just fine.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Earthwings
Administrator
Administrator


Joined: 14 Apr 2003
Posts: 7751
Location: Karlsruhe, Germany

PostPosted: Wed Aug 22, 2012 7:45 am    Post subject: Reply with quote

Split off topic 934150 which got off-topic.
_________________
KDE 4.13 - Get It While It's Hot!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum