Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[fixed] mozilla software & scim
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2588
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Jun 19, 2012 5:47 pm    Post subject: [fixed] mozilla software & scim Reply with quote

Hi

ich hab heute ein world update gemacht und www-client/firefox-10.0.5 und mail-client/thunderbird-10.0.5 wurden installiert.

Beim starten eines von beiden Programmen bekomme ich

Code:

firefox:25580): GLib-GObject-WARNING **: plugin '/usr/lib/gtk-2.0/immodules/im-scim.so' failed to register type 'GtkIMContextSCIM'


(firefox:25580): Gtk-WARNING **: Loading IM context type 'scim' failed



ich habe danach gegoogelt und meistens waren die Fragen, wie man scim mit GTK zum Laufen bringt. Doch mit allen anderen GTK Anwendungen die ich habe, läuft scim einwandfrei. Es sind nur die beiden mozilla Anwendungen.

Ich starte scim in ~/.fluxbox/startup so

Code:

export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
export XIM_PROGRAM="scim -d"
export XMODIFIERS=@im=SCIM
scim -d
scim -d -c socket -f x11 -e socket

...
exec /usr/bin/fluxbox -log ~/.fluxbox/log


Ich habe auch das hier gefunden https://bugzilla.mozilla.org/show_bug.cgi?id=643326 aber ich kann damit nicht wirklich etwas anfganen.

Ich habe versucht scim-bridge zu installieren und scim nicht mehr starten zu lassen, aber ich konnte dann nichts mehr verwenden. Erst wenn ich mit rechtem Mausklick auf ein GTK-Textfeld geklickt habe und dann Input Method -> Scim ausgewählt habe, habe ich scim nur für diese eine Anwendungen scim verwenden können. Firefox & Thunderbird lassen mir keine Inputs-Methode auswählen.

Das komische ist, dass als ich GTK_IM_MODULE auf scim-brige gesetzt habe, bekam ich die Fehlermeldungen nicht.

Kann jemand das Problem bestätigen? Hat jemand ne Ahnung, was da los geht?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!


Last edited by pablo_supertux on Tue Jun 19, 2012 10:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2588
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Jun 19, 2012 10:22 pm    Post subject: Reply with quote

Hab was gefunden: https://bugs.gentoo.org/show_bug.cgi?id=390053

diesen Patch hat mein Problem gefixt.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
kurisu
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 104
Location: Munich, Germany

PostPosted: Wed Jun 27, 2012 6:26 pm    Post subject: Reply with quote

Eine weitere Möglichkeit wäre auch auf IBus umzustellen. Als ich vor einigen Monaten auf ähnliche Probleme gestossen bin, habe ich diesen Schritt getan und bis heute nicht bereut.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum