Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Jak wymusić kompilację biblioteki 32 bit na arch. amd64?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 496

PostPosted: Sat Jun 23, 2012 7:43 pm    Post subject: Jak wymusić kompilację biblioteki 32 bit na arch. amd64? Reply with quote

Witam

Jakiś czas temu instalowałem Adobe-air i Iplę, i oczywiście Ipla wymaga 32 bitowego gnome-keyring.
Sciągnąłem z thinderboxa bibliotekę, wypakowałem do /usr/lib32 i gotowe.

Jednak chciałbym wiedzieć, na przyszłość, jak wymusić w Portage kompilację bilblioteki i386 na arch x86_64, kiedy taka jest potrzebna? - najlepiej tak, żeby była uwzględniona w systemie aktualizacji (dodana do world).

PS:
Iplę podnoszę takim skryptem, jakby ktoś szukał:
Code:
#!/bin/bash
rm -rf ~/.appdata/Adobe/AIR/ELS
env LD_LIBRARY_PATH="/usr/lib32:$LD_LIBRARY_PATH" airstart /opt/Adobe/ipla/iplalite.air


Pozdrawiam
8)
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 358
Location: Kraków

PostPosted: Sat Jun 23, 2012 8:49 pm    Post subject: Reply with quote

Musiałbyś się zainstalować crossdevem, ewentualnie kompilować samemu z palca. Generalnie, cross-kompilacja to to, co Cię interesuje.
Portage wspiera takie tricki, aczkolwiek nie jest to wymarzone wsparcie. No ale jest dość rzadko używane.
Na Twoim miejscu, jeżeli instalujesz potrzebujesz jednego pakietu dla jednego programu, to ściągnąłbym pierwszego lepszego rmpa i wrzucił do systemu plików. Tak po prostu.
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 496

PostPosted: Sat Jun 23, 2012 8:56 pm    Post subject: Reply with quote

Na razie zdażyło się z 1 (słownie jedną) biblioteką libgnome-keyring. :)

Ale chciałem wiedzieć, czy jest wykonalne cos w stylu, np:
Code:
ARCH="x86" emerge .....

czy coś podobnego.

Nawiasem pisząc, nie wiem nawet, jak z palca kompilować i386 na x86_64.
Pytam o coś podobnego do Debiana, gdzie po prostu instalujemy aptitude install paczka:i386 i gotowe.

Bo na razie ściągnąlem i wypakowalem "po prostu", ale w dokumentacji nie widzę sformulowania "po prostu" :)

Pozdrawiam
8)


Last edited by Jacekalex on Sat Jun 23, 2012 9:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 358
Location: Kraków

PostPosted: Sat Jun 23, 2012 9:00 pm    Post subject: Reply with quote

Jest też grupa pakietów dla amd64, oznaczonych jako compat. Sprawdź, czy tam nie ma.
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
znal
Apprentice
Apprentice


Joined: 12 Jul 2007
Posts: 177

PostPosted: Sun Jun 24, 2012 9:57 pm    Post subject: Reply with quote

Nie wiem czy to coś pomoże, ale jakiś czas temu instalowałem iplę (ebuild do niej i air wziąłem z http://gpo.zugaina.org/. Siedzę na ~amd64, ale nie posiadam gnome-keyring (używam KDE). Nie przypominam sobie, żebym musiał kombinować coś z ręcznym kopiowaniem plików do /usr/lib32.

Nie zagłębiałem się w dokładnie temat, ale ZTCW, to żeby mieć 32-bitowe biblioteki w 64-bitowym systemie obsługiwane przez portage, należy włączyć flagę multilib i zainstalować któryś z pakietów emul-linux-x86-*, a właściwie to powinny one być zależnościami danego ebuilda (air-sdk-bin, którego znalazłem tak ma).
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 496

PostPosted: Sun Jun 24, 2012 10:21 pm    Post subject: Reply with quote

@znal

Multilib mam włącznony, emul-linux-* zaciągnął Skype, także nie tędy droga.
Tu wszystko jest w najlepszym porządku.
Natomiast Ipla w Gnome musi mieć 32-bitową bibliotekę libgnome-keyring, i nic na to nie można poradzić, piłeczka po stronie Ipli.

Z resztą ten temat dotyczy ogólnie zagadnienia instalacji biliotek 32 bit w systemie 64 bit, i dotyczy pozycji, które nie mają opcji lib32 czy multilib.
Ipla tylko spowodowała, że zainteresowałem się tematem, bo sama Ipla u mnie juz działa od bardzo dawna. :twisted:
Jak znam życie, to mogą się kiedyś pojawić podobne kffffiatki.

Pozdrawiam
8)
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2837

PostPosted: Sun Jun 24, 2012 10:26 pm    Post subject: Reply with quote

mozesz wyslac do gcc '-m32' ale musisz miec tez wszystkie depy 32bitowe, a to jest trudne w systemie gdzie *.so nie maja zadnego sufixu odnosnie tego czy sa x86 czy x86_64, gdybym ja mial cos takiego zrobic, zbudowal bym po prostu statycznie ten lib w 32bitowym chroocie i go skopiowal, najmniej dlubania.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 496

PostPosted: Sun Jun 24, 2012 10:35 pm    Post subject: Reply with quote

Wyjście ekstremalne, ale wykonalne :)
Mam nadzieję, że nie będę miał wielu takich diabelstw, na razie tylko jedyny przypadek, bo budowanie w chroocie liba do środowiska graficznego typu Gnome zbyt wesoło nie wygląda.

Chyba jednak najmądrzejszym wyjściem (jabky w Thinderboxie czegoś brakowało) jest wypakowanie na żywca z paczki np deb albo rpm, byle z systemu o podobnych wersjach tego i owego. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum