Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openrc udev systemd update problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Thu Jun 21, 2012 11:56 pm    Post subject: openrc udev systemd update problems Reply with quote

it says openrc-0.9.9 is blocking the merging of packages (udev) and i cant figure this one out. i dont have openrc-0.9.9 installed, i have 0.9.8.(something) and cant get udev merged back, or start gdm or run startxfce4. im going to cry for an auto unblock feature with info on how to use it upon blockage... :(

edit to add that i have tried removing and reinstalling openrc and removed or installed udev wont merge back
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Jun 22, 2012 11:13 am    Post subject: Reply with quote

Please give us the complete emerge command output
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Fri Jun 22, 2012 9:01 pm    Post subject: Reply with quote

10-4, i just put ssh on the gentoo machine (im yacking from a fedora machine)...

Code:

sudo emerge udev
Calculating dependencies 
 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

... done!
[ebuild  N    ~] sys-apps/hwids-20120611
[ebuild  N    ~] sys-apps/kmod-9  USE="tools zlib -debug -doc -lzma -static-libs"
[ebuild  N    ~] sys-fs/udev-init-scripts-10
[ebuild  N    ~] sys-fs/udev-182-r3  USE="gudev hwdb introspection keymap openrc rule_generator -build -debug -doc -floppy (-selinux) -static-libs"
[blocks B      ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-182-r3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-182-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-182 required by (sys-fs/udev-init-scripts-10::gentoo, ebuild scheduled for merge)
    udev

  (sys-apps/openrc-0.9.8.4::gentoo, installed) pulled in by
    sys-apps/openrc required by (sys-fs/udev-init-scripts-10::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

sudo emerge --unmerge openrc
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 sys-apps/openrc
    selected: 0.9.8.4
   protected: none
     omitted: none

All selected packages: sys-apps/openrc-0.9.8.4

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in:  5 4 3 2 1 >>> Unmerging sys-apps/openrc-0.9.8.4...

openpty failed: 'out of pty devices'

 * GNU info directory index is up-to-date.

 * IMPORTANT: 5 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

sudo emerge udev       
Calculating dependencies 
 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

..... done!
[ebuild  N    ~] sys-apps/hwids-20120611
[ebuild  N    ~] sys-apps/kmod-9  USE="tools zlib -debug -doc -lzma -static-libs"
[ebuild  N     ] sys-apps/openrc-0.9.8.4  USE="ncurses pam unicode -debug (-selinux) -static-libs"
[ebuild  N    ~] sys-fs/udev-init-scripts-10
[ebuild  N    ~] sys-fs/udev-182-r3  USE="gudev hwdb introspection keymap openrc rule_generator -build -debug -doc -floppy (-selinux) -static-libs"
[blocks B      ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-182-r3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-182-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-182 required by (sys-fs/udev-init-scripts-10::gentoo, ebuild scheduled for merge)
    udev

  (sys-apps/openrc-0.9.8.4::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by (sys-fs/udev-init-scripts-10::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4141

PostPosted: Fri Jun 22, 2012 11:50 pm    Post subject: Reply with quote

as your output show ~ this mean you are running a stable tree and you have unmask some package.

and portage is telling you udev-182-r3 cannot be install without openrc-0.9.9 (so it doesn't tell you openrc-0.9.9 is blocking udev, but that udev is block because you cannot use it with an openrc that is not a 0.9.9 version)
right now, you don't have any openrc but portage is only grant to install the 0.9.8.4
so portage want to install udev as you ask it to do, but that version need an openrc version portage isn't grant to use.

Dunno for your solve:
- if openrc-0.9.9 is hardmask, you need to unmask that version as well so it could be install
- or you have unmask openrc, but restrict the unmask to a 0.9.8+ (but not 0.9.9) version, then, you must higher the unmask range to allow 0.9.9 too.
- or mask that udev version to use one able to build and run against the openrc-0.9.8 version
upto you...
Mixing stable and unstable... blahblahblah, i suppose someone already told you...
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Jun 23, 2012 7:25 am    Post subject: Reply with quote

Apparently you are running a mix of stable and testing. Either go with stable udev (emerge '~udev-171'), or accept testing (~) keywords for openrc (and possibly a few more packages).

And do check out the link that the emerge output gives you to the relevant part of the handbook, if you haven't already...
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Sun Jun 24, 2012 1:41 am    Post subject: Reply with quote

yes i am running a mix of stable and testing, ive built linux from scratch and other distributions and want some functions from others. ive been using auto unmask and etc update to put newer versions of somethings in. how do i unmask a package of the next version up?
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Jun 25, 2012 6:41 am    Post subject: Reply with quote

See http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3&chap=3
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Caladon
n00b
n00b


Joined: 13 Oct 2012
Posts: 15
Location: Vasa/Vörå

PostPosted: Wed Oct 24, 2012 5:53 am    Post subject: Reply with quote

Yeah I've had this type of problem too. I wanted to install the newest unstable wine application but it obviously dragged other unstable stuff too with it. For some reason I got the idea newest wine needed to have systemd totally set up too.

Then it complained about not having a really new openrc version so I uninstalled and reinstalled udev thinking "you already got udev WTH do you want?" so I deleted present version of openrc and blocked it from emerging again so the manager would get a newer version.

Good thing was it learned me to adjust packages a little. Did not know how that was done earlier.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum