Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[xorg] rafraichissement lent (contourné)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Fri Jun 22, 2012 5:09 pm    Post subject: [xorg] rafraichissement lent (contourné) Reply with quote

Bonjour,

Je viens d'installer xorg le serveur se lance bien, par contre le rafraichissement de xterm est plutôt lent quand je fais une install d'un logiciel depuis xterm l'ecran se rafraichit par vague successive idem sous fvwm quand on déplce une fenêtre on voit nettement la fenêtre se redessiner...

Est-il possible de paramétrer la fréquence de rafraichissement de l'affichage ? Est ce que cela se fait depuis xorg ou depuis le gestionnaire de fenêtre ou depuis xterm ?

Je ne sais pas trop ce dont vous avez besoin au niveau log, fichier de config etc... n'hésitez pas à me demander....

Merci pour votre aide


Last edited by Sirmk on Sun Jun 24, 2012 10:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Fri Jun 22, 2012 6:37 pm    Post subject: Reply with quote

Dans les log je viens de trouver ces lignes est ce que mon problème pourrait être lié à ça ?

Quote:
[ 2639.491] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[ 2639.491] (WW) fglrx(0): Hasn't establisted DRM connection
[ 2639.491] (WW) fglrx(0): No DRM connection for driver fglrx.
[ 2639.942] (WW) fglrx(0): ***********************************************************
[ 2639.942] (WW) fglrx(0): * DRI initialization failed *
[ 2639.942] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[ 2639.942] (WW) fglrx(0): * 2D and 3D acceleration disabled *
[ 2639.942] (WW) fglrx(0): ***********************************************************
[ 2639.966] (WW) fglrx(0): Textured Video not supported without DRI enabled.
[ 2639.968] (WW) fglrx(0): No XV video playback available
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Fri Jun 22, 2012 7:38 pm    Post subject: Reply with quote

Bonjour,

Il y a des chances que ton problème vienne effectivement d'un mauvais support matériel. Quelle est ta carte graphique et quel pilote utilises-tu ?

@+
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Fri Jun 22, 2012 8:27 pm    Post subject: Reply with quote

La commande :
Code:
lspci | grep VGA

me donne :
Quote:
01:05.0 VGA compatible controleur; Advanced Micro Devices [AMD] nee ATI RS880[Radeon HD 4200]

Il s'agit dune carte graphique intégrée sur une carte mère Asrock (AMD Athlon64).

J'utilise fglrx comme driver. Je viens de recompiler le noyau sans frame buffer et sans support DRI ce qui me donne le même message d'erreur dans le log de Xorg et n'a pas apporté d'amélioration notable.
Merci @+
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Fri Jun 22, 2012 9:23 pm    Post subject: Reply with quote

Demain j'essaierai les pilote libres je crois... :(
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 429
Location: France

PostPosted: Fri Jun 22, 2012 9:35 pm    Post subject: Reply with quote

Tu dois avoir un problème avec DRI, apparemment il n'arrive pas à s'initialiser
_________________
Save the penguins, burn the flags!
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sat Jun 23, 2012 7:51 am    Post subject: Reply with quote

Bonjour,

Je vais essayer d'installer le pilote qui m'est donné chez AMD : http://support.amd.com/fr/gpudownload/linux/Pages/radeon_linux.aspx?type=2.7&product=2.7.4.3.5.3.1&lang=English

merci pour la réponse
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sat Jun 23, 2012 2:45 pm    Post subject: Reply with quote

Le problème c'est que le support pour DRI est censé être désactivé...
http://wiki.cchtml.com/index.php/Gentoo_Installation_Guide
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sat Jun 23, 2012 2:54 pm    Post subject: Reply with quote

Faut-il activer le support AGP dans le noyau pour une carte graphique intégrée ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5609
Location: ~Brussels - Belgique

PostPosted: Sat Jun 23, 2012 10:01 pm    Post subject: Reply with quote

Oui, car la carte intégrée est vu par le système comme une carte graphique ordinaire. C'est juste que la puce n'est pas sur une autre plaquette mais sur la carte-mère, et connectée via AGP ou PCI Express.
_________________
Xavier Miller
[b:7b610e44ff](FR) Merci de respecter les règles du forum[/b:7b610e44ff].
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sat Jun 23, 2012 10:26 pm    Post subject: Reply with quote

Merci je commençais à me sentir un peu seul...
L'installation du fichier d'AMD a tous fait planter du coup j'ai refait une installation complete avec recompilation du noyau en activant le support DRM. Je vais utiliser les drivers Radeon cette fois ci. Là je compile mesa (c'est super long...) j'installerai Xorg tout à l'heure (ou demain). J'espère avoir plus de chance avec Radeon. Par contre dans /usr/src/linux/firmware je ne trouve pas mon matériel (RS880) ça m'inquiète... Je comprends pas je n'ai pourtant pas du matériel dernier cri...
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sat Jun 23, 2012 10:28 pm    Post subject: Reply with quote

XavierMiller wrote:
Oui, car la carte intégrée est vu par le système comme une carte graphique ordinaire. C'est juste que la puce n'est pas sur une autre plaquette mais sur la carte-mère, et connectée via AGP ou PCI Express.


Est ce que la connexion AGP ou PCI change quelque chose ? Je vais essayer de voir quel bus est utilisé dans la doc de ma carte mère....
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sat Jun 23, 2012 10:42 pm    Post subject: Reply with quote

Avec lspci j'ai une ligne :
Quote:
PCI bridge : Advanced blablabla RS780 PCI to PCI bridge (PCIE port 5)

ça doit être PCI express
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Sun Jun 24, 2012 10:40 pm    Post subject: Reply with quote

Bon je ne sais pas ce qu'il y a avec fglrx à mon avis le problème est soluble, toujours est-il qu'avec radeon le problème est résolu...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum