Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mplayer with vaapi?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3753
Location: sleeping in the bathtub

PostPosted: Tue Nov 29, 2011 8:37 pm    Post subject: mplayer with vaapi? Reply with quote

I know there is currently no support in mplayer proper (or mplayer2) for vaapi, but there are more than a few conflicting (and most likely outdated) sources/patchsets for this, so just wondering what exactly I need, what's the most up-to-date source, and is it just a patchset or does it require pulling a full git tree?

Also, any ebuilds? ;)

Thanks.
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
f4c3m3l70r
n00b
n00b


Joined: 19 Jul 2011
Posts: 40

PostPosted: Wed Nov 30, 2011 3:01 pm    Post subject: Reply with quote

There are new masked sources 2.0_p20111126 in portage right now.
_________________
i7-4820X | ROG RIVE | TridentX 16GB 2400MHz | SSD 840 Pro | Essence STX | GTX680
Back to top
View user's profile Send private message
LiquidAcid
Apprentice
Apprentice


Joined: 11 Sep 2006
Posts: 171

PostPosted: Tue Dec 06, 2011 9:33 am    Post subject: Reply with quote

f4c3m3l70r wrote:
There are new masked sources 2.0_p20111126 in portage right now.

mplayer2 includes no vaapi code as of now, so this won't help.

You need this:
http://gitorious.org/vaapi/mplayer
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sat Jan 07, 2012 11:29 am    Post subject: Reply with quote

since my (new) system ships an embedded intel hd card I am awaiting a simple console-based media player, able to utilize vaapi.
I moved from mplayer to mplayer2 with my old system, because mplayer would not play fine with vdpau eosd subtitles (being fubared).
on my bugreport I just got a funny answer. :o ... mplayer2 had refactored vdpau/eosd api which did just fine.

for now, I am fine with xv codec and libav threading. I do not feel like going back to mplayer.

well, enough of that cries.


since then, I moved to webkit-gtk, depending on gstreamer for html5 video - the future. :D
so, I had a look around and think that the best would be a simple player based on gstreamer - though, there is none but the basic ... or did I miss something?!

http://gitorious.org/vaapi/gstreamer-vaapi
https://github.com/felipec/gst-player/

I wonder if I should start a little project for a very basic console/gstreamer-based player to waste my sunday afternoons or so ... :twisted:
gstreamer framework looks quite neat ...
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
ryszardzonk
Apprentice
Apprentice


Joined: 18 Dec 2003
Posts: 182
Location: Rzeszów, POLAND

PostPosted: Sun Jan 22, 2012 6:41 pm    Post subject: Reply with quote

I worked over the remote console on that and yet to get to home to check on that one but I believe that my attempt for getting vaapi should deliver just fine. Based on the portage ebuild besides vaapi it has updated patches with support for CoreAVC and Stereoscopic, so get it while it's hot :)

http://bigvo.dyndns.org/overlay/media-video/mplayer/ or http://bigvo.dyndns.org/overlay/mplayer-20120109.tar.bz2 packed version of an ebuild
_________________
Sky is not the limit...
Back to top
View user's profile Send private message
pengu
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 114
Location: Germany

PostPosted: Sun Jan 22, 2012 10:50 pm    Post subject: Reply with quote

nice but it doesn't work for me.
It compiled fine on two machines (AMD 785G, HD 4200, Intel H55, Core i3 540) but I get the following error on both machines
when playing video content, no matter which video codec or audio or used video output (-vo).
Code:

Dropping frame with size not matching configured size
Too many buffered pts



is there something wrong with the coreavc pach(es)?

Edit
It's the same with or without the coreavc patch and sometimes tha ati drivers crashes with the coreavc patch (x freezes)
What could that be?

I've got another mplayer-vaapi installation from another source which works fine.
The only problem is, that I can't get it updated at the moment because the mplayer git server(s) are down(again?)
So I tried this one because the other mplayer version has a problem with die libpng 1.5, I have to disable it with configure.

The mplayer version in portage and the mentioned other mplayer-vaapi version with older patches works fine but the one in portage without vaapi.


Edit 2

Ok, it's the fault of ffmpeg because mplayer2 doing the same now on both systems.

Edit 3

using the ffmpeg 9999 ebuild solves the problem.
Back to top
View user's profile Send private message
Gregoire
Apprentice
Apprentice


Joined: 15 Apr 2006
Posts: 292

PostPosted: Fri May 04, 2012 6:14 pm    Post subject: Reply with quote

Are there any update on vaapi for mplayer ?

I wanted to try this one but I can't find mplayer-1.0_rc4_p20120109.tar.xz anywhere...

I also tried to compil http://gitorious.org/vaapi/mplayer/commits/hwaccel-vaapi

Which ends with :

Code:

cc -MD -MP -Wundef -Wall -Wno-switch -Wno-parentheses -Wpointer-arith -Wredundant-decls  -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer -fno-tree-vectorize -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -Ilibdvdread4 -I. -Iffmpeg  -D_REENTRANT  -I/usr/include/libgtop-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include     -I/usr/include/freetype2 -I/usr/include/bs2b   -I/usr/include/dirac   -I/usr/include/schroedinger-1.0 -I/usr/include/orc-0.4   -I/usr/include/liveMedia -I/usr/include/UsageEnvironment -I/usr/include/BasicUsageEnvironment -I/usr/include/groupsock -c -o libmpdemux/demux_rtp.o libmpdemux/demux_rtp.cpp
libmpdemux/demux_rtp.cpp: In function 'char* openURL_rtsp(RTSPClient*, const char*)':
libmpdemux/demux_rtp.cpp:99:20: error: 'class RTSPClient' has no member named 'describeWithPassword'
libmpdemux/demux_rtp.cpp:101:20: error: 'class RTSPClient' has no member named 'describeURL'
libmpdemux/demux_rtp.cpp: In function 'demuxer_t* demux_open_rtp(demuxer_t*)':
libmpdemux/demux_rtp.cpp:155:82: error: invalid conversion from 'int' to 'const char*'
libmpdemux/demux_rtp.cpp:155:82: error:   initializing argument 2 of 'static RTSPClient* RTSPClient::createNew(UsageEnvironment&, const char*, int, const char*, portNumBits)'
libmpdemux/demux_rtp.cpp:155:82: error: invalid conversion from 'const char*' to 'int'
libmpdemux/demux_rtp.cpp:155:82: error:   initializing argument 3 of 'static RTSPClient* RTSPClient::createNew(UsageEnvironment&, const char*, int, const char*, portNumBits)'
libmpdemux/demux_rtp.cpp:155:82: error: invalid conversion from 'int' to 'const char*'
libmpdemux/demux_rtp.cpp:155:82: error:   initializing argument 4 of 'static RTSPClient* RTSPClient::createNew(UsageEnvironment&, const char*, int, const char*, portNumBits)'
libmpdemux/demux_rtp.cpp:245:21: error: 'class RTSPClient' has no member named 'setupMediaSubsession'
libmpdemux/demux_rtp.cpp:257:24: error: 'class RTSPClient' has no member named 'playMediaSession'
libmpdemux/demux_rtp.cpp: In function 'void teardownRTSPorSIPSession(RTPState*)':
libmpdemux/demux_rtp.cpp:646:27: error: 'class RTSPClient' has no member named 'teardownMediaSession'
libmpdemux/demux_rtp.cpp: In function 'char* openURL_rtsp(RTSPClient*, const char*)':
libmpdemux/demux_rtp.cpp:103:1: warning: control reaches end of non-void function
make: *** [libmpdemux/demux_rtp.o] Error 1


Any idea ?
Back to top
View user's profile Send private message
Gregoire
Apprentice
Apprentice


Joined: 15 Apr 2006
Posts: 292

PostPosted: Mon May 07, 2012 1:42 pm    Post subject: Reply with quote

I had to remove live's useflag in order to compil but mplayer -vo vaapi -va vaapi crash at start.
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun May 13, 2012 12:54 am    Post subject: Reply with quote

Gregoire wrote:
I had to remove live's useflag in order to compil but mplayer -vo vaapi -va vaapi crash at start.


Download mplayer-vaapi here:

https://gitorious.org/vaapi/mplayer

It works for me , the cpu use is lower than vlc but the problem is tearing in the movies, ati drivers has an option to avoid it but then cpu use increase at 40% and video isnt smooth , ati drivers for gpu video suck.
I guess if you try to use coreavc it get better but i am not a big fan about privative software is is hard to me use privative ati drivers.

Regards
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Gregoire
Apprentice
Apprentice


Joined: 15 Apr 2006
Posts: 292

PostPosted: Sun May 13, 2012 5:04 pm    Post subject: Reply with quote

Arctic wrote:
Gregoire wrote:
I had to remove live's useflag in order to compil but mplayer -vo vaapi -va vaapi crash at start.


Download mplayer-vaapi here:

https://gitorious.org/vaapi/mplayer

It works for me , the cpu use is lower than vlc but the problem is tearing in the movies, ati drivers has an option to avoid it but then cpu use increase at 40% and video isnt smooth , ati drivers for gpu video suck.
I guess if you try to use coreavc it get better but i am not a big fan about privative software is is hard to me use privative ati drivers.

Regards


As I wrote in order to compil both the snapshot and the git source I had to remove live from my system.

And for example for the git :
Code:

./mplayer -vo vaapi -va vaapi /tmp/try.mkv
MPlayer SVN-r34578-4.5.3 (C) 2000-2012 MPlayer Team

Playing /tmp/try.mkv.
Cache fill:  0.00% (0 bytes)   

libavformat version 53.22.0 (internal)
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (ac3), -aid 0
[lavf] stream 2: subtitle (text), -sid 0
VIDEO:  [H264]  1280x688  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in /tmp/
libva: VA-API version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva: va_openDriver() returns 0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.39.1 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 1 ch, s16le, 640.0 kbit/83.33% (ratio: 80000->96000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
AO: [oss] 48000Hz 1ch s16le (2 bytes per sample)
Starting playback...
Unsupported PixelFormat 61
[VD_FFMPEG] Trying pixfmt=1.
Movie-Aspect is 1.86:1 - prescaling to correct movie aspect.
VO: [vaapi] 1280x688 => 1280x688 H.264 VA-API Acceleration  [fs]
[VD_FFMPEG] XVMC-accelerated MPEG-2.


MPlayer interrupted by signal 11 in module: decode video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
Parent process disappeared, exiting cache process.
Back to top
View user's profile Send private message
nicoseb
n00b
n00b


Joined: 26 Oct 2011
Posts: 13
Location: United States

PostPosted: Thu Jun 14, 2012 6:07 am    Post subject: Not working :s Reply with quote

I have managed to install the git version of mplayer-vaapi (thanks for suggesting to remove live package)
Unfortunately it did not configure with vaapi hence did not compile the vaapi Video Output driver...

I used to have it running with that "old" mplayer-vaapi ebuild, I have libva installed, and vlc is able to use it.
I also tried to force the flags "*HW_ACCEL_VAAPI*" but it could not compile because ffmpeg would not recognize these...

What did I do wrong?

Thanks,
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Thu Jun 14, 2012 2:08 pm    Post subject: Re: Not working :s Reply with quote

nicoseb wrote:
I have managed to install the git version of mplayer-vaapi (thanks for suggesting to remove live package)
Unfortunately it did not configure with vaapi hence did not compile the vaapi Video Output driver...

I used to have it running with that "old" mplayer-vaapi ebuild, I have libva installed, and vlc is able to use it.
I also tried to force the flags "*HW_ACCEL_VAAPI*" but it could not compile because ffmpeg would not recognize these...

What did I do wrong?

Thanks,


They changed site trees .....................

Browse this url :

https://gitorious.org/vaapi/mplayer/trees/hwaccel-vaapi

then in the right side you will see: Download hwaccel-vaapi as tar.gz

click to download , but when download finish you have to rename the file with extension (tar.gz) because there is a bug in this site and file download without it

Code:
tar -xvzf file_name


and you have mplayer vaapi patch ready to configure :P
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Fri Jun 15, 2012 1:58 pm    Post subject: Reply with quote

Can you paste this output and your card model ????

Code:
cat /var/log/Xorg.0.log | grep UVD


i am using an HD4290 it must load udvd2 but only load udv

Code:
(II) fglrx(0): UVD feature is enabled(II) fglrx(0):

_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
nicoseb
n00b
n00b


Joined: 26 Oct 2011
Posts: 13
Location: United States

PostPosted: Sun Jun 17, 2012 4:47 am    Post subject: Reply with quote

Arctic wrote:
Can you paste this output and your card model ????

Code:
cat /var/log/Xorg.0.log | grep UVD


i am using an HD4290 it must load udvd2 but only load udv

Code:
(II) fglrx(0): UVD feature is enabled(II) fglrx(0):


Thank you so much artic!
That was stupid of me to download the wrong thing before, and I appreciate you letting me know!

My mplayer with vaapi is finally back! :)

Otherwise, I get the exact same output than you for UVD. What is it about?

My card is a HD6310.

Thanks
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Jun 17, 2012 4:01 pm    Post subject: Reply with quote

Because i am not sure that AMD load the same UVD module for HD 6*** 5*** 4*** seires. 6 series has uvd 3 , 5 seires and 4 seires uses uvd 2 or uvd 2.2 old atis use uvd.
In phoronix's site i read that they loaded an UVD2 , but i am not sure if amd change driver an unified module or what happens because the article is 2009, and they show this output.........

Code:
 grep UVD /var/log/Xorg.0.log
(II) fglrx(0): UVD2 feature is available


I had an HD6870 and loaded UVD too .

Using and HD 4290 (integrated video) using xv_amd driver (10% cpu) and using vaapi (15% cpu)
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Gregoire
Apprentice
Apprentice


Joined: 15 Apr 2006
Posts: 292

PostPosted: Sun Jun 17, 2012 4:23 pm    Post subject: Reply with quote

Anyone able to use this mplayer -vo vaapi -va vaapi anyfile with intel GPU ?
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Sun Jun 17, 2012 6:15 pm    Post subject: Reply with quote

Gregoire wrote:
Anyone able to use this mplayer -vo vaapi -va vaapi anyfile with intel GPU ?

Yes, me. Ironlake graphics (Core i3-530 processor).
Back to top
View user's profile Send private message
a7thson
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 175
Location: your pineal gland

PostPosted: Sun Jun 17, 2012 8:22 pm    Post subject: Reply with quote

Gregoire wrote:
Anyone able to use this mplayer -vo vaapi -va vaapi anyfile with intel GPU ?


Yep. mobile i7 w/Ivy Bridge, seems to be working fine for me.

also see thread: http://forums.gentoo.org/viewtopic.php?p=7062560
_________________
Sager NP6165 | i7-3610QM | GeForce 650M
Gigabyte GA-880GMA-USB3 | AMD 1100T | Radeon HD 4250
MSI P6N-SLI | Q6600 | Sapphire HD 6870
Back to top
View user's profile Send private message
Gregoire
Apprentice
Apprentice


Joined: 15 Apr 2006
Posts: 292

PostPosted: Mon Jun 18, 2012 7:03 am    Post subject: Reply with quote

Wouah, I tried it again (i3770k) and now it work, I didn't even recompil it (well it's not the same kernel anymore and some other packages got updated also).

Really nice, thank !!!
Back to top
View user's profile Send private message
nicoseb
n00b
n00b


Joined: 26 Oct 2011
Posts: 13
Location: United States

PostPosted: Sun Jun 24, 2012 7:35 am    Post subject: Reply with quote

I have been talking too fast...

mplayer compiled with vaapi and I can now use it for my videos, but I get some artifact that I did not use to have:
- for NON-MKV videos, it shows a black screen. If I do any scrolling, the video show up for a second and then go back to a black screen
- for MKV videos (or bluray) the video shows up but with terrible artifacts, one second it is the right frames, and the next it is frames from another scene ...

Any insight guys?

Thanks
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Jun 24, 2012 11:31 am    Post subject: Reply with quote

nicoseb wrote:
I have been talking too fast...

mplayer compiled with vaapi and I can now use it for my videos, but I get some artifact that I did not use to have:
- for NON-MKV videos, it shows a black screen. If I do any scrolling, the video show up for a second and then go back to a black screen
- for MKV videos (or bluray) the video shows up but with terrible artifacts, one second it is the right frames, and the next it is frames from another scene ...

Any insight guys?

Thanks


In my HD4290 runs smooth ,but you can try VLC works better for me (vaapi)
Check video level , only right play 4.1 level or less, bluray (m2ts) linux support is not good.
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
nicoseb
n00b
n00b


Joined: 26 Oct 2011
Posts: 13
Location: United States

PostPosted: Mon Jun 25, 2012 3:08 am    Post subject: Reply with quote

Arctic wrote:
In my HD4290 runs smooth ,but you can try VLC works better for me (vaapi)
Check video level , only right play 4.1 level or less, bluray (m2ts) linux support is not good.


Hehe yeah I know both vaapi and bluray are not working too well...
VLC is working better but I just like mplayer better :(

With my earlier version, mplayer used to be able to play mkv OK without artifact...
Bluray was hopeless at the time though, now I can get it to work but with artifacts!

i'm just not sure if there is anything I can play with to help, or if this is just a lost cause...
Thanks for your answer though!

If the same issue happens to some other people: I used -vo vaapi:gl which was creating artifacts... -vo vaapi works OK a bit too slow on some videos...
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Wed Jun 27, 2012 11:33 pm    Post subject: Reply with quote

nicoseb wrote:
Arctic wrote:
In my HD4290 runs smooth ,but you can try VLC works better for me (vaapi)
Check video level , only right play 4.1 level or less, bluray (m2ts) linux support is not good.


Hehe yeah I know both vaapi and bluray are not working too well...
VLC is working better but I just like mplayer better :(

With my earlier version, mplayer used to be able to play mkv OK without artifact...
Bluray was hopeless at the time though, now I can get it to work but with artifacts!

i'm just not sure if there is anything I can play with to help, or if this is just a lost cause...
Thanks for your answer though!

If the same issue happens to some other people: I used -vo vaapi:gl which was creating artifacts... -vo vaapi works OK a bit too slow on some videos...


Try this , install the opensource driver (you can read the wiki radeon howto) , and compile mesa and mplayer with vdpau support , then try to play something using :

Code:
mplayer -vo vdpau videoiwnatoplay


In my pc the cpu uses 5-10% with blu-ray 1080p

Opensource driver has developement some code to uses vdapu api with mesa , using gallium 3d engine for video aceleratopn.


Regards
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
nicoseb
n00b
n00b


Joined: 26 Oct 2011
Posts: 13
Location: United States

PostPosted: Fri Jun 29, 2012 3:45 am    Post subject: Reply with quote

Quote:
Try this , install the opensource driver (you can read the wiki radeon howto) , and compile mesa and mplayer with vdpau support , then try to play something using :

Code:
mplayer -vo vdpau videoiwnatoplay


In my pc the cpu uses 5-10% with blu-ray 1080p

Opensource driver has developement some code to uses vdapu api with mesa , using gallium 3d engine for video aceleratopn.


Regards


Thanks again Arctic.
I used to have the opensource driver like a year ago (still installed but not in kernel anymore), but I think I had stopped because I could not get my ttys to be in high resolution!

Needless to say, I am surprised by your comment since I though VDPAU was only for nvidia drivers, and vaapi for ATI (and Intel sometimes)... but I guess this was a misunderstanding on my aprt again.
I will give that a shot next week and let you know how much luck I get
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Fri Jun 29, 2012 8:51 am    Post subject: Reply with quote

Note that you don't actually get hardware decoding with that. Gallium3D VDPAU supports only mpeg2 decoding. And if you want that (you have a mpeg2 video), you need to explicitly specify it:
Code:
mplayer -vo vdpau -vc ffmpeg12vdpau

Without specifying the codec, you only get presentation (the "p" of vdpau), which in open source drivers I don't think is any better than using the default -vo xv
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum