Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rsync fails when I run "emerge --sync"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Travis86
n00b
n00b


Joined: 14 Feb 2005
Posts: 47
Location: The Land of GMT -6

PostPosted: Sat Jun 16, 2012 5:58 pm    Post subject: rsync fails when I run "emerge --sync" Reply with quote

I'm installing Gentoo, and when I run "emerge --sync" I get the following error:

Code:
dell / # emerge --sync
>>> Starting rsync with rsync://140.211.166.189/gentoo-portage...
>>> Checking server timestamp ...
timed out
rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(549) [Receiver=3.0.9]
>>> Retrying...


>>> Starting retry 1 of 6 with rsync://91.186.30.235/gentoo-portage

[ ... same error for all mirrors ... ]

!!! Exhausted addresses for rsync.gentoo.org


I found a similar error reported on RedHat's Bugzilla. From what I gather: as of 3.0.6, one must include a username in addition the the host and path.

So, my best guess is that there is a bug in the way Portage uses rsync, but if that were the case, it would seem like everyone would be having this problem....

The rsync verison is 3.0.9. I'm using the latest stage and portage snapshots. And, I'm installing from Ubuntu according to this howto

How can I sync Portage?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4667
Location: Saint Amant, Acadiana

PostPosted: Sat Jun 16, 2012 9:43 pm    Post subject: Reply with quote

Check your Ubuntu firewall settings.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Sat Jun 16, 2012 10:49 pm    Post subject: Reply with quote

or if your are one restrictive network, you can use emerge-webrsync to sync via http.
downside, the snapshot will only be updated once per day.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
Travis86
n00b
n00b


Joined: 14 Feb 2005
Posts: 47
Location: The Land of GMT -6

PostPosted: Sat Jun 16, 2012 11:54 pm    Post subject: Reply with quote

I used emerge-webrsync as a temporary fix. Then, I tried "emerge --sync" again, and it mysteriously started working. I can't think of any change I made...

I wish there was a more definite solution, but thanks for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum