Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound -> OSS Emu -> No Sound
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Sat Dec 13, 2003 5:31 pm    Post subject: Sound -> OSS Emu -> No Sound Reply with quote

Hi,

I'm using mm-sources with ALSA compiled in, and sound has been working fine. Then I had some problems with /dev/dsp missing and realized I left out OSS emulation in my kernel config, so I went and put that in. Now I've got no sound at all. I already checked my mixer levels and they are correct, and I don't get any errors. What could be wrong? Here are the relevent kernel config options:

Under Sound:
<*> Sound card support

Under Open Sound System:
< > Open Sound System (DEPRECATED)

Under Advances Linux Sound Architecture:
<*> Advanced Linux Sound Architecture
<*> Sequencer support
< > Sequencer dummy client
[*] OSS API emulation
<*> OSS Mixer API
<*> OSS PCM (digital audio) API
[*] OSS Sequencer API
< > RTC Timer support
[ ] Verbose printk
[ ] Debug

Under PCI Devices:
<*> VIA 82C686A/B, 8233 South Bridge

-jdm
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Sat Dec 13, 2003 11:16 pm    Post subject: Reply with quote

Everything looks grand to this Goon as far as your kernel config is concerned. I'd recommend re-emerging alsa-lib alsa-tool and alsa-utils -- then make sure you replace your /etc/init.d/alsasound file with the new version and then correctly merge your pre-exsisting /etc/modules.d/alsa with the new one (if there is even a new one at all, I did not get a new one.)

Then make sure you add alsasound to your boot runlevel and you should be good to go -- at least it looks that way to me from where I am sitting.

Hope that can help!!

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Sun Dec 14, 2003 12:55 am    Post subject: Reply with quote

Alright, re-emerging alsa-lib and alsa-utils now, and emerging alsa-tools since I don't already have that installed. Is it necessary?

-jdm
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Sun Dec 14, 2003 1:15 am    Post subject: Reply with quote

Where can I find the new versions of alsasound and /etc/modules.d/alsa? For alsasound, do you mean the changes described by Murf here: http://forums.gentoo.org/viewtopic.php?t=97157&postdays=0&postorder=asc&start=25

-jdm
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Sun Dec 14, 2003 1:30 am    Post subject: Reply with quote

Just doing the emerges has not fixed the problem. Right now I do not have alsasound run at boot.

-jdm
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Mon Dec 15, 2003 2:30 am    Post subject: Reply with quote

Here is the newer /etc/init.d/alsasound file I got when I re-emerged the newest stable alsa-lib (I think that was the package that updated this file, not 100% sure though):

/etc/init.d/alsasound:
Code:
#!/sbin/runscript
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound,v 1.5 2003/12/04 16:38:42 vapier Exp $
#
# Gentoo users: add this script to 'boot' run level.
# ==================================================
#
# alsasound             This shell script takes care of starting and stopping
#                       the ALSA sound driver.
#
# This script requires /usr/sbin/alsactl and /usr/bin/aconnect programs
# from the alsa-utils package.
#
# Copyright (c) by Jaroslav Kysela <perex@suse.cz>
#
#
#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.
#
#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.
#
#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA

#       Edited to support Linux kernel 2.5 and above as well as 2.4
#       John Mylchreest <johnm@gentoo.org>
#       July 29, 2003

alsactl=/usr/sbin/alsactl
asoundcfg=/etc/asound.state
aconnect=/usr/bin/aconnect
alsascrdir=/etc/alsa.d

depend() {
        need bootmisc localmount
        before modules
        after isapnp
        provide alsa-modules
}

start() {
        if [ -d /proc/asound ] && [ -z "$(grep ' no soundcards ' /proc/asound/cards)" ] ; then
                ebegin "ALSA Detected"
        else
                ebegin "Loading ALSA drivers"

                # I really dislike this and would like to tidy it up.
                # Anyone running 2.4 + alsa-driver willing to help me?

                DRIVERS="$(modprobe -c | grep snd.* | grep pci: | awk '{ print $3 }' | uniq)"
                if [ -z "${DRIVERS}" ] ; then
                        # Fallback on older modprobe syntax
                        DRIVERS="$(/sbin/modprobe -c | grep -E "^[[:space:]]*alias[[:space:]]+snd-card-[[:digit:]]" | awk '{print $3}')"
                fi

                [ -z "${DRIVERS}" ] && eerror "Unable to find any ALSA drivers. Have you compiled alsa-drivers correctly?"
                OSS="$(modprobe -l | grep "snd.*oss" | sed -e "s:\/.*\/::" -e "s:\..*::")"
                for i in ${OSS}
                do
                        DRIVERS="${i} ${DRIVERS}"
                done

                for DRIVER in ${DRIVERS}
                do
                        if [ ! "${DRIVER}" = off ] ; then
                                einfo "Loading: ${DRIVER}"
                                /sbin/modprobe ${DRIVER}
                        fi
                done

                sleep 1

                if [ -f /proc/asound/seq/drivers ] ; then                        SEQUENCERS="$(cut -d"," -f1 /proc/asound/seq/drivers)"
                        for SEQUENCER in ${SEQUENCERS}
                        do
                                einfo "Loading: ${SEQUENCER}"
                                [ -n "${SEQUENCER}" ] && /sbin/modprobe ${SEQUENCER}
                        done
                fi

                einfo "Running card-dependent scripts"
                for DRIVER in ${DRIVERS}
                do
                        TMP=${DRIVER##snd-}
                        [ -x "${alsascrdir}/${TMP}" ] && ${alsascrdir}/${TMP}
                done

                [ ! -d /proc/asound ] && eerror "ERROR: Failed to load necessary drivers"
        fi

        einfo "Restoring Mixer Levels"
        if [ ! -r $asoundcfg ]; then
                ewarn "No mixer config in $asoundcfg, you have to unmute your card!"
                eend 1
        elif [ -x $alsactl ]; then
                CARDS="$(cat /proc/asound/cards | awk '/: / { print $1 }')"
                for CARDNUM in ${CARDS}
                do
                        $alsactl -f $asoundcfg restore ${CARDNUM}
                done
        else
                eerror -e "ERROR: Cannot find alsactl, did you forget to install media-sound/alsa-utils?"
                eend 1
        fi
        eend 0
}

stop() {
        if [ ! -d /proc/asound ] ; then
                eerror "ALSA is not loaded"
                return 0
        fi

        ebegin "Unloading ALSA"
        terminate
        einfo "Storing ALSA Mixer Levels"
        if [ -x $alsactl ]; then
                $alsactl -f $asoundcfg store
        else
                eerror -e "ERROR: Cannot find alsactl, did you forget to install media-sound/alsa-utils?"
                eend 1
        fi

        LOADED_MODULES="$(/sbin/lsmod | grep -E "^snd" | awk '{print $1}')"
        einfo "Unloading modules"
        for MODULE in ${LOADED_MODULES}
        do
                /sbin/rmmod ${MODULE} 2> /dev/null
        done
        /sbin/rmmod soundcore 2> /dev/null
        /sbin/rmmod gameport 2> /dev/null
        eend 0
}

terminate() {
        #
        # Kill processes holding open sound devices
        #
        # DEVS=`find /dev/ -follow -type c -maxdepth 1 -print 2>/dev/null | xargs ls -dils | grep "1*1[46]," | cut -d: -f2 | cut -d" " -f2; echo /proc/asound/dev/*`
        ossdevs="/dev/admmidi? /dev/adsp? /dev/amidi? /dev/audio* /dev/dmfm* \
                        /dev/dmmidi? /dev/dsp* /dev/dspW* /dev/midi0? /dev/mixer? /dev/music \
                        /dev/patmgr? /dev/sequencer* /dev/sndstat"
        alsadevs="/proc/asound/dev/*"
        fuser -k $ossdevs $alsadevs 2> /dev/null 1>/dev/null

        #
        # remove all sequencer connections if any
        #        [ -f /proc/asound/seq/clients -a -x $aconnect ] && $aconnect --removeall
}


With this in my boot rc-level it detects that ALSA has been compiled into the kernel and simply takes care of any undone stuff (which for me I think is just mostly like Murf's post -- it restores my mixer settings autmatically. However I've not gone over this entire file and it could do a lot more that I am unaware of. Course I'm still not well versed in bash scripting anyway (is this bash scripting?!? -- hehe).

Sorry I'm not much more help here -- your configuration looks good to me. Just be sure the check the basics again and try recompiling your kernel without changing the configuration -- be sure you mounted the boot partition before copying the new kernel and be sure that you update your /boot/grub/grub.conf if need be.

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Thu Dec 18, 2003 2:39 pm    Post subject: Reply with quote

Okay, while I did have the old alsasound, but even with the new there is still no sound. Let me check a few things out and I'll be back later today..

-jdm
Back to top
View user's profile Send private message
Pluvius
Apprentice
Apprentice


Joined: 15 Oct 2002
Posts: 167
Location: Phoenix, Arizona

PostPosted: Thu Dec 18, 2003 4:12 pm    Post subject: Reply with quote

You missed the most important alsa file to re-emerge, alsa-driver. Whenever you re-compile your kernel, you must re-emerge at least alsa-driver and nvidia. Before you re-emerge all the alsa files, make sure you have "alsa" and "oss" listed as USE variable in your /etc/make.conf file.

You did not say which sound card you have. The most recent "stable" release of alsa in Gentoo is alsa-driver-0.9.8. I had problems with my emu10k1 (SBlaster Live!) card. There are compatability issues with 0.9.8 and the emu10k1 card. I used the ACCEPT_KEYWORDS="~x86" preface and updated all possible alsa to 1.0.0-rc2 and sound works flawlessly now.

If you want to see which alsa files are available and which versions you have installed, su to root in a termianl window and issue this command:

emerge --verbose -s alsa

You should have at least alsa-driver, alsa-lib, alsa-oss, and alsa-utils installed.

I hope this helps,

Pluvius
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Thu Dec 18, 2003 7:27 pm    Post subject: Reply with quote

Pluvius I think maybe you missed the point of this thread, merrimanjd is using the latest kernel 2.6.0 which includes the ALSA drivers into the actual kernel and so alsa-driver is obsolete when using the 2.6.x series of kernels. Please do NOT use the alsa-drivers if you have a 2.6.x series kernel.

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Fri Dec 19, 2003 2:37 am    Post subject: Reply with quote

Yes, Bonez is right. Okay, so the new alsasound script starts fine, but when I shutdown it gives this error:
Code:
modprobe: FATAL module snd_card_1 not found

There are 7 of these, snd_card_1 through snd_card_7. I assume that this is no problem though since I compiled ALSA into my kernel and the script is looking for modules. Also, I booted into my windows partition and I do have sound then, so that rules out any hardware failure. Any other ideas?

-jdm
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Dec 19, 2003 7:33 am    Post subject: Reply with quote

merrimanjd wrote:
Yes, Bonez is right. Okay, so the new alsasound script starts fine, but when I shutdown it gives this error:
Code:
modprobe: FATAL module snd_card_1 not found

There are 7 of these, snd_card_1 through snd_card_7.


I have the same problem. It happens when the script tries to store the mixer levels.
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Wed Dec 24, 2003 6:18 pm    Post subject: Reply with quote

I still haven't gotten it to work, but I will not be around my computer again until about January 5th...

-jdm
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Fri Jan 09, 2004 6:05 pm    Post subject: Reply with quote

Okay, now I'm using mm-sources-2.6.0-r1 and still no sound... Maybe later today I'll try the modules route and see if I can get that to work.

-jdm
Back to top
View user's profile Send private message
daddio
Tux's lil' helper
Tux's lil' helper


Joined: 11 Oct 2003
Posts: 135
Location: Richland WA

PostPosted: Fri Jan 09, 2004 6:10 pm    Post subject: alsa Reply with quote

on my system 2.6 kernel, the pcm sound level is muted/zero by default (which pretty much means you get no sound...) anyway, after I emerged the gnome-alsamixer unmuted pcm, bang ! there is was. scared the poop outta me (I had xmms playing some industrial tune loud)

try that (or another alsa mixer)

its worth a try to get basic functionality
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Fri Jan 09, 2004 6:19 pm    Post subject: Reply with quote

Nope, thats not the problem. I unmuted everything with alsamixer.

-jdm
Back to top
View user's profile Send private message
stefanwa
Tux's lil' helper
Tux's lil' helper


Joined: 09 Dec 2002
Posts: 140

PostPosted: Fri Jan 09, 2004 8:23 pm    Post subject: Reply with quote

Seems like a common problem now. There has to be some serious bug. Lots of people here are reporting the same problem (including me). Today I got it working for some time, but couldn't get it to work permanently. This is what I did when I got it working...
stop alsasound
reemerge alsa-lib and alsa-utils
start alsasound
set mixer levels with alsamixer

However, I can't reproduce the procedure now. It's just not working anymore! Tried stopping/restarting alsasound several times etc, compiled as modules, bultin...no go! :evil: :(
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Fri Jan 09, 2004 8:58 pm    Post subject: Reply with quote

I'm trying your sequence out now, stefanwa. My problems started when I enabled OSS emulation.

-jdm
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Fri Jan 09, 2004 9:07 pm    Post subject: Reply with quote

Nope... still no go for me too.

-jdm
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Sat Jan 10, 2004 6:11 pm    Post subject: Reply with quote

Last night I tried removing OSS emulation and rebuilding my kernel, and I found that there is still no sound. So I am not sure exactly what has changed between when I had sound and when I lost it. I don't know what else to try now.

-jdm
Back to top
View user's profile Send private message
thewomble
n00b
n00b


Joined: 11 Jan 2004
Posts: 1
Location: Germany, Darmstadt

PostPosted: Sun Jan 11, 2004 1:11 pm    Post subject: Reply with quote

Probably you forgot to load snd_pcm_oss?
I had some quite equal problem and a "modprobe snd_pcm_oss" fixed it for me..
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Mon Jan 12, 2004 4:25 am    Post subject: Reply with quote

I can't
Code:
modprobe snd_pcm_oss
because its compiled directly into my kernel, not as a module.

By the way, now my kernel is 2.6.1-mm1 with the same problem.

-jdm
Back to top
View user's profile Send private message
georwell
Guru
Guru


Joined: 25 Jun 2003
Posts: 430
Location: Uppsala, Sweden

PostPosted: Mon Jan 12, 2004 7:19 pm    Post subject: Reply with quote

I am having the same problem. I don't get any errors on boot up and when I run enemy territory it says my sound system is muted. But I have unmuted everything using amixer.... Strange. My sound was working well but when I was playing some music with juk the computer froze (I was using 2.6.0-test9 and kde-cvs) so that was expected. But when I rebooted I didn't have any sound. I am going to go back and see what I emerged that might have caused the problem.
Back to top
View user's profile Send private message
georwell
Guru
Guru


Joined: 25 Jun 2003
Posts: 430
Location: Uppsala, Sweden

PostPosted: Mon Jan 12, 2004 9:13 pm    Post subject: Reply with quote

Well I was able to fix mine. My DAC option was set to 0 and needs to be on if I want sound. Rebooting was resetting this to 0 for some strange reason. So make sure and test all your settings with alsamixer. I can't remember if this was always set this way but I suppose that it was. Strange that it just got reset like that.... I have a Sound Fusion CS46xx by the way.

Good luck everybody!
Back to top
View user's profile Send private message
merrimanjd
n00b
n00b


Joined: 14 Sep 2003
Posts: 41
Location: Rochester, NY, US

PostPosted: Tue Jan 13, 2004 1:41 am    Post subject: Reply with quote

What is this "DAC option"?

-jdm
Back to top
View user's profile Send private message
georwell
Guru
Guru


Joined: 25 Jun 2003
Posts: 430
Location: Uppsala, Sweden

PostPosted: Tue Jan 13, 2004 8:00 am    Post subject: Reply with quote

It is available if you one alsamixer. It probably depends on your card though. It just says DAC at the top and I turned it up and boom there was the sound.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum