Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kwave-0.8.8: emake failed [SOLUCIONADO]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sat Jun 02, 2012 3:06 pm    Post subject: kwave-0.8.8: emake failed [SOLUCIONADO] Reply with quote

Hola a todos, pues he intentado actualizar kwave-0.8.8 pero siempre falla la compilación:

Code:

cd /var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8_build/libkwave && /usr/bin/cmake -E cmake_symlink_library libkwave.so.0.8.8 libkwave.so.0 libkwave.so
make[2]: se sale del directorio `/var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8_build/CMakeFiles  13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
[ 30%] Built target libkwave
make[1]: se sale del directorio `/var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8_build'
make: *** [all] Error 2
 * ERROR: media-sound/kwave-0.8.8 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =media-sound/kwave-0.8.8',
 * the complete build log and the output of 'emerge -pqv =media-sound/kwave-0.8.8'.
 * The complete build log is located at '/var/tmp/portage/media-sound/kwave-0.8.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/kwave-0.8.8/temp/environment'.
 * S: '/var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8'

>>> Failed to emerge media-sound/kwave-0.8.8, Log file:

>>>  '/var/tmp/portage/media-sound/kwave-0.8.8/temp/build.log'

 * Messages for package media-sound/kwave-0.8.8:

 * ERROR: media-sound/kwave-0.8.8 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =media-sound/kwave-0.8.8',
 * the complete build log and the output of 'emerge -pqv =media-sound/kwave-0.8.8'.
 * The complete build log is located at '/var/tmp/portage/media-sound/kwave-0.8.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/kwave-0.8.8/temp/environment'.
 * S: '/var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8'


La verdad no sé si sea un bug del mismo programa o un problema con el ebuild... Alguien podría ayudarme con esto? Gracias!


Last edited by acidrums4 on Sun Jun 10, 2012 7:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sat Jun 02, 2012 11:05 pm    Post subject: Re: kwave-0.8.8: emake failed Reply with quote

Quote:
* If you need support, post the output of 'emerge --info =media-sound/kwave-0.8.8',
* the complete build log and the output of 'emerge -pqv =media-sound/kwave-0.8.8'.
* The complete build log is located at '/var/tmp/portage/media-sound/kwave-0.8.8/temp/build.log'.

Publica la la información que dice portage para que te podamos ayudar.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sun Jun 03, 2012 1:25 am    Post subject: Reply with quote

Miércoles, se me pasó por completo! :oops:

emerge --info =media-sound/kwave-0.8.8
/var/tmp/portage/media-sound/kwave-0.8.8/temp/build.log

Qué pena por el olvido, espero pueda servir. Cualquier cosa estoy pendiente. Gracias!
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sun Jun 03, 2012 3:33 pm    Post subject: Reply with quote

Prueba a desactivar ccache. FEATURES="-ccache" en make.conf.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sun Jun 03, 2012 10:15 pm    Post subject: Reply with quote

También falló :( Aquí está el nuevo build.log (aunque por lo que alcanzo a ver, parece que es lo mismo...) Se me hace raro, y he buscado en todas partes y nadie ha reportado un bug en contra de esta versión de kwave...
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Wed Jun 06, 2012 11:10 pm    Post subject: Reply with quote

¿Que dice
Code:
emerge -pv imagemagick
?
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Thu Jun 07, 2012 12:48 am    Post subject: Reply with quote

Code:

emerge -pv imagemagick

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-gfx/imagemagick-6.7.6.4  USE="X bzip2 cxx jpeg jpeg2k lzma openmp png tiff truetype xml zlib -autotrace -corefonts -djvu -fftw -fontconfig -fpx -graphviz -gs -hdri -jbig -lcms -lqr -opencl -openexr -pango -perl -q32 -q64 -q8 -raw -static-libs -svg -test -webp -wmf" 7,400 kB

Total: 1 package (1 reinstall), Size of downloads: 7,400 kB
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Thu Jun 07, 2012 5:52 am    Post subject: Reply with quote

Prueba a reinstalar imagemagick y luego comprueba que revdep-rebuild no encuentra nada roto. Finalmente intenta kwave y si da error publica el nuevo log.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Thu Jun 07, 2012 1:14 pm    Post subject: Reply with quote

Sí, algo apareció roto desde la actualización de ayer y es dev-util/kdevelop-4.3.1-r1, que falla al compilar por lo mismo que aún no he podido actualizar a kde-base/kdeartwork-styles-4.8.3, kde-base/kdeplasma-addons-4.8.3 ni a kde-base/kget-4.8.3 (http://forums.gentoo.org/viewtopic-t-919206-highlight-.html). No creo que tenga que ver pero tampoco sé porqué esos paquetes no se pueden actualizar, por más que he buscado y buscado no encuentro respuesta (y nadie sabe o me quiere decir porqué falla su compilación).

El caso es que también volvió a fallar la compilación de media-sound/kwave-0.8.8, y aquí va el nuevo log.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Thu Jun 07, 2012 4:19 pm    Post subject: Reply with quote

Este es el comando que falla. ¿Qué pasa si lo ejecutas como root?
Code:
# /usr/bin/convert -resize 32x32 /var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8/kwave/toolbar/kwave_zoom_original.svgz /var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8_build/doc/toolbar_kwave_zoom_original.png
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Thu Jun 07, 2012 5:06 pm    Post subject: Reply with quote

Tan raro! Efectivamente algo pasa ahí...

Code:

su -c '/usr/bin/convert -resize 32x32 /var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8/kwave/toolbar/kwave_zoom_original.svgz /var/tmp/portage/media-sound/kwave-0.8.8/work/kwave-0.8.8_build/doc/toolbar_kwave_zoom_original.png'
Contraseña:
convert: non-conforming drawing primitive definition `text-align' @ error/draw.c/DrawImage/3146.


Acabo de buscar sobre ese convert: non-conforming drawing primitive definition `text-align' @ error/draw.c/DrawImage/3146 en Google, y encontré esto: http://www.andreaswacker.com/blog/2007/09/08/convert-non-conforming-drawing-primitive-definition-image/ ... Entonces vendría siendo como un bug?
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sat Jun 09, 2012 9:37 pm    Post subject: Reply with quote

*bump*
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sun Jun 10, 2012 12:29 am    Post subject: Reply with quote

acidrums4 wrote:
... Entonces vendría siendo como un bug?
Yo diría que no es el mismo caso. Comprueba que las dependencias de imagemagick están actualizadas.
Code:
# emerge -v --update --deep --newuse imagemagick
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sun Jun 10, 2012 12:41 am    Post subject: Reply with quote

Gracias por la respuesta, esto es lo que obtengo:

Code:
% emerge -upDNv imagemagick

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] kde-base/kde-env-4.8.80::kde [4.8.3::gentoo] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/oxygen-icons-4.8.80::kde [4.8.3::gentoo] USE="(-aqua) -bindist" 28,451 kB
[ebuild     U *] dev-libs/soprano-9999::kde [2.7.6::gentoo] USE="dbus raptor redland virtuoso -clucene -debug -doc -test" 0 kB
[ebuild     U ~] kde-base/kdelibs-4.8.80::kde [4.8.3::gentoo] USE="acl alsa bzip2 fam handbook jpeg2k lzma mmx nls opengl policykit semantic-desktop sse sse2 ssl udev udisks upower -3dnow (-altivec) (-aqua) -debug -doc -kerberos -openexr -spell -test (-upnp) -zeroconf" 11,410 kB
[ebuild     U ~] kde-base/katepart-4.8.80::kde [4.8.3::gentoo] USE="handbook (-aqua) -debug" 2,119 kB
[ebuild  N    ~] kde-base/nepomuk-core-4.8.80::kde  USE="(-aqua) -debug" 372 kB
[ebuild     U ~] kde-base/kdesu-4.8.80::kde [4.8.3::gentoo] USE="handbook (-aqua) -debug" 6,172 kB
[ebuild     U ~] kde-base/khelpcenter-4.8.80::kde [4.8.3::gentoo] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kwalletd-4.8.80::kde [4.8.3::gentoo] USE="(-aqua) -debug" 0 kB
[blocks B      ] <kde-base/nepomuk-4.8.80:4 ("<kde-base/nepomuk-4.8.80:4" is blocking kde-base/nepomuk-core-4.8.80)

Total: 9 packages (8 upgrades, 1 new), Size of downloads: 48,522 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-base/nepomuk-4.8.3::gentoo, installed) pulled in by
    kde-base/nepomuk required by @selected
    >=kde-base/nepomuk-4.8.3:4[-aqua] required by (kde-base/kdebase-runtime-meta-4.8.3::gentoo, installed)

  (kde-base/nepomuk-core-4.8.80::kde, ebuild scheduled for merge) pulled in by
    >=kde-base/nepomuk-core-4.8.80:4[-aqua] required by (kde-base/kdelibs-4.8.80::kde, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following keyword changes are necessary to proceed:
#required by kde-base/nepomuk-core-4.8.80, required by kde-base/kdelibs-4.8.80[semantic-desktop], required by kde-base/kwalletd-4.8.80, required by @selected, required by @world (argument)
=dev-libs/soprano-9999 **
#required by kde-base/kdelibs-4.8.80[semantic-desktop], required by kde-base/kwalletd-4.8.80, required by @selected, required by @world (argument)
=kde-base/nepomuk-core-4.8.80 ~x86

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


Pues ayer salieron las actualizaciones de KDE, lo tengo en ~x86 pero no he hecho la instalación porque desconfío ya que se trata de la versión beta de la 4.9 (4.8.80) y no la actualización regular mensual, que en este caso sería la 4.8.4 (y desde que llevo usando los archivos para la instalación de las versiones recientes de KDE, es la primera vez que suben una actualización de la versión beta). No se porqué podrá ser... De lo otro tampoco tengo idea...
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sun Jun 10, 2012 1:21 am    Post subject: Reply with quote

¿Has probado a reinstalarlo?
Code:
# emerge -v imagemagick
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sun Jun 10, 2012 1:26 am    Post subject: Reply with quote

Sí, en el mensaje del Jue Jun 07, 2012 11:19 am puse que no había roto relativo a imagemagick pero sí hay enlaces de librerías de kdevelop rotos, pues no he podido actualizarlo... es lo único que aparece para reinstalar por librerías rotas (o mejor dicho, lo que bota revdep-rebuild).
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sun Jun 10, 2012 2:29 am    Post subject: Reply with quote

¿Qué versión de librsvg tienes?
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sun Jun 10, 2012 2:35 am    Post subject: Reply with quote

Ninguna, no lo tenía instalado por sus dependencias con Gtk+... Será por eso?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sun Jun 10, 2012 2:55 am    Post subject: Reply with quote

Pudiera ser por eso.
Reinstala imagemagick con svg en la USE.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Sun Jun 10, 2012 7:44 pm    Post subject: Reply with quote

FUNCIONÓ!

Gracias de verdad! Aunque me parece el colmo que la instalación de un editor de audio se caiga porque no hay soporte svg para convertir un ícono a otro formato... De todas maneras le escribiré al autor.

Y pues para lo relacionado con lo de kget, kdevelop, kdeartwork-styles y kdeplasma-addons abriré otro tema acá en el foro de español, en el de inglés nadie dijo nada...

Muchas gracias por la ayuda :)
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Sun Jun 10, 2012 11:17 pm    Post subject: Reply with quote

El utilizar programas marcados como "en pruebas" puede tener estos inconvenientes y en este caso parece que ha ocurrido. Estábamos avisados por el Manual Gentoo.

La forma correcta de informar de un fallo es abrir un informe de error en Bugzilla, aunque supongo que un correo al autor del ebuild es mejor que nada.
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 116
Location: Al otro lado del monitor

PostPosted: Mon Jun 11, 2012 4:36 pm    Post subject: Reply with quote

Eso se sabe de sobra. Pero si uno no se arriesga y descubre estos errores nadie más lo va a hacer. Por eso me gusta Gentoo, porque aquí estas cosas se descubren mas rápidamente que en cualquier otro sitio. Además es un granito de arena que uno como usuario puede aportar a su desarrollo. De no ser así pues estaría usando otra cosa, como un Debian o Fedora.

Por otro lado, teniendo en cuenta las importantes mejoras en estabilización que tuvo kwave-0.8.8 valía la pena la actualización (en la anterior versión estable no se podía guardar en otro archivo una selección de audio, pues el programa caía por 'segfault').
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum