Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no login prompt on console
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
mcoulman
n00b
n00b


Joined: 20 Sep 2002
Posts: 34
Location: Maui

PostPosted: Tue Sep 24, 2002 2:00 am    Post subject: no login prompt on console Reply with quote

Upon reboot of a freshly installed 1.2 system there is no login prompt on the console. The last console output shows init.d/local.start as ok. I can login via ssh from another machine on the network, just not at the console itself.

Anyone have a pointer? Thanks in advance
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Tue Sep 24, 2002 4:55 am    Post subject: Have you found anything Reply with quote

I have the same problem, and I cannot figure out where does it come from.

Gilles
Back to top
View user's profile Send private message
Curious
Bodhisattva
Bodhisattva


Joined: 13 May 2002
Posts: 395
Location: Sydney, Australia

PostPosted: Tue Sep 24, 2002 5:06 am    Post subject: Reply with quote

Not sure how this would be possible, but it sounds like your inittab files might be fandangled. Can you post an extract of /etc/inittab, particularly if you have lines containing the word 'getty' / 'agetty' / 'mgetty' etc in them.

Since your normal stuff is starting up fine, I don't think there's anything wrong with your init process per se, but you might need to tweak inittab to make sure consoles are being spawned.

-- Curious.
_________________
Are you down with the Hawk?
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Tue Sep 24, 2002 5:19 am    Post subject: Reply with quote

Here is the extract of my inittab.

Quote:


#
# Default runlevel.

id:3:initdefault:

# System initialization (runs when system boots).
#DE:S12345:respawn:/sbin/devfsd /dev -fg
# Script to run when going single user (runlevel 1).
~~:S:wait:/sbin/sulogin

si:S:sysinit:/sbin/rc boot
l0:0:wait:/sbin/rc shutdown
l1:1:wait:/sbin/rc single
l2:2:wait:/sbin/rc nonetwork
l3:3:wait:/sbin/rc default
l4:4:wait:/sbin/rc default
l5:5:wait:/sbin/rc default
l6:6:wait:/sbin/rc reboot
z6:6:respawn:/sbin/sulogin

# TERMINALS
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now

# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh

# End of /etc/inittab




the agetty are there. Do you have any idea on how to get a clue on what the boot is stuck.

Of the boot message are fine [ok]

Gilles.

Back to top
View user's profile Send private message
Curious
Bodhisattva
Bodhisattva


Joined: 13 May 2002
Posts: 395
Location: Sydney, Australia

PostPosted: Tue Sep 24, 2002 5:30 am    Post subject: Reply with quote

Do you have 'Virtual Terminal' ( CONFIG_VT ) enabled in your Kernel configuration ( and optionally 'Support for console on virtual terminal' ( CONFIG_VT_CONSOLE ) )?

These are near the beginning of the 'character devices' section of the configuration. I should have probably asked this first, but it's unlikely to be something you'd turn off. :-)

-- Curious.
_________________
Are you down with the Hawk?
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Tue Sep 24, 2002 5:38 am    Post subject: Reply with quote

Quote:
Do you have 'Virtual Terminal' ( CONFIG_VT ) enabled in your Kernel configuration ( and optionally 'Support for console on virtual terminal' ( CONFIG_VT_CONSOLE ) )?
They are on.

I just made a test and change my default runlevel to 2 instead of 3 (default).
It hangs just the same way.
Might that give you an idea. Because I start having none.

Gilles
Back to top
View user's profile Send private message
mcoulman
n00b
n00b


Joined: 20 Sep 2002
Posts: 34
Location: Maui

PostPosted: Tue Sep 24, 2002 12:11 pm    Post subject: Reply with quote

Same for my inittab & kernel.
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Wed Sep 25, 2002 5:29 am    Post subject: Bump Reply with quote

Still stuck...
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Wed Sep 25, 2002 8:40 am    Post subject: Solved: no login prompt on console Reply with quote

Quote:
Upon reboot of a freshly installed 1.2 system there is no login prompt on the console. The last console output shows init.d/local.start as ok. I can login via ssh from another machine on the network, just not at the console itself.


After an investigation the problem seem simple.
make sure SMP is not selected in your kernel.
The boot process will hang after local if the network card is static
or after requetsing dhcp if the network uses it.

To recompil the kernel:
Code:
# save your .config
cd /usr/src/linux
cd .config ~
# clean your kernel compilation
# this will erase your .config
make mrproper
# copy back your .config file
cp ~/.config .config
# configure the kernel [remove SMP]
make menuconfig
# compile the kernel
make dep && make clean bzImage modules modules_install

it is now ready to be copied in /boot.


Hope this will help.
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Wed Sep 25, 2002 8:41 am    Post subject: Reply with quote

mcoulman wrote:
Same for my inittab & kernel.


Can you confirm if it was also the problem for you ?
Back to top
View user's profile Send private message
mcoulman
n00b
n00b


Joined: 20 Sep 2002
Posts: 34
Location: Maui

PostPosted: Wed Sep 25, 2002 12:41 pm    Post subject: Reply with quote

I'll build a new kernel and let you know.
Back to top
View user's profile Send private message
nuance9
Tux's lil' helper
Tux's lil' helper


Joined: 09 Sep 2002
Posts: 85

PostPosted: Thu Sep 26, 2002 12:42 pm    Post subject: Reply with quote

I had the same problem, and the mrproper / SMP solution worked for me.

Thanks!

- Justin
Back to top
View user's profile Send private message
mcoulman
n00b
n00b


Joined: 20 Sep 2002
Posts: 34
Location: Maui

PostPosted: Sat Sep 28, 2002 2:23 pm    Post subject: Reply with quote

I can confim the SMP fix too. Thanks for the pointer.
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Sat Sep 28, 2002 3:52 pm    Post subject: Reply with quote

I am happy that this fix your problem.

Have a nice and fun gentoo. :wink:

Gilles
Back to top
View user's profile Send private message
CyboChimp
n00b
n00b


Joined: 31 Oct 2002
Posts: 7

PostPosted: Tue Nov 05, 2002 11:07 pm    Post subject: Reply with quote

Thank you gillesg. This post fixed my problem too.
Back to top
View user's profile Send private message
gillesg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 90

PostPosted: Wed Nov 06, 2002 7:42 am    Post subject: Reply with quote

CyboChimp wrote:
Thank you gillesg. This post fixed my problem too.

You know what :
    It will brighten my night.

Gilles
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 454
Location: Hokkaido Japan

PostPosted: Mon Apr 11, 2011 4:32 am    Post subject: This problem often raises its ugly head in Paravirt / Xen Reply with quote

This problem often raises its ugly head in Paravirt / Xen setups.
You may need to change your inittab tty1 to hvc0 if your login prompt doesn't display
and it looks like you are stuck at local.start [OK]

In /etc/inittab change tty1 to hvc0 and add hvc0 to /etc/securetty

Code:
sed -i 's/tty1/hvc0/' /etc/inittab
echo 'hvc0' >> /etc/securetty


Cheers,
Back to top
View user's profile Send private message
rollinncoaster
n00b
n00b


Joined: 10 Nov 2003
Posts: 13

PostPosted: Mon May 21, 2012 7:07 pm    Post subject: Reply with quote

This worked! Thanks!
_________________
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning." Rich Cook
Back to top
View user's profile Send private message
drrrl
n00b
n00b


Joined: 27 Nov 2004
Posts: 70
Location: Warszawa, Poland

PostPosted: Sat Jun 09, 2012 12:45 am    Post subject: Re: This problem often raises its ugly head in Paravirt / Xe Reply with quote

newtonian wrote:
You may need to change your inittab tty1 to hvc0 if your login prompt doesn't display


I encountered the same problem in Xen guest system after upgrading from xen-sources-2.6.34-r4 to gentoo-sources-3.2.12.
Changing tty1 to hvc0 helped - thank you!
Back to top
View user's profile Send private message
drrrl
n00b
n00b


Joined: 27 Nov 2004
Posts: 70
Location: Warszawa, Poland

PostPosted: Thu Jan 31, 2013 9:20 am    Post subject: Reply with quote

Well, everything was fine since my last post until recent upgrade of udev to 197-r3 and then r4. After that I lost all Xen devices and had to recreate /dev/xvda* files manually for my system to boot properly again. Fortunately I managed to have my system up and running, but lost the console. This happened with my old kernel (3.2.12), but also with a new 3.5.7 which I installed after udev upgrade.

My boot options are:
Code:
root=/dev/xvda2 console=hvc0 xencons=tty


/etc/inittab contains the line:
Code:
c1:12345:respawn:/sbin/agetty 38400 hvc0 linux


No hvc* files exist in /dev directory

I have XEN support and DEVTMPFS compiled in the kernel:
Code:
# egrep "XEN|DEVTMP" /usr/src/linux/.config
CONFIG_XEN=y
# CONFIG_XEN_PRIVILEGED_GUEST is not set
CONFIG_XEN_PVHVM=y
CONFIG_XEN_MAX_DOMAIN_MEMORY=64
CONFIG_XEN_SAVE_RESTORE=y
# CONFIG_XEN_DEBUG_FS is not set
CONFIG_PCI_XEN=y
CONFIG_XEN_PCIDEV_FRONTEND=y
CONFIG_DEVTMPFS=y
# CONFIG_DEVTMPFS_MOUNT is not set
CONFIG_XEN_BLKDEV_FRONTEND=y
CONFIG_XEN_NETDEV_FRONTEND=y
CONFIG_INPUT_XEN_KBDDEV_FRONTEND=y
CONFIG_HVC_XEN=y
CONFIG_HVC_XEN_FRONTEND=y
CONFIG_XEN_BALLOON=y
# CONFIG_XEN_SELFBALLOONING is not set
CONFIG_XEN_SCRUB_PAGES=y
CONFIG_XEN_DEV_EVTCHN=y
CONFIG_XENFS=y
CONFIG_XEN_COMPAT_XENFS=y
CONFIG_XEN_SYS_HYPERVISOR=y
CONFIG_XEN_XENBUS_FRONTEND=y
CONFIG_XEN_GNTDEV=y
CONFIG_XEN_GRANT_DEV_ALLOC=y
CONFIG_SWIOTLB_XEN=y
CONFIG_XEN_TMEM=y
CONFIG_XEN_PRIVCMD=y


As advised in some posts I found, I commented out the "shm /dev/shm tmpfs..." line and do not have any other /dev related line in /etc/fstab, but I can see /dev/shm is mounting automatically:
Code:
# mount
rootfs on / type rootfs (rw)
/dev/root on / type ext3 (rw,relatime,errors=continue,barrier=1,data=writeback)
none on /proc type proc (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
xenfs on /proc/xen type xenfs (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
/dev/xvda1 on /boot type ext3 (rw,noatime)
/dev/xvda3 on /var type ext3 (rw,noatime)
/dev/xvda5 on /tmp type ext3 (rw,noatime)
/dev/xvda7 on /home type ext3 (rw,noatime)


Anyone had similar experience? Any ideas?

Thank you, G.
Back to top
View user's profile Send private message
drrrl
n00b
n00b


Joined: 27 Nov 2004
Posts: 70
Location: Warszawa, Poland

PostPosted: Thu Jan 31, 2013 9:52 am    Post subject: Reply with quote

Solved!

I added "CONFIG_DEVTMPFS_MOUNT=y" to kernel configuration and now I have all /dev/hvc* devices.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1225
Location: 42.68n 85.41w

PostPosted: Thu Jan 31, 2013 2:31 pm    Post subject: Reply with quote

id make sure to move your smp back to Y as it controls multi processor... id not mark that as solved, just as a temp work around. maybe GDM/XDM/KDM would be good for u, or wicd/networkmanager and turning off the dhclient/dhcpcd & network interface boot script....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum