Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iPhone absinthe-linux
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 788
Location: 127.0.0.1

PostPosted: Sun Jun 03, 2012 6:20 pm    Post subject: iPhone absinthe-linux Reply with quote

Estoy probando absinthe-linux pero me da los siguientes errores:
Code:

$ ./absinthe.x86_64
./absinthe.x86_64: /usr/lib64/libcrypto.so.1.0.0: no version information available (required by ./absinthe.x86_64)
./absinthe.x86_64: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by ./absinthe.x86_64)
./absinthe.x86_64: /usr/lib64/libssl.so.1.0.0: no version information available (required by ./absinthe.x86_64)


¿Alguien tiene idea de por que puede ser?

Bueno el de Glibc imagino por que es, pero los otros ni idea.
Code:

emerge -pv glibc
[ebuild   R    ] sys-libs/glibc-2.14.1-r3  USE="(multilib) -debug -gd (-hardened) -profile (-selinux) -vanilla" 164 kB


Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Sun Jun 03, 2012 9:08 pm    Post subject: Reply with quote

Creo que si actualizas glibc los otros 2 mensajes no impedirán que la aplicación se ejecute.
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1496

PostPosted: Sun Jun 03, 2012 9:08 pm    Post subject: Reply with quote

Reemerge absinte a ver si te arregla las dependencias.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 788
Location: 127.0.0.1

PostPosted: Mon Jun 04, 2012 9:39 am    Post subject: Reply with quote

Probare esta tarde actualizando glibc, pero por lo que cuentan los mensajes de error yo diría que no van a permitir la ejecución de la aplicación. No es una aplicación instalada desde Portage, es simplemente un ejecutable bajado de www.greenpois0n.com para hacer jailbreak al iPhone.

Gracias a los dos, un saludo.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1496

PostPosted: Mon Jun 04, 2012 11:13 am    Post subject: Reply with quote

opotonil wrote:
Probare esta tarde actualizando glibc, pero por lo que cuentan los mensajes de error yo diría que no van a permitir la ejecución de la aplicación.

Seguramente no sea tribial pero el sentido comun, que no lo que se que es mas bien poco me dice que si necesita unas prestaciones de software superiores a las que tienes es por que esta construido sobre una plataforma que corre con versiones testing o casi pero que deberia funcionar si se le da lo que pide.
En gentoo como tu sabes eso se puede hacer usando ~arch el caso es que a lo mejor te cargas una instalación estable.
Posiblemente te interese hacer una instalacion alternativa en con el ACCEPT_KEYWORDS="~amd64 o ~x86".
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Eleazar Anzola
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1253
Location: Caracas / Venezuela

PostPosted: Mon Jun 04, 2012 1:43 pm    Post subject: Re: iPhone absinthe-linux Reply with quote

opotonil wrote:
Estoy probando absinthe-linux pero me da los siguientes errores:
Code:

$ ./absinthe.x86_64
./absinthe.x86_64: /usr/lib64/libcrypto.so.1.0.0: no version information available (required by ./absinthe.x86_64)
./absinthe.x86_64: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by ./absinthe.x86_64)
./absinthe.x86_64: /usr/lib64/libssl.so.1.0.0: no version information available (required by ./absinthe.x86_64)


¿Alguien tiene idea de por que puede ser?

Bueno el de Glibc imagino por que es, pero los otros ni idea.
Code:

emerge -pv glibc
[ebuild   R    ] sys-libs/glibc-2.14.1-r3  USE="(multilib) -debug -gd (-hardened) -profile (-selinux) -vanilla" 164 kB


Salu2.


Dice que necesitas GLIBC 2.15 y tienes 2.14
_________________
Salu2
Eleazar Anzola
Linux User : # 216232
__________________________________________
Por un foro ordenado y un buscador más útil:
[TEMA] Descripción problema (estado)
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 788
Location: 127.0.0.1

PostPosted: Tue Jun 05, 2012 10:45 am    Post subject: Reply with quote

Ando un poco mal de tiempo, a ver si para el finde puedo probar.

Normalmente prefiero usar package.keywords que pasar todo el sistema a testing (ACCEPT_KEYWORDS="~amd64").

Un saludo.

-----------------------------------

EDITADO:

Sin problemas tras la actualizacion.
_________________
Localnet
Films Localnet


Last edited by opotonil on Fri Aug 10, 2012 8:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1496

PostPosted: Tue Jun 05, 2012 11:22 am    Post subject: Reply with quote

Quote:
Normalmente prefiero usar package.keywords que pasar todo el sistema a testing (ACCEPT_KEYWORDS="~amd64").

Si creo que asi lo hace todo el mundo, pero en tu caso te pide actualizar glibc y eso te toca partes sensibles como gcc drivers graficos y poco a poco te va a hacer renovar casi todo system y copiando todo el sistema a otra particion cambias a testing el make.conf y con un poco de suerte no tardes mucho en obtener lo que buscas, a la vez que mantienes tu actual sistema intacto.
Claro que seguramente tardarias más que en actualizar glibc y el otro paquete.

EDIT*
Nada que systema me hacia daño en el ojo.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum