Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201205-04 ] Chromium, V8: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1561

PostPosted: Sun May 27, 2012 11:26 pm    Post subject: [ GLSA 201205-04 ] Chromium, V8: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Chromium, V8: Multiple vulnerabilities (GLSA 201205-04)
Severity: normal
Exploitable: remote
Date: May 27, 2012
Bug(s): #417321
ID: 201205-04

Synopsis

Multiple vulnerabilities have been reported in Chromium and V8,
some of which may allow execution of arbitrary code.


Background

Chromium is an open source web browser project. V8 is Google’s open
source JavaScript engine.


Affected Packages

Package: www-client/chromium
Vulnerable: < 19.0.1084.52
Unaffected: >= 19.0.1084.52
Architectures: All supported architectures

Package: dev-lang/v8
Vulnerable: < 3.9.24.28
Unaffected: >= 3.9.24.28
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Chromium and V8. Please
review the CVE identifiers and release notes referenced below for
details.


Impact

A context-dependent attacker could entice a user to open a specially
crafted web site or JavaScript program using Chromium or V8, possibly
resulting in the execution of arbitrary code with the privileges of the
process, or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Chromium users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=www-client/chromium-19.0.1084.52"
   
All V8 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/v8-3.9.24.28"
   


References


CVE-2011-3103


CVE-2011-3104


CVE-2011-3105


CVE-2011-3106


CVE-2011-3107


CVE-2011-3108


CVE-2011-3109


CVE-2011-3111


CVE-2011-3115


Release Notes 19.0.1084.52
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum