Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] Problema aggiornamento glib e udev
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Mon May 21, 2012 3:29 pm    Post subject: [risolto] Problema aggiornamento glib e udev Reply with quote

Ciao ragazzi aggiornando mi sono trovato davanti a questo problema:

Quote:
emerge -uNDpv @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] dev-libs/icu-49.1.1-r1 [4.8.1.1-r1] USE="-debug -doc -examples -static-libs" 0 kB
[ebuild U ] dev-libs/libffi-3.0.11 [3.0.10] USE="-debug -static-libs -test" 0 kB
[ebuild N ] dev-libs/libyaml-0.1.2 USE="-doc -examples -test" 0 kB
[ebuild N ] dev-util/ragel-6.6 USE="vim-syntax" 0 kB
[ebuild UD ] dev-libs/glib-2.30.3 [2.32.1] USE="static-libs* -debug -doc (-fam) (-selinux) -systemtap -test -utils -xattr" 0 kB
[ebuild U ] dev-libs/libxml2-2.8.0_rc1-r1000 [2.7.8-r5] USE="icu ipv6 python readline -debug -doc -examples -lzma% -static-libs -test" PYTHON_ABIS="2.7 -2.5 -2.6" 0 kB
[ebuild U ] dev-lang/v8-3.9.24.21 [3.8.9.19] 0 kB
[ebuild N ] dev-python/ply-3.4 USE="-examples" 0 kB
[ebuild R ] sys-libs/cracklib-2.8.19-r1000 USE="nls python zlib%* -static-libs" PYTHON_ABIS="2.7 3.2 -2.5 -2.6 -3.1 (-3.3)" 0 kB
[ebuild U ] dev-python/numpy-1.6.2-r1000 [1.6.1-r2] USE="-doc -lapack -test" PYTHON_ABIS="2.7 3.2 -2.5 -2.6 -3.1 (-3.3)" 0 kB
[ebuild UD ] sys-fs/udev-160-r3 [171-r2] USE="extras -introspection (-selinux) (-gudev%*) (-hwdb%*)" 0 kB
[ebuild U ] dev-vcs/git-1.7.10.2 [1.7.10] USE="blksha1 curl iconv pcre perl python threads webdav -cgi -cvs -doc -emacs -gtk (-ppcsha1) -subversion -test -tk -xinetd" 0 kB
[ebuild U ] app-portage/layman-1.4.2-r3 [1.4.1] USE="bazaar cvs git mercurial subversion -darcs -test" 0 kB
[ebuild U ] sys-power/upower-0.9.16 [0.9.13-r1] USE="introspection -debug -doc -ios" 0 kB
[ebuild U ] app-admin/sudo-1.8.5_p1 [1.8.3_p2] USE="ldap nls pam -offensive (-selinux) -skey" 0 kB
[ebuild U ] media-libs/taglib-1.7.2 [1.7.1] USE="asf mp4 -debug -examples -test" 0 kB
[ebuild U ] dev-python/pygobject-3.2.2-r1000 [3.2.1-r1000] USE="cairo threads -examples -test" PYTHON_ABIS="2.7 3.2 -2.6 -3.1 (-3.3)" 0 kB
[ebuild U ] www-client/chromium-19.0.1084.46-r2 [18.0.1025.168] USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) -test" LINGUAS="it -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild NS ] dev-lang/ruby-1.9.3_p125 [1.8.7_p357] USE="berkdb gdbm ipv6 ncurses rdoc readline ssl yaml -debug -doc -examples -rubytests -socks5 -tk -xemacs" 0 kB
[ebuild U ] dev-ruby/rubygems-1.8.24 [1.8.15] USE="-server -test" RUBY_TARGETS="ruby18 ruby19%* -jruby -ree18" 0 kB
[ebuild N ] virtual/rubygems-4 RUBY_TARGETS="(ruby19)" 0 kB
[ebuild N ] virtual/rubygems-1 RUBY_TARGETS="(ruby18)" 0 kB
[ebuild N ] dev-ruby/rake-0.8.7-r6 USE="-bash-completion -doc -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild N ] dev-ruby/racc-1.4.6-r1 USE="-test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild N ] dev-ruby/json-1.5.4-r1 USE="-doc -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild N ] dev-ruby/rdoc-3.12 USE="-doc -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild R ] media-video/vlc-1.1.13 USE="X a52 aac aalib alsa cdda cddb dbus dts dvd ffmpeg flac gcrypt gnutls kde libcaca libnotify libv4l libv4l2 matroska mmx mp3 mpeg ncurses ogg opengl png samba sdl skins sse stream svg taglib theora truetype twolame udev v4l vorbis wma-fixed x264 xcb xml xv (-altivec) -atmo -avahi -bidi -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -gnome -httpd -id3tag -ieee1394 -jack -kate -libass -libproxy -libtiger -lirc -live -lua -modplug -mtp -musepack -optimisememory -oss -projectm -pulseaudio -pvr -qt4 -remoteosd -rtsp -run-as-root -schroedinger -sdl-image -shine -shout -speex -sqlite (-svga) -upnp -vaapi -vcdx -vlm (-win32codecs) -xosd -zvbi (-nsplugin%)" 0 kB

Total: 27 packages (13 upgrades, 2 downgrades, 9 new, 1 in new slot, 2 reinstalls), Size of downloads: 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/glib-2.32.1::gentoo, installed) pulled in by
>=dev-libs/glib-2.31.22:2 required by (dev-libs/gobject-introspection-1.32.0::gentoo, installed)
(and 1 more with the same problem)

sys-fs/udev:0

(sys-fs/udev-160-r3::gentoo, ebuild scheduled for merge) pulled in by
<sys-fs/udev-171[extras] required by (sys-power/upower-0.9.16::gentoo, ebuild scheduled for merge)

(sys-fs/udev-171-r2::gentoo, installed) pulled in by
>=sys-fs/udev-171[gudev] required by (gnome-base/gvfs-1.10.1::gentoo, installed)
(and 2 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Potete consigliarmi la best practice per eseguire l'aggiornamento? 8)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Mon May 21, 2012 7:49 pm    Post subject: Reply with quote

é probabile che tu abbia fatto casini con i file package.*

Avendo tutto stabile non succede...prova a dare un occhiata.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Mon May 21, 2012 8:10 pm    Post subject: Reply with quote

guarda ho controllato dentro keywords ma non riesco a ricavarne nulla :( o meglio non riesco a focalizzare il problema :evil:
Back to top
View user's profile Send private message
Climber
n00b
n00b


Joined: 25 Sep 2011
Posts: 39
Location: Roma

PostPosted: Tue May 22, 2012 9:48 am    Post subject: Reply with quote

Posta il tuo package.keywords perché è lì che dovrebbe essere il tuo problema. Controlla come hai smascherato >=dev-libs/glib-2.31.22:2 magari è quello che ti crea problemi.

Non ti assicuro niente perché a me non è mai capitato ma dovrebbe essere questo il problema
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Tue May 22, 2012 10:03 am    Post subject: Reply with quote

eccolo
Quote:
app-admin/eselect-boost ~amd64
=app-arch/snappy-1.0.4 ~amd64
app-crypt/truecrypt ~amd64
app-emulation/vmware-workstation ~amd64
app-emulation/vmware-modules ~amd64
app-emulation/vmware-tools ~amd64
=app-emulation/emul-linux-x86-xlibs-20120520 ~amd64
=app-emulation/emul-linux-x86-opengl-20120520 ~amd64
=app-emulation/emul-linux-x86-qtlibs-20120520 ~amd64
=app-emulation/emul-linux-x86-baselibs-20120520 ~amd64
=app-emulation/emul-linux-x86-medialibs-20120520 ~amd64
=app-emulation/emul-linux-x86-soundlibs-20120520 ~amd64
=app-emulation/emul-linux-x86-db-20120520 ~amd64
dev-db/mongodb ~amd64
dev-java/oracle-jdk-bin ~amd64
dev-java/oracle-jre-bin ~amd64
dev-java/java-config ~amd64
dev-java/javatoolkit ~amd64
=dev-lang/spidermonkey-1.7.0-r2 ~amd64
dev-lang/python ~amd64
dev-libs/libxslt ~amd64
#=dev-libs/glib-2.32.1 ~amd64
#=dev-libs/gobject-introspection-1.32.0 ~amd64
#=dev-libs/gobject-introspection-common-1.32.0 ~amd64
dev-libs/gobject-introspection ~amd64
dev-libs/gobject-introspection-common ~amd64
dev-python/pygobject ~amd64
dev-python/pycairo ~amd64
dev-python/setuptools ~amd64
dev-python/dbus-python ~amd64
dev-python/PyQt4 ~amd64
dev-python/sip ~amd64
dev-python/numpy ~amd64
dev-python/pycrypto ~amd64
dev-python/argparse ~amd64
dev-python/cython ~amd64
dev-python/paramiko ~amd64
dev-python/pycurl ~amd64
dev-python/pygtk ~amd64
dev-python/urwid ~amd64
dev-util/android-sdk-update-manager ~amd64
dev-util/scons ~amd64
dev-util/boost-build ~amd64
dev-util/nvidia-cuda-sdk ~amd64
dev-util/nvidia-cuda-toolkit ~amd64
dev-vcs/bzr ~amd64
dev-vcs/subversion ~amd64
kde-base/activitymanager ~amd64
kde-base/akonadi ~amd64
kde-base/akonadiconsole ~amd64
kde-base/akregator ~amd64
kde-base/amor ~amd64
kde-base/ark ~amd64
kde-base/attica ~amd64
kde-base/blinken ~amd64
kde-base/blogilo ~amd64
kde-base/bomber ~amd64
kde-base/bovo ~amd64
kde-base/cantor ~amd64
kde-base/cervisia ~amd64
kde-base/dolphin ~amd64
kde-base/dolphin-plugins ~amd64
kde-base/dragonplayer ~amd64
kde-base/drkonqi ~amd64
kde-base/ffmpegthumbs ~amd64
kde-base/filelight ~amd64
kde-base/freespacenotifier ~amd64
kde-base/granatier ~amd64
kde-base/gwenview ~amd64
kde-base/jovie ~amd64
kde-base/juk ~amd64
kde-base/kabcclient ~amd64
kde-base/kaccessible ~amd64
kde-base/kaddressbook ~amd64
kde-base/kajongg ~amd64
kde-base/kalarm ~amd64
kde-base/kalgebra ~amd64
kde-base/kalzium ~amd64
kde-base/kamera ~amd64
kde-base/kanagram ~amd64
kde-base/kapman ~amd64
kde-base/kapptemplate ~amd64
kde-base/kate ~amd64
kde-base/katepart ~amd64
kde-base/katomic ~amd64
kde-base/kbattleship ~amd64
kde-base/kblackbox ~amd64
kde-base/kblocks ~amd64
kde-base/kbounce ~amd64
kde-base/kbreakout ~amd64
kde-base/kbruch ~amd64
kde-base/kcachegrind ~amd64
kde-base/kcalc ~amd64
kde-base/kcharselect ~amd64
kde-base/kcheckpass ~amd64
kde-base/kcminit ~amd64
kde-base/kcmshell ~amd64
kde-base/kcolorchooser ~amd64
kde-base/kcontrol ~amd64
kde-base/kcron ~amd64
kde-base/kde-env ~amd64
kde-base/kde-l10n ~amd64
kde-base/kde-meta ~amd64
kde-base/kde-wallpapers ~amd64
kde-base/kdeaccessibility-colorschemes ~amd64
kde-base/kdeaccessibility-iconthemes ~amd64
kde-base/kdeaccessibility-meta ~amd64
kde-base/kdeaccounts-plugin ~amd64
kde-base/kdeadmin-meta ~amd64
kde-base/kdeartwork-colorschemes ~amd64
kde-base/kdeartwork-desktopthemes ~amd64
kde-base/kdeartwork-emoticons ~amd64
kde-base/kdeartwork-iconthemes ~amd64
kde-base/kdeartwork-kscreensaver ~amd64
kde-base/kdeartwork-meta ~amd64
kde-base/kdeartwork-sounds ~amd64
kde-base/kdeartwork-styles ~amd64
kde-base/kdeartwork-wallpapers ~amd64
kde-base/kdeartwork-weatherwallpapers ~amd64
kde-base/kdebase-cursors ~amd64
kde-base/kdebase-data ~amd64
kde-base/kdebase-desktoptheme ~amd64
kde-base/kdebase-kioslaves ~amd64
kde-base/kdebase-menu ~amd64
kde-base/kdebase-menu-icons ~amd64
kde-base/kdebase-meta ~amd64
kde-base/kdebase-pam ~amd64
kde-base/kdebase-runtime-meta ~amd64
kde-base/kdebase-startkde ~amd64
kde-base/kdebase-wallpapers ~amd64
kde-base/kdebindings-csharp ~amd64
kde-base/kdebindings-meta ~amd64
kde-base/kdebindings-perl ~amd64
kde-base/kdebindings-ruby ~amd64
kde-base/kdebugdialog ~amd64
kde-base/kdeedu-meta ~amd64
kde-base/kdegames-meta ~amd64
kde-base/kdegraphics-meta ~amd64
kde-base/kdegraphics-strigi-analyzer ~amd64
kde-base/kdelibs ~amd64
kde-base/kdemultimedia-kioslaves ~amd64
kde-base/kdemultimedia-meta ~amd64
kde-base/kdenetwork-filesharing ~amd64
kde-base/kdenetwork-meta ~amd64
kde-base/kdepasswd ~amd64
kde-base/kdepim-common-libs ~amd64
kde-base/kdepim-icons ~amd64
kde-base/kdepim-kresources ~amd64
kde-base/kdepim-l10n ~amd64
kde-base/kdepim-meta ~amd64
kde-base/kdepim-runtime ~amd64
kde-base/kdepim-strigi-analyzer ~amd64
kde-base/kdepim-wizards ~amd64
kde-base/kdepimlibs ~amd64
kde-base/kdeplasma-addons ~amd64
kde-base/kdesdk-kioslaves ~amd64
kde-base/kdesdk-meta ~amd64
kde-base/kdesdk-misc ~amd64
kde-base/kdesdk-scripts ~amd64
kde-base/kdesdk-strigi-analyzer ~amd64
kde-base/kdesu ~amd64
kde-base/kdetoys-meta ~amd64
kde-base/kdeutils-meta ~amd64
kde-base/kdewebdev-meta ~amd64
kde-base/kdf ~amd64
kde-base/kdialog ~amd64
kde-base/kdiamond ~amd64
kde-base/kdm ~amd64
kde-base/kdnssd ~amd64
kde-base/kdontchangethehostname ~amd64
kde-base/keditbookmarks ~amd64
kde-base/keditfiletype ~amd64
kde-base/kephal ~amd64
kde-base/kfile ~amd64
kde-base/kfilereplace ~amd64
kde-base/kfind ~amd64
kde-base/kfloppy ~amd64
kde-base/kfmclient ~amd64
kde-base/kfourinline ~amd64
kde-base/kgamma ~amd64
kde-base/kgeography ~amd64
kde-base/kget ~amd64
kde-base/kglobalaccel ~amd64
kde-base/kgoldrunner ~amd64
kde-base/kgpg ~amd64
kde-base/khangman ~amd64
kde-base/khelpcenter ~amd64
kde-base/khotkeys ~amd64
kde-base/kiconfinder ~amd64
kde-base/kig ~amd64
kde-base/kigo ~amd64
kde-base/killbots ~amd64
kde-base/kimagemapeditor ~amd64
kde-base/kimono ~amd64
kde-base/kinfocenter ~amd64
kde-base/kioclient ~amd64
kde-base/kiriki ~amd64
kde-base/kiten ~amd64
kde-base/kjots ~amd64
kde-base/kjumpingcube ~amd64
kde-base/kleopatra ~amd64
kde-base/klettres ~amd64
kde-base/klickety ~amd64
kde-base/klines ~amd64
kde-base/klinkstatus ~amd64
kde-base/klipper ~amd64
kde-base/kmag ~amd64
kde-base/kmahjongg ~amd64
kde-base/kmail ~amd64
kde-base/kmenuedit ~amd64
kde-base/kmimetypefinder ~amd64
kde-base/kmines ~amd64
kde-base/kmix ~amd64
kde-base/kmousetool ~amd64
kde-base/kmouth ~amd64
kde-base/kmplot ~amd64
kde-base/knetattach ~amd64
kde-base/knetwalk ~amd64
kde-base/knewstuff ~amd64
kde-base/knode ~amd64
kde-base/knotes ~amd64
kde-base/knotify ~amd64
kde-base/kolf ~amd64
kde-base/kollision ~amd64
kde-base/kolourpaint ~amd64
kde-base/kommander ~amd64
kde-base/kompare ~amd64
kde-base/konq-plugins ~amd64
kde-base/konqueror ~amd64
kde-base/konquest ~amd64
kde-base/konsole ~amd64
kde-base/konsolekalendar ~amd64
kde-base/kontact ~amd64
kde-base/kopete ~amd64
kde-base/korganizer ~amd64
kde-base/korundum ~amd64
kde-base/kpasswdserver ~amd64
kde-base/kpat ~amd64
kde-base/kppp ~amd64
kde-base/kquitapp ~amd64
kde-base/krdc ~amd64
kde-base/kreadconfig ~amd64
kde-base/kremotecontrol ~amd64
kde-base/kreversi ~amd64
kde-base/krfb ~amd64
kde-base/krossjava ~amd64
kde-base/krosspython ~amd64
kde-base/krossruby ~amd64
kde-base/kruler ~amd64
kde-base/krunner ~amd64
kde-base/ksaneplugin ~amd64
kde-base/kscd ~amd64
kde-base/kscreensaver ~amd64
kde-base/kshisen ~amd64
kde-base/ksirk ~amd64
kde-base/ksmserver ~amd64
kde-base/ksnapshot ~amd64
kde-base/kspaceduel ~amd64
kde-base/ksplash ~amd64
kde-base/ksquares ~amd64
kde-base/kstars ~amd64
kde-base/kstart ~amd64
kde-base/kstartperf ~amd64
kde-base/kstartupconfig ~amd64
kde-base/kstyles ~amd64
kde-base/ksudoku ~amd64
kde-base/ksysguard ~amd64
kde-base/ksystemlog ~amd64
kde-base/ksystraycmd ~amd64
kde-base/kteatime ~amd64
kde-base/ktimer ~amd64
kde-base/ktimetracker ~amd64
kde-base/ktimezoned ~amd64
kde-base/ktouch ~amd64
kde-base/ktraderclient ~amd64
kde-base/ktron ~amd64
kde-base/ktuberling ~amd64
kde-base/kturtle ~amd64
kde-base/ktux ~amd64
kde-base/kubrick ~amd64
kde-base/kuiserver ~amd64
kde-base/kuiviewer ~amd64
kde-base/kurifilter-plugins ~amd64
kde-base/kuser ~amd64
kde-base/kvtml-data ~amd64
kde-base/kwallet ~amd64
kde-base/kwalletd ~amd64
kde-base/kwin ~amd64
kde-base/kwordquiz ~amd64
kde-base/kwrite ~amd64
kde-base/kwrited ~amd64
kde-base/libkcddb ~amd64
kde-base/libkcompactdisc ~amd64
kde-base/libkdcraw ~amd64
kde-base/libkdeedu ~amd64
kde-base/libkdegames ~amd64
kde-base/libkdepim ~amd64
kde-base/libkexiv2 ~amd64
kde-base/libkipi ~amd64
kde-base/libkleo ~amd64
kde-base/libkmahjongg ~amd64
kde-base/libkonq ~amd64
kde-base/libkpgp ~amd64
kde-base/libksane ~amd64
kde-base/libkworkspace ~amd64
kde-base/liboxygenstyle ~amd64
kde-base/libplasmaclock ~amd64
kde-base/libplasmagenericshell ~amd64
kde-base/libtaskmanager ~amd64
kde-base/lokalize ~amd64
kde-base/lskat ~amd64
kde-base/marble ~amd64
kde-base/mplayerthumbs ~amd64
kde-base/nepomuk ~amd64
kde-base/nsplugins ~amd64
kde-base/okteta ~amd64
kde-base/okular ~amd64
kde-base/oxygen-icons ~amd64
kde-base/palapeli ~amd64
kde-base/parley ~amd64
kde-base/perlkde ~amd64
kde-base/perlqt ~amd64
kde-base/phonon-kde ~amd64
kde-base/plasma-apps ~amd64
kde-base/plasma-runtime ~amd64
kde-base/plasma-workspace ~amd64
kde-base/powerdevil ~amd64
kde-base/printer-applet ~amd64
kde-base/pykde4 ~amd64
kde-base/qguiplatformplugin_kde ~amd64
kde-base/qtruby ~amd64
kde-base/qyoto ~amd64
kde-base/renamedlg-plugins ~amd64
kde-base/rocs ~amd64
kde-base/smoke ~amd64
kde-base/smokegen ~amd64
kde-base/smokekde ~amd64
kde-base/smokeqt ~amd64
kde-base/solid ~amd64
kde-base/solid-runtime ~amd64
kde-base/step ~amd64
kde-base/superkaramba ~amd64
kde-base/svgpart ~amd64
kde-base/sweeper ~amd64
kde-base/system-config-printer-kde ~amd64
kde-base/systemsettings ~amd64
kde-base/thumbnailers ~amd64
kde-base/umbrello ~amd64
kde-base/kactivities ~amd64
kde-base/ksecrets ~amd64
kde-base/kdm ~amd64
kde-base/kcron ~amd64
kde-misc/plasma-applet-daisy ~amd64
kde-misc/quickaccess ~amd64
kde-misc/wicd-client-kde ~amd64
kde-misc/kcm-grub2 ~amd64
media-libs/libdmtx ~amd64
media-libs/prison ~amd64
media-sound/kradio ~amd64
net-im/skype ~amd64
net-im/emesene ~amd64
net-misc/tinc ~amd64
net-misc/ps3mediaserver ~amd64
sys-apps/kmod **
sys-apps/hwids ~amd64
sys-apps/bleachbit ~amd64
sys-auth/polkit-qt ~amd64
#sys-fs/udev **
#=sys-fs/udev-160-r3 *
sys-kernel/gentoo-sources ~amd64
sys-kernel/linux-headers **
=sys-libs/timezone-data-2012c ~amd64
sys-power/bbswitch ~amd64
virtual/python-argparse ~amd64
www-plugins/google-talkplugin ~amd64
www-servers/nginx ~amd64
=x11-misc/virtualgl-2.3-r1 ~amd64
=x11-misc/bumblebee-3.0-r1 ~amd64


glib ed edev sono entrambi commentati. Non capisco... :cry:
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Tue May 22, 2012 5:03 pm    Post subject: Reply with quote

Non facevi prima a stare in ~arch? :P

Il warning brevemente dice che ci sono più programmi che necessitano forzatamente di 2 versioni di uno stesso programma e siccome non esiste slot, non si può fare.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Tue May 22, 2012 6:02 pm    Post subject: Reply with quote

Non posso installarlo in uno slot forzatamente?

Non so se è un mito o una leggenda, ma stare in ~arch con tutto il sistema non è sconsigliato per chi ci lavoro con il pc perchè potrebbe trovarsi a fixare problemi un giorno si e l'altro pure?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Wed May 23, 2012 10:34 am    Post subject: Reply with quote

Stare in ~arch con tutto il sistema è da imbecilli, non è una leggenda.

La ragione è molto semplice e sta nelle dipendenze.
Alcuni pacchetti, pur essendo instabili, dipendono da librerie stabili o più spesso non dipendono dall'ultima versione instabile disponibile.

Il sistema in ~arch ti riporta tutto all'ultima versione instabile. Utilissimo per i tester e i devel per verificare i casi di cui sopra e rimediare (quando... chissà ... :roll: ).

Hai smascherato mezzo sistema senza limitare le versioni e questo ti comporta gli stessi problemi di un sistema ~arch di fatto.
Smaschera i pacchetti secondo la minima versione instabile richiesta lasciando solo la possibilità di includere l'ultima revisione;

e ci sono cose come questa
Quote:
sys-kernel/gentoo-sources ~amd64
sys-kernel/linux-headers **
gli headers è bene che siano un minimo aggiornati ma così finisce che ti trovi una versione del kernel inferiore a quella degli header e questo porta grane.
al massimo ~amd64 ma non andarsi a prendere una versione che non è stata neppure provata per quell'architettura;

e via dicendo...

@ago: continuo a ripetere che è grave dover evidenziare il sarcasmo ma questo è uno dei tanti casi. Purtroppo la tivvù di regime per prima cosa spegne l'ironia.
@stiffler83: meno televisione o quanto meno evita tolk show e reality... :twisted: :twisted: :twisted:

Tanto per evitare le solite lamentele e lacrime in stile "fornero" per la proditoria ed ingiustificata aggressione personale ribadisco che quanto sopra deve esser letto in tono ilare. C'è troppo di cui piangere proviamo almeno qui a predenre la vita con un poco di allegria...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Wed May 23, 2012 10:57 am; edited 1 time in total
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Wed May 23, 2012 10:56 am    Post subject: Reply with quote

Grazie ad entrambi per il supporto. 8)

@djinnZ sei sempre molto utile, ma ti consiglio un pò di relax perché essere cosi scontroso o almeno cosi risulti dai post non è piacevole per chi ti legge :D
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Wed May 23, 2012 11:05 am    Post subject: Reply with quote

djinnZ wrote:
Tanto per evitare le solite lamentele e lacrime in stile "fornero" per la proditoria ed ingiustificata aggressione personale ribadisco che quanto sopra deve esser letto in tono ilare. C'è troppo di cui piangere proviamo almeno qui a predenre la vita con un poco di allegria...
djinnZ's signature wrote:
verba et risus abundat in orae stultorum sed etiam semper severi insani sunt :wink:
mala tempora currunt... mater stultorum semper pregna est :twisted:
Murpy'sLaw: If anything can go wrong, it will - O'Toole's Corollary: Murphy was an optimist
Quanto grande lo devo scrivere che in ogni caso scherzo? :lol:
Tentiamo di non prenderci troppo sul serio ed alla lettera...

dimenticavo: per smascherare kde prendi il file di unmask dall'overlay, fai prima e meglio. :wink:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Wed May 23, 2012 11:12 am    Post subject: Reply with quote

Ma tranquillo era solo una considerazione non me la sono presa ;)

Grazie di nuovo a tutti e due, queste spiegazioni saranno molto utile per tutti.

P.S. Ora che faccio metto SOLVED sul topic visto che il problema è stato risolto?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Wed May 23, 2012 12:34 pm    Post subject: Reply with quote

djinnZ wrote:
Stare in ~arch con tutto il sistema è da imbecilli, non è una leggenda.


Avere tutto arch o ~arch è sicuramente più efficiente e consigliato di avere metà e metà :)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Wed May 23, 2012 3:05 pm    Post subject: Reply with quote

ago wrote:
Avere tutto arch o ~arch è sicuramente più efficiente e consigliato di avere metà e metà :)


bugia...

un metà e metà fatto "cum grano salis" è paragonabile ad un sistema stabile. Un metà e metà "ad cazzum canis" invece...
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Wed May 23, 2012 3:22 pm    Post subject: Reply with quote

Onip wrote:
ago wrote:
Avere tutto arch o ~arch è sicuramente più efficiente e consigliato di avere metà e metà :)


bugia...

un metà e metà fatto "cum grano salis" è paragonabile ad un sistema stabile. Un metà e metà "ad cazzum canis" invece...


Nessuna bugia, quello dici da appunto manforte alle mie parole. Non tutti sanno costruire un sistema metà e metà che abbia stabilità, quindi onde evitare casini, si consiglia un estremo o l'altro.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Wed May 23, 2012 5:56 pm    Post subject: Reply with quote

"Inizio a subdorare ein fregaturen" (cit. Sturmtruppen) chissà perché mi par proprio che voialtri devel e tester lasciate ambigua la spiegazione e consigliate tutto instabile per far fare agli altri il lavoro di verifica sulle dipendenze... ma è risaputo che sono malfidato, al limite della paranoia :lol:

Scherzi a parte in genere basta tenersi alla più bassa versione instabile richiesta e le cose sono facili. (e basta l'autounmask o usare l'apposto file per kde)
Ma è spiegato molto male.

Certo se 1k e passa pacchetti di un sistema completo metà sono instabili ... ma siamo sempre a quel "cum grano salis" di Don Camillo & Peppone :twisted:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Fri May 25, 2012 1:04 pm    Post subject: Reply with quote

In generale, visti i tempi con cui si stabilizza, a parte esigenze particolari, io terrei(tengo) tutto stabile.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Fri May 25, 2012 2:54 pm    Post subject: Reply with quote

ago wrote:

Nessuna bugia, quello dici da appunto manforte alle mie parole. Non tutti sanno costruire un sistema metà e metà che abbia stabilità, quindi onde evitare casini, si consiglia un estremo o l'altro.


ripeto meglio: il metà/metà nella _peggiore_ delle ipotesi è equivalente ad un sistema completamente ~. Non vedo seriamente il motivo di consigliare ~ rispetto al misto.
Io, di regola, uso i pacchetti base (X, toolchain e compagnia) stabili e aggiungo a ~ solamente gli strumenti di sviluppo o i pacchetti che voglio aiutare a testare o, ad esempio, gnome a circa metà strada tra l'introduzione in portage e la sua stabilizzazione. Non ho mai avuto grossi problemi o, ad ogni modo, non mi sono mai trovato con il sistema che non bootava. Con uno completamente ~, invece, non si è al riparo praticamente da niente...
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Fri May 25, 2012 3:57 pm    Post subject: Reply with quote

Onip wrote:
il metà/metà nella _peggiore_ delle ipotesi è equivalente ad un sistema completamente ~.


nel peggiore delle _TUE_(basate sulla tua esperienza) ipotesi.

Ripeto meglio anche io: nel caso in cui hai tutto ~ è più semplice trovare problemi che nel caso metà/metà.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum