Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
With systemd, KDE doesn't think NetworkManager is running
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
widremann
Veteran
Veteran


Joined: 14 Mar 2005
Posts: 1314

PostPosted: Sat May 19, 2012 3:47 pm    Post subject: With systemd, KDE doesn't think NetworkManager is running Reply with quote

I'm using systemd and the NetworkManager service is running (verified with systemctl). I have internet connectivity. However, I see a red X in the system tray and it says "Network Manager is not running. Please start it". As such, I can't configure the networks from KDE, which is my preference.

I took a break from systemd for a few weeks, but before that, this setup was working fine. Now after an upgrade cycle or two, KDE is no longer detecting NetworkManager.

Installed relevant packages (with ~amd64):

sys-apps/systemd-44-r1 USE="acl pam plymouth tcpd -audit -cryptsetup -lzma (-selinux)"
net-misc/networkmanager-0.9.4.0-r2 USE="bluetooth dhcpcd introspection nss ppp systemd wext -avahi -connection-sharing -dhclient -doc -gnutls -modemmanager -resolvconf -wimax"

I'm not sure which package provides the KDE network widget.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 584
Location: United Kingdom

PostPosted: Sat May 19, 2012 5:40 pm    Post subject: Re: With systemd, KDE doesn't think NetworkManager is runnin Reply with quote

widremann wrote:
I'm not sure which package provides the KDE network widget.

These days it is kde-misc/networkmanagement rather than KNetworkManager:

Code:
$ eix -I networkmanagement
[I] kde-misc/networkmanagement
     Available versions:  (4) 0.8_p20110714^t (~)0.9.0.1 (~)0.9.0.2
        {{aqua consolekit debug linguas_ar linguas_ca linguas_cs linguas_da linguas_de linguas_el linguas_es linguas_et linguas_fa linguas_fi linguas_ga linguas_hu linguas_it linguas_ja linguas_km linguas_lt linguas_nb linguas_nds linguas_nl linguas_nn linguas_pl linguas_pt linguas_pt_BR linguas_se linguas_sk linguas_sv linguas_tr linguas_uk linguas_zh_TW}}
     Installed versions:  0.9.0.2(4)(00:06:02 15/05/12)(linguas_pt_BR -aqua -debug -linguas_ar -linguas_ca -linguas_cs -linguas_da -linguas_de -linguas_el -linguas_es -linguas_et -linguas_fa -linguas_fi -linguas_ga -linguas_hu -linguas_it -linguas_ja -linguas_km -linguas_lt -linguas_nb -linguas_nds -linguas_nl -linguas_nn -linguas_pl -linguas_pt -linguas_se -linguas_sk -linguas_sv -linguas_tr -linguas_uk -linguas_zh_TW)
     Homepage:            http://kde.org/
     Description:         KDE frontend for NetworkManager

_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
widremann
Veteran
Veteran


Joined: 14 Mar 2005
Posts: 1314

PostPosted: Sat May 19, 2012 6:15 pm    Post subject: Re: With systemd, KDE doesn't think NetworkManager is runnin Reply with quote

Fitzcarraldo wrote:
widremann wrote:
I'm not sure which package provides the KDE network widget.

These days it is kde-misc/networkmanagement rather than KNetworkManager:

Code:
$ eix -I networkmanagement
[I] kde-misc/networkmanagement
     Available versions:  (4) 0.8_p20110714^t (~)0.9.0.1 (~)0.9.0.2
        {{aqua consolekit debug linguas_ar linguas_ca linguas_cs linguas_da linguas_de linguas_el linguas_es linguas_et linguas_fa linguas_fi linguas_ga linguas_hu linguas_it linguas_ja linguas_km linguas_lt linguas_nb linguas_nds linguas_nl linguas_nn linguas_pl linguas_pt linguas_pt_BR linguas_se linguas_sk linguas_sv linguas_tr linguas_uk linguas_zh_TW}}
     Installed versions:  0.9.0.2(4)(00:06:02 15/05/12)(linguas_pt_BR -aqua -debug -linguas_ar -linguas_ca -linguas_cs -linguas_da -linguas_de -linguas_el -linguas_es -linguas_et -linguas_fa -linguas_fi -linguas_ga -linguas_hu -linguas_it -linguas_ja -linguas_km -linguas_lt -linguas_nb -linguas_nds -linguas_nl -linguas_nn -linguas_pl -linguas_pt -linguas_se -linguas_sk -linguas_sv -linguas_tr -linguas_uk -linguas_zh_TW)
     Homepage:            http://kde.org/
     Description:         KDE frontend for NetworkManager

I'm using networkmanagement already, and it's at the latest version.
Back to top
View user's profile Send private message
Xytovl
Tux's lil' helper
Tux's lil' helper


Joined: 15 Mar 2009
Posts: 92

PostPosted: Sun May 20, 2012 8:48 am    Post subject: Reply with quote

I have had similar issues, I think it is related by the "systemd" useflag that replaces consolekit with systemd.
You have to tell pam to use pam_systemd.so, I have tried adding "session optional pam-systemd.so" in /etc/pam.d/system-auth. It mostly works for polkit which disabled the power button in gnome.
However this is probably not the exact fix: I still have no power button in gdm and when "su" command ends I have a "killed" message.
Back to top
View user's profile Send private message
widremann
Veteran
Veteran


Joined: 14 Mar 2005
Posts: 1314

PostPosted: Tue May 29, 2012 4:49 am    Post subject: Reply with quote

Xytovl wrote:
I have had similar issues, I think it is related by the "systemd" useflag that replaces consolekit with systemd.
You have to tell pam to use pam_systemd.so, I have tried adding "session optional pam-systemd.so" in /etc/pam.d/system-auth. It mostly works for polkit which disabled the power button in gnome.
However this is probably not the exact fix: I still have no power button in gdm and when "su" command ends I have a "killed" message.

That seemed to do the trick. Haven't tested power button, but I'm not using GDM.
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sat Jun 02, 2012 2:04 pm    Post subject: Reply with quote

Xytovl wrote:
I have had similar issues, I think it is related by the "systemd" useflag that replaces consolekit with systemd.
You have to tell pam to use pam_systemd.so, I have tried adding "session optional pam-systemd.so" in /etc/pam.d/system-auth. It mostly works for polkit which disabled the power button in gnome.
However this is probably not the exact fix: I still have no power button in gdm and when "su" command ends I have a "killed" message.


I also had these weird issue's when I tried to use lightdm with consolekit. Adding the pam_loginuid module fixed these issue's. Maybe here as well?

session optional pam_loginuid.so
session optional pam_ck_connector.so nox11

P.S. I still have no idea what it exactly does, it's man page is like black magic to me.
Back to top
View user's profile Send private message
warrens
Apprentice
Apprentice


Joined: 04 Jan 2005
Posts: 231
Location: Don't Tread On Me!

PostPosted: Mon Jan 21, 2013 10:24 pm    Post subject: Reply with quote

I had the problem as op.Fixed by adding "session optional pam_systemd.so" to /etc/pam.d/system-auth. After rebooting networkmanagement came right up in the panel showing my connection to the network.
_________________
The BIGGER the GOVERNMENT, the smaller the citizen.

DON'T TREAD ON ME!!!

My Bias #1
The best government is the government that governs least.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum