Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Autouruchamianie KDE w Gentoo 6.3.1 [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Wed Apr 18, 2012 10:07 am    Post subject: Autouruchamianie KDE w Gentoo 6.3.1 [solved] Reply with quote

Witam.
Mam problem z serwerem w firmie. Chciałbym, żeby środowisko KDE uruchamiało się automatycznie. Obecnie aby uruchomić KDE muszę:
1. włączyć komputer i poczekać aż pojawi się czarny ekran z białym "X"
2. następnie muszę nacisnąć klawisze Ctrl + Alt + Backspace
3. wpisać nazwę użytkownika: root
4. wpisać hasło roota
5. wpisać kdm i nacisnąć enter.
Dopiero w tym momencie pojawia się graficzne okno logowania z możliwością wprowadzenia użytkownika i hasła.

Czy jest jakiś prosty sposób na zautomatyzowanie tego procesu. Chciałbym widzieć graficzne okno logowania bez wpisywania hasła roota.

Pozdrawam, Sylwek


Last edited by jogurt2003 on Mon Apr 30, 2012 8:38 am; edited 1 time in total
Back to top
View user's profile Send private message
Crenshaw
Guru
Guru


Joined: 23 Jun 2004
Posts: 474
Location: Poland

PostPosted: Wed Apr 18, 2012 11:34 am    Post subject: Reply with quote

Zajrzyj do dokumentacji gentoo. Jesli to nie pomoze to idz tutaj:

http://bit.ly/Jc6CzW
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Tue Apr 24, 2012 8:13 am    Post subject: Reply with quote

Ustawiłem w /etc/X11/Sessions:
DISPLAYMANAGER="kdm"
XSESSION="kde-3.1.5"

oraz dodałem wpis:
# rc-update add xdm default

Po restarcie uruchomiło się okno logowania KDE:). Niby problem rozwiązany.
Niestety po kolejnym restarcie serwera znów pojawił się czarny ekran z X-em, znów należy wprowadzać komendy root, hasło, kdm.

Korzystam z 3 poziomu startowego.
Zmiana na poziom 5 nie pomaga. Natomiast po zmianie w /etc/inittab poziomu z 5 na 3 pierwsze logowanie odbywa się za pomocą KDE a nie X.
Oczywiście kolejne uruchomienia już tylko z X

Gdzie szukać rozwiązania problemu?
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Tue Apr 24, 2012 8:28 am    Post subject: Reply with quote

Dodanie

kdm

do /etc/conf.d/local.start

też nie pomogło.
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Tue Apr 24, 2012 9:58 am    Post subject: Pliki konfiguracyjne Reply with quote

/etc/X11/xdm/xdm-config
! $Xorg: xdm-conf.cpp,v 1.3 2000/08/17 19:54:17 cpqbld Exp $
!
!
!
!
! $XFree86: xc/programs/xdm/config/xdm-conf.cpp,v 1.10 2002/11/30 19:11:32 herrb Exp $
!
DisplayManager.errorLogFile: /var/log/xdm.log
DisplayManager.pidFile: /var/run/xdm.pid
DisplayManager.keyFile: /etc/X11/xdm/xdm-keys
DisplayManager.servers: /etc/X11/xdm/Xservers
DisplayManager.accessFile: /etc/X11/xdm/Xaccess
DisplayManager.willing: su nobody -c /etc/X11/xdm/Xwilling
! All displays should use authorization, but we cannot be sure
! X terminals may not be configured that way, so they will require
! individual resource settings.
DisplayManager*authorize: true
! The following three resources set up display :0 as the console.
DisplayManager._0.setup: /etc/X11/xdm/Xsetup_0
DisplayManager._0.startup: /etc/X11/xdm/GiveConsole
DisplayManager._0.reset: /etc/X11/xdm/TakeConsole
!
DisplayManager*resources: /etc/X11/xdm/Xresources
DisplayManager*session: /etc/X11/xdm/Xsession
DisplayManager*authComplain: true



! SECURITY: do not listen for XDMCP or Chooser requests
! Comment out this line if you want to manage X terminals with xdm
DisplayManager.requestPort: 0
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Tue Apr 24, 2012 9:58 am    Post subject: Reply with quote

/etc/inittab
#
# /etc/inittab: This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@cistron.nl>
# Modified by: Patrick J. Volkerding, <volkerdi@ftp.cdrom.com>
# Modified by: Daniel Robbins, <drobbins@gentoo.org>
# Modified by: Martin Schlemmer, <azarah@gentoo.org>
#
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/inittab,v 1.6 2003/01/06 21:32:43 azarah Exp $

#
# Default runlevel.
id:3:initdefault:

# System initialization, mount local filesystems, etc.
si::sysinit:/sbin/rc sysinit

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/rc boot

l0:0:wait:/sbin/rc shutdown
l1:S1:wait:/sbin/rc single
l2:2:wait:/sbin/rc nonetwork
l3:3:wait:/sbin/rc default
l4:4:wait:/sbin/rc default
l5:5:wait:/sbin/rc default
l6:6:wait:/sbin/rc reboot
#z6:6:respawn:/sbin/sulogin

# TERMINALS
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now

# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh

# End of /etc/inittab
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Tue Apr 24, 2012 9:59 am    Post subject: Reply with quote

/etc/conf.d/local.start
# /etc/conf.d/local.start:
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/local.start,v 1.4 2002/11/18 19:39:22 azarah Exp $

# This is a good place to load any misc.
# programs on startup ( 1>&2 )
/sbin/./sysctl -p /etc/sysctl.conf
setserial /dev/ttyS0 low_latency
chmod a+rw /dev/parport0
su - -c /usr/X11R6/bin/X pcig &
kdm
echo "completed /etc/conf.d/local.start"
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Tue Apr 24, 2012 10:01 am    Post subject: Reply with quote

/etc/rc.conf
# /etc/rc.conf: Global startup script configuration settings
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/rc.conf,v 1.22 2003/10/21 06:09:42 vapier Exp $

# Use KEYMAP to specify the default console keymap. There is a complete tree
# of keymaps in /usr/share/keymaps to choose from. This setting is used by the
# /etc/init.d/keymaps script.

KEYMAP="us"

# Should we first load the 'windowkeys' console keymap? Most x86 users will
# say "yes" here. Note that non-x86 users should leave it as "no".

SET_WINDOWKEYS="no"

# The maps to load for extended keyboards. Most users will leave this as is.

EXTENDED_KEYMAPS=
#EXTENDED_KEYMAPS="backspace keypad"

# CONSOLEFONT specifies the default font that you'd like Linux to use on the
# console. You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).

CONSOLEFONT="default8x16"

# CONSOLETRANSALTION is the charset map file to use. Leave commented to use
# the default one. Have a look in /usr/share/consoletrans for a selection of
# map files you can use.

#CONSOLETRANSLATION="8859-1_to_uni"

# Set CLOCK to "UTC" if your system clock is set to UTC (also known as
# Greenwich Mean Time). If your clock is set to the local time, then set CLOCK
# to "local". This setting is used by the /etc/init.d/clock script.

CLOCK="UTC"

# Set EDITOR to your preferred editor.

EDITOR="/bin/nano"
#EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"

# Set PROTOCOLS to the protocols that you plan to use. Gentoo Linux will only
# enable module auto-loading for these protocols, eliminating annoying module
# not found errors.
#
# NOTE: Do NOT uncomment the next lines, but add them to 'PROTOCOLS=...' line!!
#
# Num Protocol
# 1: Unix
# 2: IPv4
# 3: Amateur Radio AX.25
# 4: IPX
# 5: DDP / appletalk
# 6: Amateur Radio NET/ROM
# 9: X.25
# 10: IPv6
# 11: ROSE / Amateur Radio X.25 PLP
# 19: Acorn Econet

# Most users want this:
PROTOCOLS="1 2 10"

#For IPv6 support:
#PROTOCOLS="1 2 10"

# What display manager do you use ? [ xdm | gdm | kdm | entrance ]
DISPLAYMANAGER="kdm"

# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit. The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to. The support scripts is smart enouth to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enligtenment" can also work. This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE: 1) this behaviour is overridden when a ~/.xinitrc exists, and startx
# is called.
# 2) even if a ~/.xsession exist, if XSESSION can be resolved, it will
# be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (ex: kde-3.0.2)
# Xsession - will start a terminal and a few other nice apps

XSESSION="kde-3.1.5"
Back to top
View user's profile Send private message
Crenshaw
Guru
Guru


Joined: 23 Jun 2004
Posts: 474
Location: Poland

PostPosted: Tue Apr 24, 2012 11:04 am    Post subject: Reply with quote

jogurt2003 wrote:
Ustawiłem w /etc/X11/Sessions:
DISPLAYMANAGER="kdm"
XSESSION="kde-3.1.5"

oraz dodałem wpis:
# rc-update add xdm default

Po restarcie uruchomiło się okno logowania KDE:). Niby problem rozwiązany.
Niestety po kolejnym restarcie serwera znów pojawił się czarny ekran z X-em, znów należy wprowadzać komendy root, hasło, kdm.

Korzystam z 3 poziomu startowego.
Zmiana na poziom 5 nie pomaga. Natomiast po zmianie w /etc/inittab poziomu z 5 na 3 pierwsze logowanie odbywa się za pomocą KDE a nie X.
Oczywiście kolejne uruchomienia już tylko z X

Gdzie szukać rozwiązania problemu?


Moze sproboj odpalic xdm recznie

/etc/init.d/xdm start

i moze w logach powie Ci co go boli...

I druga rzecz ja mam plik /etc/X11/Sessions/KDE-4 ktory nalezy do pakietu kdebase-startkde i nigdy nie musialem zagladac do X11/Sessions, moze tego Ci brakuje?
Back to top
View user's profile Send private message
jogurt2003
n00b
n00b


Joined: 18 Apr 2012
Posts: 10

PostPosted: Thu Apr 26, 2012 10:50 am    Post subject: Reply with quote

Sprawa rozwiązana.

Pomogło dodanie do /etc/conf.d/local.start:
/etc/init.d/xdm start

i deaktywacja komendy
# su - -c /usr/X11R6/bin/X pcig &

Dzięki Crenshaw za pomoc.
Back to top
View user's profile Send private message
ryba84
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2008
Posts: 109

PostPosted: Fri Apr 27, 2012 8:55 pm    Post subject: Reply with quote

A pokaż
Code:
rc-update list
bo problem leży chyba gdzie indziej ;)
_________________
Poziomki powstają przez przewracanie pionków ;)
Back to top
View user's profile Send private message
lazy_bum
l33t
l33t


Joined: 16 Feb 2005
Posts: 690

PostPosted: Sat Apr 28, 2012 8:05 pm    Post subject: Reply with quote

ryba84 wrote:
bo problem leży chyba gdzie indziej ;)

Między krzesłem a klawiaturą…
_________________
roslin uberlay | grubelek
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum