Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kernel]clavier/souris sans fil microsoft (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Tue Apr 17, 2012 10:35 am    Post subject: [kernel]clavier/souris sans fil microsoft (résolu) Reply with quote

Bonjour,

Pour préparer une installation de gentoo, je me rode en compilant un noyau debian (3.2.14).

Après le chargement de la configuration par défaut (make defconfig), les claviers et souris filaires usb fonctionnent.
Mais je n'ai pas trouvé l'option pour les claviers et souris sans fil microsoft.
Ceux-ci fonctionnent évidemment avec le noyau standard.

Merci de votre aide.


Last edited by avi3000 on Thu Apr 19, 2012 10:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Tue Apr 17, 2012 2:00 pm    Post subject: Reply with quote

Salut,

Vérifie que l'option CONFIG_USB_HID soit compilée en dur.
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Tue Apr 17, 2012 2:16 pm    Post subject: Reply with quote

de mémoire je l'ai codée en dur.

Après réflexion, il me semble que j'ai désactivé le bluetooth.
Je vérifierai ce soir.

Merci.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Tue Apr 17, 2012 2:25 pm    Post subject: Reply with quote

Dans ce cas on ne parle pas de la même chose. Sans fil != bluetooth.
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Tue Apr 17, 2012 3:12 pm    Post subject: Reply with quote

Sans fil=RF ou driver manquant ??

Clavier Microsoft Wireless Media Desktop 1000
Back to top
View user's profile Send private message
Deusexodus
Tux's lil' helper
Tux's lil' helper


Joined: 30 May 2005
Posts: 124
Location: Paris

PostPosted: Tue Apr 17, 2012 9:18 pm    Post subject: Reply with quote

Sans fil veut dire logiquement (enfin pour moi) que ta souris et ton clavier communique en radio-frequence avec un dongle fournis. Sans precision de la technologie je ne vois que cela. Sinon on tape sur du Wi-Fi, WiMAX, bluetooth et que sais-je encore...

Je te conseille de lancer `make gconfig` pour le kernel et avec le mode recherche tu auras moyen de te faciliter la vie (je ne dis pas que tu n'as pas chercher), je viens de voir cette option qui me semble pas mal :

Code:
Networking support
  -> Bluetooth subsystem support
    -> HIDP protocol support


Bon courage.
_________________
Lenovo x220 | Lenovo S12 | Hp mini 2133 | Via VB8001
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Apr 18, 2012 6:37 am    Post subject: Reply with quote

Sur un système j'ai exactement le même combo clavier/souris, la liaison wireless est une liaison radio (RF) à 27MHz.
Fonctionne comme un clavier tout ce qu'il a de plus classique, avec :
Code:

# zgrep -E 'USB|INPUT' /proc/config.gz | grep '=y'
CONFIG_INPUT=y
CONFIG_INPUT_FF_MEMLESS=y
CONFIG_INPUT_POLLDEV=y
CONFIG_INPUT_MOUSEDEV=y
CONFIG_INPUT_JOYDEV=y
CONFIG_INPUT_EVDEV=y
CONFIG_INPUT_KEYBOARD=y
CONFIG_INPUT_MOUSE=y
CONFIG_INPUT_JOYSTICK=y
CONFIG_INPUT_MISC=y
CONFIG_INPUT_PCSPKR=y
CONFIG_USB_HID=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_SUPPORT=y
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_ARCH_HAS_OHCI=y
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB=y
CONFIG_USB_DEBUG=y
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
CONFIG_USB_DEVICEFS=y
CONFIG_USB_SUSPEND=y
CONFIG_USB_MON=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_UHCI_HCD=y
CONFIG_USB_PRINTER=y
CONFIG_USB_STORAGE=y
CONFIG_USB_LIBUSUAL=y

Et le pilote evdev sous xorg. Comment testes tu ton clavier ? dans un TTY ou sous X ?
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Wed Apr 18, 2012 9:02 am    Post subject: Reply with quote

Code:
Networking support
  -> Bluetooth subsystem support
    -> HIDP protocol support

sans résultat

Deusexodus wrote:
Bon courage.
il en faut.

@netfab
Je vérifierai toutes ces options ce soir.
Je n'ai pas eu le réflexe de tester en tty.
Où se trouvent les options à positionner pour une liaison radio (RF) à 27MHz ?
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Apr 18, 2012 9:18 am    Post subject: Reply with quote

avi3000 wrote:

Où se trouvent les options à positionner pour une liaison radio (RF) à 27MHz ?

Il n'y a aucune option. La liaison radio wireless s'effectue entre tes claviers/souris et le récepteur que tu branches par USB. Rien à voir avec le kernel.
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Wed Apr 18, 2012 2:07 pm    Post subject: Reply with quote

netfab wrote:
avi3000 wrote:

Où se trouvent les options à positionner pour une liaison radio (RF) à 27MHz ?

Il n'y a aucune option. La liaison radio wireless s'effectue entre tes claviers/souris et le récepteur que tu branches par USB. Rien à voir avec le kernel.

Mais il faut quand même activer l'USB ;) Cela va sans dire, mais cela va mieux en le disant.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Wed Apr 18, 2012 6:08 pm    Post subject: Reply with quote

chris972 wrote:
Mais il faut quand même activer l'USB ;) Cela va sans dire, mais cela va mieux en le disant.

C'est vrai :mrgreen:

Mais dans ce cas on tourne en rond, car dans son premier post il a écrit :
Quote:

les claviers et souris filaires usb fonctionnent.

C'est donc que le support USB du kernel est activé.

Or, un clavier filaire USB peut très bien fonctionner sans l'option CONFIG_USB_HID (tout dépend du modèle de clavier).
En revanche, ce clavier là précisément ne fonctionne pas tant que CONFIG_USB_HID n'est pas chargé (c'est le bug #270983). D'où ma première réponse.

Sinon, la phrase suivante :
Quote:

Je n'ai pas eu le réflexe de tester en tty.

me fait penser à un simple problème de configuration xorg (en admettant que la config kernel soit bonne).

Il faudrait donc plus de précisions pour déterminer l'origine du problème.
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Wed Apr 18, 2012 7:44 pm    Post subject: Reply with quote

ma config
Code:
CONFIG_RFKILL_INPUT=y
CONFIG_INPUT=y
CONFIG_INPUT_FF_MEMLESS=y
CONFIG_INPUT_POLLDEV=y
CONFIG_INPUT_SPARSEKMAP=y
CONFIG_INPUT_MOUSEDEV=y
CONFIG_INPUT_EVDEV=y
CONFIG_INPUT_KEYBOARD=y
CONFIG_INPUT_MOUSE=y
CONFIG_INPUT_JOYSTICK=y
CONFIG_INPUT_TABLET=y
CONFIG_INPUT_TOUCHSCREEN=y
CONFIG_INPUT_MISC=y
CONFIG_SND_USB=y
CONFIG_USB_HID=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_SUPPORT=y
CONFIG_USB_COMMON=y
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_ARCH_HAS_OHCI=y
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB_ARCH_HAS_XHCI=y
CONFIG_USB=y
CONFIG_USB_DEBUG=y
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
CONFIG_USB_DEVICEFS=y
CONFIG_USB_MON=y
CONFIG_USB_WUSB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_UHCI_HCD=y
CONFIG_USB_WHCI_HCD=y
CONFIG_USB_HWA_HCD=y
CONFIG_USB_PRINTER=y
CONFIG_USB_WDM=y
CONFIG_USB_STORAGE=y
CONFIG_USB_LIBUSUAL=y

j'ai testé en tty, ce n'est pas mieux.
Si la config xorg avait posé problème, je pense que le problème aurait été le même avec le kernel standard.

quand je démarre avec le clavier filaire branché, le clavier microsoft fonctionne, mais mal.
il faut taper plusieurs fois sur les touches ou à l'inverse il y a répétition de la touche.

:evil: :evil:
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Thu Apr 19, 2012 10:11 pm    Post subject: Reply with quote

J'ai résolu/contourné le problème.

make localyesconfig ou make localmodconfig en lieu et place de make defconfig
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Fri Apr 20, 2012 6:30 am    Post subject: Reply with quote

Ok, mais on n'en sait pas plus, puisqu'en gros çà a copié ta config debian pour la compil de ton kernel.
Bizarre cette histoire. Je vais tester le defconfig avec ce clavier dès que j'aurai 2 minutes.

Edit: Ouais, en fait je ne sais pas si j'aurai le temps de tester, d'autant que çà serait avancer à l'aveuglette tant que je n'arrive pas à reproduire ce comportement.
Si çà t'intéresse je peux te donner un diff entre ma config qui fonctionne sur une gentoo et le defconfig.
Par rapport au defconfig (que je n'ai jamais utilisé) en gros je désactive un maximum d'options dont je n'ai pas besoin, dont certains pilotes CONFIG_HID_* qui entrent peut-être en conflit...
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Fri Apr 20, 2012 9:57 am    Post subject: Reply with quote

Comme je ne trouvais pas, j'ai compilé le noyau avec le config générique.
Une heure de compile sur un i5, mais le pack clavier/souris fonctionnait.

la 2ème étape était le locayesconfig, 30mn de compile, mais toujours fonctionnel.

les 3èmes, 4èmes ... Nèmes étapes étaient des configurations manuelles et des restaurations,
pour arriver à 7'40 de compile, un kernel de 3,4 Mo et un initrd de 2,4Mo.

Le tout fonctionne parfaitement, mais les gains en vitesse de chargement sont infimes.
L'empreinte mémoire est réduite de 3-4%.
J'ai également pu supprimer des pseudo-démons comme cpufrequtils ou loadcpufreq.

L'important est de l'avoir fait.

merci pour ton aide.
Back to top
View user's profile Send private message
avi3000
n00b
n00b


Joined: 24 Dec 2011
Posts: 8
Location: France

PostPosted: Tue May 01, 2012 5:21 pm    Post subject: Reply with quote

après qq tests il faut ajouter CONFIG_USB_EHCI_TT_NEWSCHED=y à la config par défaut
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum