Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
@preserved-rebuild nag nag nag !!!!!!
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 3991
Location: india

PostPosted: Wed Apr 11, 2012 2:58 am    Post subject: @preserved-rebuild nag nag nag !!!!!! Reply with quote

Code:
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: xfce-base/libxfce4util-4.9.0
 *  - /usr/lib/libxfce4util.so.4
 *  - /usr/lib/libxfce4util.so.4.1.1
 *      used by /usr/bin/xfce4-power-information (xfce-extra/xfce4-power-manager-1.0.11)
 *      used by /usr/bin/xfce4-power-manager (xfce-extra/xfce4-power-manager-1.0.11)
 *      used by /usr/bin/xfce4-power-manager-settings (xfce-extra/xfce4-power-manager-1.0.11)
 *      used by 19 other files
>>> package: net-misc/curl-7.25.0
 *  - /usr/lib/libcurl.so.4
 *  - /usr/lib/libcurl.so.4.2.0
 *      used by /usr/lib/enlightenment/modules/evry-websearch/linux-gnu-i686-ver-pre-svn-08/module.so (x11-plugins/e_modules-everything-websearch-9999)
 *      used by /usr/lib/libecore_con.so.1.1.0 (dev-libs/ecore-9999)
 *      used by /usr/lib/libecore_file.so.1.1.0 (dev-libs/ecore-9999)
 *      used by 2 other files
>>> package: dev-libs/icu-4.8.1.1-r1
 *  - /usr/lib/libicuuc.so.49
 *  - /usr/lib/libicuuc.so.49.1
 *      used by /usr/bin/bibtexu (dev-tex/bibtexu-3.71_p20110705)
 *      used by /usr/lib/libraptor2.so.0.0.0 (media-libs/raptor-2.0.7)
 *      used by /usr/lib/qt4/libQtWebKit.so.4.9.0 (x11-libs/qt-webkit-4.8.1)
 *      used by /usr/lib/tracker-0.12/libtracker-data.so.0.1200.10 (app-misc/tracker-0.12.10)
 *  - /usr/lib/libicui18n.so.49
 *  - /usr/lib/libicui18n.so.49.1
 *      used by /usr/bin/bibtexu (dev-tex/bibtexu-3.71_p20110705)
 *      used by /usr/lib/tracker-0.12/libtracker-data.so.0.1200.10 (app-misc/tracker-0.12.10)
 *  - /usr/lib/libicudata.so.49
 *  - /usr/lib/libicudata.so.49.1
Use emerge @preserved-rebuild to rebuild packages using these libraries
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.
localtux ramaswamy # emerge @preserved-rebuild
Calculating dependencies... done!

!!! All ebuilds that could satisfy "x11-libs/qt-webkit:4" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-webkit-4.8.1::gentoo (masked by: package.mask)
- x11-libs/qt-webkit-4.7.4::gentoo (masked by: package.mask)
- x11-libs/qt-webkit-4.7.2::gentoo (masked by: package.mask)
- x11-libs/qt-webkit-4.6.3-r2::gentoo (masked by: package.mask)
- x11-libs/qt-webkit-4.6.3-r1::gentoo (masked by: package.mask)
- x11-libs/qt-webkit-4.6.3::gentoo (masked by: package.mask)

(dependency required by "@preserved-rebuild" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

localtux ramaswamy # nano -w /etc/portage/package.mask
localtux ramaswamy # emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "xfce-extra/thunar-vfs:0".
(dependency required by "@preserved-rebuild" [argument])
localtux ramaswamy #


mask unmask did not help
how can i get rid of this nags
if i manually emerge the packages which are the ones i have to emerge?
can i delete the preserved libs ?
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Wed Apr 11, 2012 5:38 am    Post subject: Re: @preserved-rebuild nag nag nag !!!!!! Reply with quote

padoor wrote:
Code:

emerge: there are no ebuilds to satisfy "xfce-extra/thunar-vfs:0".
(dependency required by "@preserved-rebuild" [argument])
localtux ramaswamy #


mask unmask did not help
how can i get rid of this nags
if i manually emerge the packages which are the ones i have to emerge?
can i delete the preserved libs ?
You need to read your output. thunar-vfs is no longer in portage, so you should unmerge that package before proceeding with preserved-rebuild.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 669

PostPosted: Wed Apr 11, 2012 7:56 am    Post subject: Reply with quote

You should do 'emerge --depclean -a' more often.
_________________
My political bias.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3181

PostPosted: Wed Apr 11, 2012 9:13 am    Post subject: Reply with quote

pigeon768 wrote:
You should do 'emerge --depclean -a' more often.
Actually, I don't think depclean will remove packages like this always. depclean removes stuff which are no longer in the world file or which don't have reverse deps in the world file. In some cases, it might be possible that the package is still listed on the world file but the version installed is too old or the package is removed from portage. In these cases, depclean will probably not remove that package.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 3991
Location: india

PostPosted: Wed Apr 11, 2012 10:48 am    Post subject: Reply with quote

Code:
* Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep @world` prior to depclean.

Calculating dependencies  .. ... ... ....... ...... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 app-admin/system-config-printer-gnome
    selected: 1.3.7
   protected: none
     omitted: none

 x11-plugins/e_modules-diskio
    selected: 9999
   protected: none
     omitted: none

 sys-fs/sysfsutils
    selected: 2.1.0
   protected: none
     omitted: none

 app-office/dia
    selected: 0.97.1
   protected: none
     omitted: none

 x11-plugins/e_modules-iiirk
    selected: 9999
   protected: none
     omitted: none

 x11-themes/detourious
    selected: 9999
   protected: none
     omitted: none

 media-libs/libtiger
    selected: 0.3.4
   protected: none
     omitted: none

 media-plugins/gst-plugins-esd
    selected: 0.10.30
   protected: none
     omitted: none

 x11-plugins/e_modules-penguins
    selected: 9999
   protected: none
     omitted: none

 x11-libs/neXtaw
    selected: 0.15.1-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-slideshow
    selected: 9999
   protected: none
     omitted: none

 virtual/blas
    selected: 1.0
   protected: none
     omitted: none

 net-libs/eupnp
    selected: 9999
   protected: none
     omitted: none

 x11-misc/alacarte
    selected: 0.13.2
   protected: none
     omitted: none

 media-video/transcode
    selected: 1.1.7-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-snow
    selected: 9999
   protected: none
     omitted: none

 x11-libs/dnd
    selected: 1.1-r1
   protected: none
     omitted: none

 media-libs/zvbi
    selected: 0.2.33
   protected: none
     omitted: none

 x11-plugins/e_modules-alarm
    selected: 9999
   protected: none
     omitted: none

 media-video/dvdauthor
    selected: 0.7.0
   protected: none
     omitted: none

 media-libs/win32codecs
    selected: 20071007-r4
   protected: none
     omitted: none

 media-video/emovix
    selected: 0.9.0
   protected: none
     omitted: none

 dev-libs/libappindicator
    selected: 0.4.1-r201
   protected: none
     omitted: none

 dev-games/ggz-client-libs
    selected: 0.0.14.1
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-places
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-net
    selected: 9999
   protected: none
     omitted: none

 dev-libs/boost
    selected: 1.47.0-r1
   protected: none
     omitted: none

 dev-libs/libconfig
    selected: 1.4.8
   protected: none
     omitted: none

 media-libs/vigra
    selected: 1.7.1-r1
   protected: none
     omitted: none

 media-libs/e_phys
    selected: 9999
   protected: none
     omitted: none

 dev-python/telepathy-python
    selected: 0.15.19
   protected: none
     omitted: none

 x11-plugins/e_modules-winselector
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-news
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-wlan
    selected: 9999
   protected: none
     omitted: none

 sys-libs/libavc1394
    selected: 0.5.3
   protected: none
     omitted: none

 media-video/ogle
    selected: 0.9.2-r2
   protected: none
     omitted: none

 x11-themes/gnome-themes
    selected: 2.32.1-r1
   protected: none
     omitted: none

 media-libs/libmtp
    selected: 1.1.2
   protected: none
     omitted: none

 sys-libs/ememoa
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-eweather
    selected: 9999
   protected: none
     omitted: none

 dev-python/feedparser
    selected: 5.0.1
   protected: none
     omitted: none

 x11-plugins/e_modules-moon
    selected: 9999
   protected: none
     omitted: none

 sys-process/time
    selected: 1.7-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-comp-scale
    selected: 9999
   protected: none
     omitted: none

 media-libs/libprojectm
    selected: 2.0.1-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-engage
    selected: 9999
   protected: none
     omitted: none

 x11-libs/xosd
    selected: 2.2.14-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-screenshot
    selected: 9999
   protected: none
     omitted: none

 app-text/epdf
    selected: 9999
   protected: none
     omitted: none

 x11-themes/blingbling
    selected: 9999
   protected: none
     omitted: none

 media-libs/schroedinger
    selected: 1.0.10-r1
   protected: none
     omitted: none

 dev-python/reportlab
    selected: 2.5
   protected: none
     omitted: none

 virtual/fam
    selected: 0
   protected: none
     omitted: none

 x11-plugins/e_modules-language
    selected: 9999
   protected: none
     omitted: none

 dev-python/httplib2
    selected: 0.7.1
   protected: none
     omitted: none

 net-wireless/wireless-tools
    selected: 30_pre9
   protected: none
     omitted: none

 x11-libs/libva
    selected: 1.0.15
   protected: none
     omitted: none

 x11-libs/libXaw3d
    selected: 1.5-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-tracker
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-deskshow
    selected: 9999
   protected: none
     omitted: none

 net-libs/libupnp
    selected: 1.6.14
   protected: none
     omitted: none

 x11-plugins/e_modules-tclock
    selected: 9999
   protected: none
     omitted: none

 media-gfx/exquisite
    selected: 9999
   protected: none
     omitted: none

 app-cdr/dvd+rw-tools
    selected: 7.1-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-mpdule
    selected: 9999
   protected: none
     omitted: none

 media-libs/compface
    selected: 1.5.2
   protected: none
     omitted: none

 x11-plugins/e_modules-mail
    selected: 9999
   protected: none
     omitted: none

 gnome-extra/deskbar-applet
    selected: 2.32.0
   protected: none
     omitted: none

 app-admin/pessulus
    selected: 2.30.4
   protected: none
     omitted: none

 media-libs/enlil
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/ecomorph
    selected: 9999
   protected: none
     omitted: none

 dev-python/python-edje
    selected: 9999
   protected: none
     omitted: none

 dev-libs/check
    selected: 0.9.8-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-wallpaper
    selected: 9999
   protected: none
     omitted: none

 media-sound/fluidsynth
    selected: 1.1.5
   protected: none
     omitted: none

 gnome-extra/swfdec-gnome
    selected: 2.30.1
   protected: none
     omitted: none

 dev-libs/libunique
    selected: 1.1.6-r1
   protected: none
     omitted: 3.0.2

 gnome-extra/hamster-applet
    selected: 2.32.1
   protected: none
     omitted: none

 x11-plugins/e_modules-e-tiling
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-shotgun
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/eplanet
    selected: 9999
   protected: none
     omitted: none

 gnome-extra/gtkhtml
    selected: 3.32.2
   protected: none
     omitted: 4.2.3

 x11-plugins/e_modules-taskbar
    selected: 9999
   protected: none
     omitted: none

 media-libs/lightmediascanner
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-execwatch
    selected: 9999
   protected: none
     omitted: none

 dev-python/python-e_dbus
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-eooorg
    selected: 9999
   protected: none
     omitted: none

 media-sound/sox
    selected: 14.3.2-r1
   protected: none
     omitted: none

 media-libs/libdc1394
    selected: 2.1.4
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-websearch
    selected: 9999
   protected: none
     omitted: none

 media-libs/imlib2_loaders
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-cpu
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-tiling
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-flame
    selected: 9999
   protected: none
     omitted: none

 media-libs/game-music-emu
    selected: 0.5.5
   protected: none
     omitted: none

 x11-plugins/e_modules-quickaccess
    selected: 9999
   protected: none
     omitted: none

 dev-python/gst-python
    selected: 0.10.22
   protected: none
     omitted: none

 x11-themes/detour-elm
    selected: 9999
   protected: none
     omitted: none

 media-libs/faac
    selected: 1.28-r2
   protected: none
     omitted: none

 media-libs/libmatroska
    selected: 1.3.0
   protected: none
     omitted: none

 dev-python/python-efl_utils
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-uptime
    selected: 9999
   protected: none
     omitted: none

 media-libs/libmodplug
    selected: 0.8.8.4
   protected: none
     omitted: none

 x11-plugins/e_modules-calendar
    selected: 9999
   protected: none
     omitted: none

 media-video/vcdimager
    selected: 0.7.23-r1
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-pidgin
    selected: 9999
   protected: none
     omitted: none

 x11-themes/efenniht
    selected: 9999
   protected: none
     omitted: none

 dev-libs/eio
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-places
    selected: 9999
   protected: none
     omitted: none

 media-libs/libcddb
    selected: 1.3.2
   protected: none
     omitted: none

 x11-plugins/e_modules-winlist-ng
    selected: 9999
   protected: none
     omitted: none

 media-libs/musicbrainz
    selected: 2.1.5
   protected: none
     omitted: 3.0.3

 virtual/logger
    selected: 0
   protected: none
     omitted: none

 x11-plugins/e_modules-drawer
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/edgar
    selected: 9999
   protected: none
     omitted: none

 sci-geosciences/emap
    selected: 9999
   protected: none
     omitted: none

 app-xemacs/mule-base
    selected: 1.56
   protected: none
     omitted: none

 app-i18n/canna
    selected: 3.7_p3-r2
   protected: none
     omitted: none

 x11-libs/libXvMC
    selected: 1.0.6
   protected: none
     omitted: none

 dev-db/postgresql-base
    selected: 9.1.2
   protected: none
     omitted: none

 x11-plugins/e_modules-weather
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-photo
    selected: 9999
   protected: none
     omitted: none

 dev-vcs/bzr
    selected: 2.4.1
   protected: none
     omitted: none

 media-libs/libshout
    selected: 2.2.2
   protected: none
     omitted: none

 x11-plugins/extramenu
    selected: 9999
   protected: none
     omitted: none

 gnome-base/gnome-menus
    selected: 3.0.1-r1
   protected: none
     omitted: 3.2.0.1-r1

 virtual/perl-Version-Requirements
    selected: 0.101.20-r2
   protected: none
     omitted: none

 x11-plugins/e_modules-everything-mpris
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-forecasts
    selected: 9999
   protected: none
     omitted: none

 dev-libs/libxdg-basedir
    selected: 1.1.1
   protected: none
     omitted: none

 x11-plugins/e_modules-mem
    selected: 9999
   protected: none
     omitted: none

 x11-plugins/e_modules-rain
    selected: 9999
   protected: none
     omitted: none

 media-video/dirac
    selected: 1.0.2
   protected: none
     omitted: none

 app-admin/system-config-printer-common
    selected: 1.3.7
   protected: none
     omitted: none

 dev-python/notify-python
    selected: 0.1.1-r2
   protected: none
     omitted: none

 app-text/xmlto
    selected: 0.0.24-r1
   protected: none
     omitted: none

 app-admin/eselect-boost
    selected: 0.3
   protected: none
     omitted: none

 media-libs/libkate
    selected: 0.4.1
   protected: none
     omitted: none

 sci-libs/blas-reference
    selected: 20070226-r2
   protected: none
     omitted: none

 x11-wm/ecomp
    selected: 9999
   protected: none
     omitted: none

 media-libs/libiptcdata
    selected: 1.0.4
   protected: none
     omitted: none

 dev-libs/libindicator
    selected: 0.4.1-r201
   protected: none
     omitted: none

 dev-libs/libdbusmenu
    selected: 0.5.1-r200
   protected: none
     omitted: none

 dev-games/libggz
    selected: 0.0.14.1
   protected: none
     omitted: none

 sci-libs/hdf5
    selected: 1.8.8
   protected: none
     omitted: none

 media-fonts/ttf-bitstream-vera
    selected: 1.10-r3
   protected: none
     omitted: none

 net-libs/libeweather
    selected: 9999
   protected: none
     omitted: none

 x11-misc/emprint
    selected: 9999
   protected: none
     omitted: none

 dev-libs/libebml
    selected: 1.2.2
   protected: none
     omitted: none

 media-libs/glew
    selected: 1.7.0
   protected: none
     omitted: none

 media-libs/ftgl
    selected: 2.1.3_rc5
   protected: none
     omitted: none

 app-admin/eselect-postgresql
    selected: 1.0.10
   protected: none
     omitted: none

 dev-python/libgnome-python
    selected: 2.28.1
   protected: none
     omitted: none

 app-admin/gamin
    selected: 0.1.10
   protected: none
     omitted: none

 media-libs/libmpd
    selected: 11.8.17
   protected: none
     omitted: none

 dev-python/gnome-keyring-python
    selected: 2.32.0
   protected: none
     omitted: none

 dev-python/bug-buddy-python
    selected: 2.32.0
   protected: none
     omitted: none

 net-libs/azy
    selected: 9999
   protected: none
     omitted: none

 app-admin/eselect-xvmc
    selected: 0.3
   protected: none
     omitted: none

 media-libs/swfdec
    selected: 0.8.4
   protected: none
     omitted: none

 x11-misc/xplanet
    selected: 1.2.2
   protected: none
     omitted: none

 media-libs/libmp4v2
    selected: 1.9.1
   protected: none
     omitted: none

 dev-python/python-ecore
    selected: 9999
   protected: none
     omitted: none

 dev-python/paramiko
    selected: 1.7.7.1
   protected: none
     omitted: none

 app-xemacs/apel
    selected: 1.34
   protected: none
     omitted: none

 perl-core/Version-Requirements
    selected: 0.101.20
   protected: none
     omitted: none

 dev-python/gnome-desktop-python
    selected: 2.32.0
   protected: none
     omitted: none

 sys-libs/libraw1394
    selected: 2.0.7
   protected: none
     omitted: none

 dev-python/libwnck-python
    selected: 2.32.0
   protected: none
     omitted: none

 media-libs/ethumb
    selected: 9999
   protected: none
     omitted: none

 app-admin/eselect-blas
    selected: 0.1
   protected: none
     omitted: none

 media-libs/freeglut
    selected: 2.8.0
   protected: none
     omitted: none

 app-admin/gam-server
    selected: 0.1.10
   protected: none
     omitted: none

 dev-libs/libdbusmenu
    selected: 0.5.1-r300
   protected: none
     omitted: none

 gnome-extra/bug-buddy
    selected: 2.32.0-r2
   protected: none
     omitted: none

 dev-libs/libindicator
    selected: 0.4.1-r300
   protected: none
     omitted: none

 dev-python/pycups
    selected: 1.9.60
   protected: none
     omitted: none

 dev-python/gnome-vfs-python
    selected: 2.28.1
   protected: none
     omitted: none

 gnome-base/gnome-desktop
    selected: 2.32.1-r1
   protected: none
     omitted: 3.2.1

 app-xemacs/fsf-compat
    selected: 1.19
   protected: none
     omitted: none

 media-libs/imlib2
    selected: 9999
   protected: none
     omitted: none

 dev-python/libbonobo-python
    selected: 2.28.1
   protected: none
     omitted: none

 dev-python/python-evas
    selected: 9999
   protected: none
     omitted: none

 dev-libs/libgamin
    selected: 0.1.10-r2
   protected: none
     omitted: none

 dev-python/libgnomecanvas-python
    selected: 2.28.1
   protected: none
     omitted: none

 dev-python/pyorbit
    selected: 2.24.0
   protected: none
     omitted: none

 dev-python/cython
    selected: 0.14.1
   protected: none
     omitted: none

 sys-apps/galago-daemon
    selected: 0.5.1
   protected: none
     omitted: none

 dev-libs/libgalago
    selected: 0.5.2
   protected: none
     omitted: none

All selected packages: media-libs/game-music-emu-0.5.5 x11-plugins/e_modules-e-tiling-9999 net-libs/azy-9999 media-libs/glew-1.7.0 media-video/transcode-1.1.7-r1 x11-plugins/e_modules-language-9999 x11-plugins/e_modules-everything-places-9999 app-admin/system-config-printer-common-1.3.7 media-libs/imlib2_loaders-9999 dev-python/libwnck-python-2.32.0 media-video/dvdauthor-0.7.0 x11-themes/blingbling-9999 x11-plugins/e_modules-snow-9999 x11-plugins/e_modules-weather-9999 perl-core/Version-Requirements-0.101.20 app-admin/eselect-blas-0.1 x11-plugins/e_modules-mpdule-9999 app-xemacs/apel-1.34 media-libs/libmp4v2-1.9.1 x11-libs/neXtaw-0.15.1-r1 dev-libs/libconfig-1.4.8 dev-python/paramiko-1.7.7.1 x11-plugins/e_modules-execwatch-9999 media-libs/imlib2-9999 media-libs/e_phys-9999 dev-games/ggz-client-libs-0.0.14.1 x11-plugins/e_modules-everything-websearch-9999 dev-python/gnome-vfs-python-2.28.1 dev-games/libggz-0.0.14.1 media-libs/win32codecs-20071007-r4 x11-plugins/e_modules-alarm-9999 dev-python/gst-python-0.10.22 dev-python/telepathy-python-0.15.19 sys-fs/sysfsutils-2.1.0 x11-libs/libva-1.0.15 app-admin/system-config-printer-gnome-1.3.7 x11-plugins/e_modules-flame-9999 media-sound/fluidsynth-1.1.5 dev-python/python-edje-9999 app-i18n/canna-3.7_p3-r2 x11-plugins/e_modules-everything-mpris-9999 media-libs/libmpd-11.8.17 media-libs/freeglut-2.8.0 gnome-base/gnome-menus-3.0.1-r1 x11-plugins/e_modules-diskio-9999 gnome-extra/bug-buddy-2.32.0-r2 dev-python/pycups-1.9.60 app-text/epdf-9999 x11-plugins/e_modules-everything-tracker-9999 app-text/xmlto-0.0.24-r1 x11-plugins/e_modules-engage-9999 virtual/perl-Version-Requirements-0.101.20-r2 x11-plugins/e_modules-slideshow-9999 media-libs/libtiger-0.3.4 media-libs/libiptcdata-1.0.4 x11-wm/ecomp-9999 x11-plugins/e_modules-eweather-9999 dev-python/gnome-desktop-python-2.32.0 media-fonts/ttf-bitstream-vera-1.10-r3 x11-plugins/e_modules-mem-9999 x11-plugins/e_modules-quickaccess-9999 dev-python/cython-0.14.1 x11-misc/alacarte-0.13.2 x11-plugins/e_modules-forecasts-9999 x11-misc/emprint-9999 media-libs/libdc1394-2.1.4 dev-libs/libindicator-0.4.1-r201 dev-python/python-ecore-9999 media-libs/libcddb-1.3.2 app-admin/eselect-boost-0.3 dev-libs/check-0.9.8-r1 media-libs/musicbrainz-2.1.5 x11-libs/libXvMC-1.0.6 x11-themes/detourious-9999 media-libs/ethumb-9999 media-libs/libkate-0.4.1 x11-plugins/e_modules-iiirk-9999 app-office/dia-0.97.1 dev-python/bug-buddy-python-2.32.0 x11-plugins/e_modules-everything-shotgun-9999 gnome-base/gnome-desktop-2.32.1-r1 gnome-extra/swfdec-gnome-2.30.1 x11-plugins/e_modules-everything-wallpaper-9999 x11-plugins/e_modules-cpu-9999 dev-python/python-evas-9999 x11-plugins/e_modules-uptime-9999 app-admin/gam-server-0.1.10 dev-libs/libdbusmenu-0.5.1-r200 dev-python/feedparser-5.0.1 x11-plugins/e_modules-moon-9999 sci-libs/blas-reference-20070226-r2 media-plugins/gst-plugins-esd-0.10.30 media-libs/swfdec-0.8.4 sys-apps/galago-daemon-0.5.1 dev-python/libgnome-python-2.28.1 net-libs/libupnp-1.6.14 media-video/dirac-1.0.2 x11-plugins/e_modules-net-9999 app-xemacs/fsf-compat-1.19 x11-plugins/e_modules-photo-9999 media-libs/faac-1.28-r2 x11-plugins/e_modules-tiling-9999 dev-python/pyorbit-2.24.0 x11-plugins/extramenu-9999 x11-plugins/e_modules-everything-pidgin-9999 dev-python/httplib2-0.7.1 dev-python/notify-python-0.1.1-r2 media-libs/libmodplug-0.8.8.4 media-video/vcdimager-0.7.23-r1 media-libs/enlil-9999 media-libs/libmtp-1.1.2 dev-libs/libgamin-0.1.10-r2 sys-libs/ememoa-9999 x11-plugins/e_modules-deskshow-9999 media-libs/compface-1.5.2 media-video/ogle-0.9.2-r2 x11-libs/xosd-2.2.14-r1 media-libs/schroedinger-1.0.10-r1 dev-python/gnome-keyring-python-2.32.0 x11-plugins/e_modules-screenshot-9999 gnome-extra/gtkhtml-3.32.2 gnome-extra/hamster-applet-2.32.1 gnome-extra/deskbar-applet-2.32.0 sci-geosciences/emap-9999 media-libs/vigra-1.7.1-r1 media-sound/sox-14.3.2-r1 dev-libs/libebml-1.2.2 sci-libs/hdf5-1.8.8 dev-libs/libappindicator-0.4.1-r201 app-admin/pessulus-2.30.4 sys-process/time-1.7-r1 x11-plugins/e_modules-winlist-ng-9999 app-admin/gamin-0.1.10 virtual/blas-1.0 sys-libs/libavc1394-0.5.3 dev-libs/libxdg-basedir-1.1.1 media-libs/libprojectm-2.0.1-r1 virtual/logger-0 x11-plugins/e_modules-penguins-9999 media-libs/libmatroska-1.3.0 x11-plugins/edgar-9999 app-admin/eselect-xvmc-0.3 x11-plugins/e_modules-taskbar-9999 x11-plugins/eplanet-9999 x11-themes/detour-elm-9999 dev-python/libgnomecanvas-python-2.28.1 dev-libs/libunique-1.1.6-r1 x11-themes/efenniht-9999 media-libs/ftgl-2.1.3_rc5 net-libs/eupnp-9999 app-admin/eselect-postgresql-1.0.10 x11-libs/libXaw3d-1.5-r1 x11-plugins/ecomorph-9999 x11-plugins/e_modules-eooorg-9999 media-gfx/exquisite-9999 dev-python/python-e_dbus-9999 media-video/emovix-0.9.0 media-libs/lightmediascanner-9999 dev-python/reportlab-2.5 x11-plugins/e_modules-mail-9999 x11-libs/dnd-1.1-r1 app-cdr/dvd+rw-tools-7.1-r1 media-libs/libshout-2.2.2 x11-plugins/e_modules-rain-9999 dev-libs/eio-9999 sys-libs/libraw1394-2.0.7 x11-plugins/e_modules-places-9999 x11-misc/xplanet-1.2.2 net-libs/libeweather-9999 x11-plugins/e_modules-news-9999 media-libs/zvbi-0.2.33 x11-plugins/e_modules-comp-scale-9999 dev-libs/boost-1.47.0-r1 x11-plugins/e_modules-calendar-9999 dev-vcs/bzr-2.4.1 net-wireless/wireless-tools-30_pre9 x11-plugins/e_modules-winselector-9999 dev-libs/libgalago-0.5.2 virtual/fam-0 x11-plugins/e_modules-tclock-9999 app-xemacs/mule-base-1.56 dev-python/libbonobo-python-2.28.1 x11-themes/gnome-themes-2.32.1-r1 dev-db/postgresql-base-9.1.2 x11-plugins/e_modules-wlan-9999 dev-python/python-efl_utils-9999 x11-plugins/e_modules-drawer-9999 dev-libs/libdbusmenu-0.5.1-r300 dev-libs/libindicator-0.4.1-r300

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No] n

Quitting.

Packages installed:   1635
Packages in world:    320
Packages in system:   42
Required packages:    1446
Number to remove:     189
localtux ramaswamy #



so many packages removal?
i don't know which are very essential
which can be removed
help is needed
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Wed Apr 11, 2012 11:19 am    Post subject: Reply with quote

padoor, please start thinking. is this so hard?

none of them are - but then again that depends on what you need and use. If the top level package you installed, then I guess those packages are not or no longer required.

and initial glance showed, that it wants to get rid of e17 and some gnome2 packages.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Apr 11, 2012 11:52 am    Post subject: Reply with quote

/usr/lib/qt4/libQtWebKit.so.4.9.0?

is qt 4.9 out?

OT
you really need to think if your fixation on kde 3.5.10 is worth while the issues you are facing, you have three options:
  • leave kde 3.5.10 and upgrade to newer version of kde
  • migrate to another DE
  • don't upgrade your computer


your stubbornness on halting kde while upgrading the rest doesn't do good for your heart.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Wed Apr 11, 2012 11:59 am    Post subject: Reply with quote

nah - /usr/lib/qt4/libQtWebKit.so.4.9.0 belongs to x11-libs/qt-webkit-4.8.1.

<sarcasm>
I am just waiting for the moment they remove gnome2.... then the OP will have 2 DE to maintain...
</sarcasm>
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 3991
Location: india

PostPosted: Wed Apr 11, 2012 12:20 pm    Post subject: Reply with quote

oh well i will run the depclean fully
what shows kde-3 is causing the above packages removal?
i will remove e17 though it works decently
gnome-3 is struggling to make a desktop ,most often shows Oh no ! something has gone wrong logout
let me see what happens after depclean
i don't want to merge qt-webkit for 17 hrs
qt-webkit-4.8.1 is the latest how it ask for 4.9
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Apr 11, 2012 12:36 pm    Post subject: Reply with quote

Veldrin wrote:
nah - /usr/lib/qt4/libQtWebKit.so.4.9.0 belongs to x11-libs/qt-webkit-4.8.1.

it doesn't make sense...

padoor wrote:
oh well i will run the depclean fully
what shows kde-3 is causing the above packages removal?
i will remove e17 though it works decently
gnome-3 is struggling to make a desktop ,most often shows Oh no ! something has gone wrong logout
let me see what happens after depclean
i don't want to merge qt-webkit for 17 hrs
qt-webkit-4.8.1 is the latest how it ask for 4.9

nope but when you stay with old deprecated DE while updating the rest of the system, eventually package inconsistency will be introduced.
ones can be fixed other cannot.
for example, package a which is known to work well for kde-3.5.10 under version b may cause problem when you upgrade to a later version of it.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 205

PostPosted: Wed Apr 11, 2012 1:55 pm    Post subject: Reply with quote

Use the kde-sunset overlay for KDE 3.5.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Apr 11, 2012 2:33 pm    Post subject: Reply with quote

Apheus wrote:
Use the kde-sunset overlay for KDE 3.5.

he is using it...
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 205

PostPosted: Wed Apr 11, 2012 2:48 pm    Post subject: Reply with quote

DaggyStyle wrote:
Apheus wrote:
Use the kde-sunset overlay for KDE 3.5.

he is using it...


Oh sorry. Where could I have seen that? Text search for "kde-sunset" or "overlay" on the whole page shows only my post and your reply.

I assumed that such problems would not occur with the overlay...
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 3991
Location: india

PostPosted: Wed Apr 11, 2012 4:07 pm    Post subject: Reply with quote

Code:
>>> Unmerging (169 of 172) app-dicts/aspell-en-6.0.0...
>>> Unmerging (170 of 172) app-text/aspell-0.60.6.1...
>>> Unmerging (171 of 172) sys-apps/galago-daemon-0.5.1...
>>> Unmerging (172 of 172) dev-libs/libgalago-0.5.2...
Packages installed:   1432
Packages in world:    319
Packages in system:   42
Required packages:    1432
Number removed:       172

 * Regenerating GNU info directory index...
 * Processed 194 info files.

!!! existing preserved libs:
>>> package: net-misc/curl-7.25.0
 *  - /usr/lib/libcurl.so.4
 *  - /usr/lib/libcurl.so.4.2.0
 *      used by /usr/lib/libreoffice/basis3.4/program/libucpftp1.so (app-office/libreoffice-bin-3.4.5.2-r1)
>>> package: dev-libs/icu-4.8.1.1-r1
 *  - /usr/lib/libicuuc.so.49
 *  - /usr/lib/libicuuc.so.49.1
 *      used by /usr/lib/qt4/libQtWebKit.so.4.9.0 (x11-libs/qt-webkit-4.8.1)
 *  - /usr/lib/libicudata.so.49
 *  - /usr/lib/libicudata.so.49.1
Use emerge @preserved-rebuild to rebuild packages using these libraries


after depclean i get above preserved-rebuild
does the above mean i can unmerge qt-webkit as 4.9 is not still available?
libreoffice i cannot avoid rebuild.
i will also run revdep-rebuild to see what more it will ask
kde3 is still kept . i will remove it as a last resort
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Apr 11, 2012 4:16 pm    Post subject: Reply with quote

Apheus wrote:
DaggyStyle wrote:
Apheus wrote:
Use the kde-sunset overlay for KDE 3.5.

he is using it...


Oh sorry. Where could I have seen that? Text search for "kde-sunset" or "overlay" on the whole page shows only my post and your reply.

I assumed that such problems would not occur with the overlay...


not here, in other posts :wink:
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Wed Apr 11, 2012 4:29 pm    Post subject: Reply with quote

padoor wrote:
does the above mean i can unmerge qt-webkit as 4.9 is not still available?
libreoffice i cannot avoid rebuild.

Apparently you are still not able to read the portage output correctly:

/usr/lib/qt4/libQtWebKit.so.4.9.0 belogns to x11-libs/qt-webkit-4.8.1, as I already stated previously, and as you output confirms. but you should rebuild it, as it is using some old libs. (alternatively you could run equery d qt-webkit to find out which package does require it)

It does not matter how often you try install libreoffice-bin (you will not every build it), the error will still remain (unless maybe there is an upgrade), as the dependency is hardcoded in the package.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 3991
Location: india

PostPosted: Thu Apr 12, 2012 2:31 am    Post subject: Reply with quote

Code:
ramaswamy@localtux ~ $  equery d qt-webkit
 * These packages depend on qt-webkit:
app-office/libreoffice-bin-3.4.5.2-r1 (kde ? >=x11-libs/qt-webkit-4.7.0:4)
dev-python/PyQt4-4.9.1 (webkit ? >=x11-libs/qt-webkit-4.7.2:4)
ramaswamy@localtux ~ $


revdep-rebuild all consistent
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Thu Apr 12, 2012 10:04 am    Post subject: Reply with quote

that's interesting. but as qt-webkit is a dependency on a built package (PyQt4), you should rebuild it.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 3991
Location: india

PostPosted: Thu Apr 12, 2012 1:04 pm    Post subject: Reply with quote

Code:
ramaswamy@localtux ~ $ su
Password:
localtux ramaswamy # emerge @preserved-rebuild
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Running pre-merge checks for app-office/libreoffice-bin-3.4.5.2-r1
>>> Emerging (1 of 1) app-office/libreoffice-bin-3.4.5.2-r1
>>> Installing (1 of 1) app-office/libreoffice-bin-3.4.5.2-r1
>>> Jobs: 1 of 1 complete                           Load avg: 3.55, 3.32, 2.47
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: net-misc/curl-7.25.0
 *  - /usr/lib/libcurl.so.4
 *  - /usr/lib/libcurl.so.4.2.0
 *      used by /usr/lib/libreoffice/basis3.4/program/libucpftp1.so (app-office/libreoffice-bin-3.4.5.2-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries
localtux ramaswamy #


as you said earlier after emerge @preserved-rebuild the webkit and libreoffice merged again it claims to rebuild the libreoffice.
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Thu Apr 12, 2012 1:08 pm    Post subject: Reply with quote

Padoor - for the last time - you are NOT using libreoffice, but libreoffice-bin.
You do NOT build or rebuild libreoffice-bin as it is a binary package. You only install it.
Any missing or changed deps can only be resolved by a new version of that specific binary package (libreoffice-bin in your case)!

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 442
Location: Kraków, PL

PostPosted: Thu Apr 12, 2012 2:00 pm    Post subject: Reply with quote

Stable version of libreoffice-bin does not work with unstable version of curl. Re-emerging will not help.

This is just a specific case of a more general rule that mixing stable and unstable packages on the same system is not supported.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Arkhelion
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2010
Posts: 131
Location: France

PostPosted: Thu Apr 12, 2012 3:03 pm    Post subject: Reply with quote

Code:
emerge --unmerge libreoffice-bin
emerge libreoffice


After a couple of hours, you should just be OK
_________________
Arkhelion
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 442
Location: Kraków, PL

PostPosted: Thu Apr 12, 2012 3:27 pm    Post subject: Reply with quote

Arkhelion wrote:
Code:
emerge --unmerge libreoffice-bin
emerge libreoffice


After a couple of hours, you should just be OK

Yesterday it took me 1.5h to compile the newest LO on an AMD X3 450 - compiling from source is indeed not a problem nowadays.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Thu Apr 12, 2012 3:57 pm    Post subject: Reply with quote

true - but considering the machine of the OP, it should be possible in 6 hours (single core pentium-m IIRC).

OTOH, if it takes already 17h to compile qt-webkit, then I would not suggest to use libreoffice.
But then again, I have my doubts, that those 17h are normal.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 442
Location: Kraków, PL

PostPosted: Thu Apr 12, 2012 4:23 pm    Post subject: Reply with quote

Ah, I haven't noticed ;)
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum