Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
H67 Express Chipset kein Standby
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Thu Apr 05, 2012 6:27 pm    Post subject: H67 Express Chipset kein Standby Reply with quote

Hallo,

ich habe heute mal den neuen Kernel 3.3.1 gentoo installiert. Leider schaltet sich der Rechner im Standby gar nicht mehr aus. Aufwecken ist demzufolge auch nicht mehr möglich. Bei den älteren Kerneln ging er wenigstens noch in Standby....Aufwecken ging da aber auch nicht.

Achso keine weiter Grafik als die Onboard Intel.

Verwende ein Asus P8H67-V mit Core i7 CPU

Kann das jemand bestätigen?


Last edited by Tinitus on Fri Aug 10, 2012 8:40 am; edited 2 times in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3954
Location: Irgendwo im Nirgendwo

PostPosted: Thu Apr 05, 2012 6:49 pm    Post subject: Reply with quote

Hängt vllt. hiermit zusammen:
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.3.1 wrote:
commit 8aff97e587de738baccdd9b6f3bf9902fad8fa63
Author: Dave Airlie <airlied@redhat.com>
Date: Wed Mar 28 10:48:49 2012 +0100

drm/i915: suspend fbdev device around suspend/hibernate

commit 3fa016a0b5c5237e9c387fc3249592b2cb5391c6 upstream.

Looking at hibernate overwriting I though it looked like a cursor,
so I tracked down this missing piece to stop the cursor blink
timer. I've no idea if this is sufficient to fix the hibernate
problems people are seeing, but please test it.

Both radeon and nouveau have done this for a long time.

I've run this personally all night hib/resume cycles with no fails.

Reviewed-by: Keith Packard <keithp@keithp.com>
Reported-by: Petr Tesarik <kernel@tesarici.cz>
Reported-by: Stanislaw Gruszka <sgruszka@redhat.com>
Reported-by: Lots of misc segfaults after hibernate across the world.
Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=37142
Tested-by: Dave Airlie <airlied@redhat.com>
Tested-by: Bojan Smojver <bojan@rexursive.com>
Tested-by: Andreas Hartmann <andihartmann@01019freenet.de>
Signed-off-by: Dave Airlie <airlied@redhat.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>

Aber bei mir ging suspend noch nie richtig :( Entweder er kommt gar nicht hoch (Festplatte rattert kurz mal, dann ist Sense, auch der Monitor blinkt fleißig, als wär nix), oder der Desktop friert kurz nach dem erfolgreichen Resume ein...
Hab auch nen i7 mit iGPU auf nem Z68er mini-ITX von Asrock.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3954
Location: Irgendwo im Nirgendwo

PostPosted: Tue Apr 10, 2012 10:20 am    Post subject: Reply with quote

franzf wrote:
Aber bei mir ging suspend noch nie richtig :(

Und jetzt gehts :D
pf-sources installiert (hauptsächlich deshalb, weil es ein 3.3.1er linux mit tuxonice-patches ist) und mehrere suspend-resume-cycles überstanden. Vielleicht ist das ja auch was für dich?
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Tue Apr 10, 2012 12:42 pm    Post subject: Reply with quote

franzf wrote:
franzf wrote:
Aber bei mir ging suspend noch nie richtig :(

Und jetzt gehts :D
pf-sources installiert (hauptsächlich deshalb, weil es ein 3.3.1er linux mit tuxonice-patches ist) und mehrere suspend-resume-cycles überstanden. Vielleicht ist das ja auch was für dich?


Bin gerade am compilieren. Geht das auch mit genkernel?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3954
Location: Irgendwo im Nirgendwo

PostPosted: Tue Apr 17, 2012 3:30 pm    Post subject: Reply with quote

Tinitus wrote:
Geht das auch mit genkernel?

Ich geh mal stark davon aus...
Ansonsten:
Geht es bei dir jetzt? Die ersten Tests mit den pf-sources waren super. 15-20 Mal hinterinenander suspend+resume, und immer ist der Rechner wieder korrekt (fast: oss4 macht Probleme...) aufgewacht. Dann der erste längere Schlaf - und nicht mehr aufgewacht. Mist :/

Heute auf pf-sources-3.3.2 aktualisiert, und bereits 2 erfolgreiche resumes nach jeweils über einer Stunde Schlaf :)
kernel-3.3.2 hat einige Fixes betreffend PM und i915, siehe ChangeLog:
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.3.2
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Tue Apr 17, 2012 3:45 pm    Post subject: Reply with quote

franzf wrote:
Tinitus wrote:
Geht das auch mit genkernel?

Ich geh mal stark davon aus...
Ansonsten:
Geht es bei dir jetzt? Die ersten Tests mit den pf-sources waren super. 15-20 Mal hinterinenander suspend+resume, und immer ist der Rechner wieder korrekt (fast: oss4 macht Probleme...) aufgewacht. Dann der erste längere Schlaf - und nicht mehr aufgewacht. Mist :/

Heute auf pf-sources-3.3.2 aktualisiert, und bereits 2 erfolgreiche resumes nach jeweils über einer Stunde Schlaf :)
kernel-3.3.2 hat einige Fixes betreffend PM und i915, siehe ChangeLog:
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.3.2


Hallo,

geht nicht...

schit
Back to top
View user's profile Send private message
mrsteven
Veteran
Veteran


Joined: 04 Jul 2003
Posts: 1899

PostPosted: Tue Apr 17, 2012 7:48 pm    Post subject: Reply with quote

Es gibt ein Problem mit dem USB-Treiber ehci_hcd und einigen Mainboards, siehe Kernel-Mailingliste. Meine vorübergehende Abhilfe ist es, die USB-Treiber als Modul zu kompilieren und dann folgende Datei anzulegen:
/etc/pm/config.d/modules:
SUSPEND_MODULES="ehci_hcd xhci_hcd"

_________________
Unix philosophy: "Do one thing and do it well."
systemd: "Do everything and do it wrong."
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Wed May 23, 2012 4:43 am    Post subject: Reply with quote

Hallo,

Update

auch mit Kernel 3.4 geht es nicht...
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Tue Aug 07, 2012 1:17 pm    Post subject: Reply with quote

Tinitus wrote:
Hallo,

Update

auch mit Kernel 3.4 geht es nicht...


Update

mit Kernel 3.5 klappt es endlich!
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Fri Aug 10, 2012 8:40 am    Post subject: Reply with quote

Tinitus wrote:


Update

mit Kernel 3.5 klappt es endlich!


Kommando zurück. Neues Bios wegen anderem Prozessor ...nun klappt es wieder nicht mehr.

Grummel

Edit: Jetzt geht noch nicht mal mehr der Shutdown....bleibt bei Power down hängen.
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 235

PostPosted: Tue Sep 11, 2012 12:01 pm    Post subject: Reply with quote

Ich habe dasselbe Problem, und zwar mit einem Asus P5N-T deluxe und mit einem EVGA 750i SLI: Der Rechner braucht ziemlich genau 60 Sekunden, um sich beim Suspend abzuschalten. Manchmal (selten) schafft er es gar nicht, dann hilft nur noch Hard-Reset. Das ist seit Kernel 3.3 so, deshalb bin ich bei meinem wichtigen Haupt-PC noch auf dem 3.2-Kernel-Zweig. Auf dem anderen Rechner habe ich einige 3.5-Versionen probiert, ohne Erfolg. Und ich habe noch jemanden gefunden:

https://bbs.archlinux.org/viewtopic.php?id=140257

Obwohl bei mir die Rechner schnell wieder aufwachen, falls Suspend erfolgreich war (anders als im Arch-Forum berichtet).

Den EHCI-Trick habe ich noch nicht probiert. XHCI haben meine Mainboards nicht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum