Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[firefox] segmentation fault (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Wed Mar 21, 2012 10:10 am    Post subject: [firefox] segmentation fault (résolu) Reply with quote

Bonjour,

Voilà quelques temps maintenant que j'ai mis à jour mon système, et j'ai des "erreur de segmentation" de manière aléatoire sur firefox.
Je n'en peux plus de ces crash intempestifs !! J'ai cherché un peu sur le net, et sur ce forum, et j'ai trouvé d'autres personnes ayant eu le même problème,
mais tous liés à gnome (gconf). Or moi je n'utilise pas gnome du tout, et il n'est pas et n'a jamais été installé sur ma gentoo.

Auriez-vous des infos concernant la résolution de ce problème ?

Code:
xxxx@xxxx [ ~ ] :: eix firefox
[U] www-client/firefox
     Available versions:  3.6.20 (~)3.6.22 8.0{tbz2} 9.0{tbz2} (~)10.0 10.0.1{tbz2} (~)10.0.1-r1{tbz2} (~)11.0 {+alsa bindist +crashreporter custom-cflags custom-optimization +dbus debug elibc_FreeBSD gnome +ipc java libnotify linguas_af linguas_ak linguas_ar linguas_as linguas_ast linguas_be linguas_bg linguas_bn linguas_bn_BD linguas_bn_IN linguas_br linguas_bs linguas_ca linguas_cs linguas_csb linguas_cy linguas_da linguas_de linguas_el linguas_en linguas_en_GB linguas_en_US linguas_en_ZA linguas_eo linguas_es linguas_es_AR linguas_es_CL linguas_es_ES linguas_es_MX linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_fy linguas_fy_NL linguas_ga linguas_ga_IE linguas_gd linguas_gl linguas_gu linguas_gu_IN linguas_he linguas_hi linguas_hi_IN linguas_hr linguas_hu linguas_hy linguas_hy_AM linguas_id linguas_is linguas_it linguas_ja linguas_ka linguas_kk linguas_kn linguas_ko linguas_ku linguas_lg linguas_lt linguas_lv linguas_mai linguas_mk linguas_ml linguas_mr linguas_nb linguas_nb_NO linguas_nl linguas_nn linguas_nn_NO linguas_nso linguas_oc linguas_or linguas_pa linguas_pa_IN linguas_pl linguas_pt linguas_pt_BR linguas_pt_PT linguas_rm linguas_ro linguas_ru linguas_si linguas_sk linguas_sl linguas_son linguas_sq linguas_sr linguas_sv linguas_sv_SE linguas_ta linguas_ta_LK linguas_te linguas_th linguas_tr linguas_uk linguas_vi linguas_zh linguas_zh_CN linguas_zh_TW linguas_zu +minimal pgo selinux startup-notification system-sqlite +webm wifi}
     Installed versions:  10.0.1-r1{tbz2}(20:18:50 02/03/2012)(alsa crashreporter dbus ipc libnotify linguas_fr minimal startup-notification webm -bindist -custom-cflags -custom-optimization -debug -linguas_af -linguas_ak -linguas_ar -linguas_as -linguas_ast -linguas_be -linguas_bg -linguas_bn_BD -linguas_bn_IN -linguas_br -linguas_bs -linguas_ca -linguas_cs -linguas_csb -linguas_cy -linguas_da -linguas_de -linguas_el -linguas_en_GB -linguas_en_ZA -linguas_eo -linguas_es_AR -linguas_es_CL -linguas_es_ES -linguas_es_MX -linguas_et -linguas_eu -linguas_fa -linguas_fi -linguas_fy_NL -linguas_ga_IE -linguas_gd -linguas_gl -linguas_gu_IN -linguas_he -linguas_hi_IN -linguas_hr -linguas_hu -linguas_hy_AM -linguas_id -linguas_is -linguas_it -linguas_ja -linguas_kk -linguas_kn -linguas_ko -linguas_ku -linguas_lg -linguas_lt -linguas_lv -linguas_mai -linguas_mk -linguas_ml -linguas_mr -linguas_nb_NO -linguas_nl -linguas_nn_NO -linguas_nso -linguas_or -linguas_pa_IN -linguas_pl -linguas_pt_BR -linguas_pt_PT -linguas_rm -linguas_ro -linguas_ru -linguas_si -linguas_sk -linguas_sl -linguas_son -linguas_sq -linguas_sr -linguas_sv_SE -linguas_ta -linguas_ta_LK -linguas_te -linguas_th -linguas_tr -linguas_uk -linguas_vi -linguas_zh_CN -linguas_zh_TW -linguas_zu -pgo -selinux -system-sqlite -wifi)
     Homepage:            http://www.mozilla.com/firefox
     Description:         Firefox Web Browser


emerge info:
Code:
xxx@xxx [ ~ ] :: sudo emerge --info
Portage 2.1.10.47 (default/linux/x86/10.0/desktop, gcc-4.4.5, glibc-2.14.1-r2, 3.1.5-gentoo i686)
=================================================================
System uname: Linux-3.1.5-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Wed, 21 Mar 2012 02:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.5, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo ardunio x-toolchains
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/maven-bin-3.0/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/arduino /usr/src/toolchains"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif extras fam firefox flac fortran gd gdbm gdu gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3 qt3support qt4 readline sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 x86 xcb xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
- zerros -


Last edited by zerros on Mon Apr 16, 2012 5:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 429
Location: France

PostPosted: Wed Mar 21, 2012 12:12 pm    Post subject: Reply with quote

J'ai eu ce problème du fait que j'avais installé le correcteur orthographique Français dans Firefox. En compilant hunspell pour le français et en ayant viré le dico de Firefox, plus de problème.
_________________
Save the penguins, burn the flags!
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Sun Apr 01, 2012 10:43 am    Post subject: Reply with quote

mouai, j'ai tout essayé, mais idem. Je suis en train de mettre à jour le système et ensuite xulrunner puis recompilation de firefox pour voir ...

Je ne sais pas ce que ça va donner.
_________________
- zerros -
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Thu Apr 05, 2012 7:13 am    Post subject: Reply with quote

Bonjour,

Voilà, le système est complètement à jour, et la nouvelle version de firefox installée. ET .... toujours des plantages segmentation fault !!!

Ca me rend fou !!! Personne n'a ce problème ?
_________________
- zerros -
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5564
Location: ~Brussels - Belgique

PostPosted: Thu Apr 05, 2012 7:22 am    Post subject: Reply with quote

Salut,

As-tu essayé de supprimer ton profil / désactiver toutes les extensions ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Thu Apr 05, 2012 7:23 am    Post subject: Reply with quote

désactiver les extensions, oui. Supprimer le profile, je ne sais plus. Je vais tenter ça ce soir, de retour du taff :s
_________________
- zerros -
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 429
Location: France

PostPosted: Thu Apr 05, 2012 8:13 am    Post subject: Reply with quote

Par contre, je ne sais pas si mettre à jour xulrunner est vraiment utile, du fait que firefox n'en dépend plus…
_________________
Save the penguins, burn the flags!
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Thu Apr 05, 2012 8:16 am    Post subject: Reply with quote

il l'a de toute façon été durant la mise à jour du système.

j'ai d'ailleurs bien galéré pour la mise à jour car la nouvelle version de lvm2 présente un bug.
_________________
- zerros -
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Fri Apr 06, 2012 2:09 pm    Post subject: Reply with quote

Est ce que tu as essayé de voir si en installant la version binaire de firefox ça marche juste pour essayer d'isoler le problème.

[tahiry]
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Fri Apr 06, 2012 2:51 pm    Post subject: Reply with quote

Bon, j'ai supprimer mon profile et j'en ai recréer un. Pendant 1h, rien à signaler, alors j'ai installer mes extensions:

- firebug
- xmarks
- un thème
- search preview

Au niveau des plugns, je n'ai que flash et le plugin java de icedtea.

Pour le moment rien à signaler, mais je n'ai pas encore eu l'occasion de faire d'utiliser le pc depuis.

à suivre donc ...
_________________
- zerros -
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Tue Apr 10, 2012 7:47 am    Post subject: Reply with quote

Bon, alors j'en ai marre de ce plantage de ~#{ˇ(désolé, fallait que ça sorte) !!!

Ça continue de planter. J'ai resupprimer le profile, re-créer un profile vierge, et ça plante toujours !!!
ça plante généralement sur le rafraîchissement automatique des résultats de recherche de google.

Je n'utilise pas gnome, mais j'ai un .gconf et .gconfd dans mon home. Et je vois que gconf est aussi installé.
J'ai donc supprimer .gconf et .gconfd, désinstallé gconf et réinstallé. Idem ça continue de planter.

J'ai installer google-chrome en attendant de trouver le problème. Vous auriez une piste à me filer ?
_________________
- zerros -
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Tue Apr 10, 2012 10:50 am    Post subject: Reply with quote

Les joies de la branche testing :mrgreen:

Une petite backtrace via gdb pourra peut-être t'orienter ? mais encore faut t'il avoir compilé ce qu'il faut avec les options de debug... Tu as testé ta RAM ?
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Tue Apr 10, 2012 11:22 am    Post subject: Reply with quote

bon, c'est décidé, je vais re-passer en stable !! Je backup mon home, et zou !

J'ai aussi des bugs avec des libs de la toolchain avr, bugs que je n'avais pas auparavant.
Le mieux est de repartir d'une version stable et nette.

Merci.
_________________
- zerros -
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5564
Location: ~Brussels - Belgique

PostPosted: Tue Apr 10, 2012 11:45 am    Post subject: Reply with quote

C'est bizarre, tout ça : je suis en instable depuis 8 ans, et ça fait au moins 2-3 ans que la branche "testing" est hyper stable de mon côté.

As-tu bien suivi tous les messages elog, fait des revdep-rebuild ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 150

PostPosted: Mon Apr 16, 2012 5:51 pm    Post subject: Reply with quote

oui, j'avais tout le système OK avec revdep-rebuild, pas de souci elog, pas d'etc-update foireux, etc...

Pas grave, j'ai réinstallé une stable et cette fois-ci je n'installe que certains paquets qui sont en instable.
Firefox refonctionne correctement.
_________________
- zerros -
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum