Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] couldn't mount because of unsupported optional
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
percy_vere_uk
Apprentice
Apprentice


Joined: 13 Dec 2008
Posts: 200
Location: Dorset UK

PostPosted: Sat Jul 02, 2011 1:26 pm    Post subject: [solved] couldn't mount because of unsupported optional Reply with quote

Hi

I am in the process of installing gentoo_64bit on a multiboot system but have to use the 'install-amd64-minimal-2008.0.iso' disk because this is the only 64bit system on the box.
The partitioning is as follows:
sda1 boot partition ext2
sda2 root partition ext4
sda6 swap

I have carried out a stage3 install and portage snapshot. On trying to boot I get the following errors:
.
.
ext3-fs (sda2): error: couldn't mount because of unsupported optional features (240)
ext2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
ext4-fs (sda2): mounted file system with ordered data mode: opts: (null)
.
.
Looking at various post's this is often caused by ext4 needing 'large (2tb) block devices & file option' to be enabled in the kernel.
But this option does not appear in menuconfig with 64bit.

So any ideas please.

percy


Last edited by percy_vere_uk on Sat Jul 09, 2011 12:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 645

PostPosted: Sat Jul 02, 2011 2:10 pm    Post subject: Reply with quote

No, it's actually working perfectly fine:
Quote:
ext3-fs (sda2): error: couldn't mount because of unsupported optional features (240)
ext2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
ext4-fs (sda2): mounted file system with ordered data mode: opts: (null)

The ext2 and ext3 drivers don't know what to do with the filesystem, because it's ext4.

If this annoys you you can change these options in your .config:
Code:
# CONFIG_EXT2_FS is not set
# CONFIG_EXT3_FS is not set
CONFIG_EXT4_USE_FOR_EXT23=y

Then the (better) ext4 driver will be used for all ext2/ext3 devices by default (the ext4 driver is fully backwards-compatible with ext2 and ext3).
Back to top
View user's profile Send private message
percy_vere_uk
Apprentice
Apprentice


Joined: 13 Dec 2008
Posts: 200
Location: Dorset UK

PostPosted: Sun Jul 03, 2011 11:34 am    Post subject: Reply with quote

The problem is that I am unable to boot the system.

Code:

.
.
.
ext3-fs (sda2): error: couldn't mount because of unsupported optional features (240)
ext2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
ext4-fs (sda2): mounted file system with ordered data mode: opts: (null)
VFS: Mounted  root (ext4 filesystem) readonly on device 8:2
Freeing unused kernel memory: 600k freed.
Write protecting the kernel read-only data: 8192k
Freeing unused kernel memory: 632k freed
Freeing unused kernel memory: 128k freed
init-early.sh used greatest stack depth: 4440 bytes left

At this point the boot process freezes.

percy
Back to top
View user's profile Send private message
percy_vere_uk
Apprentice
Apprentice


Joined: 13 Dec 2008
Posts: 200
Location: Dorset UK

PostPosted: Mon Jul 04, 2011 11:39 am    Post subject: Reply with quote

Hi

Does anyone have any idea what could be causing this problem, as I am keen to get this system booted.

percy
Back to top
View user's profile Send private message
percy_vere_uk
Apprentice
Apprentice


Joined: 13 Dec 2008
Posts: 200
Location: Dorset UK

PostPosted: Sat Jul 09, 2011 12:42 pm    Post subject: Reply with quote

I finally managed to get the answer (thanks to NeddySeagoon) and get the system to boot see:
'http://forums.gentoo.org/viewtopic-t-880149.html'
The content of /dev in the stage3 tarball is wrong.

As I thought this was a kernel configuration problem and trying different options. I have probably recompiled the kernel 10 times or more this week. Anyhow it boots up fine now.

percy
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Wed Mar 28, 2012 3:15 pm    Post subject: Reply with quote

Hello,

I've encountered the same problem with a new install (2012/02/28 ) using the current stage3.
Actually, the system boots and all works fine but I get these messages in the log:

Code:
EXT2-fs (sdc4): error: couldn't mount because of unsupported optional features (240)
EXT4-fs (sdc4): mounted filesystem with ordered data mode. Opts: (null)


I really don't understand why this happens, because I only use ext2, reiserfs and ext4 filesystems and for this reason I've compiled these drivers into the kernel:
CONFIG_EXT2_FS=y
CONFIG_EXT4_FS=y
CONFIG_EXT4_FS_XATTR=y
CONFIG_REISERFS_FS=y

I also had CONFIG_EXT4_USE_FOR_EXT23 set to "y" before, but I've disabled it to see if the messages above disappear. But no luck with it.
What does it happen? The system works, the filesystems gonna be mounted, but such messages doesn't say anything good to me.

What's the problem?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2215
Location: Netherlands

PostPosted: Wed Mar 28, 2012 6:11 pm    Post subject: Reply with quote

fbcyborg,
I get them too since I switched from ext3 to ext4 a long time ago.
They are perfectly harmless,just disregard them.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Wed Mar 28, 2012 6:38 pm    Post subject: Reply with quote

OK, thanks for the information.
Good to know that they are harmeless.

I was just wandering why this happens (while it doesn't happen in other chroots I have).
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2280
Location: UK

PostPosted: Wed Mar 28, 2012 6:42 pm    Post subject: Reply with quote

Put "rootfstype=ext4" on your boot command line and it should go away.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Wed Mar 28, 2012 6:52 pm    Post subject: Reply with quote

Thanks for the tip. It worked! ;)
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 324

PostPosted: Sun Jul 29, 2012 6:12 pm    Post subject: Reply with quote

Ant P. wrote:
Put "rootfstype=ext4" on your boot command line and it should go away.

I just switched to ext4 and had the same boot error messages. This suggestion got rid of them without any kernel recompile.

Thanks.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 350
Location: Stockholm, Sweden

PostPosted: Sun Mar 03, 2013 9:06 pm    Post subject: Reply with quote

Ant P. wrote:
Put "rootfstype=ext4" on your boot command line and it should go away.


This doesn't seem to help for me. I've had that added for a long time, but still get the warning.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum