Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ vaapi + xbmc ] Htpc (résolu)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Wed Mar 21, 2012 6:47 pm    Post subject: Reply with quote

Je suis curieux aussi, je suis en ati-drivers 12.1 et je n'ai toujours pas la possibilité d'avoir une sortie xv.
Back to top
View user's profile Send private message
RBoudin
n00b
n00b


Joined: 13 Aug 2006
Posts: 16
Location: France

PostPosted: Sun Mar 25, 2012 3:15 pm    Post subject: Reply with quote

J'utilise xbmc avec fglrx sur un e-350 avec VAAPI (presque) sans soucis.

La subtilité c'est que l'utilisation d'une version externe de ffmpeg semble ne pas fonctionner avec VAAPI activé.
De base xbmc utilise une version custom de ffmpeg compilée avec xbmc (et c'est l'option par défaut).

L'ebuild xbmc force l’utilisation d'une version externe de ffmpeg.
Donc pour faire fonctionne VAAPI avec XBMC je modifie l'ebuild :

Code:

cd /usr/portage/media-tv/xbmc
vi xbmc-11.0_r2.ebuild

Puis commenter la ligne suivante
Code:

 --enable-external-libraries \


Ensuite il faut refaire le manifest :
Code:

ebuild xbmc-11.0_r2.ebuild digest


Puis il suffit d'emerger xbmc.


Si quelqu'un a une solution plus propre je suis preneur, mais ça fonctionne ^^
Back to top
View user's profile Send private message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Wed Mar 28, 2012 6:30 am    Post subject: Reply with quote

Je suppose que le driver ati fourni par Gentoo ne permet pas d'avoir toute les options relatives à accélération matérielle.

Pour ma part, lors de l'utilisation des paquets fournie par Gentoo, je n'avais aucun message d'erreur, que se soit à la compilation ou à l'utilisation.

Je sais aussi, que sur Debian il faut récupérer les sources et les installer sinon ça ne fonctionne pas.

J'avais aussi tester les paquets officiels il y a un an sur mon autre poste (Q9550 + ATI5750) et impossible d'avoir l'accélération matérielle, j'avais les mêmes symptômes.

Bizarre....
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1
Back to top
View user's profile Send private message
RBoudin
n00b
n00b


Joined: 13 Aug 2006
Posts: 16
Location: France

PostPosted: Wed Mar 28, 2012 8:26 am    Post subject: Reply with quote

Le driver fglrx (ati-drivers) permet d'utiliser vaapi (de toute façon il n'est pas opensource, donc il ne peut y avoir de modifs propres à une distrib).
J'ai fait toute mon installation a partir des ebuilds de portage et l’accélération matérielle fonctionne très bien (en modifiant l'ebuild d'xbmc comme spécifié ci-dessus)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum