Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Dostęp do dysku NTFS.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Sun Mar 18, 2012 6:32 pm    Post subject: [SOLVED] Dostęp do dysku NTFS. Reply with quote

Mam problem z montowaniem dysku z systemem plików NTFS. Nie ma do nich dostępu mój użytkownik, a jedynie root. Montowanie przebiega bezproblemowo.
Przy użyciu ntfs-3g problem znika, aczkolwiek chciałbym aby montowanie było zintegrowane z Dolphinem i nie wymagało wchodzenia do konsoli i montowania.

Code:
/mnt/segate: Brak dostępu

Code:
groups rolmo
disk wheel audio cdrom video usb users games plugdev storage rolmo

Code:
/dev/sdb3       /mnt/segate     ntfs    noauto,defaults,user            0 0
/dev/sda4       /mnt/western    ntfs    noauto,defaults,user            0 0


Last edited by Rolmo on Fri May 11, 2012 11:50 am; edited 3 times in total
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sun Mar 18, 2012 8:20 pm    Post subject: Reply with quote

Montowanie przy użyciu ntfs-3g nie wymaga wchodzenia do konsoli, wystarczy się zaopatrzyć w odpowiedni wpis w fstab.

U mnie wygląda to tak:
Code:
/dev/sda4               /media/windows  ntfs-3g         defaults        0 0
Back to top
View user's profile Send private message
gexcite
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2005
Posts: 101

PostPosted: Wed Mar 21, 2012 9:34 pm    Post subject: Reply with quote

Nawet bez wpisu do /etc/fstab montuje bezproblemowo
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Thu Mar 22, 2012 3:58 pm    Post subject: Reply with quote

Code:
Mount is denied because setuid and setgid root ntfs-3g is insecure with the
external FUSE library. Either remove the setuid/setgid bit from the binary
or rebuild NTFS-3G with integrated FUSE support and make it setuid root.
Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged


Code:
 File systems  --->
     <M> FUSE (Filesystem in Userspace) support


Quote:
sys-fs/ntfs3g-2011.4.12 USE="acl crypt external-fuse udev -debug -ntfsprogs -static-libs -suid* -xattr"


Co robię źle?


Last edited by Rolmo on Fri Mar 23, 2012 6:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Thu Mar 22, 2012 6:41 pm    Post subject: Reply with quote

Masz w jajku to co trzeba, ale ładujesz w ogóle te moduły? Bo one same z siebie Ci nie wystartują.

Masz je w /etc/conf.d/modules ??
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Thu May 10, 2012 6:33 pm    Post subject: Reply with quote

Przeinstalowałem gentoo. Tym razem mam XFCE4.
Problem jest ten sam. FUSE mam skompilowane na stałe w jądrze, lecz nic to nie zmienia.

Przy próbie zamontowania:
Code:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2821

PostPosted: Thu May 10, 2012 8:32 pm    Post subject: Reply with quote

Blad jest bardzo wymowny, mowi dlaczego i podaje ew rozwiazania.
_________________
BitBucket -- better-initramfs to address many usecases and linux's limitations.
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Fri May 11, 2012 7:19 am    Post subject: Reply with quote

Wszystkie wymagania są spełnione. Co więcej, nie mogę też zamontować cdromów, usb i innych urządzeń mimo (prawdopodobnie) poprawnych ustawień.
Back to top
View user's profile Send private message
eTux
n00b
n00b


Joined: 11 May 2012
Posts: 1

PostPosted: Fri May 11, 2012 9:21 am    Post subject: Reply with quote

Miałem swego czasu podobny problem ;)
Code:

[I] sys-fs/ntfs3g
     Available versions:  2012.1.15-r1 {{acl crypt debug +external-fuse extras +ntfsprogs static-libs suid +udev xattr}}
     Installed versions:  2012.1.15-r1(10:43:29 11.05.2012)(acl crypt ntfsprogs suid udev -debug -external-fuse -extras -static-libs -xattr)
     Homepage:            http://www.tuxera.com/community/ntfs-3g-download/
     Description:         Open source read-write NTFS driver that runs under FUSE

Code:


-rwsr-xr-x 1 root usb 129K 05-11 10:43 /usr/bin/ntfs-3g*


/etc/fstab
Code:

/dev/sdc1               /mnt/usb3       ntfs-3g         defaults,user,uid=1000,gid=100,dmask=027,fmask=137,utf8         0 0

oraz dopisanie użytkownika do grupy disk rozwiązało problem.
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Fri May 11, 2012 11:50 am    Post subject: Reply with quote

Dzięki. Dodaję [SOLVED].
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum