Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lettore di schede lento
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Fri Mar 16, 2012 5:26 pm    Post subject: Lettore di schede lento Reply with quote

Salve a tutti,

è un po' di tempo che ho questo lettore di schede da due lire (in realtà 3 euro) usb che va nel drive bay da 3.5"; tanto tempo fa (e forse anche con una configurazione hardware diversa) funzionava piuttosto velocemente nei trasferimenti. Mi ricordo che ebbe un calo enorme al passaggio da Fedora 13 a Fedora 14. Da allora, dovendo trasferire comunque pochi gB di dati, non ci ho mai pensato, però adesso, con Gentoo e un pc più decente, mi è tornato in mente! Qualcuno può aiutarmi a capire come mai va più lento e come risolvere? C'è forse qualche opzione nel kernel che ne può migliorare le prestazioni?

Ecco qui l'output di lsusb -dv 15a4:1336:

Quote:
Bus 007 Device 002: ID 15a4:1336 Afatech Technologies, Inc. SDHC/MicroSD/MMC/MS/M2/CF/XD Flash Card Reader
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x15a4 Afatech Technologies, Inc.
idProduct 0x1336 SDHC/MicroSD/MMC/MS/M2/CF/XD Flash Card Reader
bcdDevice 1.00
iManufacturer 1 Generic
iProduct 2 Mass Storage Device
iSerial 3 00000000000006
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 32
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 100mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 2
bInterfaceClass 8 Mass Storage
bInterfaceSubClass 6 SCSI
bInterfaceProtocol 80 Bulk (Zip)
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x01 EP 1 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 1
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x82 EP 2 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 1
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 1
Device Status: 0x0000
(Bus Powered)


Grazie.
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Fri Mar 16, 2012 5:40 pm    Post subject: Reply with quote

Ho appena notato anche questo:

Quote:
usb 7-3: not running at top speed; connect to a high speed hub


in dmesg.

Inoltre ho anche avuto in regalo un hub usb che sulla scatola ha scritto essere usb 2.0 ma che in realtà va alla velocità dell'1.1, ma questo mi succede anche se lo provo su Windows XP quindi penso che semplicemente che mi abbia fatto il pacco il venditore...

(Considerando che ho una scheda madre piuttosto recente (ASUS M4A88TD-V EVO/USB3))

P.s.
Altra cosa notata:

Quote:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 014: ID 0e8f:0016 GreenAsia Inc. 4 port USB 1.1 hub UH-174
Bus 004 Device 003: ID 0471:0311 Philips (or NXP) PCVC740K ToUcam Pro [pwc]
Bus 004 Device 004: ID 062a:0000 Creative Labs Optical mouse
Bus 007 Device 002: ID 15a4:1336 Afatech Technologies, Inc. SDHC/MicroSD/MMC/MS/


Sembra che ci siano 4 hub 1.1, esattamente quelli cui sono collegati sia il lettore sia l'hub esterno... Ma che senso ha? La scheda madre ha tutte porte 2.0!
Back to top
View user's profile Send private message
Dun
Apprentice
Apprentice


Joined: 17 Apr 2004
Posts: 172
Location: Amsterdam (NL) / Venice (IT)

PostPosted: Sat Mar 17, 2012 6:53 am    Post subject: Reply with quote

Gia' passato per http://www.gentoo.org/doc/en/usb-guide.xml ?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1493
Location: Cosenza, Italy

PostPosted: Sat Mar 17, 2012 9:26 am    Post subject: Reply with quote

Moved from Forum italiano (Italian) to Forum di discussione italiano.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Sat Mar 17, 2012 11:23 am    Post subject: Reply with quote

Dun wrote:
Gia' passato per http://www.gentoo.org/doc/en/usb-guide.xml ?


No, grazie! Però mi sembra che non dica niente che non sapevo già.

Comunque mi ha dato l'idea di andare a disattivare il supporto a OHCI e UHCI nel kernel così vedo che succede...

P.s. Cosa che ho notato: I "root hub", non sono collegati alla porta fisica, se collego l'hard disk esterno ad una porta, me lo vede come 2.0 e lo collega al bus relativo all'hub 2.0, se collego alla STESSA porta, l'hub, la webcam o il mouse, me li mette su un bus da 4-7 che sono root hub 1.1... Quindi sembrerebbe che ogni porta fisica abbia sia il root hub 2.0 che 1.1 (infatti sono 4 e 4). Però la cosa continua a puzzarmi...

Dopo questa prima prova, proverò ad aggiungere nel kernel tutti i driver esistenti per gli HCI usb e il mass storage presenti in "Device drivers->USB support..." e vedo se magari mi acchiappa un driver più adatto al mio controller... Magari ne starà usando uno generico.
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Sat Mar 17, 2012 11:31 am    Post subject: Reply with quote

La prima prova ha avuto infatti l'esito già immaginato: Non funzionava più il mouse né le altre periferiche.

La seconda prova è stata altrettanto fallimentare: Non è cambiato niente...

L'ultima cosa che posso provare è mettere sul vecchio pc Fedora 13 e il lettore di schede e vedere cosa succede... Ma credo che non lo farò per MOOOLTO tempo... Quindi se qualcuno ha qualche suggerimento è ancora ben accetto!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4719
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Mon Mar 19, 2012 10:33 am    Post subject: Reply with quote

IMHO dipende dalle impostazioni di usb mass storage o dalle altre impostazioni per la gestione dell'usb pm, device etc. od ancora dalle impostazioni per il bus scsi (qualcosa di troppo). Rivedi la configurazione del kernel.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Mon Mar 19, 2012 11:11 am    Post subject: Reply with quote

djinnZ wrote:
IMHO dipende dalle impostazioni di usb mass storage o dalle altre impostazioni per la gestione dell'usb pm, device etc. od ancora dalle impostazioni per il bus scsi (qualcosa di troppo). Rivedi la configurazione del kernel.


Ci ho provato, ma fino ad un certo punto, ora non so più dove mettere mano! (Un po' ho letto le descrizioni in menuconfig e un po' la guida USB di Gentoo)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum