Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EMERGE] lirc-0.8.7 -> compil failed avec kernel 3.x
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
jaypeche
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jun 2007
Posts: 115
Location: France

PostPosted: Thu Mar 15, 2012 10:38 am    Post subject: [EMERGE] lirc-0.8.7 -> compil failed avec kernel 3.x Reply with quote

Bonjour à tous,

Je viens poster par içi car j'ai un souçi avec la compilation de LIRC...

Je cherche à faire fonctionner ma telecommande SOUNDGRAPH IMON_PAD, mais depuis mon passage en kernel 3.2.1-r2, je n'arrive pas à compiler LIRC. Je pensais d'abord que cela était dû au fait que le driver Imon était passé dans le kernel, mais ça ne semble pas être le cas.

J'ai cherché de l'info sur la toile, mais je n'ai pas réussi à la faire fonctionner. Pour contourner le problème, j'ai essayé avec INPUTLIRCD sans grand succès !

J'essaye pour le moment de compiler lirc sans la prise en charge des pilotes, mais rien de mieux ! Grrr !

Code:
dbox2 linux # USE="debug" emerge -av lirc

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-misc/lirc-0.8.7  USE="X debug -doc -hardware-carrier -transmitter" LIRC_DEVICES="-accent -act200l -act220l -adaptec -all -alsa_usb -animax -asusdh -atilibusb -atiusb -audio -audio_alsa -avermedia -avermedia98 -avermedia_vdomate -awlibusb -bestbuy -bestbuy2 -breakoutbox -bte -bw6130 -caraca -chronos -commandir -cph06x -creative -creative_infracd -devinput -digimatrix -dsp -dvico -ea65 -ene0100 -exaudio -flyvideo -ftdi -gvbctv5pci -hauppauge -hauppauge_dvb -hercules_smarttv_stereo -i2cuser -igorplugusb -iguanaIR -imon -imon_24g -imon_knob -imon_lcd -imon_pad -imon_rsc -inputlirc -irdeo -irdeo_remote -irlink -irman -irreal -it87 -ite8709 -knc_one -kworld -leadtek_0007 -leadtek_0010 -leadtek_pvr2000 -livedrive_midi -livedrive_seq -logitech -macmini -mceusb -mediafocusI -mouseremote -mouseremote_ps2 -mp3anywhere -mplay -nslu2 -packard_bell -parallel -pcmak -pcmak_usb -pctv -pixelview_bt878 -pixelview_pak -pixelview_pro -provideo -realmagic -remote_wonder_plus -remotemaster -sa1100 -samsung -sasem -sb0540 -serial -serial_igor_cesko -silitek -sir -slinke -streamzap -tekram -tekram_bt829 -tira -ttusbir -tuxbox -tvbox -udp -uirt2 -uirt2_raw -usb_uirt_raw -usbirboy -usbx -userspace -wpc8769l -xboxusb" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y


Code:
>>> Failed to emerge app-misc/lirc-0.8.7, Log file:

>>>  '/var/tmp/portage/app-misc/lirc-0.8.7/temp/build.log'

 * Messages for package app-misc/lirc-0.8.7:

 * If your LIRC device requires modules, you'll need MODULE_UNLOAD
 * support in your kernel.
 *
 * Compiling only the lirc-applications, but no drivers.
 * Enable drivers with LIRC_DEVICES if you need them.
 * Setting default lirc-device to /dev/lirc0
 * Disabling lirc_gpio driver as it does no longer work Kernel 2.6.22+
 * ERROR: app-misc/lirc-0.8.7 failed (compile phase):
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=-m elf_x86_64   all
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 4075:  Called linux-mod_src_compile
 *   environment, line 3132:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"          CROSS_COMPILE=${CHOST}-                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}       ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *
 * If you need support, post the output of 'emerge --info =app-misc/lirc-0.8.7',
 * the complete build log and the output of 'emerge -pqv =app-misc/lirc-0.8.7'.
 * The complete build log is located at '/var/tmp/portage/app-misc/lirc-0.8.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/lirc-0.8.7/temp/environment'.
 * S: '/var/tmp/portage/app-misc/lirc-0.8.7/work/lirc-0.8.7'

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


MODULE_UNLOAD est pourtant setté à Yes.

Je vois bien ce message avec lirc_gpio, mais je comprends pas trop comment solutionner le problème. Un modprobe lirc_gpio ne charge aucun module, je n'ai donc pas l'impression que celui-çi soit présent...

Code:
* Disabling lirc_gpio driver as it does no longer work Kernel 2.6.22+


J'ai tenté un grep sur la config noyau pour voir :

Code:
dbox2 linux # cat /etc/kernels/kernel-config-x86_64-3.2.1-gentoo-r2 | grep -i gpio
CONFIG_GENERIC_GPIO=y
# CONFIG_MDIO_GPIO is not set
# CONFIG_KEYBOARD_GPIO is not set
# CONFIG_KEYBOARD_GPIO_POLLED is not set
# CONFIG_MOUSE_GPIO is not set
# CONFIG_INPUT_GPIO_ROTARY_ENCODER is not set
# CONFIG_I2C_GPIO is not set
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_GPIOLIB=y
# CONFIG_DEBUG_GPIO is not set
# CONFIG_GPIO_SYSFS is not set
# Memory mapped GPIO drivers:
# CONFIG_GPIO_GENERIC_PLATFORM is not set
# CONFIG_GPIO_IT8761E is not set
# CONFIG_GPIO_SCH is not set
# CONFIG_GPIO_VX855 is not set
# I2C GPIO expanders:
# CONFIG_GPIO_MAX7300 is not set
# CONFIG_GPIO_MAX732X is not set
# CONFIG_GPIO_PCA953X is not set
# CONFIG_GPIO_PCF857X is not set
# CONFIG_GPIO_SX150X is not set
# CONFIG_GPIO_ADP5588 is not set
# PCI GPIO expanders:
# CONFIG_GPIO_BT8XX is not set
# CONFIG_GPIO_LANGWELL is not set
# CONFIG_GPIO_PCH is not set
# CONFIG_GPIO_ML_IOH is not set
# CONFIG_GPIO_RDC321X is not set
# SPI GPIO expanders:
# CONFIG_GPIO_MCP23S08 is not set
# AC97 GPIO expanders:
# MODULbus GPIO expanders:
# CONFIG_CHARGER_GPIO is not set
# CONFIG_SENSORS_GPIO_FAN is not set
# CONFIG_MFD_SM501_GPIO is not set
CONFIG_USB_GPIO_VBUS=m
# CONFIG_LEDS_GPIO is not set
# CONFIG_LEDS_TRIGGER_GPIO is not set


J'ai bien essayé de désactiver GPIO depuis menuconfig, sans succès.

:idea: Quelqu'un a t'il eu le même problème ? Peut être m'aider à interpréter ce message d'alerte ?

emerge --info :
http://pastebin.com/QTSuXUFY

Même chose en 0.9.0... :( Merçi pour votre aide !
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Fri Mar 16, 2012 6:41 pm    Post subject: Reply with quote

Fais voir le contenu de :
Code:

/var/tmp/portage/app-misc/lirc-0.8.7/temp/build.log
Back to top
View user's profile Send private message
jaypeche
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jun 2007
Posts: 115
Location: France

PostPosted: Fri Mar 16, 2012 8:22 pm    Post subject: Reply with quote

Slt,

Build.log : http://pastebin.com/2A3CjE80

Merçi de t'interesser mon cas. :wink:
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Fri Mar 16, 2012 8:34 pm    Post subject: Reply with quote

Code:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: unrecognised emulation mode: -Wl,-soname

bug #396653. çà ne m'a pas l'air très clair comme histoire, j'ai lu en travers, ya plusieurs patchs différents proposés. Si tu veux compiler rapidement, tu devrais lire et tenter les commentaires #12 et #13.
Back to top
View user's profile Send private message
jaypeche
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jun 2007
Posts: 115
Location: France

PostPosted: Fri Mar 16, 2012 8:44 pm    Post subject: Reply with quote

Ok je n'avais pas vu ce bug, je tente le coup et je vous tiens au courant..
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum