Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nowy laptop samsunga i nie dzialajace X na nvidia driver
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
maczetax
Tux's lil' helper
Tux's lil' helper


Joined: 20 Sep 2004
Posts: 124
Location: Warsaw

PostPosted: Wed Feb 01, 2012 3:02 pm    Post subject: nowy laptop samsunga i nie dzialajace X na nvidia driver Reply with quote

Witam,

Kupilem niedawno laptopa i oczywiscie zaistalowalem gentoo, prawie wszytko juz dziala... ale nie moge zmsic mojej karty nvidia do dzialania w x, jesli w xorg.conf wybiore nvidia nie dziala, jesli wybiore driver intela wszystko dziala jak nalezy... gdzie est blad...

log z wersji z dzialajacym sterownikiem intela
http://pastebin.com/AWEGcgBq

log z nidzialajacej wersji nvidia
http://pastebin.com/jwid7WqK
dziwne jest to ze wszystko w tyle sie wlancza slysze powitalny dzwiek ale brak obrazu(jest tylko kursor w lewym gornym rogu)

ktos ma jakies pomysly?
_________________
pozdrawiam
maczeta

| Registered Linux User# 263545| maczetaxxx@wp.pl
www.maczeta.no-ip.org | 1553095(gg)
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2831

PostPosted: Wed Feb 01, 2012 4:17 pm    Post subject: Reply with quote

A wystarczylo by poszukac.

Masz laptopa z nvidia optimus, o ile nie wybierzesz w biosie (o ile w ogole masz taka opcje) startu z karta nvidia lub nie przelaczysz sie na nia po starcie systemu (switcheroo) to nie bedziesz w stanie jej uzyc. Najlepsze co mozesz zrobic, to wylaczenie karty nvidia co by pradu nie jadla.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
maczetax
Tux's lil' helper
Tux's lil' helper


Joined: 20 Sep 2004
Posts: 124
Location: Warsaw

PostPosted: Wed Feb 01, 2012 11:14 pm    Post subject: Reply with quote

Dziekuje za odpowiedz, oczywiscie w biose nie mam opcji zmiany glownej karty graficznej, co do switcheroo to nie udalo mi sie tego uruchomi, chociaz robilem wszystko zgodnie z instrukcja... uzylem wiec opcji Bumblebee i akceleracja nvidii dziala, lecz stracilem akceleracje na intelu :/ nie wiem o co chodzi... gdzie jest blad...

Code:

bestia ~ # glxgears
Error: couldn't get an RGB, Double-buffered visual
bestia ~ # optirun glxgears
4259 frames in 5.0 seconds = 851.790 FPS
4277 frames in 5.0 seconds = 855.258 FPS
bestia ~ # glxinfo | grep direct
Error: couldn't find RGB GLX visual or fbconfig

_________________
pozdrawiam
maczeta

| Registered Linux User# 263545| maczetaxxx@wp.pl
www.maczeta.no-ip.org | 1553095(gg)
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2831

PostPosted: Thu Feb 02, 2012 10:15 am    Post subject: Reply with quote

Bumblebee to bubel moim zdaniem, ostatni raz jak to sprawdzalem byly to tragicznie napisane skrypty basha ktore odpalaly drugi X server i puszczaly GL po VirtualGL do karty nvidia. Nawet udalo im sie popsuc systemy kilku userow jak w skrypcie do wylaczania wrzucili "rm -rf /usr lib/cos", rm odczytal to jako 2 parametry i zaoral /usr.

z Bumbleebee nie bedziesz mogl nadal uzywac VDPAU. Proponuje wylaczyc karte przez acpi_call i cieszyc sie dluzszym czasem pracy na baterii. Przynajmniej do czasu az vgaswitcheroo zacznie dzialac.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
maczetax
Tux's lil' helper
Tux's lil' helper


Joined: 20 Sep 2004
Posts: 124
Location: Warsaw

PostPosted: Thu Feb 02, 2012 2:19 pm    Post subject: Reply with quote

Zrobiłem tak jak napisałeś, zrezygnowałem z bumblebee i mecze się dalej ze switcheroo, nie wiem dlaczego ale nie potrafie włączyć obsługi zmiany kart :(

nie posiadam kataloku switchero..

debugfs zamontowane

Code:

bestia ~ # mount | grep deb
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)


a katalogu brak:

Code:

bestia ~ # ls -l /sys/kernel/debug/
razem 0
drwxr-xr-x  2 root root 0 02-02 16:06 acpi
drwxr-xr-x 30 root root 0 02-02 16:06 bdi
drwxr-xr-x  3 root root 0 02-02 16:06 bluetooth
drwxr-xr-x  3 root root 0 02-02 16:06 boot_params
drwxr-xr-x  6 root root 0 02-02 16:06 dri
-r--r--r--  1 root root 0 02-02 16:06 gpio
drwxr-xr-x  3 root root 0 02-02 16:06 hid
drwxr-xr-x  3 root root 0 02-02 16:07 ieee80211
drwxr-xr-x  2 root root 0 02-02 16:06 kprobes
drwxr-xr-x  2 root root 0 02-02 16:06 mce
-r--r--r--  1 root root 0 02-02 16:06 suspend_stats
drwxr-xr-x  5 root root 0 02-02 16:06 tracing
drwxr-xr-x  6 root root 0 02-02 16:06 usb
-r--r--r--  1 root root 0 02-02 16:06 wakeup_sources
drwxr-xr-x  2 root root 0 02-02 16:06 x86


pewnie cos w konfigu kernela ale nie wiem co, kombinuje i nadal nic..

http://pastebin.com/fqBmx3LV
_________________
pozdrawiam
maczeta

| Registered Linux User# 263545| maczetaxxx@wp.pl
www.maczeta.no-ip.org | 1553095(gg)
Back to top
View user's profile Send private message
joi_
Apprentice
Apprentice


Joined: 28 Mar 2005
Posts: 171

PostPosted: Fri Feb 03, 2012 2:38 pm    Post subject: Reply with quote

Zastanów się nad zwrotem sprzętu sprzedawcy, skoro sterowniki nvidii nie wspierają go...

Jedyna szansa na normalne działanie Twojego sprzętu to nouveau, ale dopiero gdy Dave Airlie skończy
pracę nad przerzeźbieniem całego stosu grafiki w Linuksie... a to jeszcze trochę potrwa

http://airlied.livejournal.com/75405.html
http://airlied.livejournal.com/75555.html
http://www.phoronix.com/scan.php?page=news_item&px=MTAzMjM
Back to top
View user's profile Send private message
maczetax
Tux's lil' helper
Tux's lil' helper


Joined: 20 Sep 2004
Posts: 124
Location: Warsaw

PostPosted: Sat Feb 11, 2012 4:10 pm    Post subject: Reply with quote

Witam,

VGA switcheroo nie zadziała , gdyż mam niestety laptopa z grafika optimusa... gdybym to wieszał przy kupnie... :/ a specjalnie kierowałem sie przy zakupie kartą od nvidii a nie ati bo wiedziałem że ma lepsze wsparcie...

Pozostaje wiec bumblebee....
Czyli mam rozumieć że sterowniki nvidii nie zadziałają bo będą sie gryzły GL czy mesa, nie wiem z czym dokładnie ale jakoś tak jest.

Mam bumblebee nowe sterowniki nouveau wsparcie 3D dla intela ale optirun nie wykrywa mi karty nvidii....

Czy to przez to że sterowniki nouveau nie mają jeszcze wsparcia dla mojej karty?
_________________
pozdrawiam
maczeta

| Registered Linux User# 263545| maczetaxxx@wp.pl
www.maczeta.no-ip.org | 1553095(gg)
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 493

PostPosted: Sun Mar 11, 2012 1:06 pm    Post subject: Reply with quote

Najnowszy bumbleebe dziala nie najgorzej, stawiałem kumplowi Debiana testing na lapku, i ruszył.
W Ubuntu 11.10 tez chodzi prawidłowo (bubmlebee 3.0 z ppa).

Za każdym razem ze sterownikiem Nvidii.

Osobiście odradzam na razie zabawy z Nouveau, jeszcze trochę wody w Wiśle uplynie, zanim to będzie stabilne rozwiazanie dla Nvidii.
U mnie ostatnio (testowany na Debianie Wheezy) włączenie Xów wyłączało konsolę całkowicie.

Pozdro
8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum