Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] WPA_SUPPLICANT e NetworkManager
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 117
Location: Ferrara

PostPosted: Sun Mar 04, 2012 6:04 pm    Post subject: [RISOLTO] WPA_SUPPLICANT e NetworkManager Reply with quote

Salve ragazzi, da diverse ore sto provando a configurare il mio laptop per il wifi, ma senza uscirne vivo. Uso NetworkManager e wpa_supplicant. Tramite la gui di NetworkManager riesco vedere tranquillamente l'AP, ma non riesco a connettermi. Uso il modem di alice e la cifratura di tipo WPA-PSK TKIP a 256 bit. Di seguito un po di configurazioni che potrebbero aiutarvi a capire perche' non si connette:

gentoo realnot # /etc/wpa_supplicant/wpa_supplicant.conf:
#Generated by NetworkManager
###### Global Configuration ######
ctrl_interface_group=0
ap_scan=1
ctrl_interface=/var/run/wpa_supplicant

###### Security Configuration ######
network={
        proto=WPA
        pairwise=CCMP TKIP
        key_mgmt=WPA-PSK
        priority=1
        group=CCMP TKIP WEP104 WEP40
        mode=0
        ssid=416C6963652D3934353639353533
        psk="w6rzrfq4lc1ghlbv1qeqq2mn"
}


gentoo realnot # /etc/conf.d/net:
#Generated by NetworkManager
###### Global Configuration ######
modules="iwconfig"

###### Connection Configuration ######
#----------------------------------
enable_ipv6_0x416C6963652D3934353639353533="false"
auto_0x416C6963652D3934353639353533="true"
config_0x416C6963652D3934353639353533=( "dhcp" )
#----------------------------------
config_wlan0=( "dhcp" )
#----------------------------------
dns_search_eth0="192.168.1.1"
auto_eth0="true"
config_eth0=( "192.168.1.11/24" )
dns_servers_eth0="208.67.222.222 208.67.220.220"
routes_eth0=( "default via 192.168.1.1" )
enable_ipv6_eth0="false"


/etc/resolv.conf:
# Generated by NetworkManager
search 192.168.1.1
nameserver 208.67.222.222
nameserver 208.67.220.220


ifconfig:
eth0      Link encap:Ethernet  HWaddr 00:23:54:44:96:bc 
          inet addr:192.168.1.11  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:54ff:fe44:96bc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:852 errors:0 dropped:0 overruns:0 frame:0
          TX packets:865 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:231500 (226.0 KiB)  TX bytes:133440 (130.3 KiB)
          Interrupt:16 Base address:0xb800

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:680 errors:0 dropped:0 overruns:0 frame:0
          TX packets:680 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:52016 (50.7 KiB)  TX bytes:52016 (50.7 KiB)

sit0      Link encap:IPv6-in-IPv4 
          inet6 addr: ::127.0.0.1/96 Scope:Unknown
          UP RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:22:43:20:51:c5 
          inet6 addr: fe80::222:43ff:fe20:51c5/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3176 (3.1 KiB)  TX bytes:3834 (3.7 KiB)


Per ora ho fatto riferimento alle seguenti guide:



La cosa perfetta sarebbe riuscire ad avere piu configurazioni per piu AP, ad esempio uno per quando sono a casa, l'altro per l'università ecc... inoltre usare il dhcp per il wifi, mentre per la configurazione manuale no.

Non so proprio come potrei risolvere :?
_________________
I'm not stupid, only mentally free...


Last edited by Realnot on Mon Mar 05, 2012 10:19 pm; edited 2 times in total
Back to top
View user's profile Send private message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Sun Mar 04, 2012 7:50 pm    Post subject: Reply with quote

io per configurare la rete su Gentoo ho seguito questa guida http://en.gentoo-wiki.com/wiki/NetworkManager
in /etc/conf.d/net io non ho niente
Code:
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
dns_domain_lo="gentoo-network"


per il dhcp o l'ip statico puoi fare tutto da networkmanager
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 117
Location: Ferrara

PostPosted: Sun Mar 04, 2012 11:10 pm    Post subject: Reply with quote

Ho modificato alcune le configurazioni come segue e sembra che ci sia un lieve miglioramento:

gentoo realnot # /etc/wpa_supplicant/wpa_supplicant.conf:
#Generated by NetworkManager
###### Global Configuration ######

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1
ap_scan=1

###### Security Configuration ######

network={
        ssid="Alice-94569553"
        scan_ssid=1
        key_mgmt=WPA-PSK
        group=CCMP TKIP WEP104 WEP40
        pairwise=CCMP TKIP
        psk="w6rzrfq4lc1ghlbv1qeqq2mn"
}


gentoo realnot # /etc/conf.d/net:
#Generated by NetworkManager
###### Global Configuration ######
modules_wlan0="wpa_supplicant"

###### Connection Configuration ######
#----------------------------------
dns_search_eth0="192.168.1.1"
auto_eth0="true"
config_eth0=( "192.168.1.11/24" )
dns_servers_eth0="208.67.222.222 208.67.220.220"
routes_eth0=( "default via 192.168.1.1" )
enable_ipv6_eth0="false"


wlan0 inattiva::
/etc/init.d/net.wlan0 restart
 * Bringing down interface wlan0
 *   Removing addresses
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...                                 [ ok ]
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlan0 has started, but is inactive


iwconfig - mentre tento di connettermi all'AP:
lo        no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Alice-94569553" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1D:8B:58:71:A0   
          Bit Rate=36 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-29 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0

eth0      no wireless extensions.


passano circa 20 secondi o forse 30 poi comprare una schermata in cui mi viene chiesta la password per l'AP, io metto quella che ho usato in wpa_supplicant: w6rzrfq4lc1ghlbv1qeqq2mn. Passano altri 30 secondi e mi richiede la password. Significa che la psw non e' corretta? anche se in realtà sono sicuro che lo sia... cosa dite voi?
_________________
I'm not stupid, only mentally free...


Last edited by Realnot on Mon Mar 05, 2012 4:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4720
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Mon Mar 05, 2012 12:38 pm    Post subject: Reply with quote

Per piacere quando riporti un file aggiungi il nome al tag ... correggi ... :?
/etc/wpa_supplicant/wpa_supplicant.conf wrote:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=2
update_config=1
country=it

network={
ssid="..."
psk="..."
proto=RSN
key_mgmt=WPA-PSK
pairwise=TKIP
auth_alg=OPEN
eap=PSK
}

network={
ssid="..."
...
}
qui non capisco dov'è il problema (ma mai andrò a pensare a networkmanager e non ho idea delle sue impennate,) le aggiungi e tanti saluti, ma
/etc/rc.conf:
rc_hotplug="net.lo !net.* !bluetooth"
/etc/conf.d/net wrote:
# wlan0 - wan interface (wpa_supplicant)
modules_wlan0="wpa_supplicant !iwconfig"
# ifdown_wlan0="yes"
# channel_wlan0="11"
# preup_wlan0 () { rfkill unblock 0 }
# postup_wlan0 () { rfkill unblock 0 }
In genere tutti i problemi sono in questo. La chiamata ad rfkill serve solo per alcune schede, come la disattivazione e l'impostazione statica del canale, ovviamente; ma non credo che tu abbia problemi e warn di "unable to reset device" o qualcosa del genere. Quindi dovrebbe bastare la prima riga.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 117
Location: Ferrara

PostPosted: Mon Mar 05, 2012 2:07 pm    Post subject: Reply with quote

Ho modificato i file come hai suggerito, ma non ottengo miglioramenti:

/etc/rc.conf
http://paste.pocoo.org/show/561255/

ifconfig
http://paste.pocoo.org/show/561256/


gentoo realnot # iwconfig:
wlan0     IEEE 802.11bgn  ESSID:"Alice-94569553" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1D:8B:58:71:A0   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=69/70  Signal level=-41 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:6   Missed beacon:0



gentoo realnot # /etc/wpa_supplicant/wpa_supplicant.conf:
#Generated by NetworkManager
###### Global Configuration ######

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
update_config=1
ap_scan=1

###### Security Configuration ######

network={
   ssid="Alice-94569553"
   scan_ssid=1
   proto=RSN
   key_mgmt=WPA-PSK
   pairwise=TKIP
   auth_alg=OPEN
   eap=PSK
   psk="w6rzrfq4lc1ghlbv1qeqq2mn"
}



gentoo realnot # /etc/conf.d/net:
#Generated by NetworkManager
###### Global Configuration ######
modules_wlan0="wpa_supplicant !iwconfig"

###### Connection Configuration ######
#----------------------------------
dns_search_eth0="192.168.1.1"
auto_eth0="true"
config_eth0=( "192.168.1.11/24" )
dns_servers_eth0="208.67.222.222 208.67.220.220"
routes_eth0=( "default via 192.168.1.1" )
enable_ipv6_eth0="false"


Quando provo a connettermi, ogni 30 secondi ottengo questa schermata:
http://s17.postimage.org/npkffjry7/password.jpg

La scansione viene effettuata correttamente, visto che mi rileva la rete:
http://s16.postimage.org/9oex0rm0l/network.jpg

@djinnZ: non ho capito cosa intendi per: "Per piacere quando riporti un file aggiungi il nome al tag [...]". Quale tag?

UPDATE:
Controllando sul quel baracchino del modem di alice, mentre cerco di connettermi all'access point, si puo' notare che avviene la connessione.http://s15.postimage.org/gkr6dp5pn/alice.jpg

Anche nei filtri MAC:
http://s18.postimage.org/nt6xxcqx5/alice2.jpg

Il tutto scompare quando mi rompo i coglioni di mettere la solita password nella scheramata precedente http://s17.postimage.org/npkffjry7/password.jpg
_________________
I'm not stupid, only mentally free...


Last edited by Realnot on Mon Mar 05, 2012 4:02 pm; edited 2 times in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4720
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Mon Mar 05, 2012 2:57 pm    Post subject: Reply with quote

Invece di scrivere ecco il file xxx modificare il tag code o quote per includere direttamente il nome. Come ho fatto io.

Comunque è un problema di networkmanager non di configurazione (a quel che so solo la modifica ad rc.conf serve sempre).

Piuttosto NM con quali use è stato installato?
Su alcuni router scassi di una certa azienda italiana (che non nominerò ma era meglio se continuava a fare gomme piuttosto...) ho trovato molti problemi con il dhcp che si bloccava.
Non è che ha quella strana modalità di sicurezza che impedisce di connettersi se non si preme un pulsantino rosso o qualcosa del genere?

Quello che ti ho postato è un esempio di configurazione manuale, parte con un banale
Code:
/etc/init.d/net.wlan0 start
.
Prova se funziona senza NM attivo, per incominciare.

Altrimenti spero che ci sia qualcuno che lo usa. Personalmente non ho mai pensato ad installarlo.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 117
Location: Ferrara

PostPosted: Mon Mar 05, 2012 3:59 pm    Post subject: Reply with quote

djinnZ wrote:
Piuttosto NM con quali use è stato installato?


gentoo realnot # emerge -pv networkmanager:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-misc/networkmanager-0.8.4.0-r2  USE="avahi bluetooth connection-sharing dhcpcd ppp -dhclient -doc -gnutls -nss -resolvconf" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

gentoo realnot #


Quando ho emerso NetworkManager la prima volta, avevo abilitato anche la FlagUSE resolvconf, che andava a modificare direttamente /etc/resolv.conf. Successivamente o disabilitato dale Flag e emerso nuovamente.

gentoo realnot # /etc/init.d/net.wlan0 start:

 * WARNING: net.wlan0 has already started, but is inactive


gentoo realnot # /etc/init.d/net.wlan0 restart:

 * Bringing down interface wlan0
 *   Removing addresses
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
Could not set interface wlan0 flags: Operation not possible due to RF-kill
Failed to initialize driver interface
 *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'        [ !! ]
 * ERROR: net.wlan0 failed to start


Ho eliminato net.Wlan0 e NetworkManager dal runlevel default, quindi ho riavviato.


gentoo realnot # /etc/init.d/net.wlan0 start:

 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...                                 [ ok ]
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlan0 has started, but is inactive


gentoo realnot # wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.


Da tenere presente che qui ho usato wext Linux wireless extensions (generic), ma i driver per la mia scheda sono ath9h_hw

gentoo realnot # grep -i ATH9K /usr/src/linux/.config:

CONFIG_ATH9K_HW=y
CONFIG_ATH9K_COMMON=y
CONFIG_ATH9K=y
CONFIG_ATH9K_PCI=y
CONFIG_ATH9K_AHB=y
# CONFIG_ATH9K_DEBUGFS is not set
CONFIG_ATH9K_RATE_CONTROL=y
# CONFIG_ATH9K_HTC is not set


Che non sembrano essere supportati da wpa_supplicant (almeno, non li vedo nella lista)

gentoo realnot # wpa_supplicant:


[...]

drivers:
  wext = Linux wireless extensions (generic)
  nl80211 = Linux nl80211/cfg80211
  hostap = Host AP driver (Intersil Prism2/2.5/3)
  atmel = ATMEL AT76C5XXx (USB, PCMCIA)
  ndiswrapper = Linux ndiswrapper (deprecated; use wext)
  ipw = Intel ipw2100/2200 driver (old; use wext with Linux 2.6.13 or newer)
  wired = Wired Ethernet driver
  ralink = Ralink Wireless Client driver

[...]



Quindi faccio quello che mi consiglia il messaggio sopra:

Code:
gentoo realnot # rm /var/run/wpa_supplicant/wlan0

gentoo realnot # wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf:
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.


djinnZ wrote:
Non è che ha quella strana modalità di sicurezza che impedisce di connettersi se non si preme un pulsantino rosso o qualcosa del genere?


Si, avevi ragione. Non ho mai notato questa cosa, poiche' mia sorella nel'appartamento di fianco al mio si collegga con windows XP, e lo fa senza il pulsante REG. Ad ogni modo, dall'user guide del device ho recuperato:
http://s18.postimage.org/n8tr05tft/reg_button.jpg
http://s17.postimage.org/uoan2znlr/reg_button2.jpg

Quindi ora vedo, se scopro qualcosa di nuovo faccio un update. Intanto modifico i messaggi precedenti come mi hai suggerito. Colgo l'occasione per ringraziarti, per la tua disponibilità ed il tuo tempo.[/code]
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4720
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Mon Mar 05, 2012 4:49 pm    Post subject: Reply with quote

hai una atheros (la mia è una 5k e capita)quindi tanto vale verificare se non devi sbloccare il device
rfkill list:
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
Se riporta yes lancia
Code:
rfkill unblock 0
e riprova. Se funziona basta solo che aggiungi le funzioni di preup e postup che ti ho riportato, NM o non NM forse era qui il problema.

Ma con le 9k sapevo che non capitava... mah.
Se usi il driver "ufficiale" incluso nel kernel è sempre nl80211/wext (con i kernel recenti è nl80211 visto che LWE è deprecato).
Controlla la conf del kernel, sezione "NET" non "drivers".

Il filtro ARP dovrebbe essere disabilitato se usi wpa ma con codesti affari nulla è certo.

Nel peggiore dei casi lascia solo
/etc/wpa_supplicant/wpa_supplicant.conf:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=2
update_config=1
country=it
e lanci
Code:
/etc/init.d/net.wlan0 start
wpa_cli

Risolto il problema a livello di sistema potrai incominciare ad occuparti di NM se vuoi.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Realnot
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2007
Posts: 117
Location: Ferrara

PostPosted: Mon Mar 05, 2012 7:57 pm    Post subject: Reply with quote

Soft blocked era bloccato, ma ho eseguito il comando che mi hai fornito. Ora sembra ok.

gentoo realnot # rfkill list:
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no


Ho dato uno sguardo nel kernel, però non conosco le voci...

gentoo realnot # grep -i WEXT /usr/src/linux/.config:
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_CFG80211_WEXT=y


gentoo realnot # grep -i NL80211 /usr/src/linux/.config:
# CONFIG_NL80211_TESTMODE is not set


gentoo realnot # grep -i IWLWIFI /usr/src/linux/.config:
# CONFIG_IWLWIFI is not set


gentoo realnot # grep -i cfg80211 /usr/src/linux/.config:
CONFIG_CFG80211=y
# CONFIG_CFG80211_DEVELOPER_WARNINGS is not set
# CONFIG_CFG80211_REG_DEBUG is not set
CONFIG_CFG80211_DEFAULT_PS=y
# CONFIG_CFG80211_DEBUGFS is not set
# CONFIG_CFG80211_INTERNAL_REGDB is not set
CONFIG_CFG80211_WEXT=y


Ho tolto networkmanager dal runlevel, ora uso solo wpa_supplicant con la configurazione:

djinnZ wrote:
/etc/wpa_supplicant/wpa_supplicant.conf::

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=2
update_config=1
country=it


Ho anche cambiato impostazioni della rete wifi nel router, ora e' aperta senza alcun tipo di crittografia e controllo accessi tramite MAC. Non ho famigliarita' con wpa_cli, come potrei provare a connettermi?

PS: ho provato ad inserire la live di Kubuntu per vedere se si connetteva, ebbene si. Ho cercato disperatamente un file wpa_supplicant.conf ma in kubuntu non esiste. Ho anche provato a guardare se c'era /etc/conf.d/net ma non ho trovato nulla di simile. Volevo provare a vedere i file di configurazione sulla live per vedere le differenze con i miei. Non capisco perche' la gira e qui no. In kubuntu usano networkmanager con wpa_supplicant.
Non ho la live DVD di Gentoo qui con me, altrimenti mettevo su quella, il wi-fi dalla Live DVD dovrebbe andare subito e almeno so dove sono le configurazioni che mi interessano. A sto punto non so piu cosa fare :(

I misteri della vita :/

UPDATE 1:

Sto rispondendo collegato all'AP senza cavo ethernet, quindi in Wi-Fi. NetworkManager e' down, i file di configurazione sono rispettivamente:

/etc/conf.d/net:
#Generated by NetworkManager
###### Global Configuration ######

modules_wlan0="wpa_supplicant !iwconfig"

###### Connection Configuration ######
#----------------------------------
dns_search_eth0="192.168.1.1"
auto_eth0="true"
config_eth0=( "192.168.1.11/24" )
dns_servers_eth0="208.67.222.222 208.67.220.220"
routes_eth0=( "default via 192.168.1.1" )
enable_ipv6_eth0="false"


/etc/wpa_supplicant/wpa_supplicant.conf:
#Generated by NetworkManager
###### Global Configuration ######

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=2
update_config=1
country=it
ap_scan=1

###### Security Configuration ######

network={
        ssid="Alice-94569553"
        key_mgmt=NONE
        priority=-999
}


ifconfig:
http://paste.pocoo.org/show/561509/

iwconfig:
http://paste.pocoo.org/show/561511/

Questo e' un piccolo passo. Adesso provo ad aggiungere parametri alla configurazione :)

UPDATE 2:


ifconfig:
 [...]
wlan0     Link encap:Ethernet  HWaddr 00:22:43:20:51:c5 
inet addr:192.168.1.215  Bcast:192.168.1.255  Mask:255.255.255.0
inet6 addr: fe80::222:43ff:fe20:51c5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:1412 errors:0 dropped:0 overruns:0 frame:0
TX packets:1417 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:685208 (669.1 KiB)  TX bytes:234358 (228.8 KiB)


Ora riesco a navigare liberamente con WPA-PSK TKIP 256. L'interfaccia eth0 e' down, ma per sicureza ho tolto il cavo ethernet :P

gentoo realnot # /etc/init.d/net.eth0 stop:

 * WARNING: net.eth0 is already stopped


/etc/conf.d/net:
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).

#### net.wlan0

modules_wlan0="wpa_supplicant !iwconfig"
config_wlan0=( "dhcp" )

#### net.eth0

auto_eth0="true"
dns_search_eth0="192.168.1.1"
dns_servers_eth0="208.67.222.222 208.67.220.220"
config_eth0=( "192.168.1.11/24" )
routes_eth0=( "default via 192.168.1.1" )

enable_ipv6_eth0="false"


/etc/wpa_supplicant/wpa_supplicant.conf:
###### Global Configuration ######

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=2
update_config=1
country=it
ap_scan=1

###### Security Configuration ######

network={
        ssid="Alice-94569553"
        psk="w6rzrfq4lc1ghlbv1qeqq2mn"
        pairwise=TKIP
        eap=PSK
        key_mgmt=WPA-PSK
        priority=-999
}


Funziona tutto perfettamente, ma senza l'uso di NetworkManager. Modifico il titolo del post e considero il problema risolto. Nei prossimi giorni proverò nuovamente ad usare NetworkManager e vedere come si comporta. Nel caso scoprissi qualcosa, aggiornero' questo post.

Grazie djinnZ per il supporto :)
_________________
I'm not stupid, only mentally free...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4720
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Tue Mar 06, 2012 9:58 am    Post subject: Reply with quote

Mettiamola così: NM non lo uso perchè le mie configurazioni sono abbastanza "statiche" e non mi serve a nulla ma, in generale, è qualcosa che poggia sui driver del kernel e wpa_supplicant.
In caso di problemi meglio verificare prima i componenti di base senza NM che "nasconde" eventuali incongruenze.

Quando sai quali possono essere i possibili problemi e sei certo che la connessione non ha ostacoli ti applichi ad NM.

Possibile che semplicemente non riesce a resettare il device (però mi pare che da qualche parte ha una opzione apposita).

Se hai problemi, anche saltuari, al riavvio od alla disconnessione con il soft blocked attivo tanto vale che aggiungi i comandi che ti ho indicato.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum