Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[sata_via] VT6421: ne fonctione pas
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sat Jan 21, 2012 5:29 pm    Post subject: [sata_via] VT6421: ne fonctione pas Reply with quote

Bonjours à tous,
j'ai actuelement un petit souci (décidement j'en ai pas mal ces temps ci :p) avec une carte controleur sata que j'ai acheté il y a maintenant un moment mais que je n'ai jamais pu faire marcher

voici ce que j'en tire:

Quote:
StarK adamaru # lspci | grep RAID
07:01.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID Controller (rev 50)
StarK adamaru # lsmod | grep via
sata_via 6828 0
pata_via 7660 0
libata 120868 55 libsas,pdc_adma,sata_inic162x,sata_mv,ata_piix,ahci,libahci,sata_qstor,sata_vsc,sata_uli,sata_sis,sata_sx4,sata_nv,sata_via,sata_svw,sata_sil24,sata_sil,sata_promise,pata_sl82c105,pata_cs5530,pata_cs5520,pata_via,pata_jmicron,pata_marvell,pata_sis,pata_netcell,pata_sc1200,pata_pdc202xx_old,pata_triflex,pata_atiixp,pata_opti,pata_amd,pata_ali,pata_it8213,pata_pcmcia,pata_ns87415,pata_ns87410,pata_serverworks,pata_platform,pata_cypress,pata_oldpiix,pata_artop,pata_it821x,pata_optidma,pata_hpt3x2n,pata_hpt3x3,pata_hpt37x,pata_hpt366,pata_cmd64x,pata_efar,pata_rz1000,pata_sil680,pata_radisys,pata_pdc2027x,pata_mpiix


quand je branche un disque dur derriere la carte et que je fais un tail -f /var/log/messages
je n'ai rien concernant un éventuel disque dur (comme si la carte n'était pas reconue)

quelqu'un aurais une idée ?
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sat Jan 21, 2012 5:55 pm    Post subject: Reply with quote

J'ai pas trop googlé, mais : as-tu essayé de faire tourner tout ça avec le driver AHCI, et désactiver le driver sata_via/pata_via (pour éviter les conflits) ?
La plupart des chipsets SATA répondant correctement à la norme fonctionnent avec AHCI (d'ailleurs AHCI est le seul driver qui te permettra de faire du hotplug SATA/eSATA)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sat Jan 21, 2012 6:31 pm    Post subject: Reply with quote

hum non je n'ai pas encore éssayé
pour désactiver un module on fait comment ?

car si je fais juste un modprobe -r j'imagine que le module se re-loadera tout seul

apres je tiens à la fonction hotplug (car c'est pour brancher sur un rack ICY DOCK qui à 3 ports (j'en ai deux fonctionels mais je dois metre le 3eme sur cette carte^))

edit:
jai mis en blacklist dans modprobe.d/blacklist.conf les modules: sata_via et pata_via (d'ailleur c'est quoi pata ?)
je dois rebooter apres ca ou je peu faire reconaitre la carte via ahci directement ? (si oui comment ?)
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sat Jan 21, 2012 7:29 pm    Post subject: Reply with quote

Perso, les drivers comme ça, je les mets en dur, jamais en module. Je ne sais absolument pas comment ça réagit en module... Donc dans ce cas, je recompile un kernel avec ahci et sans via_*

accessoirement : le driver "pata", c'est pour de l'ide, pas du sata ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Jan 22, 2012 12:53 pm    Post subject: Reply with quote

bon alors je viens de recompiler la kernaille et reboot (par contre le ahci je ne peu que le compiler en module pas en dur apparement)
et la carte ne marche toujours pas (il faut dire explicitement a ahci de prendre la carte en charge ?)

avec un lspci -vk je tombe bien sur:

Code:

07:01.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID Controller (rev 50)
   Subsystem: VIA Technologies, Inc. VT6421 IDE RAID Controller


donc pas de trace du module,

se pourais il que la carte ne soit pas prise en charge par ahci ?
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sun Jan 22, 2012 1:45 pm    Post subject: Reply with quote

Oui bien sûr, c'est possible que ahci ne la prenne pas en charge.

Bon, ben y a rien de mieux que le grep dans le code du noyau... c'est sata_via:
Code:
sata_via.c:     { PCI_VDEVICE(VIA, 0x3249), vt6421 }, /* 2 sata chnls, 1 pata chnl */

Donc bon, laisse tomber la piste ahci ;)
Par contre, de ce que j'avais lu, sous linux, le hotplug SATA ne fonctionne que avec AHCI...
Si tu branches ton disque en SATA avant de booter, il apparait ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Jan 22, 2012 2:02 pm    Post subject: Reply with quote

hum ce n'est pas tout a fait exact par contre :)

je fais du hotplug avec une carte sata_promise (et donc le module associé) sans soucis :)
jai recompilé le noyeau avec sata_via ce coup ci et jai unload et reload le module a la main pour voir ce que ca donnerais du coté des logs et:

Quote:
Jan 22 15:42:09 StarK kernel: sata_via 0000:07:01.0: version 2.6
Jan 22 15:42:09 StarK kernel: sata_via 0000:07:01.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Jan 22 15:42:09 StarK kernel: sata_via 0000:07:01.0: routed to hard irq line 12
Jan 22 15:42:09 StarK kernel: scsi27 : sata_via
Jan 22 15:42:09 StarK kernel: scsi28 : sata_via
Jan 22 15:42:09 StarK kernel: scsi29 : sata_via
Jan 22 15:42:09 StarK kernel: ata28: SATA max UDMA/133 port i16@0xbf00 bmdma 0xbb00 irq 19
Jan 22 15:42:09 StarK kernel: ata29: SATA max UDMA/133 port i16@0xbe00 bmdma 0xbb08 irq 19
Jan 22 15:42:09 StarK kernel: ata30: PATA max UDMA/133 port i16@0xbd00 bmdma 0xbb10 irq 19
Jan 22 15:42:09 StarK kernel: ata28: SATA link down (SStatus 0 SControl 310)
Jan 22 15:42:10 StarK kernel: ata29: SATA link down (SStatus 0 SControl 310)


edit: meme en bootan avec le hdd sur le carte avant, il n'es pas pris en charge^
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sun Jan 22, 2012 2:22 pm    Post subject: Reply with quote

Bon bah, je donne ma langue au chat.
Pas de problème de conflit d'IRQ ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Jan 22, 2012 2:59 pm    Post subject: Reply with quote

hum aucune idée, il existe une commande pour avoir la liste des IRQ utilisée et d'éventuels conflits ?
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sun Jan 22, 2012 3:08 pm    Post subject: Reply with quote

Pour voir comment ça se répartit, cat /proc/interrupts. Vérifier que tout passe bien par l'IO-APIC. S'il y a trop de monde sur une IRQ, éventuellement faire un tour dans le BIOS pour voir ce qui peut se régler.
Mais bon, ça reste une piste sans grand enthousiasme...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Jan 22, 2012 3:43 pm    Post subject: Reply with quote

voici le retour que j'ai des interups:

Quote:
StarK adamaru # cat /proc/interrupts
CPU0 CPU1 CPU2 CPU3
0: 31 5 6 4 IO-APIC-edge timer
1: 0 0 1 1 IO-APIC-edge i8042
7: 0 0 0 0 IO-APIC-edge parport0
9: 0 0 0 0 IO-APIC-fasteoi acpi
14: 0 0 0 0 IO-APIC-edge ide0
15: 0 0 0 0 IO-APIC-edge ide1
16: 227059 227757 227355 227625 IO-APIC-fasteoi pata_it8213, ahci, uhci_hcd:usb3, uhci_hcd:usb9, nvidia
17: 53 68 46 43 IO-APIC-fasteoi pata_jmicron, snd_hda_intel
18: 4486 4466 4506 4531 IO-APIC-fasteoi sata_promise, ehci_hcd:usb1, uhci_hcd:usb5, uhci_hcd:usb8
19: 209195 208502 209040 208717 IO-APIC-fasteoi uhci_hcd:usb7, sata_via
21: 436 485 443 438 IO-APIC-fasteoi uhci_hcd:usb4
23: 0 1 2 0 IO-APIC-fasteoi ehci_hcd:usb2, uhci_hcd:usb6
41: 6016 5967 5938 6024 PCI-MSI-edge ahci
42: 104 106 99 100 PCI-MSI-edge ahci
43: 1 0 0 0 PCI-MSI-edge xhci_hcd
44: 0 0 0 0 PCI-MSI-edge xhci_hcd
45: 0 0 0 0 PCI-MSI-edge xhci_hcd
46: 0 0 0 0 PCI-MSI-edge xhci_hcd
47: 0 0 0 0 PCI-MSI-edge xhci_hcd
48: 172364 172367 172289 172246 PCI-MSI-edge eth0
49: 156 154 153 149 PCI-MSI-edge snd_hda_intel
NMI: 0 0 0 0 Non-maskable interrupts
LOC: 2965125 2980984 1144131 1170470 Local timer interrupts
SPU: 0 0 0 0 Spurious interrupts
PMI: 0 0 0 0 Performance monitoring interrupts
IWI: 0 0 0 0 IRQ work interrupts
RES: 855474 853848 116526 116628 Rescheduling interrupts
CAL: 7770 8683 12595 14110 Function call interrupts
TLB: 23359 26828 18546 19730 TLB shootdowns
TRM: 0 0 0 0 Thermal event interrupts
THR: 0 0 0 0 Threshold APIC interrupts
MCE: 0 0 0 0 Machine check exceptions
MCP: 24 24 24 24 Machine check polls
ERR: 0
MIS: 0


quelque chose d'anormal la dedans ?
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sun Jan 22, 2012 4:49 pm    Post subject: Reply with quote

Suis pas super expert, mais je trouve le niveau d'interruptions très élevé sur l'irq 19 pour une carte qui ne fonctionne pas. A moins que le port USB 7 soit très utilisé...
Je trouve aussi étrange que ahci et la carte son utilisent à la fois les IO-APIC ET les MSI. A priori, c'est soit l'un, soit l'autre.

Il y a du monde dis-donc sur ce PC : 3 controlleurs SATA et 2 controlleurs PATA ! 8O

Tu as essayé de changer de port PCI ? à tout hasard ?
LE kernel ne crache rien de spécial à propos des interruptions ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Jan 22, 2012 10:00 pm    Post subject: Reply with quote

ah oui sur le pc y'a pas mal de monde :p
en gros:

Quote:
StarK adamaru # lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1a.1 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1a.2 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1a.7 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1c.6 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 7 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1d.1 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1d.2 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1d.3 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1d.7 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
03:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
04:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
04:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
05:00.0 IDE interface: Marvell Technology Group Ltd. Device 91a3 (rev 11)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
07:01.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID Controller (rev 50)
07:02.0 Mass storage controller: Promise Technology, Inc. PDC40718 (SATA 300 TX4) (rev 02)
07:03.0 IDE interface: Integrated Technology Express, Inc. IT8213 IDE Controller
07:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
StarK adamaru # cat /etc/fstab
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#<fs> <mount point> <type> <opts> <dump/pass>
UUID=ba2a4003-d0d1-41cd-9d8c-07911512792b none swap sw 0 0
UUID=ae68c1a2-8577-4e45-a14a-e81803a4a54c / ext3 defaults,noatime 0 1
UUID=6397665d-47d2-4b1f-a86f-9d9639ac14cf /mnt/Atherion ext3 defaults 0 0
UUID=a9956587-1a7d-420b-8b0b-f09a918dc742 /mnt/Zeus xfs defaults 0 0
UUID=d4c13022-5b79-4c22-9022-df625bbc83af /mnt/Thor xfs defaults 0 0
UUID=25ae5b27-6363-4af8-9e09-25c8a16ab0c6 /mnt/Pandore xfs defaults 0 0
UUID=d09dd650-6bc2-4370-8bf3-61d876afc1e6 /mnt/Odin xfs defaults 0 0
UUID=612f2531-aeb8-4378-adb2-e3a647a5b4ae /mnt/Ares xfs defaults 0 0
#UUID=714a250c-c373-44fd-b8d6-74bbccf32620 /mnt/Onsokumaru btrfs defaults 0 0
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0
/mnt/Ares/packages /usr/portage/packages none bind 0 0
//Freebox/Disque\040dur /mnt/FreeBox cifs defaults,password=,iocharset=utf-8 0 0
StarK adamaru # df -h
Sys. fich. Taille Util. Dispo Uti% Monté sur
rootfs 75G 57G 14G 81% /
udev 10M 692K 9,4M 7% /dev
/dev/sda1 75G 57G 14G 81% /
rc-svcdir 1,0M 160K 864K 16% /lib64/rc/init.d
cgroup_root 10M 0 10M 0% /sys/fs/cgroup
shm 5,9G 668K 5,9G 1% /dev/shm
/dev/sdf1 294G 121G 159G 44% /mnt/Atherion
/dev/sdc1 932G 879G 53G 95% /mnt/Zeus
/dev/sde1 932G 930G 1,8G 100% /mnt/Thor
/dev/sdd1 1,4T 423G 974G 31% /mnt/Pandore
/dev/sdb1 1,9T 1,4T 482G 75% /mnt/Odin
/dev/sdg1 1,9T 1,3T 618G 67% /mnt/Ares


je vais éssayer de changer la carte de port PCI demain dans ce cas,
par contre comment faire pour savoir si le kernel cache quelque chose ? (je suis en 3.2.1 la)
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Feb 26, 2012 5:34 pm    Post subject: Reply with quote

bon je me suis (enfin) motivé a re-ouvrir la bête pour changer la carte de port pci mais voila un "leger" probleme se pose:

http://img577.imageshack.us/img577/8490/20120226182823.jpg

et oui... je n'ai que deux port pci, celui du bas étant deja occupé par la carte sata_promise il ne reste plus que celui du haut

j'ai comme qui dirais le sentiment d'être dans une impasse...
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2872
Location: Paris

PostPosted: Mon Feb 27, 2012 9:58 am    Post subject: Reply with quote

Je n'ai pas vérifié si ton contrôleur était récent ou non, mais pour avoir eu du vieux contrôleur SATA VIA il y a qq années, j'ai dû effectuer une manip' sur le DD pour forcer le mode SATA 1 (via un jumper), le contrôleur ne le voyant pas sinon.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Fri Mar 02, 2012 5:59 pm    Post subject: Reply with quote

j'ai tenté avec un jumper pour brider en sata 1 -> aucune detection (rien dans les logs /var/log/messages)

j'ai finis par commander une autre carte controleur (en pci-e 4x ce coup ci^)
histoire de metre ca dans le pci-e 8x qu'il me reste de dispo

car la je me demande si le probleme ne serais pas tout simplement materiel (étange car la carte es pourtant reconue)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum