Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cinnamon for Gentoo
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Sat Dec 31, 2011 3:52 pm    Post subject: Cinnamon for Gentoo Reply with quote

Hi all,
There is a new alternative to gnome-shell called Cinnamon developed by linux mint, it could be interresing to try it on gentoo.
In practice it looks like gnome 2 but it is written using gnome3.
Could anyone write an ebuild? https://github.com/linuxmint/Cinnamon

Thanks
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
gentooP4
Apprentice
Apprentice


Joined: 20 Sep 2010
Posts: 160
Location: was London, now Kapiti - NZ :-)

PostPosted: Sat Dec 31, 2011 3:58 pm    Post subject: Reply with quote

Isn't it just gnome 3 with a traditional looking menu bar?

I watched a few reviews on YouTube and they were disapointed
_________________
Neo wasn't searching for the matrix.. he was doing an overnight emerge
Reiser is a killer filesystem.
Back to top
View user's profile Send private message
greut
n00b
n00b


Joined: 20 Nov 2009
Posts: 8

PostPosted: Tue Jan 10, 2012 8:55 am    Post subject: Reply with quote

the ebuild is here!

http://packages.gentoo.org/package/gnome-extra/cinnamon
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Sun Jan 15, 2012 2:45 pm    Post subject: Reply with quote

Thanks

I would like to try a live ebuild, anyone has it?
Seems to be interesing new feature in git version
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
pengu
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 114
Location: Germany

PostPosted: Tue Jan 24, 2012 7:13 pm    Post subject: Reply with quote

nice but it can't be launched via lxdm, why?
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4159
Location: Removed by Neddy

PostPosted: Tue Jan 24, 2012 10:44 pm    Post subject: Reply with quote

yellowhat wrote:
Thanks

I would like to try a live ebuild, anyone has it?
Seems to be interesing new feature in git version
you could always write one
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
pengu
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 114
Location: Germany

PostPosted: Tue Jan 24, 2012 11:33 pm    Post subject: Reply with quote

hehe

i'm using the cinnamon 1.1.3 ebuild.

I've tried to launch it directly fom another running window manager with the --replace option but this fails too.
It's not possible to see why it's failing because I always return to the login manager.

I'll have a closer look on this.

Edit

launching cinnamon from the .xinitrc doesn't work too but now I see what's going wrong.

There are some js errors there, something like:

[code]

Execution of main.js threw exeption: TypeError root is null

{/code]
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4159
Location: Removed by Neddy

PostPosted: Tue Jan 24, 2012 11:41 pm    Post subject: Reply with quote

cinnamon 1.1.3 works for me but the latest does look to have alot of improvements
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
pengu
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 114
Location: Germany

PostPosted: Tue Jan 24, 2012 11:49 pm    Post subject: Reply with quote

hmm different packages? different use flags perhaps?

I'm using a multi monitor environment, could this be the problem?

ok this is the whole error message:

Code:



Fensterverwalter-Warnung:Log level 16: Failed to load apps: Failed to look up menu_file for "applications.menu"

    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/usr/share/cinnamon/js/ui/panelLaunchers.js' line 224 exception 0 number 157
Fensterverwalter-Warnung:Log level 8: gmenu_tree_get_root_directory: assertion `tree->loaded' failed
    JS ERROR: !!!   Exception was: TypeError: root is null
    JS ERROR: !!!     lineNumber = '594'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/menu.js"'
    JS ERROR: !!!     stack = '"()@/usr/share/cinnamon/js/ui/menu.js:594
()@/usr/share/cinnamon/js/ui/menu.js:791
()@/usr/share/cinnamon/js/ui/menu.js:441
ApplicationsButton()@/usr/share/cinnamon/js/ui/menu.js:391
()@/usr/share/cinnamon/js/ui/panel.js:955
Panel()@/usr/share/cinnamon/js/ui/panel.js:896
start()@/usr/share/cinnamon/js/ui/main.js:219
@<main>:1
"'
    JS ERROR: !!!     message = '"root is null"'
Fensterverwalter-Warnung:Log level 32: Execution of main.js threw exception: TypeError: root is null

Back to top
View user's profile Send private message
unixbhaskar
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2007
Posts: 85
Location: India

PostPosted: Mon Jan 30, 2012 11:42 am    Post subject: Cinnamon install error Reply with quote

I am getting this :

Code:

bhaskar@GentooLinux_16:24:02_Mon Jan 30:~> sudo emerge -av cinnamon
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] gnome-extra/cinnamon-1.2-r1  USE="bluetooth networkmanager" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) gnome-extra/cinnamon-1.2-r1
 * cinnamon-1.2.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                 [ ok ]
>>> Unpacking source...
>>> Unpacking cinnamon-1.2.tar.gz to /var/tmp/portage/gnome-extra/cinnamon-1.2-r1/work
>>> Source unpacked in /var/tmp/portage/gnome-extra/cinnamon-1.2-r1/work
>>> Preparing source in /var/tmp/portage/gnome-extra/cinnamon-1.2-r1/work/linuxmint-Cinnamon-185383f ...
 * Applying cinnamon-1.1.3-automagic-gnome-bluetooth.patch ...                                                                         [ ok ]
 * Applying cinnamon-1.2-optional-networkmanager.patch ...                                                                             [ ok ]
 * Applying cinnamon-1.1.3-extensionjs_path.patch ...                                                                                  [ ok ]
 * Applying cinnamon-1.1.3-xdg-open.patch ...                                                                                          [ ok ]
mv: cannot move `files/usr/lib' to a subdirectory of itself, `files/usr/lib/lib'
 * ERROR: gnome-extra/cinnamon-1.2-r1 failed (prepare phase):
 *   mv failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_prepare
 *   environment, line 6002:  Called die
 * The specific snippet of code:
 *       mv files/usr/lib files/usr/$(get_libdir) || die "mv failed";
 *
 * If you need support, post the output of 'emerge --info =gnome-extra/cinnamon-1.2-r1',
 * the complete build log and the output of 'emerge -pqv =gnome-extra/cinnamon-1.2-r1'.
 * The complete build log is located at '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/temp/environment'.
 * S: '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/work/linuxmint-Cinnamon-185383f'

>>> Failed to emerge gnome-extra/cinnamon-1.2-r1, Log file:

>>>  '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/temp/build.log'

 * Messages for package gnome-extra/cinnamon-1.2-r1:

 * ERROR: gnome-extra/cinnamon-1.2-r1 failed (prepare phase):
 *   mv failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_prepare
 *   environment, line 6002:  Called die
 * The specific snippet of code:
 *       mv files/usr/lib files/usr/$(get_libdir) || die "mv failed";
 *
 * If you need support, post the output of 'emerge --info =gnome-extra/cinnamon-1.2-r1',
 * the complete build log and the output of 'emerge -pqv =gnome-extra/cinnamon-1.2-r1'.
 * The complete build log is located at '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/temp/environment'.
 * S: '/var/tmp/portage/gnome-extra/cinnamon-1.2-r1/work/linuxmint-Cinnamon-185383f'


Correct me if I missed out anything!!

-Bhaskar
_________________
Musing with GNU/Linux :)

Dell Vostro 3350
i686 Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz GenuineIntel GNU/Linux
RAM : 4 GB
Kernel :Linux GentooLinux 3.1.10-gentoo-r1
OS: Gentoo/Arch/Slackware/Debian/openSUSE/Fedora
Intel 965GM Chipset
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Mon Jan 30, 2012 6:56 pm    Post subject: Re: Cinnamon install error Reply with quote

unixbhaskar wrote:

Correct me if I missed out anything!!

-Bhaskar
https://bugs.gentoo.org/show_bug.cgi?id=401223
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Wed Feb 01, 2012 7:17 pm    Post subject: Reply with quote

I am looking for weather extension, anyone know how to install?
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
donc_oe
n00b
n00b


Joined: 26 Feb 2012
Posts: 8

PostPosted: Sun Feb 26, 2012 10:04 pm    Post subject: Reply with quote

i'm only using gentoo on mobile devices so far, but with cinnamon going open source i might give it a try to install gentoo on my desktop machine.
how is the experience/performance?

yellowhat wrote:
I am looking for weather extension, anyone know how to install?

i'm not using cinnamon with gentoo yet, but a weather extension should be included in the clock applet at the panel. simply click the clock and add a location and confirm with password. (at least that's the way in LMDE.)
Back to top
View user's profile Send private message
unixbhaskar
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2007
Posts: 85
Location: India

PostPosted: Mon Feb 27, 2012 3:43 am    Post subject: Cinnamon not activating!! Reply with quote

Guys I have installed cinnamon and it show the entry in Login window..once I select this and try to login I am still thrown at Gnome shell fallback mode(Gnome shell standard mode never works for me on Gentoo!!)

Kindly suggest what am I missing to run cinnamon properly on Gentoo.

Here is my .xinitrc in home look like :

Code:

bhaskar@GentooLinux_09:11:42_Mon Feb 27:~> cat .xinitrc                                                                                       
ck-launch-session gnome-session-cinnamon                                                                                                     


-Bhaskar
_________________
Musing with GNU/Linux :)

Dell Vostro 3350
i686 Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz GenuineIntel GNU/Linux
RAM : 4 GB
Kernel :Linux GentooLinux 3.1.10-gentoo-r1
OS: Gentoo/Arch/Slackware/Debian/openSUSE/Fedora
Intel 965GM Chipset
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Mon Feb 27, 2012 3:55 am    Post subject: Reply with quote

I believe cinnamon requires compositing & a working video setup just like gnome-shell... get us an xorg log and we can help with that, probably
Back to top
View user's profile Send private message
ssn
n00b
n00b


Joined: 23 Apr 2005
Posts: 41

PostPosted: Wed Mar 07, 2012 12:13 pm    Post subject: Reply with quote

gentooP4 wrote:
Isn't it just gnome 3 with a traditional looking menu bar?

I watched a few reviews on YouTube and they were disapointed


nope, it also uses a different windowmanager
Back to top
View user's profile Send private message
kegman
n00b
n00b


Joined: 01 Mar 2012
Posts: 11
Location: hovering over east coast

PostPosted: Sat Mar 10, 2012 5:15 pm    Post subject: Reply with quote

about weather ext. here is like. It is working for me...

https://github.com/simon04/gnome-shell-extension-weather
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Tue Aug 14, 2012 9:55 am    Post subject: Reply with quote

Has someone a cinnamon-9999 ebuild to emerge the live version from git (https://github.com/linuxmint/Cinnamon/)?
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST


Last edited by yellowhat on Sat Sep 08, 2012 4:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
scottishduck
n00b
n00b


Joined: 07 Oct 2010
Posts: 4
Location: Scotland

PostPosted: Thu Aug 23, 2012 5:57 am    Post subject: Reply with quote

yellowhat wrote:
Anyone has a cinnamon-9999 ebuild to emerge the live version from git (https://github.com/linuxmint/Cinnamon/)?


I'm also looking for this.
_________________
Freedom is the right of the individual to choose the software he installs, not the right of GNU to force you into GPL.

Member of the Board of Governors at PPUK.
Back to top
View user's profile Send private message
Dr. Strangelove
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 104
Location: Germania

PostPosted: Sun Aug 26, 2012 9:02 am    Post subject: Reply with quote

yellowhat wrote:
Anyone has a cinnamon-9999 ebuild to emerge the live version from git (https://github.com/linuxmint/Cinnamon/)?

Yes! And I'm using it since ages!!! 8)

cinnamon-9999.ebuild
Code:
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header:

EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="2:2.5"
PYTHON_USE_WITH="xml"

inherit autotools eutils gnome2 multilib pax-utils python git-2

DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
HOMEPAGE="http://cinnamon.linuxmint.com/"
SRC_URI=""

EGIT_REPO_URI="git://github.com/linuxmint/Cinnamon.git"
##EGIT_COMMIT="4aaf04d3a3517a2da502ac6871ec2732d357c9f0"
#EGIT_BRANCH="stable"

LICENSE="GPL-2"
SLOT="0"
IUSE="+bluetooth +networkmanager"
KEYWORDS="~amd64 ~x86"

# gnome-desktop-2.91.2 is needed due to header changes, db82a33 in gnome-desktop
# latest gsettings-desktop-schemas is needed due to commit 602fa1c6
# latest g-c-c is needed due to https://bugs.gentoo.org/show_bug.cgi?id=360057
# libXfixes-5.0 needed for pointer barriers
# gnome-menus-3.2.0.1-r1 needed for new 10-xdg-menu-gnome
COMMON_DEPEND=">=dev-libs/glib-2.29.10:2
   >=dev-libs/gjs-1.29.18
   >=dev-libs/gobject-introspection-0.10.1
   x11-libs/gdk-pixbuf:2[introspection]
   >=x11-libs/gtk+-3.0.0:3[introspection]
   >=media-libs/clutter-1.7.5:1.0[introspection]
   app-misc/ca-certificates
   >=dev-libs/json-glib-0.13.2
   >=gnome-base/gnome-desktop-2.91.2:3[introspection]
   >=gnome-base/gsettings-desktop-schemas-2.91.91
   >=gnome-extra/evolution-data-server-2.91.6
   >=media-libs/gstreamer-0.10.16:0.10
   >=media-libs/gst-plugins-base-0.10.16:0.10
   net-libs/libsoup:2.4[introspection]
   >=sys-auth/polkit-0.100[introspection]
   >=x11-wm/muffin-1.0.2[introspection]

   dev-libs/dbus-glib
   dev-libs/libxml2:2
   x11-libs/pango[introspection]
   >=dev-libs/libcroco-0.6.2:0.6

   gnome-base/gconf:2[introspection]
   >=gnome-base/gnome-menus-3.2.0.1-r1:3[introspection]
   gnome-base/librsvg
   media-libs/libcanberra
   media-sound/pulseaudio

   >=x11-libs/startup-notification-0.11
   x11-libs/libX11
   >=x11-libs/libXfixes-5.0
   x11-apps/mesa-progs

   bluetooth? ( >=net-wireless/gnome-bluetooth-3.1.0[introspection] )
   networkmanager? (
      gnome-base/libgnome-keyring
      >=net-misc/networkmanager-0.8.999[introspection] )"
# Runtime-only deps are probably incomplete and approximate.
# Each block:
# 2. Introspection stuff + dconf needed via imports.gi.*
# 3. gnome-session is needed for gnome-session-quit
# 4. Control shell settings
# 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
#    user switching with gdm-3.1.x)
# 6. caribou needed for on-screen keyboard
# 7. xdg-utils needed for xdg-open, used by extension tool
# 8. gconf-python needed for cinnamon-settings
# 9. gnome-icon-theme-symbolic needed for various icons
# 10. pygtk and gnome-menus:0 needed for menu editor
RDEPEND="${COMMON_DEPEND}
   >=gnome-base/dconf-0.4.1
   >=gnome-base/libgnomekbd-2.91.4[introspection]
   sys-power/upower[introspection]

   >=gnome-base/gnome-session-3.2.1-r1

   >=gnome-base/gnome-settings-daemon-2.91
   >=gnome-base/gnome-control-center-2.91.92-r1

   >=sys-apps/accountsservice-0.6.14[introspection]

   >=app-accessibility/caribou-0.3

   x11-misc/xdg-utils

   dev-python/dbus-python
   dev-python/gconf-python:2

   x11-themes/gnome-icon-theme-symbolic

   dev-python/pygtk
   gnome-base/gnome-menus:0[python]

   networkmanager? (
      net-misc/mobile-broadband-provider-info
      sys-libs/timezone-data )"
DEPEND="${COMMON_DEPEND}
   >=sys-devel/gettext-0.17
   virtual/pkgconfig
   >=dev-util/intltool-0.40
   gnome-base/gnome-common
   !!=dev-lang/spidermonkey-1.8.2*"
# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
# https://bugs.gentoo.org/show_bug.cgi?id=360413

src_unpack() {
   git-2_src_unpack
   cd "${S}"
}

pkg_setup() {
   DOCS="AUTHORS NEWS README"
   # Don't error out on warnings
   G2CONF="${G2CONF}
      --enable-compile-warnings=maximum
      --disable-schemas-compile
      --disable-jhbuild-wrapper-script
      $(use_with bluetooth)
      $(use_enable networkmanager)
      --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
      BROWSER_PLUGIN_DIR=${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
   python_set_active_version 2
   python_pkg_setup
}

src_prepare() {
   # Fix automagic gnome-bluetooth dep, bug #398145
   epatch "${FILESDIR}/${PN}-1.1.3-automagic-gnome-bluetooth.patch"

   # Make networkmanager optional, bug #398593
   epatch "${FILESDIR}/${P}-optional-networkmanager.patch"

   # Gentoo uses /usr/libexec
   sed -e "s:/usr/lib/gnome-session/gnome-session-check-accelerated:${EPREFIX}/usr/libexec/gnome-session-check-accelerated:" \
      -i "files/usr/share/gnome-session/sessions/cinnamon.session" || die "sed 1 failed"

   # Gentoo uses /usr/$(get_libdir), not /usr/lib even for python
   sed -e "s:/usr/lib/:/usr/$(get_libdir)/:" \
      -e 's:"/usr/lib":"/usr/'"$(get_libdir)"'":' \
      -i files/usr/bin/cinnamon-menu-editor \
      -i files/usr/bin/cinnamon-settings \
      -i files/usr/lib/cinnamon-menu-editor/Alacarte/config.py \
      -i files/usr/lib/cinnamon-settings/cinnamon-settings.py \
      -i files/generate_desktop_files || die "sed 2 failed"
   if [[ "$(get_libdir)" != lib ]]; then
      mv files/usr/lib "files/usr/$(get_libdir)" || die "mv failed"
   fi

   if ! use bluetooth; then
      rm -rv files/usr/share/cinnamon/applets/bluetooth@cinnamon.org || die
   fi

   if ! use networkmanager; then
      rm -rv files/usr/share/cinnamon/applets/network@cinnamon.org || die
   fi

   eautoreconf
   gnome2_src_prepare

   # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
   # Note: sed Makefile.in because it is generated from several Makefile.ams
   sed -e 's/-DG_DISABLE_DEPRECATED//g' \
      -i src/Makefile.in browser-plugin/Makefile.in || die "sed 3 failed"
}

src_install() {
   gnome2_src_install
   python_convert_shebangs 2 "${ED}usr/bin/cinnamon-extension-tool" \
      "${ED}usr/bin/cinnamon-menu-editor" \
      "${ED}usr/bin/cinnamon-settings" \
      "${ED}usr/$(get_libdir)/cinnamon-settings/cinnamon-settings.py"

   # Required for gnome-shell on hardened/PaX, bug #398941
   pax-mark mr "${ED}usr/bin/cinnamon"
}

pkg_postinst() {
   gnome2_pkg_postinst
   python_mod_optimize "/usr/$(get_libdir)/"cinnamon-{menu-editor,settings}

   if ! has_version '>=media-libs/gst-plugins-good-0.10.23' || \
      ! has_version 'media-plugins/gst-plugins-vp8'; then
      ewarn "To make use of Cinnamon's built-in screen recording utility,"
      ewarn "you need to either install >=media-libs/gst-plugins-good-0.10.23"
      ewarn "and media-plugins/gst-plugins-vp8, or use dconf-editor to change"
      ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
   fi

   if ! has_version ">=x11-base/xorg-server-1.11"; then
      ewarn "If you use multiple screens, it is highly recommended that you"
      ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
      ewarn "pointer barriers which will make it easier to use hot corners."
   fi

   if has_version "<x11-drivers/ati-drivers-12"; then
      ewarn "Cinnamon has been reported to show graphical corruption under"
      ewarn "x11-drivers/ati-drivers-11.*; you may want to use GNOME in"
      ewarn "fallback mode, or switch to open-source drivers."
   fi

   if has_version "media-libs/mesa[video_cards_radeon]"; then
      elog "Cinnamon is unstable under classic-mode r300/r600 mesa drivers."
      elog "Make sure that gallium architecture for r300 and r600 drivers is"
      elog "selected using 'eselect mesa'."
      if ! has_version "media-libs/mesa[gallium]"; then
         ewarn "You will need to emerge media-libs/mesa with USE=gallium."
      fi
   fi

   if has_version "media-libs/mesa[video_cards_intel]"; then
      elog "Cinnamon is unstable under gallium-mode i915/i965 mesa drivers."
      elog "Make sure that classic architecture for i915 and i965 drivers is"
      elog "selected using 'eselect mesa'."
      if ! has_version "media-libs/mesa[classic]"; then
         ewarn "You will need to emerge media-libs/mesa with USE=classic."
      fi
   fi
}

pkg_postrm() {
   gnome2_pkg_postrm
   python_mod_cleanup "/usr/$(get_libdir)/"cinnamon-{menu-editor,settings}
}


cinnamon-9999-optional-networkmanager.patch
Code:
From aebde5fad2f477f40b62c96118128011bd821be0 Mon Sep 17 00:00:00 2001
From: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Wed, 25 Jan 2012 01:58:07 -0500
Subject: [PATCH] Make NM optional

Derived from a patch for gnome-shell by Michael Biebl <biebl@debian.org>
(see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652482#29)
---
 configure.ac         |   48 ++++++++++++++++++++++++++++++++++++++++++++++--
 js/misc/config.js.in |    2 ++
 js/ui/main.js        |    7 +++++--
 src/Makefile.am      |   13 ++++++++-----
 4 files changed, 61 insertions(+), 9 deletions(-)

diff --git a/configure.ac b/configure.ac
index 49b5401..508a8cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,8 +94,40 @@ PKG_CHECK_MODULES(CINNAMON, gio-2.0 >= $GIO_MIN_VERSION
                               libstartup-notification-1.0 >= $STARTUP_NOTIFICATION_MIN_VERSION
                               gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_MIN_VERSION
                 libcanberra
-                               polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes
-                               libnm-glib libnm-util gnome-keyring-1)
+                               polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes)
+
+##########################
+# Check for NetworkManager
+##########################
+NM_MIN_VERSION=0.9
+AC_ARG_ENABLE(networkmanager,
+              AS_HELP_STRING([--disable-networkmanager],
+                             [disable NetworkManager support @<:@default=auto@:>@]),,
+              [enable_networkmanager=auto])
+
+if test "x$enable_networkmanager" != "xno"; then
+   PKG_CHECK_MODULES(NETWORKMANAGER,
+                     [libnm-glib libnm-util gnome-keyring-1],
+                     [have_networkmanager=yes],
+                     [have_networkmanager=no])
+
+   CINNAMON_CFLAGS="$CINNAMON_CFLAGS $NETWORKMANAGER_CFLAGS"
+   CINNAMON_LIBS="$CINNAMON_LIBS $NETWORKMANAGER_LIBS"
+else
+   have_networkmanager="no  (disabled)"
+fi
+
+if test "x$have_networkmanager" = "xyes"; then
+   AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
+   AC_SUBST([HAVE_NETWORKMANAGER], [1])
+else
+   if test "x$enable_networkmanager" = "xyes"; then
+      AC_MSG_ERROR([Couldn't find NetworkManager.])
+   fi
+   AC_SUBST([HAVE_NETWORKMANAGER], [0])
+fi
+
+AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
 
 PKG_CHECK_MODULES(CINNAMON_PERF_HELPER, gtk+-3.0 gio-2.0)
 
@@ -250,3 +282,15 @@ AC_CONFIG_FILES([
   files/Makefile
 ])
 AC_OUTPUT
+
+echo "
+Build configuration:
+
+   Prefix:                                 ${prefix}
+   Source code location:                   ${srcdir}
+   Compiler:                               ${CC}
+   Compiler Warnings:                      $enable_compile_warnings
+
+   Support for NetworkManager:             $have_networkmanager
+   Support for GStreamer recording:        $build_recorder
+"
diff --git a/js/misc/config.js.in b/js/misc/config.js.in
index 704989b..df7e014 100644
--- a/js/misc/config.js.in
+++ b/js/misc/config.js.in
@@ -8,5 +8,7 @@ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
 const GJS_VERSION = '@GJS_VERSION@';
 /* 1 if gnome-bluetooth is available, 0 otherwise */
 const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
+/* 1 if networkmanager is available, 0 otherwise */
+const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
 /* The system TLS CA list */
 const CINNAMON_SYSTEM_CA_FILE = '@CINNAMON_SYSTEM_CA_FILE@';
diff --git a/js/ui/main.js b/js/ui/main.js
index ae15997..803e6f4 100644
--- a/js/ui/main.js
+++ b/js/ui/main.js
@@ -14,6 +14,7 @@ const St = imports.gi.St;
 
 const AutomountManager = imports.ui.automountManager;
 const AutorunManager = imports.ui.autorunManager;
+const Config = imports.misc.config;
 const EndSessionDialog = imports.ui.endSessionDialog;
 const PolkitAuthenticationAgent = imports.ui.polkitAuthenticationAgent;
 const ExtensionSystem = imports.ui.extensionSystem;
@@ -27,7 +28,7 @@ const PlacesManager = imports.ui.placesManager;
 const RunDialog = imports.ui.runDialog;
 const Layout = imports.ui.layout;
 const LookingGlass = imports.ui.lookingGlass;
-const NetworkAgent = imports.ui.networkAgent;
+const NetworkAgent = Config.HAVE_NETWORKMANAGER ? imports.ui.networkAgent : null;
 const NotificationDaemon = imports.ui.notificationDaemon;
 const WindowAttentionHandler = imports.ui.windowAttentionHandler;
 const Scripting = imports.ui.scripting;
@@ -88,7 +89,9 @@ function _createUserSession() {
     placesManager = new PlacesManager.PlacesManager();   
     automountManager = new AutomountManager.AutomountManager();
     //autorunManager = new AutorunManager.AutorunManager();
-    networkAgent = new NetworkAgent.NetworkAgent();
+    if (Config.HAVE_NETWORKMANAGER) {
+        networkAgent = new NetworkAgent.NetworkAgent();
+    }

    Meta.later_add(Meta.LaterType.BEFORE_REDRAW, _checkWorkspaces);

diff --git a/src/Makefile.am b/src/Makefile.am
index 182bf17..54770e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -108,9 +108,7 @@ cinnamon_public_headers_h =      \
    cinnamon-generic-container.h   \
    cinnamon-gtk-embed.h      \
    cinnamon-global.h         \
-   cinnamon-mobile-providers.h   \
    cinnamon-mount-operation.h      \
-   cinnamon-network-agent.h      \
    cinnamon-perf-log.h      \
    cinnamon-slicer.h         \
    cinnamon-stack.h         \
@@ -145,9 +143,7 @@ libcinnamon_la_SOURCES =      \
    cinnamon-generic-container.c   \
    cinnamon-gtk-embed.c      \
    cinnamon-global.c         \
-   cinnamon-mobile-providers.c   \
    cinnamon-mount-operation.c      \
-   cinnamon-network-agent.c      \
    cinnamon-perf-log.c      \
    cinnamon-polkit-authentication-agent.h   \
    cinnamon-polkit-authentication-agent.c   \
@@ -161,6 +157,10 @@ libcinnamon_la_SOURCES =      \
    cinnamon-wm.c         \
    cinnamon-xfixes-cursor.c
 
+if HAVE_NETWORKMANAGER
+libcinnamon_la_SOURCES += cinnamon-mobile-providers.h cinnamon-mobile-providers.c cinnamon-network-agent.h cinnamon-network-agent.c
+endif
+
 libcinnamon_la_gir_sources = \
    $(filter-out %-private.h $(cinnamon_recorder_non_gir_sources), $(cinnamon_public_headers_h) $(libcinnamon_la_SOURCES))
 
@@ -272,7 +272,10 @@ libcinnamon_la_LIBADD =      \
 libcinnamon_la_CPPFLAGS = $(cinnamon_cflags)
 
 Cinnamon-0.1.gir: libcinnamon.la St-1.0.gir
-Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 Soup-2.4 GMenu-3.0 NetworkManager-1.0 NMClient-1.0
+Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 Soup-2.4 GMenu-3.0
+if HAVE_NETWORKMANAGER
+Cinnamon_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
+endif
 Cinnamon_0_1_gir_CFLAGS = $(libcinnamon_la_CPPFLAGS) -I $(srcdir)
 Cinnamon_0_1_gir_LIBS = libcinnamon.la
 Cinnamon_0_1_gir_FILES = $(libcinnamon_la_gir_sources)
--
1.7.8.4



I also have an git ebuild of muffin, which is tagged as version 1.0.6 now!!!

muffin-9999.ebuild
Code:
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/muffin-1.0.0.ebuild,v 1.1 2012/01/25 08:42:11 tetromino Exp $

EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"

inherit autotools eutils git-2 gnome2

DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
HOMEPAGE="http://cinnamon.linuxmint.com/"
SRC_URI=""
EGIT_REPO_URI="git://github.com/linuxmint/muffin.git"

LICENSE="GPL-2"
SLOT="0"
IUSE="+introspection test xinerama"
KEYWORDS="~amd64 ~x86"

COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
   >=x11-libs/cairo-1.10[X]
   x11-libs/gdk-pixbuf:2[introspection?]
   >=x11-libs/gtk+-3.3.3:3[introspection?]
   >=gnome-base/gconf-2:2
   gnome-base/gsettings-desktop-schemas
   >=dev-libs/glib-2.14:2
   >=media-libs/clutter-1.7.5:1.0[introspection?]
   >=media-libs/libcanberra-0.26[gtk3]
   >=x11-libs/startup-notification-0.7
   >=x11-libs/libXcomposite-0.2

   x11-libs/libICE
   x11-libs/libSM
   x11-libs/libX11
   x11-libs/libXcursor
   x11-libs/libXdamage
   x11-libs/libXext
   x11-libs/libXfixes
   x11-libs/libXrandr
   x11-libs/libXrender

   gnome-extra/zenity

   introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
   xinerama? ( x11-libs/libXinerama )
"
DEPEND="${COMMON_DEPEND}
   >=app-text/gnome-doc-utils-0.8
   sys-devel/gettext
   virtual/pkgconfig
   >=dev-util/intltool-0.35
   test? ( app-text/docbook-xml-dtd:4.5 )
   xinerama? ( x11-proto/xineramaproto )
   x11-proto/xextproto
   x11-proto/xproto"
RDEPEND="${COMMON_DEPEND}
   !x11-misc/expocity"

src_unpack() {
   if [[ ${PV} == "9999" ]] ; then
      git-2_src_unpack
      cd "${S}"
#      rm -f configure
   else
      unpack ${A}
      cd "${S}"
   fi

   # need to run autoreconf, https://github.com/linuxmint/muffin/issues/16
   eautoreconf
}

pkg_setup() {
   DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
   G2CONF="${G2CONF}
      --disable-static
      --enable-gconf
      --enable-shape
      --enable-sm
      --enable-startup-notification
      --enable-xsync
      --enable-verbose-mode
      --enable-compile-warnings=maximum
      --with-libcanberra
      $(use_enable introspection)
      $(use_enable xinerama)"
}


Also I am using lightdm as login-manager, and the Light-themes(ubuntu-ish) for gnome! For Cinnamon I am using the Ambiance theme!!! Looks nice together!!!

Bye and have fun!
Back to top
View user's profile Send private message
Dr. Strangelove
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 104
Location: Germania

PostPosted: Sun Aug 26, 2012 9:15 am    Post subject: Reply with quote

Obligatory screenshot:
http://ompldr.org/vZjhxZw

The icon theme is faenza-icon-theme.

Source for the Ambiance theme (goes into your .themes folder)
http://cinnamon-spices.linuxmint.com/themes/view/43

Bye
Back to top
View user's profile Send private message
Dr. Strangelove
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 104
Location: Germania

PostPosted: Fri Sep 07, 2012 11:42 am    Post subject: Reply with quote

Update:
For the cinnamon-9999.ebuild, the file cinnamon-9999-optional-networkmanager.patch has to be updated in regard of this git commit:
https://github.com/linuxmint/Cinnamon/commit/671fbef417fead2a470b092013f34cc6f815fbe3

Just search for the line and add the two slashes. Then manifest the ebuild.

Also, if there are problems with copy&paste'ing from the forums (like rejected patches), I can upload them. Just let me know.

Heil Gentoo!
Back to top
View user's profile Send private message
Donman
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2005
Posts: 117

PostPosted: Sat Sep 08, 2012 9:55 pm    Post subject: Reply with quote

@Dr. Strangelove,

Thanks for the ebuilds! I've been wanting to upgrade my cinnamon installation past 1.4 for a while now, but haven't had any success. I do have a few questions though. What packages did you need to unmask to build the latest versions of Cinnamon and muffin? I've unmasked clutter and cogl, but I'm wondering if there are additional packages I should unmask. Also, whenever I try and compile the latest Cinnamon, I always get a libtool error when linking the Cinnamon binary (you can see my build.log here). I get this error with your cinnamon-9999 ebuilds and my own 1.5.7 ebuilds (which are pretty much the same). You are able to build Cinnamon from the latest sources, correct? If so, then there is something wrong with my system and I have no idea what it is!
Back to top
View user's profile Send private message
Dr. Strangelove
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 104
Location: Germania

PostPosted: Sun Sep 09, 2012 10:29 am    Post subject: Reply with quote

@Donman,

Donman wrote:
What packages did you need to unmask [...]

Wow! I just was about to post my package.unmask, but decided to proof-check it, and with the latest emerge --sync, the gnome-3.4 mask is gone! But I'm on ~amd64. So just resync, and go with:
Code:
ACCEPT_KEYWORDS="~amd64" emerge -uvpND cinnamon
(Adapt your arch)

Donman wrote:
whenever I try and compile the latest Cinnamon, I always get a libtool error [...]

Which version of libtool is installed? Here it is libtool-2.4.2. Also I'd suggest to google around for this issue, this is what I got at a first glance: http://lists.gnu.org/archive/html/libtool/2010-11/msg00035.html

Or you can search here: https://bugs.gentoo.org/buglist.cgi?quicksearch=ALL+pthread
Maybe you need to recompile some or all of the toolchain components.

Donman wrote:
You are able to build Cinnamon from the latest sources, correct?

Yes, that is correct. And with respect to our loved and hated Larry the cow, I'm sort of glad of it.
:D 8)
Back to top
View user's profile Send private message
Donman
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2005
Posts: 117

PostPosted: Sun Sep 09, 2012 12:55 pm    Post subject: Reply with quote

I finally got it installed! I must have missed a package when I was unmasking things, as running an emerge --sync and updating world was all I needed to do to get the latest Cinnamon to build.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum