Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Capire il terminale e correggere errori
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Thu Feb 23, 2012 6:37 pm    Post subject: Capire il terminale e correggere errori Reply with quote

Salve a tutti :)

Con comando "emerge -e system" si ricompila il sistema... ma ad un certo punto l'operazione si blocca restituendo questo errore:


Quote:
* Messages for package sys-devel/gettext-0.18.1.1-r1:

* ERROR: sys-devel/gettext-0.18.1.1-r1 failed (compile phase):
* emake failed
*
* Call stack:
* ebuild.sh, line 85: Called src_compile
* environment, line 2801: Called _eapi2_src_compile
* phase-helpers.sh, line 577: Called die
* The specific snippet of code:
* emake || die "emake failed"
*
* If you need support, post the output of 'emerge --info =sys-devel/gettext-0.18.1.1-r1',
* the complete build log and the output of 'emerge -pqv =sys-devel/gettext-0.18.1.1-r1'.
* The complete build log is located at '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r1/temp/environment'.
* S: '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r1/work/gettext-0.18.1.1'


Essendo un lol non so come intervenire e tanto meno a capire cio' che il terminale mi sta chiedendo di fare...

Se qualcuno a voglia di spiegarmelo grazie.


Last edited by ..db.. on Sat Feb 25, 2012 3:15 pm; edited 2 times in total
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Thu Feb 23, 2012 6:55 pm    Post subject: Reply with quote

... mi sa che ho trovato la risposta ...

Con un po' di pazienza su internet trovi di tutto.

in pratica il terminale dice di lanciare il comando emerge --info in questo caso

emerge --info =sys-kernel/gentoo-sources-3.2.1-r2

il quale spieghera' come impostare le USE necessarie per la compilazione del pacchetto :

Quote:
=================================================================
Package Settings
=================================================================

sys-devel/gettext-0.18.1.1-r1 was built with the following:
USE="acl cxx git (multilib) nls openmp -doc -emacs"
CFLAGS="-O2 -pipe"
CXXFLAGS="-O2 -pipe"


alche si pone davanti al comando d'installazione tali USE:

USE="acl cxx git (multilib) nls openmp -doc -emacs" emerge sys-kernel/gentoo-sources

ed il pacchetto viene installato e compilato... e poi un emerge --resume --skipfirst per riprendere l'aggiornamento

sono nuovo di GentOO ma posso gia' dire che e' fantastico!!!!


Last edited by ..db.. on Sat Feb 25, 2012 3:17 pm; edited 3 times in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Thu Feb 23, 2012 7:16 pm    Post subject: Reply with quote

Benvenuto.

Il pacchetto che hai detto che falliva era gettext, poi hai detto gentoo-sources.

In ogni caso devi vedere l'errore di compilazione reale, quello è solo l'output di emerge.

P.S. 'emerge -e' ricompila il sistema non aggiorna
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Thu Feb 23, 2012 7:38 pm    Post subject: Reply with quote

ciao ago...

penso che per mantenere un forum ci voglia molto impegno quindi grazie (naturalmente e' rivolto a tutti, anche chi solo vi partecipa).

per ritornare al discorso di prima quale sarebbe il modo giusto per intervenire.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Thu Feb 23, 2012 7:49 pm    Post subject: Reply with quote

devi leggere l'errore di compilazione
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Thu Feb 23, 2012 8:18 pm    Post subject: Reply with quote

... io sono due giorni che barcollo nel buio per portare a termine un'installazione, pensa che non sono ancora riuscito ad installare un desktop e tu mi esci con

devi leggere l'errore di compilazione

vabbe' che uso ubuntu da un po' ma qua siamo proprio in un altro mondo 8O... struttura file system e kernel tanto quanto ma compilazione nnnnniente

ago grazie per l'instradamente :D adesso mi informo un po', tanto per imparare due termini e capire cosa devo fare... e al massimo so che qua posso trovare un aiuto e sicuramente due cosigli...

a proposito ne hai gia' da darmene, ad esempio ti piace l'immagine del profilo :roll:


Last edited by ..db.. on Thu Feb 23, 2012 8:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Thu Feb 23, 2012 8:39 pm    Post subject: Reply with quote

Non ho capito se è ironico o meno, un build log si posta per intero, tipo questo https://405051.bugs.gentoo.org/attachment.cgi?id=302605

Se non l'avessi capito la parte di build log che hai postato tu ha utilità 0 poiché non c'è scritto da nessuna parte *COSA* fa fallire la compilazione

Tra l'altro è scritto esplicitamente nella parte di log che hai postato tu:

* If you need support, post the output of 'emerge --info =sys-devel/gettext-0.18.1.1-r1',
* the complete build log and the output of 'emerge -pqv =sys-devel/gettext-0.18.1.1-r1'.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Thu Feb 23, 2012 8:53 pm    Post subject: Reply with quote

chiaro che era ironico ago...

probabilmente il build log ha utilita' 0 perche' sono ancora in fase di installazione... e' il primo emerge -e system che faccio, intanto io leggo sto post

http://www.gentoo.org/doc/it/bugzilla-howto.xml

aproposito un utente come me, o meglio un niubbio come me, come puo essere d'aiuto ad uno sviluppatore?
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Thu Feb 23, 2012 9:24 pm    Post subject: Reply with quote

mi sto preoccupando ago...

sento un strana e piacevole sensazione mentre vedo gentoo crescere nella partizione a lei dedicata 8O aiutooo

alla domanda sopra mi rispondo da solo: per adesso niente ma in futuro, quando mi confrontero' con qualche bel bug, ed avro' imparato a postaro un log build, allora se ne riparlera' 8).

per adesso ago grazie, la tua presenza mi a dato sicurezza e coraggio per affrontare questa avventura...
e speriamo che questa discussione aiuti qualcun'altro a non scoraggiarsi, daltronde tutti iniziamo dal basso :lol:

ciao ago mi sa che ci risentiremo.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Fri Feb 24, 2012 11:18 am    Post subject: Reply with quote

molto semplicemente quello che hai postato tu è il messaggio che emerge ti da e dice "occhio che si è rotto qualcosa, per sapere cosa leggi sopra"

e "il sopra" è (almeno nelle parti finali dove si individua l'errore) quello che serve ed è conservato in /var/tmp/portage/cat-egoria/pacchetto/temp/build.log (oppure lo vedi scrollando in su il terminale)
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 167
Location: cesenatico

PostPosted: Fri Feb 24, 2012 12:37 pm    Post subject: Reply with quote

..db.. wrote:
... io sono due giorni che barcollo nel buio per portare a termine un'installazione, pensa che non sono ancora riuscito ad installare un desktop e tu mi esci con

devi leggere l'errore di compilazione

vabbe' che uso ubuntu da un po' ma qua siamo proprio in un altro mondo 8O... struttura file system e kernel tanto quanto ma compilazione nnnnniente

ago grazie per l'instradamente :D adesso mi informo un po', tanto per imparare due termini e capire cosa devo fare... e al massimo so che qua posso trovare un aiuto e sicuramente due cosigli...

a proposito ne hai gia' da darmene, ad esempio ti piace l'immagine del profilo :roll:


quando ti trovi con cd live nell'installazione usa una schermata con il chroot dentro gentoo, premendo ALT+F2 ti trovi un'altra schermata sempre a riga di comando usa links della live

Code:
links http://www.gentoo.org

e poi navighi alla ricerca di quello che cerchi, è semplicissimo a d usarlo e con ALT+F1 ritorni all'installazione e procedi, non sei al buoi è un modo diverso di installare una distro...
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Fri Feb 24, 2012 2:31 pm    Post subject: Reply with quote

vediamo se imparo...

Ho un problema con il pacchetto sys-apps/sandbox-2.5 il terminale mi restituisce questo

Quote:
ERROR: sys-apps/sandbox-2.5 failed (compile phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 85: Called src_compile
* environment, line 2477: Called econf
* phase-helpers.sh, line 467: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =sys-apps/sandbox-2.5',
* the complete build log and the output of 'emerge -pqv =sys-apps/sandbox-2.5'.
* If configure failed with a 'cannot run C compiled programs' error, try this:
* FEATURES=-sandbox emerge sandbox
* The complete build log is located at '/var/tmp/portage/sys-apps/sandbox-2.5/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-apps/sandbox-2.5/temp/environment'.
* S: '/var/tmp/portage/sys-apps/sandbox-2.5/work/sandbox-2.5'

>>> Failed to emerge sys-apps/sandbox-2.5, Log file:

>>> '/var/tmp/portage/sys-apps/sandbox-2.5/temp/build.log'

* Messages for package sys-apps/sandbox-2.5:

* ERROR: sys-apps/sandbox-2.5 failed (compile phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 85: Called src_compile
* environment, line 2477: Called econf
* phase-helpers.sh, line 467: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =sys-apps/sandbox-2.5',
* the complete build log and the output of 'emerge -pqv =sys-apps/sandbox-2.5'.
* If configure failed with a 'cannot run C compiled programs' error, try this:
* FEATURES=-sandbox emerge sandbox
* The complete build log is located at '/var/tmp/portage/sys-apps/sandbox-2.5/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-apps/sandbox-2.5/temp/environment'.
* S: '/var/tmp/portage/sys-apps/sandbox-2.5/work/sandbox-2.5'


digito => emerge -pqv =sys-apps/sandbox-2.5

Quote:
Portage 2.1.10.44 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.13-r4, 3.2.1-030201-generic x86_64)
=================================================================
System Settings
=================================================================
System uname: Linux-3.2.1-030201-generic-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.0.3
Timestamp of tree: Thu, 23 Feb 2012 23:30:01 +0000
app-shells/bash: 4.1_p9
dev-lang/python: 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.0.3
sys-apps/openrc: 0.9.8.4
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.68
sys-devel/automake: 1.11.1
sys-devel/binutils: 2.21.1-r1
sys-devel/gcc: 4.5.3-r2
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc: 2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support readline sdl session socialweb spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
Package Settings
=================================================================

sys-apps/sandbox-2.5 was built with the following:
USE="(-multilib)"[/code]

il make.conf invece e' cosi'

[code]CFLAGS="-march=k8 -O2 -pipe"
CXXFLAGS="${CFLAGS}"

CHOST="x86_64-pc-linux-gnu"

USE="mmx sse sse2 -qt4 -kde X dbus gtk gnome"

MAKEOPTS="-j3 -s"

GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"

LINGUAS="it"
LANG="it"

VIDEO_CARDS="nvidia"

LDFLAGS="-Wl,-O1,--as-needed"

ACCEPT_LICENSE="*"

FEATURES="parallel-fetch userfetch"


allora provo a digitare => USE="(-multilib)" emerge sys-apps/sandbox
ma non risolve il problema 8O

allora leggo il codice di errore e digito => FEATURES=-sandbox emerge sandbox
ma niente 8O


allora provo a cercare una soluzione sul web ma sono niubbio e non ci capisco niente :evil:

quindi vengo sul forum, ne aprofitto per ringraziare, e vi chiedo una possibile soluzione... giusto no

p.s. per l'installazione sono partito con lo stage3, niente live cd tutto da ubuntu con chroot su partizione ext4....


Last edited by ..db.. on Sat Feb 25, 2012 3:19 pm; edited 2 times in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Fri Feb 24, 2012 4:15 pm    Post subject: Reply with quote

ero indeciso se buttarmi o no in questa discussione... dal momento che non trovo di meglio da fare eccomi qui :D

Quote:
Essendo un lol non so come intervenire e tanto meno a capire cio' che il terminale mi sta chiedendo di fare...


eeeeeh??? essendo un lol? cosa diavolo vorrebbe dire?

Quote:
sys-devel/gettext-0.18.1.1-r1 was built with the following:
USE="acl cxx git (multilib) nls openmp -doc -emacs"
CFLAGS="-O2 -pipe"
CXXFLAGS="-O2 -pipe"

alche si pone davanti al comando d'installazione tali USE:

USE="acl cxx git (multilib) nls openmp -doc -emacs" emerge sys-kernel/gentoo-sources


perchè hai fatto questo mix di pacchetti? hai preso le use di gettext e le vuoi applicare a gentoo-sources?? in ogni caso in quel modo è una modifica "temporanea" al prossimo emerge -uDN world le flag vengono reimpostate, se vuoi che rimangano quelle devi impostarle in /etc/portage/package.use per uno specifico pacchetto.

Quote:
ed il pacchetto viene installato e compilato... e poi un emerge --resume --skipfirst per riprendere l'aggiornamento


da dove l'hai tirata fuori questa?? non è detto che magicamente il pacchetto venga compilato semplicemente cambiando le use flags, in ogni caso se eri nel bel mezzo di un aggiornamento e fai come dici, al momento di dare emerge --resume non resumi un bel niente, perchè dopo la compilazione fallita hai lanciato un'altra volta emerge. se proprio potresti usare --skipfirst per risolvere il problema di quel pacchetto successivamente e intanto continuare se è possibile, ma a questo punto puoi usare anche --keep-going aggiornando ed eviti il --resume --skipfirst.

Quote:
probabilmente il build log ha utilita' 0 perche' sono ancora in fase di installazione...


neanche questa frase ha senso, il buil log avrebbe sì utilità, solo che tu non l'hai postato da nessuna parte, è la parte che hai postato che ha utilità 0 senza la parte che ci sta sopra, che trovi appunto nel build log. bello questo giro di parole no?? in sostanza, posta il build log completo, ma su pastebin o simili, non direttamente qui nel topic, altrimenti diventa una pagina chilometrica.

e senza offesa, ma prima di pensare di riportare un bug imparerei ad usare bene gentoo se fossi in te, al momento attuale sono quasi sicuro che il 99% dei bug che apriresti verrebbero chiusi come "RESOLVED INVALID", e non lo sto dicendo con cattiveria, semplicemente è una mia opinione vedendo tanta confusione in questo topic da parte tua

Quote:
ed avro' imparato a postaro un log build


non ci vuole chissà che cosa, ti ha già detto onip dove lo trovi

Quote:
Ho un problema con il pacchetto sys-apps/sandbox-2.5 il terminale mi restituisce questo


ancora senza offesa, ma mi sembra proprio che tu non abbia capito un bel niente di ciò che ti ha detto ago. l'errore vero sta alcune righe più sopra a quello che tu hai postato, per quello serve il build log completo, e non hai scuse, oltre al fatto che te l'ha detto onip in generale dove lo trovi, te lo sta dicendo anche emerge ora:
Quote:

The complete build log is located at '/var/tmp/portage/sys-apps/sandbox-2.5/temp/build.log'.
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Fri Feb 24, 2012 4:56 pm    Post subject: Reply with quote

Ciao k01... grazie per l'ennesima bastonata... mi sa che mi devo impegnare un po' di piu'...

Vi chiedo un favore, sempre che abbiate tempo, mi seguite passo passo per risolvere questo problema in modo che capisco come intervenire e usare gentoo?

incomincio a postare il log build

http://www.nomorepasting.com/getpaste.php?pasteid=38004

a proposito il make.conf puo andare bene?


Last edited by ..db.. on Fri Feb 24, 2012 6:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4734
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Fri Feb 24, 2012 5:35 pm    Post subject: Reply with quote

[OT]
k01 wrote:
ero indeciso se buttarmi o no in questa discussione... dal momento che non trovo di meglio da fare eccomi qui :D
Io intervengo solo per ribadire le mie posizioni in materia di comportamenti "al limite" e per confessare ...
ago wrote:
[omissis]
..db.. wrote:
ciao ago mi sa che ci risentiremo.
... che me la sto godendo. :twisted:
voce fuori campo/coro greco wrote:
e djinnZ continua a ridere, immaginando la faccia di ago...
Ma elevo la solita pietosa prece in memoria della lingua italiana spirata al seguito dei ripetuti stupri e violenze. Ed a buon intenditor ...

@..db.. : sono questioni (peraltro scherzose) tra noialtri, non ti curare di questo mio intervento, non ti riguarda.[/OT]
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 167
Location: cesenatico

PostPosted: Fri Feb 24, 2012 7:56 pm    Post subject: Reply with quote

butta l'occhio quì per le use da mettere a make.conf
http://www.gentoo.org/dyn/use-index.xml

me l'ha accenato Onip e mi è servito molto, così usi il sistema su come lo vuoi usare globalmente...
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Fri Feb 24, 2012 9:33 pm    Post subject: Reply with quote

in effetti queste di default potevo evitarle "mmx sse sse2" e le piu importanti penso che le abbia selezionate il profilo "default/linux/amd64/10.0/desktop/gnome".

poi disattivero' cups e altre che non mi servono...

intanto leggo questa guida

http://www.gentoo.it/doc/handbook/working/sp/handbook.html

pero' non ancora capito dove'l'errore di sandbox... penso che sia da modificare chost giusto?
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Feb 25, 2012 11:16 am    Post subject: Reply with quote

Quote:
intanto leggo questa guida

http://www.gentoo.it/doc/handbook/working/sp/handbook.html


questa è la guida ufficiale: http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=2 quella che stai seguendo è stata copiata da qui ma parecchio tempo fa probabilmente, quindi ci sarà qualcosa di non aggiornato. gentoo.it non è un sito ufficiale e da quello che si legge anche in home non è più mantenuto in pratica.

Quote:
pero' non ancora capito dove'l'errore di sandbox... penso che sia da modificare chost giusto?


sbagliatissimo. l'errore di preciso che sta nel build.log (che finalmente ti sei deciso a postare) è "configure: error: C compiler cannot create executables" e a questo punto nessun altro pacchetto dovrebbe compilarsi, perchè sembra che tu abbia rotto qualcosa in gcc. quel qualcosa non ben definito qui, dovrebbe essere meglio definito in config.log come dice il build.log una riga più sotto: "See `config.log' for more details". comunque questi errori non sono normali, cioè non pensare che ogni giorno in gentoo salti fuori una cosa simile, questo è perchè probabilmente hai fatto qualche casino tu agendo un po' in modalità random. in ogni caso gcc-config -l cosa dice?
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Sat Feb 25, 2012 11:51 am    Post subject: Reply with quote

Il comando: # gcc-config -l

riporta:
Quote:
* gcc-config: No gcc profile is active!

* gcc-config: No gcc profile is active; please select one!
[1] x86_64-pc-linux-gnu-4.5.3[/code]


alche ho dato # gcc-config 1

ottenendo:
Quote:
* Switching cross-compiler to x86_64-pc-linux-gnu-4.5.3 ...
* gcc-config: No gcc profile is active!
>>> Regenerating /etc/ld.so.cache... [ ok ]

* If you intend to use the gcc from the new profile in an already
* running shell, please remember to do:

* . /etc/profile


ho ancora dato env-update && source /etc/profile che ha rigenerato /etc/ld.so.cache
e finalmente gcc-config -l ni rstituisce:
Quote:
* Switching cross-compiler to x86_64-pc-linux-gnu-4.5.3 ...
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Feb 25, 2012 11:58 am    Post subject: Reply with quote

bene, quindi dovresti aver risolto, prova a compilare qualcosa e vedi
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Sat Feb 25, 2012 12:10 pm    Post subject: Reply with quote

ho provato con sandbox ma continua a ripetersi l'errore...
i comandi che ho dato sono
Quote:
USE="(multilib)" emerge sandbox
FEATURES=-sandbox emerge sandbox

indirizzo del log build e' sempre questo http://www.nomorepasting.com/getpaste.php?pasteid=38004
porto alla tua attenzione questo
Quote:
cchecking for i686-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc -m32
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/sys-apps/sandbox-2.5/work/build-x86':
configure: error: C compiler cannot create executable

k01 mi permetto d chiedere: non e' che mancano librerie o dipendenza? GentOO impratica deve essere ancora installata..

a proposito buon appetito :D
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Feb 25, 2012 12:35 pm    Post subject: Reply with quote

ho riletto meglio il tuo post:

Quote:
* Switching cross-compiler to x86_64-pc-linux-gnu-4.5.3 ...


c'è qualcosa che non va perchè dovrebbe essere semplicemente native-compiler non cross-compiler, devi aver combinato qualcosa che qua non hai spiegato, magari hai provato a cambiare chost come volevi fare?

Quote:
USE="(multilib)" emerge sandbox


assolutamente inutile specificare use flag tra parentesi, non puoi alterarle

Quote:
k01 mi permetto d chiedere: non e' che mancano librerie o dipendenza? GentOO impratica deve essere ancora installata..


le dipendenze vengono gestite dal gestore dei pacchetti, portage nel caso di gentoo, e funziona egregiamente, l'errore comunque sarebbe diverso se proprio mancasse una dipendenza.

visto che dici che deve essere ancora installata, fossi in te rinizierei da capo facendo attenzione a seguire l'handbook ed evitando di agire frettolosamente e a caso. oppure se proprio vuoi cercare di chiarire meglio questa storia, il config.log è sempre lì
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Sat Feb 25, 2012 12:43 pm    Post subject: Reply with quote

anch'io pensavo di ricominciare... formatto la partizione ed installo stage e portage... tanto sarebbe "solo" la quinta volta che riprovo :oops: .

solo una cosa prima mi avete fatto notare che il metodo d'installazione
Quote:
USE=[use necessarie] emerge [pacchetto]
rende le use all'interno del pacchetto temporane comme faccio a renderle definitive? in modo che un'eventuale aggiornamento del sistema ne prenda considerazione?
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Feb 25, 2012 12:48 pm    Post subject: Reply with quote

..db.. wrote:
prima mi avete fatto notare che il metodo d'installazione
Quote:
USE=[use necessarie] emerge [pacchetto]
rende le use all'interno del pacchetto temporane comme faccio a renderle definitive? in modo che un'eventuale aggiornamento del sistema ne prenda considerazione?


k01 wrote:
in ogni caso in quel modo è una modifica "temporanea" al prossimo emerge -uDN world le flag vengono reimpostate, se vuoi che rimangano quelle devi impostarle in /etc/portage/package.use per uno specifico pacchetto.
Back to top
View user's profile Send private message
..db..
n00b
n00b


Joined: 22 Feb 2012
Posts: 26
Location: Aosta

PostPosted: Sat Feb 25, 2012 1:07 pm    Post subject: Reply with quote

voila' partito con emerge --sync

cambiato locale - time zone - profile(desktop/gnome)- fstab - hosts - make.conf....

fra poco arrivo con qualche problemino :D

######################

eccone uno: l'aggiornamento si ferma improvvisamente 8O che fare?

http://www.nomorepasting.com/getpaste.php?pasteid=38011

io faccio ctrl+c installo il pacchetto incriminato e un bel emerge --resume se fosse sbagliato, e' tardi, ma correggetemi almeno imparo!

######################

ed eccone un'altro
Quote:
>>> Failed to emerge x11-libs/pixman-0.24.0, Log file:

>>> '/var/tmp/portage/x11-libs/pixman-0.24.0/temp/build.log'

* Messages for package x11-libs/pixman-0.24.0:

* ERROR: x11-libs/pixman-0.24.0 failed (prepare phase):
* Cannot find the latest automake! Tried 1.11
*
* Call stack:
* ebuild.sh, line 85: Called src_prepare
* environment, line 3415: Called xorg-2_src_prepare
* environment, line 4287: Called xorg-2_reconf_source
* environment, line 4238: Called eautoreconf
* environment, line 1127: Called eaclocal
* environment, line 1045: Called eaclocal_amflags
* environment, line 1053: Called autotools_env_setup
* environment, line 699: Called die
* The specific snippet of code:
* [[ ${WANT_AUTOMAKE} == "latest" ]] && die "Cannot find the latest automake! Tried ${_LATEST_AUTOMAKE}";
*
* If you need support, post the output of 'emerge --info =x11-libs/pixman-0.24.0',
* the complete build log and the output of 'emerge -pqv =x11-libs/pixman-0.24.0'.
* The complete build log is located at '/var/tmp/portage/x11-libs/pixman-0.24.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-libs/pixman-0.24.0/temp/environment'.
* S: '/var/tmp/portage/x11-libs/pixman-0.24.0/work/pixman-0.24.0'

* IMPORTANT: 2 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

il comando qlist -Iv automake restituisce
Quote:
sys-devel/automake-wrapper-6

risolto -e da solo- incomicio a fare progressi
ho seguito questo post https://bugs.gentoo.org/show_bug.cgi?id=400629 dove spiega di installare libtool ante x11... che culo :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum