Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Welche Erfahrungen habt ihr mit xbmc, vdr und Co?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Mon Feb 20, 2012 7:43 pm    Post subject: Reply with quote

Quote:
Das sieht ein wenig nach Programmierfehler oder ungewöhnliche CFlags aus. vll auch mal mit MAKEOPTS=-j1 bauen?


Hatte ich in dem Versuch bereits getan, das ganze wurde mit
Code:
mAKEOPTS="-j1" FEATURES="-distcc -ccache" EXTRA_ECONF="--disable-external-ffmpeg" emerge xbmc
angestossen.
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4115

PostPosted: Mon Feb 20, 2012 7:48 pm    Post subject: Reply with quote

Code:
ximapng.h: In static member function 'static void CxImagePNG::user_error_fn(png_struct*, const char*)':
ximapng.h:72:25: error: invalid use of incomplete type 'struct png_struct'
/usr/include/libpng15/png.h:851:16: error: forward declaration of 'struct png_struct'
ximapng.h:73:18: error: invalid use of incomplete type 'struct png_struct'
/usr/include/libpng15/png.h:851:16: error: forward declaration of 'struct png_struct'
ximaenc.cpp: In member function 'bool CxImage::CheckFormat(BYTE*, DWORD, DWORD)':
ximaenc.cpp:1114:28: warning: NULL used in arithmetic

es scheint so als ob xbmc mit libpng >=1.5.0 nicht kompatibel ist. Denn ab 1.5.0 wird die die struktur png_struct nicht mehr im header definiert sondern ist nur noch eine interne struktur.
Und xbmc scheint direkt auf die elemente der struktur zuzugreifen.

Aus der manpage von libpng:
Quote:
II. Structures
There are two main structures that are important to libpng, png_struct and png_info. Both are internal structures that are no longer exposed in the libpng interface (as of libpng 1.5.0).

The png_info structure is designed to provide information about the PNG file. At one time, the fields of png_info were intended to be directly accessible to the user. However, this tended to cause problems with applications using dynamically loaded libraries, and
as a result a set of interface functions for png_info (the png_get_*() and png_set_*() functions) was developed, and direct access to the png_info fields was deprecated..


Es gibt hierfür auch einen bugreport:
http://trac.xbmc.org/ticket/12001
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Mon Feb 20, 2012 8:17 pm    Post subject: Reply with quote

Quote:
es scheint so als ob xbmc mit libpng >=1.5.0 nicht kompatibel ist. Denn ab 1.5.0 wird die die struktur png_struct nicht mehr im header definiert sondern ist nur noch eine interne struktur.


Das war mir zum Teil bekannt, hatte deswegen schon vorher libpng in ner alten Version installiert:
Code:
server ~ # emerge -vp libpng

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/libpng-1.2.47  0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Deswegen frage ich mich wie im Build-Log etwas von libpng1.5 stehen kann wenn doch ne Version <1.5 installiert ist?
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2657
Location: de

PostPosted: Mon Feb 20, 2012 10:38 pm    Post subject: Reply with quote

Installier mal libpng-1.4. Bereinige aber das System, d.h. deinstallier die 1.5 und überprüf, ob das System noch konsistent ist.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Mon Feb 20, 2012 11:09 pm    Post subject: Reply with quote

Hmm, wäre schön wenn ich irgendwie die Version 1.4 installiert bekommen würde, aber irgendwie spinnt portage bei mir :
Code:
server portage # emerge -va =media-libs/libpng-1.4.8-r2

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=media-libs/libpng-1.4.8-r2".

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


So langsam glaube ich mein System hat ein Eigenleben entwickelt. Ich habe alle Versionen > 1.5 maskiert und das System sagt mir es gäbe keine 1.4....
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Mon Feb 20, 2012 11:58 pm    Post subject: Reply with quote

Ist 1.4.8-r2 bei dir auch gekeyworded?
Code:
[I] media-libs/libpng
     Available versions: 
        (1.2)   1.2.46
        (1.4)   (~)1.4.8-r2
        (0)     1.5.8 1.5.9

_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Tue Feb 21, 2012 12:18 am    Post subject: Reply with quote

ja, leider .... sonst wäre es einfach. Siehe
Code:
server ~ # cat /etc/portage/package.keywords
sys-power/sispmctl
x11-drivers/nvidia-drivers
=app-admin/eselect-opencl-1.1.0 ~x86
net-misc/miniupnpd
media-tv/xmltv
=net-libs/libmicrohttpd-0.9.15 ~x86
net-wireless/bluez
media-video/vdr

=media-tv/gentoo-vdr-scripts-0.4.10.1 ~x86
=media-plugins/vdr-xineliboutput-9999 **
=media-plugins/vdr-xvdr-9999 **
=media-plugins/xbmc-addon-xvdr-9999 **
media-libs/xine-lib
media-libs/libbluray
media-video/vdr-vdrmanager
=media-tv/xbmc-11.0_p65 ~x86

media-libs/libpng
server ~ # cat /etc/portage/package.mask
=media-libs/libpng-1.5.8

_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Tue Feb 21, 2012 12:24 am    Post subject: Reply with quote

Seltsam... was sagt denn bei dir ein eix libpng...
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Tue Feb 21, 2012 1:03 am    Post subject: Reply with quote

Code:
server ~ # eix libpng
[U] media-libs/libpng
     Available versions:
        (1.2)   1.2.47
        (0)     [m]1.5.8 1.5.9
        {apng neon static-libs}
     Installed versions:  1.2.47(1.2)(00:02:15 02/21/12)
     Homepage:            http://www.libpng.org/
     Description:         Portable Network Graphics library

* media-plugins/gst-plugins-libpng
     Available versions:  (0.10) 0.10.23!t 0.10.28!t 0.10.30!t
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         GStreamer encoder/decoder for PNG images

Found 2 matches.


Daraus werde ich nicht wirklich schlau.

So, habe jetzt einfach das entsprechende Ebuild per Download gezogen und dann per Hand ins entsprechende Portage-Ordner kopiert.
und siehe da, auf einmal kennt mein System die Version 1.4

Ich frag mich zwar wie es sein kann das die Version von alleine verschindet, aber egal. Mal schauen ob das compilen von xbmc jetzt mit der Version 1.4 von libpng endlich klappt ....

.... und nein, diesesmal ist xbmc der meinung das libpng nicht installiert sei.
Code:
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for FONTCONFIG... yes
checking for FRIBIDI... yes
checking for SQLITE3... yes
checking for PNG... no
configure: error: Could not find a required library. Please see the README for your platform.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-tv/xbmc-11.0_p65/work/opdenkamp-xbmc-cbe2cf3/config.log
 * ERROR: media-tv/xbmc-11.0_p65 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   85:  Called src_configure
 *        environment, line 5912:  Called econf '--docdir=/usr/share/doc/xbmc-11.0_p65' '--disable-ccache' '--disable-optimizations' '--enable-external-libraries' '--enable-gl' '--enable-airplay' '--enable-avahi' '--enable-libbluray' '--enable-dvdcss' '--disable-debug' '--disable-goom' '--disable-hal' '--enable-joystick' '--disable-mid' '--disable-profiling' '--enable-projectm' '--disable-pulse' '--enable-rsxs' '--disable-rtmp' '--enable-samba' '--enable-vaapi' '--enable-vdpau' '--enable-webserver' '--enable-xrandr'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =media-tv/xbmc-11.0_p65',
 * the complete build log and the output of 'emerge -pqv =media-tv/xbmc-11.0_p65'.
 * This ebuild is from an overlay named 'x-portage': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/media-tv/xbmc-11.0_p65/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/xbmc-11.0_p65/temp/environment'.
 * S: '/var/tmp/portage/media-tv/xbmc-11.0_p65/work/opdenkamp-xbmc-cbe2cf3'


aber installiert ist nur(!) die Version 1.4
Code:
server libpng # eix libpng
[UD] media-libs/libpng
     Available versions:
        (1.2)   1.2.47
        (0)     1.5.8 1.5.9
        {apng neon static-libs}
     Installed versions:  1.4.8-r2(1.4)(02:15:52 02/21/12)(apng)
     Homepage:            http://www.libpng.org/
     Description:         Portable Network Graphics library

* media-plugins/gst-plugins-libpng
     Available versions:  (0.10) 0.10.23!t 0.10.28!t 0.10.30!t
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         GStreamer encoder/decoder for PNG images

Found 2 matches.


macht alles irgendwie keinen Spass mehr, nur um in xbmc vdr zum laufen zu bekommen ....
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Tue Feb 21, 2012 7:14 am    Post subject: Reply with quote

alles sehr seltsam, vorallem weil libpng-1.4 slottet ist...

Achja, vll möchte xbmc auch das gst-plugin-png versuchs mal so.
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2657
Location: de

PostPosted: Tue Feb 21, 2012 10:10 am    Post subject: Reply with quote

Max Steel wrote:
Achja, vll möchte xbmc auch das gst-plugin-png versuchs mal so.

Glaub ich weniger. Der Wechsel von libpng-1.4 zu libpng-1.5 war ziemlich problembehaftet, da die libpng-Version in den la-Files des Systems irgendwie fest verdrahtet war. Ich hatte das gemerkt, als ich einen Bug-Report dazu geschrieben hatte. Der wurde als Duplikat eines anderen Bugs wieder geschlossen. In den folgenden Monaten gab's dann irgendwie jeden Tag einen neuen Bug-Report.

Den Upgrade-Guide gibt's hier:

http://forums.gentoo.org/viewtopic-t-894950.html

Analog dazu musst du auch den Downgrade wieder durchführen. Ich hatte das Problem bei meiner XBMC-Installation ebenfalls. Hab da auch libpng-1.5 erstmal maskiert. Allerdings dachte ich, das die Leute von XBMC das inzwischen mal gefixt hätten.

Hier findet man übrigens Deine Fehlermeldung:
http://www.htpc-forum.de/forum/index.php?showtopic=8824
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Tue Feb 21, 2012 12:57 pm    Post subject: Reply with quote

.la files? vll reicht ja einmal der lafilefixer --justfixit
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2280
Location: Germany

PostPosted: Tue Feb 21, 2012 1:40 pm    Post subject: Reply with quote

@Gucky_der_Mausbiber

Hm, ich halte es für keine gute Idee sich nun nur wegen dieser XBMC Version aus einem Overlay die veraltete, schon nicht mehr im Tree verfügbare libpng14 Version wieder ins System zu schießen.
Ich würde versuchen das System wieder mit der aktuellen stable libpng15 Version in einen gesunden Zustand zu bringen.
Beachte auch das dein portage dich immer wieder auf
Code:
 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
hinweist - tue dir doch mal den Gefallen und lese die News ;)
In den News sollte normal auch hilfreiche Information zum libpng15 Update zu finden sein.

Und wenn es wirklich die XBMC Version aus einem Overlay sein muss, dann versuche doch besser diese mit der aktuellen libpng15 Version kompatibel zu machen (wie schon in diesen Beitrag erwähnt.)

Eventuell ist es auch ein Versuch wert die aktuellen live ebuilds
xbmc-9999
und
xbmc-addon-xvdr-9999
aus dem portage Tree zu testen.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Tue Feb 21, 2012 3:59 pm    Post subject: Reply with quote

Uff ...

SO, erstmal danke an alle bis hierher.

Also, aus dem offiziellen Portage Zweig habe ich wirklich alle Kombinationen versucht, sowohl mit der *-9999 also auch mit der Beta3. Trotzdem habe ich es nicht geschafft in xbmc einen Eintrag für vdr zu finden.
Was sehr seltsam ist, immerhin gibt es das USE-Flag "pvr", aber anscheinend nutzlos.
Mein Hauptproblem war auch nicht die libpng. Die aktuelle Beta3 aus dem Portage habe ich ohne Probleme mit der libpng-1.5 installiert bekommen. Nur eben ohne vdr (obwohl "pvr" gesetzt).

Ich habe mir auch die Links von musv angesehen und muss jetzt zu dem Schluss kommen das xbmc und vdr im Augenblick nicht zusammen funktionieren. Zumindest nicht ohne enormen Aufwand. Schade eigentlich, weil in xine kann ich wunderbar fernsehen (gut nen paar Probleme mit HD-Fernsehen, aber okay). Aber ich habe jetzt so viele Fehlschläge gehabt und die Anleitung im Link von musv wird mir einfach zu kompliziert, das ganze up-, downgraden, patchen, usw.. da verliere ich langsam den Überblick.

Ich werde jetzt wohl wieder zur mythbox wechseln obwohl das auch alles andere als optimal ist.
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
yuhu
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2006
Posts: 82

PostPosted: Tue Feb 21, 2012 7:36 pm    Post subject: Reply with quote

Hallo,

mit dem aktuelle xbmc-9999.ebuild sollte es mit den Änderungen funktionieren (x86_64)

Code:
cat /etc/portage/package.keywords
=media-tv/xbmc-9999 **
=net-wireless/bluez-4.98-r2


Code:
diff /usr/portage/media-tv/xbmc/xbmc-9999.ebuild /usr/local/portage/media-tv/xbmc/xbmc-9999.ebuild
9c9
< EGIT_REPO_URI="git://github.com/xbmc/xbmc.git"
---
> EGIT_REPO_URI="git://github.com/opdenkamp/xbmc.git"
115c115
<    epatch "${FILESDIR}"/${PN}-9999-nomythtv.patch
---
> #   epatch "${FILESDIR}"/${PN}-9999-nomythtv.patch


Code:
emerge -av xbmc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] media-tv/xbmc-9999  USE="alsa css projectm pulseaudio rsxs samba sse sse2 udev xrandr -airplay (-altivec) -avahi -bluray -debug -goom -joystick -midi -mysql -profile -pvr -rtmp -vaapi -vdpau -webserver" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

Would you like to merge these packages? [Yes/No] Y


...


-----------------------
XBMC built successfully
-----------------------
>>> Source compiled.
>>> Test phase [not enabled]: media-tv/xbmc-9999

>>> Install xbmc-9999 into /var/tmp/portage/media-tv/xbmc-9999/image/ category media-tv
make -j7 -l7 DESTDIR=/var/tmp/portage/media-tv/xbmc-9999/image/ install
Copying support and legal files...                                             
Copying XBMC binary to /var/tmp/portage/media-tv/xbmc-9999/image//usr/lib64/xbmc/xbmc.bin
You can run XBMC with the command 'xbmc'                                       
Done!ibdvdcss-x86_64-linux.so                                                 
Copying system files to /var/tmp/portage/media-tv/xbmc-9999/image//usr/share/xbmc
>>> Completed installing xbmc-9999 into /var/tmp/portage/media-tv/xbmc-9999/image/

 * QA Notice: Unrecognized configure options:
 *
 *    configure: WARNING: unrecognized options: --disable-mysql, --disable-mythtv
 *    configure: WARNING: unrecognized options: --disable-mysql, --disable-mythtv
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line
   usr/lib64/xbmc/xbmc-xrandr
   usr/lib64/xbmc/system/players/paplayer/adpcm-x86_64-linux.so
   usr/lib64/xbmc/system/players/paplayer/libsidplay2-x86_64-linux.so
   usr/lib64/xbmc/system/players/paplayer/stsoundlibrary-x86_64-linux.so
   usr/lib64/xbmc/system/players/paplayer/timidity-x86_64-linux.so
   usr/lib64/xbmc/system/players/paplayer/nosefart-x86_64-linux.so
   usr/lib64/xbmc/system/players/paplayer/vgmstream-x86_64-linux.so
   usr/lib64/xbmc/system/players/dvdplayer/libdvdnav-x86_64-linux.so
   usr/lib64/xbmc/system/players/dvdplayer/libdvdcss-x86_64-linux.so
   usr/lib64/xbmc/system/libcpluff-x86_64-linux.so
   usr/lib64/xbmc/system/libid3tag-x86_64-linux.so
   usr/lib64/xbmc/system/libcmyth-x86_64-linux.so
   usr/lib64/xbmc/system/libexif-x86_64-linux.so
   usr/lib64/xbmc/system/ImageLib-x86_64-linux.so
   usr/lib64/xbmc/system/hdhomerun-x86_64-linux.so
   usr/lib64/xbmc/addons/visualization.waveform/Waveform.vis
   usr/lib64/xbmc/addons/library.xbmc.gui/libXBMC_gui-x86_64-linux.so
   usr/lib64/xbmc/addons/screensaver.rsxs.solarwinds/Solarwinds.xbs
   usr/lib64/xbmc/addons/screensaver.rsxs.plasma/Plasma.xbs
   usr/lib64/xbmc/addons/visualization.projectm/projectM.vis
   usr/lib64/xbmc/addons/library.xbmc.addon/libXBMC_addon-x86_64-linux.so
   usr/lib64/xbmc/addons/pvr.hts/XBMC_Tvheadend.pvr
   usr/lib64/xbmc/addons/pvr.mythtv/XBMC_Mythtv.pvr
   usr/lib64/xbmc/addons/pvr.vdr.vnsi/XBMC_VDR_vnsi.pvr
   usr/lib64/xbmc/addons/library.xbmc.pvr/libXBMC_pvr-x86_64-linux.so
   usr/lib64/xbmc/addons/visualization.glspectrum/opengl_spectrum.vis
   usr/lib64/xbmc/addons/screensaver.rsxs.euphoria/Euphoria.xbs
   usr/lib64/xbmc/addons/pvr.team-mediaportal.tvserver/XBMC_MPTV.pvr
   usr/lib64/xbmc/addons/pvr.demo/XBMC_demo.pvr
   usr/lib64/xbmc/xbmc.bin
ecompressdir: bzip2 -9 /usr/share/doc

 * QA Notice: The following files contain writable and executable sections
 *  Files with such sections will not work properly (or at all!) on some
 *  architectures/operating systems.  A bug should be filed at
 *  http://bugs.gentoo.org/ to make sure the issue is fixed.
 *  For more information, see http://hardened.gentoo.org/gnu-stack.xml
 *  Please include the following list of files in your report:
 *  Note: Bugs should be filed for the respective maintainers
 *  of the package in question and not hardened@g.o.
 * RWX --- --- usr/lib64/xbmc/xbmc.bin


>>> Installing (1 of 1) media-tv/xbmc-9999
 * Visit http://wiki.xbmc.org/?title=XBMC_Online_Manual
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Tue Feb 21, 2012 8:41 pm    Post subject: Reply with quote

wow

@yuhu
Vielen Herzlichen Dank ... unglaublich, aber scheint jetzt zu funktionieren .... und sogar sehr flott beim umschalten, nettes GUI und bisher recht stabil. Mal schauen was der Dauertest sagt.

Aber ich war echt am aufgeben und dann kam hier die Rettung, genial.
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
yuhu
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2006
Posts: 82

PostPosted: Tue Feb 21, 2012 9:17 pm    Post subject: Reply with quote

Kein Problem.

Kurz zu meinem System / Erfahrungen.

MythTV hatte ich vor 2-3 Jahre kurzzeitig im Test. Es war damals voll von Stolpersteinen und irgendwie bin ich einfach nicht warm damit geworden.

VDR lief einfach nach der Installation. Das OSD vom VDR ist einfach nur häßlich. Daher kommt bei mir xbmc auf die Matscheibe.

Der VDR läuft hier auf einem Server mit 2 2-fach DVB-C Karten (ddbridge).

XBMC läuft auf einem µATX ATOM Board mit ION Chipsatz.

VDR und XBMC benutzen das xvdr Plugin.

Zugriff übers Web zum VDR läuft hier mit dem Live Plugin (mit epgsearch, streamdev). Damit kannst auch via VLC den VDR-Stream abgreifen.

Ich warte schon lange auf eine wirklich stabile Version vom XBMC mit PVR. Hoffentlich kommt der PVR Zweig nachdem Eden Release endlich in den Hauptentwicklerzweig.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Sat Mar 17, 2012 12:07 pm    Post subject: Reply with quote

So, nun habe ich endlich mein VDR-System (Server/Client) laufen, doch die Einrichtung des Tons auf dem Client bekomme ich einfach nicht hin. Einfach absolute Stille. Hat da jemand eine Idiotensichere Anleitung wie bspw.:
Code:
cat /proc/asound/devices
aplay -l
audio.device.alsa_front_device=xy
Am besten gleichzeitig über HDMI und SPDIF.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2657
Location: de

PostPosted: Tue Mar 20, 2012 10:49 pm    Post subject: Reply with quote

LinuxTom wrote:
Am besten gleichzeitig über HDMI und SPDIF.

Dafür hast du 2 Möglichkeiten:
- http://www.vdr-portal.de/board16-video-disk-recorder/board7-dolby-ac3-digital/82397-gelöst-audio-via-hdmi-und-spdif-gleichzeitig
- Pulseaudio

Ersteres hab ich nicht wirklich zum Laufen bekommen. Bei mir streikt sogar der Ton irgendwie fast generell, wenn ich den über HDMI laufen lassen will. Evtl. werd ich das noch mal genauer austesten. Ich übertrag den Ton per Toslink zum AV-Receiver. Der TV ist per HDMI direkt an den Computer angeschlossen.

Pulseaudio ist bei mir nicht installiert aufgrund mehrfach schlechter Erfahrungen.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Wed Mar 21, 2012 5:47 pm    Post subject: Reply with quote

Schlimmer ist das Ruckeln. Es ist (selbst bei SD) immer ein leichetes Ruckeln zu sehen. Besonders, wenn sich das OSD ändert, stockt das Billd kurzzeitig. So habe ich mir das nicht vorgestellt.

Vielleicht kann mir ja mal jemand seine xine-Config geben, da ich vermute, dass man da noch einiges einstellen kann/muss.
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1813
Location: Germany

PostPosted: Tue May 01, 2012 1:11 am    Post subject: Reply with quote

Hmm....

So wie lange habt ihr gebraucht um die Sendersuche neu zu starten die wechselnden HD bzw. Öffentlich Rechtlichen neu zu sortieren?

Edit:
Es hat sich wohl nicht viel geändert lediglich die ARTE HD, Das Erste HD, ZDF HD haben den Transponder gewechselt. Dazu haben einige Öffentlich Rechtliche jetzt einen HD-Kanal.

Habe mit mythtv-setup einfach einen neuen Transponderscan durchlaufen lassen fertig. Allerdings sollte man sich vorher vergewissern das die Liste der bekannten Transponder vollständig ist.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Fri Nov 30, 2012 10:15 am    Post subject: Reply with quote

Ich habe mit media-tv/channeleditor vielleicht eine viertel Stunde gebraucht, alles neu zu sortieren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum