Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failing to build app-misc/lirc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Hyper_Eye
Guru
Guru


Joined: 17 Aug 2003
Posts: 441
Location: Huntsville, AL.

PostPosted: Sat Dec 24, 2011 6:27 pm    Post subject: Failing to build app-misc/lirc Reply with quote

Last night there were a few updates along with gentoo-sources-3.1.5. After updating I cannot build app-misc/lirc of any version. This is the output:

Code:
/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=k8 -O2 -pipe -version-info 2:1:2 -m elf_x86_64 -o liblirc_client.la -rpath /usr/lib64 lirc_client.lo 
libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/lirc_client.o    -march=k8 -O2 -m   -Wl,-soname -Wl,liblirc_client.so.0 -o .libs/liblirc_client.so.0.2.1
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: unrecognised emulation mode: -Wl,-soname
Supported emulations: elf_x86_64 elf32_x86_64 elf_i386 i386linux elf_l1om elf_k1om
collect2: ld returned 1 exit status
make[2]: *** [liblirc_client.la] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-misc/lirc-0.9.0/work/lirc-0.9.0/tools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-misc/lirc-0.9.0/work/lirc-0.9.0'
make: *** [all] Error 2
emake failed
 * ERROR: app-misc/lirc-0.9.0 failed (compile phase):
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=-m elf_x86_64   all
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 4350:  Called linux-mod_src_compile
 *   environment, line 3360:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CROSS_COMPILE=${CHOST}-                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *
 * If you need support, post the output of 'emerge --info =app-misc/lirc-0.9.0',
 * the complete build log and the output of 'emerge -pqv =app-misc/lirc-0.9.0'.
 * The complete build log is located at '/var/tmp/portage/app-misc/lirc-0.9.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/lirc-0.9.0/temp/environment'.
 * S: '/var/tmp/portage/app-misc/lirc-0.9.0/work/lirc-0.9.0'

>>> Failed to emerge app-misc/lirc-0.9.0, Log file:

>>>  '/var/tmp/portage/app-misc/lirc-0.9.0/temp/build.log'


Code:
emerge --info =app-misc/lirc-0.9.0
Portage 2.1.10.42 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r1, 3.1.5-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.5-gentoo-x86_64-AMD_Phenom-tm-_II_X4_975_Processor-with-gentoo-2.1
Timestamp of tree: Sat, 24 Dec 2011 05:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.5, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo sunrise roslin kde-sunset x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 LOKI-EULA ut2003 DOOM3 Q3AEULA ETQW googleearth teamspeak3 AdobeFlash-10.1 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo ftp://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.tds.net/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/roslin /var/lib/layman/kde-sunset /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi adplug alsa amd64 apng berkdb bindist bittorrent bluetooth branding bzip2 cairo cdda cddb cdr chardet cleartype cli consolekit corefonts cracklib crypt cups curl cxx dbus declarative dri dts dv dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran ftp gdbm gdu gif gnutls gpm gtk gtkhtml iconv imagemagick ipv6 jack java javascript joystick jpeg kde kipi kpathsea lame lastfm lcms ldap libnotify libsamplerate lirc lm_sensors mad md5sum melt midi minizip mmx mmxext mng modplug modules mp3 mp3tunes mp4 mpeg mplayer mudflap multilib musepack ncurses netplay network nls nptl nptlonly nsplugin nss ogg openal opengl openmp oss pam pango pcre pdf perl phonon plasma png policykit ppds pppd private-headers python qt qt3support qt4 quicktime rar readline samba sdl semantic-desktop session sid sndfile speech speex spell sse sse2 sse4 ssl ssse3 startup-notification subversion svg sysfs tcpd tga theora threads tiff timidity truetype tta udev unicode usb vorbis wavpack webkit wma wxwidgets x264 xcb xcomposite xine xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" LIRC_DEVICES="sb0540" NETBEANS_MODULES="*" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-misc/lirc-0.9.0 was built with the following:
USE="X (consolekit) (multilib) (policykit) -debug -doc -hardware-carrier -transmitter" LIRC_DEVICES="sb0540 -accent -act200l -act220l -adaptec -all -alsa_usb -animax -asusdh -atilibusb -atiusb -audio -audio_alsa -avermedia -avermedia98 -avermedia_vdomate -awlibusb -bestbuy -bestbuy2 -breakoutbox -bte -bw6130 -caraca -chronos -commandir -cph06x -creative -creative_infracd -devinput -digimatrix -dsp -dvico -ea65 -ene0100 -exaudio -flyvideo -ftdi -gvbctv5pci -hauppauge -hauppauge_dvb -hercules_smarttv_stereo -i2cuser -igorplugusb -iguanaIR -imon -imon_24g -imon_knob -imon_lcd -imon_pad -imon_rsc -inputlirc -irdeo -irdeo_remote -irlink -irman -irreal -it87 -ite8709 -knc_one -kworld -leadtek_0007 -leadtek_0010 -leadtek_pvr2000 -livedrive_midi -livedrive_seq -logitech -macmini -mceusb -mediafocusI -mouseremote -mouseremote_ps2 -mp3anywhere -mplay -nslu2 -packard_bell -parallel -pcmak -pcmak_usb -pctv -pixelview_bt878 -pixelview_pak -pixelview_pro -provideo -realmagic -remote_wonder_plus -remotemaster -sa1100 -samsung -sasem -serial -serial_igor_cesko -silitek -sir -slinke -streamzap -tekram -tekram_bt829 -tira -ttusbir -tuxbox -tvbox -udp -uirt2 -uirt2_raw -usb_uirt_raw -usbirboy -usbx -userspace -wpc8769l -xboxusb"


Thanks for any suggestions.
_________________
Gentoo Gaming Videos
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Sat Dec 24, 2011 8:42 pm    Post subject: Reply with quote

And I thought I was the only one...

I know the problem is here:

Quote:

libtool: link: x86_64-pc-linux-gnu-gcc -shared -fPIC -DPIC .libs/lirc_client.o -march=k8 -O2 -m -Wl


(It's missing the emulation parameter.)

But I have no idea how to fix it.
Back to top
View user's profile Send private message
macin
n00b
n00b


Joined: 28 Apr 2004
Posts: 50

PostPosted: Sun Dec 25, 2011 8:24 pm    Post subject: Reply with quote

Same problem here. The libtool call contains the "-m elf_x86_64" parameter but somehow consumes the second half of it instead of passing it on to the linker call. This parameter seems to originate from portage since it specifies 'LDFLAGS=-m elf_x86_64' on the command line when calling make. This seems to be superfluous at least in my case. The following is an ugly workaround which works for me to get it installed:

Code:
ebuild /usr/portage/app-misc/lirc/lirc-0.9.0.ebuild compile
# compilation will fail here so continue manually without 'LDFLAGS=-m elf_x86_64'
cd /var/tmp/portage/app-misc/lirc-0.9.0/work/lirc-0.9.0/
make
# this should succeed and installation of package can continue
ebuild /usr/portage/app-misc/lirc/lirc-0.9.0.ebuild install qmerge


Regards,
Tobias
Back to top
View user's profile Send private message
daniel.santos
n00b
n00b


Joined: 05 Jun 2007
Posts: 27

PostPosted: Sun Dec 25, 2011 10:10 pm    Post subject: Reply with quote

same problem. Anybody file a bug for this yet?
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 368

PostPosted: Mon Dec 26, 2011 6:36 am    Post subject: Reply with quote

Already a bug for this looks like its existed for almost 3 years.
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Mon Dec 26, 2011 7:03 am    Post subject: Reply with quote

salahx wrote:
Already a bug for this looks like its existed for almost 3 years.


That's not the same error. It's missing the parameter in this recent problem (i.e. it's not there at all.) In that bug the parameter is passed along and it causes an error. In our case it's not even there (the switch is, the parameter isn't.)
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 368

PostPosted: Mon Dec 26, 2011 8:19 am    Post subject: Reply with quote

Both show the same pattern:
Code:

/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=k8 -O2 -pipe -version-info 2:1:2 -m elf_x86_64 -o liblirc_client.la -rpath /usr/lib64 lirc_client.lo
libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/lirc_client.o    -march=k8 -O2 -m   -Wl,-soname -Wl,liblirc_client.so.0 -o .libs/liblirc_client.so.0.2.1


The -m elf_x86_64 is in the first line, not the second so I thought the 2 problems might be same, or at least related. Though I do not use lirc, I tried to compile it myself and I'm getting the same problem others are in this thread).
Back to top
View user's profile Send private message
priiice
n00b
n00b


Joined: 15 Jan 2011
Posts: 5

PostPosted: Mon Dec 26, 2011 3:13 pm    Post subject: Reply with quote

I'm having the same issue too. There's some new (within the last couple weeks) activity concerning this here: http://bugs.gentoo.org/160134 but it might be better to just open a new ticket.
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Mon Dec 26, 2011 5:40 pm    Post subject: Reply with quote

salahx wrote:
Both show the same pattern:

The -m elf_x86_64 is in the first line, not the second so I thought the 2 problems might be same, or at least related. Though I do not use lirc, I tried to compile it myself and I'm getting the same problem others are in this thread).


Gah, sorry. I was tired when I looked at it.
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Tue Dec 27, 2011 2:58 am    Post subject: Reply with quote

I did something unorthodox.

I changed my make.defaults for my profile temporarily to compile lirc:

Code:

# eselect profile list
  [5]   default/linux/amd64/10.0/desktop/kde *

# vi /usr/portage/profiles/arch/amd64/make.defaults


and commented out the offending line (The LDFLAGS line):

Code:

# 64bit specific settings.
CFLAGS_amd64="-m64"
#LDFLAGS_amd64="-m elf_x86_64"
CHOST_amd64="x86_64-pc-linux-gnu"


I then compiled lirc and it compiled successfully. After that I reverted my change in make.defaults.

I needed my dang remote to work! ;)
Back to top
View user's profile Send private message
Hyper_Eye
Guru
Guru


Joined: 17 Aug 2003
Posts: 441
Location: Huntsville, AL.

PostPosted: Tue Dec 27, 2011 12:43 pm    Post subject: Reply with quote

Thanks for such a simple work-around.
_________________
Gentoo Gaming Videos
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2429
Location: Silver City, NM

PostPosted: Wed Dec 28, 2011 12:19 am    Post subject: Reply with quote

The simple /usr/portage/profiles/arch/amd64/make.defaults work-around worked here too.

Thank you!
Back to top
View user's profile Send private message
Hyper_Eye
Guru
Guru


Joined: 17 Aug 2003
Posts: 441
Location: Huntsville, AL.

PostPosted: Fri Dec 30, 2011 1:40 am    Post subject: Reply with quote

Did a bug report get submitted for this issue?
_________________
Gentoo Gaming Videos
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Fri Dec 30, 2011 2:16 am    Post subject: Reply with quote

Doesn't look a new one. An old bug exists that was posted earlier in this thread that's 3 years old.

I'll create another one later and put the solution from this thread in it. Although in order to make it work they'll probably have to rewrite that ebuild...

I read earlier that the LDFLAGS was removed from make.defaults but was added back in recently.
Edit: Wow, there's lots of bugs for lirc...
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Fri Dec 30, 2011 5:36 pm    Post subject: Reply with quote

New bug. Might want to vote on it or make comments (like the workaround works for you.)
Back to top
View user's profile Send private message
darkwire
n00b
n00b


Joined: 19 Sep 2005
Posts: 8

PostPosted: Sun Jan 01, 2012 10:37 pm    Post subject: Reply with quote

A temporary less obtrusive workaround is just to put the following into /etc/make.conf

LDFLAGS_amd64=""

I checked the make.defaults to make sure it wasn't being appended to and I commented it back out after I was done with lirc compilation.
Back to top
View user's profile Send private message
P.Kosunen
Tux's lil' helper
Tux's lil' helper


Joined: 21 Nov 2005
Posts: 88
Location: Finland

PostPosted: Fri Jan 13, 2012 12:21 pm    Post subject: Reply with quote

darkwire wrote:
A temporary less obtrusive workaround is just to put the following into /etc/make.conf


Code:
LDFLAGS_amd64="" emerge -av lirc


Or just pass it from shell.
Back to top
View user's profile Send private message
Arrta
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 102

PostPosted: Tue Jul 03, 2012 4:06 pm    Post subject: Reply with quote

Apparently this has been a bug that has been opened for 5+ years now.
https://bugs.gentoo.org/show_bug.cgi?id=160134

The patch for the 0.9.0 ebuild will work on people using other versions as well, but has to be manually applied.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum