Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Desura Game Client error: GTK+2 and GTK+3 in same process
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
kokyu
n00b
n00b


Joined: 22 Dec 2011
Posts: 13

PostPosted: Thu Dec 22, 2011 10:23 am    Post subject: Desura Game Client error: GTK+2 and GTK+3 in same process Reply with quote

Hey all,

I just wanted to install the Desure Game Client for linux, and the install went fine, however, cd'ing into ~/desura to ./desura raised this error message on the terminal:

Code:
laptop [~/desura] > ./desura

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported


I'm not using GNOME at all, and try to avoid anything related to it, however, I still run into GTK issues like these :(

how can I fix that?
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 351
Location: Stockholm, Sweden

PostPosted: Fri Dec 23, 2011 7:55 pm    Post subject: Reply with quote

I'm going to try installing it soon, so I'll see if I have any issues. I have seen this problem before though, have a look at:

http://forums.gentoo.org/viewtopic-t-889328-highlight-minecraft.html
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
kokyu
n00b
n00b


Joined: 22 Dec 2011
Posts: 13

PostPosted: Sun Dec 25, 2011 12:37 pm    Post subject: Reply with quote

azp wrote:
I'm going to try installing it soon, so I'll see if I have any issues. I have seen this problem before though, have a look at:

http://forums.gentoo.org/viewtopic-t-889328-highlight-minecraft.html

the desura game client is no java, so juggling around with JDKs doesn't help here :(
Back to top
View user's profile Send private message
Lupusceleri
n00b
n00b


Joined: 14 May 2010
Posts: 10

PostPosted: Mon Dec 26, 2011 12:31 pm    Post subject: Reply with quote

http://www.desura.com/groups/desura/forum/thread/desura-client-fails-to-launch-issues-with-gtk

Short version is that you have to recompile x11-libs/cairo with -qt4 USE flag, so add this in /etc/portage/package.use.

I'm about to try this and see if it works.

EDIT: This works. Fixed. 8)
_________________
Main PC: Intel Core i7 920 -- Gentoo ~amd64 KDE4 -- Windows 7 Ultimate
Laptop: Intel Core Duo T2450 -- Gentoo ~x86 KDE4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum