Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] problema avvio xorg da utente non root
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sat Dec 17, 2011 8:30 pm    Post subject: [Risolto] problema avvio xorg da utente non root Reply with quote

salve a tutti, ho installato xorg e ho dato da root X -config /root/xorg.config e da root xorg si avvia senza errori solo che se provo ad avviarlo da utente non root mi da degli errori e ho anche provato a dare X -configure da utente non root per; mi dice che posso dare i comandi di configurazione solo da root, come posso risolvere? l' errore che mi da non posso scriverlo perche e' troppo lungo e non so dov' e' il file dei log da dove prenderlo.

Last edited by system-infet on Mon Dec 19, 2011 2:29 pm; edited 3 times in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Dec 17, 2011 10:40 pm    Post subject: Reply with quote

guarda in /var/log/ altrimenti puoi sempre redirigere l'output di un comando in dei file:
Code:

startx > output_normale.txt 2> output_errori.txt
Back to top
View user's profile Send private message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Sat Dec 17, 2011 10:53 pm    Post subject: Reply with quote

il file di log è
Code:
/var/log/Xorg.0.log
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sun Dec 18, 2011 11:08 am    Post subject: Reply with quote

questo mi sembra che sia il file dei log dell errore

Code:
xauth:  timeout in locking authority file //.serverauth.11296
xauth:  timeout in locking authority file //.Xauthority
xauth:  timeout in locking authority file //.Xauthority
xauth:  timeout in locking authority file //.Xauthority
xauth:  timeout in locking authority file //.Xauthority


X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-11-generic x86_64 Gentoo
Current Operating System: Linux localhost 2.6.38-sysrescue-std220 #1 SMP Sat Dec 17 16:20:14 CET 2011 x86_64
Kernel command line: BOOT_IMAGE=/kernel-sysrescue-std-x86_64-2.6.38-sysrescue-std220 real_root=/dev/sda3
Build Date: 17 December 2011  05:55:57PM
 
Current version of pixman: 0.24.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 18 13:08:24 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
mkdir: cannot create directory `//.fluxbox': Permission denied
mkdir: cannot create directory `//.fluxbox': Permission denied
mkdir: cannot create directory `//.fluxbox': Permission denied
/usr/bin/startfluxbox: line 64: //.fluxbox/startup: No such file or directory
chmod: cannot access `//.fluxbox/startup': No such file or directory
sh: //.fluxbox/startup: No such file or directory
xinit: connection to X server lost


waiting for X server to shut down Server terminated successfully (0). Closing log file.

xauth:  timeout in locking authority file //.Xauthority


Last edited by system-infet on Sun Dec 18, 2011 2:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Dec 18, 2011 11:16 am    Post subject: Reply with quote

presumo che questo sia il log di quando funziona perchè non vedo errori, a parte il fatto che non trova vesa e fbdev ma poi tanto utilizza correttamente i driver intel
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sun Dec 18, 2011 11:49 am    Post subject: Reply with quote

ho provato a dare il comando per scrivere i log su un file personalizzato ma il file resta vuoto
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Dec 18, 2011 11:56 am    Post subject: Reply with quote

significa che non hai dato il comando giusto, che cosa hai scritto esattamente?
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sun Dec 18, 2011 12:04 pm    Post subject: Reply with quote

scusa avevo sbagliato comando mi dispiace, il log e" questo

Code:
xauth:  timeout in locking authority file //.serverauth.11296
xauth:  timeout in locking authority file //.Xauthority
xauth:  timeout in locking authority file //.Xauthority
xauth:  timeout in locking authority file //.Xauthority
xauth:  timeout in locking authority file //.Xauthority


X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-11-generic x86_64 Gentoo
Current Operating System: Linux localhost 2.6.38-sysrescue-std220 #1 SMP Sat Dec 17 16:20:14 CET 2011 x86_64
Kernel command line: BOOT_IMAGE=/kernel-sysrescue-std-x86_64-2.6.38-sysrescue-std220 real_root=/dev/sda3
Build Date: 17 December 2011  05:55:57PM
 
Current version of pixman: 0.24.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 18 13:08:24 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
mkdir: cannot create directory `//.fluxbox': Permission denied
mkdir: cannot create directory `//.fluxbox': Permission denied
mkdir: cannot create directory `//.fluxbox': Permission denied
/usr/bin/startfluxbox: line 64: //.fluxbox/startup: No such file or directory
chmod: cannot access `//.fluxbox/startup': No such file or directory
sh: //.fluxbox/startup: No such file or directory
xinit: connection to X server lost


waiting for X server to shut down Server terminated successfully (0). Closing log file.

xauth:  timeout in locking authority file //.Xauthority


Last edited by system-infet on Sun Dec 18, 2011 2:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Dec 18, 2011 12:29 pm    Post subject: Reply with quote

Quote:
scusa avevo sbagliato comando mi dispiace


non c'è problema, qui non ti mangia nessuno ;)

Quote:
mkdir: cannot create directory `//.fluxbox': Permission denied


hai creato la home directory per il tuo utente? se si, hai i permessi corretti di scrittura/lettura? l'utente è stato aggiunto al gruppo video?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sun Dec 18, 2011 1:21 pm    Post subject: Reply with quote

The Extremer wrote:
non c'è problema, qui non ti mangia nessuno ;)
parla per te ... :twisted: i niubbi vanno bastonati ... :lol:
Fatta la battuta idiota possiamo tornare più seri.

Mi pare che il problema sia già stato affrontato (ma quando non è kde tento a fregarmene un tantino quindi posso aver sbagliato wm) ed è necessario creare uno script di startup per fluxbox nella home utente (possibilissimo che abbiano corretto) ma in ogni caso verifica per il gruppo video come ti è già stato suggerito (tanto serve comunque e se funziona è un mezzo errore).

Già che ci sia siamo ti ricordo che molto probabilmente ti servirà iscrivere l'utente anche ai gruppi audio, cdrom, disk, cdrw, usb, scanner e forse plugdev, secondo quello che usi. Finanche wheel ma ci andrei molto cauto per le implicazioni di sicurezza che comporta.

Se non sono molesto (lo faccio apposta) vorrei capire perché non usare un login manager. Non è una esclusiva di primati e sauri ...

Xorg.log wrote:
mkdir: cannot create directory `//.fluxbox': Permission denied
A naso mi pare un problema di path, sta cercando di creare la directory privata nella root del filesystem e non nella home. Sicuro che l'utente ha le variabili HOME & C correttamente impostate?
Non so sui sistemi "normali" ma in genere è sempre meglio usare adduser (e simili) e non procedere editando direttamente /etc/passwd. Se lo hai fatto correggi.
Verifica anche che non ci siano script balordi nella home e nel caso riporta l'ouput di
Code:
set | grep 'nomeutente'
.

Ci si può scherzare più o meno bonariamente ma il tuo post è un obbrobbrio, per cortesia editalo e rimuovi quel log inutile e lunghissimo.
Negli altri correggi ed impara che per leggibilità e praticità si usano i tag code e quote per riportare gli output. esempio (quello che ho riportato sopra) :
Code:
[quote="Xorg.log"]mkdir: ...[/quote]

Ti avverto (per il futuro) che il tag code prevede un carattere a spaziatura fissa non consente di evidenziare (con colori e cabio dimensione del carattere come ho fatto nell'esempio), non consente di mandare a capo le righe troppo lunghe e pertanto andrebbe usato solo nei casi in cui devi mantenere l'allineamento di un output o consentire il copia ed incolla di un comando, in tutti gli altri casi è sempre meglio quote.

Forse sarebbe il caso prima o poi di aggiungere codeste informazioni alle linee guida (perché come usare i tag non è documentato per niente).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sun Dec 18, 2011 2:50 pm    Post subject: Reply with quote

vi ringrazio :) è tutto sistemato, mi scuso per non aver messo i tag e per non aver scritto correttamente ma avevo la tastiera inglese e mi veniva male anche a dare i comandi e non riuscivo a settarla in italiano neanche con loadkeys ma ora ho installato setxkbmap.
ora tolgo tutto e metto i tag e il tag risolto nel titolo del post.
vi ringrazio ancora per l' aiuto :)
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sun Dec 18, 2011 3:40 pm    Post subject: Reply with quote

scusatemi ma.. avrei un altro problema: quando cerco di installare vlc mi dice che devo smascherare la libreria zlib e di usare l' opzione --autounmask-write io l' ho usata dando il comando: emerge --autounmask-write vlc ma mi dice che quest opzione non esiste quindi dove la devo mettere quest' opzione? ho cercato sia nella documentazione che su google ma non ho trovato niente.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sun Dec 18, 2011 3:44 pm    Post subject: Reply with quote

system-infet wrote:
mi scuso per non aver messo i tag e per non aver scritto correttamente
hai corretto quindi le scuse non sono necessarie.

A futura memoria, sarebbe bene che indicassi come hai risolto e quale era la causa.

Nella guida non è spiegata la differenza tra xorg-x11 ed xorg server.
xorg-x11 non è altro che xorg-server con l'aggiunta di font, setxkbkmap etc. Chi usa kde non ha bisogno di questa roba perchè se ne occupano le librerie del DM a settare la tasiera etc, chi usa altri WM meno "barocchi" e non ha bisogno di guardare al singolo MB di disco libero fa bene ad installarlo, invece. :wink:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Sun Dec 18, 2011 4:09 pm    Post subject: Reply with quote

:) grazie :), il problema era che l' utente non aveva una cartella home e non aveva i permessi necessari come avete detto tu e The Extremer. potresti aiutarmi col problema dei pacchetti mascherati di vlc?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum