Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] polskie znaki
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Polish OTW
View previous topic :: View next topic  
Author Message
marco_00
n00b
n00b


Joined: 04 Dec 2011
Posts: 3

PostPosted: Sun Dec 04, 2011 7:35 pm    Post subject: [SOLVED] polskie znaki Reply with quote

Witam
Na poczatku podkreslam ze czytalem juz chyba wszystkie artykuly o lokalizacji Gentoo, probowalem wielu sposobow i dalej nic. Nie mam juz sily wiec grzecznie pytam.
Posiadam Gentoo 2.6.39-gentoo-r3, config klawiatury z X'ow :
Code:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option  "XkbLayout" "pl2, fr"
        Option  "XkbModel"      "pc105"
        Option  "XkbOptions"    "grp:alt_shift_toogle,grp_led:scroll"
EndSection


locale :
Code:


Gentoo mark # locale
LANG=pl_PL.utf-8
LC_CTYPE=pl_PL.utf-8
LC_NUMERIC="pl_PL.utf-8"
LC_TIME="pl_PL.utf-8"
LC_COLLATE=C
LC_MONETARY="pl_PL.utf-8"
LC_MESSAGES=en_US.utf-8
LC_PAPER="pl_PL.utf-8"
LC_NAME="pl_PL.utf-8"
LC_ADDRESS="pl_PL.utf-8"
LC_TELEPHONE="pl_PL.utf-8"
LC_MEASUREMENT="pl_PL.utf-8"
LC_IDENTIFICATION="pl_PL.utf-8"
LC_ALL=


plik /etc/env.d/02locale
Code:

LANG="pl_PL.utf-8"
LC_MESSAGES="en_US.utf-8"
LC_CTYPE="pl_PL.utf-8"
LC_COLLATE="en_US.utf-8"


/etc/locale-gen
Code:

pl_PL.UTF-8 UTF-8
en_US.UTF-8 UTF-8




/etc/conf.d/keymaps
Code:

KEYMAP="pl2"



Wspomne jeszcze ze polskie znaki widze i moge wprowadzac w konsoli glownej (tej zanim odpale X'y), ale juz w atermie nie widze i nie moge wprowadzac , w przegladarce widze , ale nie moge wprowadzac.

I przepraszam za brak polskich znakow :)
Prosze o pomoc.


Last edited by marco_00 on Tue Dec 20, 2011 8:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 624
Location: /dev/null

PostPosted: Sun Dec 04, 2011 8:25 pm    Post subject: Reply with quote

Dodaj do make.conf

Quote:
LANGUAGE=48
LINGUAS="pl"
Back to top
View user's profile Send private message
marco_00
n00b
n00b


Joined: 04 Dec 2011
Posts: 3

PostPosted: Sun Dec 04, 2011 9:22 pm    Post subject: Reply with quote

Niestety nie dziala :(. Dodam jeszcze ze w xtermie dziaja alty , z tym ze nie tak ja powinny : áááññ÷ååòïïðð.
W przegladarce (google chrome) alt + znak dziala jak skroty klawiszowe.

Prosze o pomoc.
Back to top
View user's profile Send private message
lsdudi
Guru
Guru


Joined: 12 Nov 2006
Posts: 386
Location: Warsaw

PostPosted: Sun Dec 04, 2011 10:24 pm    Post subject: Reply with quote

kbd jest deprected uzyj evdev
sprawdz czy masz polskie znaki bez trybu graficznego (bo moze to znazac ze musisz dokonfigurwać konkretny WM)
_________________
RLU#416942
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 763

PostPosted: Mon Dec 05, 2011 9:13 am    Post subject: Reply with quote

Code:
        Option  "XkbLayout" "pl2, fr"

sprawdź, czy jak zmienisz na "pl", to zacznie działać.
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
marco_00
n00b
n00b


Joined: 04 Dec 2011
Posts: 3

PostPosted: Tue Dec 20, 2011 8:03 pm    Post subject: Reply with quote

dzięki, działa 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Polish OTW All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum