Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg Errors and Warnings
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Thu Nov 10, 2011 6:44 am    Post subject: Xorg Errors and Warnings Reply with quote

Hi,

I followed the official Gentoo docs and installed Xorg as well as twm and xterm for testing purpose. Now I can see a few xterm windows if I run startx, and the keyboard and touchpad are working well.

But there are still some Errors and Warnings:
Code:
# cat /var/log/Xorg.0.log | grep EE
[  5295.143] (EE) Failed to load module "vesa" (module does not exist, 0)
[  5295.210] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  5295.932] (EE) Query no Synaptics: 6003C8
[  5295.932] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[  5295.960] (EE) PreInit returned 11 for "SynPS/2 Synaptics TouchPad"

Code:
# cat /var/log/Xorg.0.log |grep WW
[  5295.136] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  5295.136] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  5295.136] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  5295.136] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  5295.137] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  5295.138] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  5295.143] (WW) Warning, couldn't open module vesa
[  5295.210] (WW) Warning, couldn't open module fbdev
[  5295.482] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

My laptop comes with two graphics cards, an Intel integrated card and an ATI card. I want to use only the Intel card for output because I have had trouble getting my ATI card to work properly, also, I knew I could use only the Intel card as it was the case on my former Ubuntu Box, so I didn't build any drivers for the ATI card and didn't enable GPU switching support in kernel, but I didn't disable the ATI card in BIOS.

So what do these Errors and Warnings mean and how can I make them disappear?

If you want me to paste more information, just tell me.
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Thu Nov 10, 2011 12:15 pm    Post subject: Reply with quote

You don't make them disappear. They're not actually errors. Ignore them.

Of course you're one of those who absolutely. must. get. rid. of. all. warnings. type, so you won't be satisfied with my answer, despite now having the knowledge that there's nothing wrong with your machine. :)
Hint: there's been a thread pretty much exactly like this one not long ago.
Back to top
View user's profile Send private message
dziadu
Guru
Guru


Joined: 04 May 2006
Posts: 433
Location: Kraków/Darmstadt/Munich

PostPosted: Thu Nov 10, 2011 1:23 pm    Post subject: Reply with quote

Most of the warning you can easily fix with this commands (in bash):
Code:
mkdir /usr/share/fonts/TTF/ -p
mkdir /usr/share/fonts/OTF/ -p
mkdir /usr/share/fonts/Type1/ -p

[ ! -e /usr/share/fonts/TTF/fonts.dir ] && echo "0" > /usr/share/fonts/TTF/fonts.dir
[ ! -e /usr/share/fonts/OTF/fonts.dir ] && echo "0" > /usr/share/fonts/OTF/fonts.dir
[ ! -e /usr/share/fonts/Type1/fonts.dir ] && echo "0" > /usr/share/fonts/Type1/fonts.dir

[ ! -e /usr/share/fonts/100dpi/fonts.dir ] && echo "0" > /usr/share/fonts/100dpi/fonts.dir
[ ! -e /usr/share/fonts/75dpi/fonts.dir ] && echo "0" > /usr/share/fonts/75dpi/fonts.dir

:)
_________________
1% Twojego podatku to 100% naszej pasji!
Back to top
View user's profile Send private message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Thu Nov 10, 2011 2:49 pm    Post subject: Reply with quote

dziadu wrote:
Most of the warning you can easily fix with this commands (in bash):
Code:
mkdir /usr/share/fonts/TTF/ -p
mkdir /usr/share/fonts/OTF/ -p
mkdir /usr/share/fonts/Type1/ -p

[ ! -e /usr/share/fonts/TTF/fonts.dir ] && echo "0" > /usr/share/fonts/TTF/fonts.dir
[ ! -e /usr/share/fonts/OTF/fonts.dir ] && echo "0" > /usr/share/fonts/OTF/fonts.dir
[ ! -e /usr/share/fonts/Type1/fonts.dir ] && echo "0" > /usr/share/fonts/Type1/fonts.dir

[ ! -e /usr/share/fonts/100dpi/fonts.dir ] && echo "0" > /usr/share/fonts/100dpi/fonts.dir
[ ! -e /usr/share/fonts/75dpi/fonts.dir ] && echo "0" > /usr/share/fonts/75dpi/fonts.dir

:)

Thank you, but what about the others. I don't want to see any errors or warnings in my system, just as Gusar said.
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Thu Nov 10, 2011 4:33 pm    Post subject: Reply with quote

fangwen wrote:
I don't want to see any errors or warnings in my system, just as Gusar said.

Let me ask you something. Would you rather have:
a) unneeded modules installed (granted, they're small and compile quickly, but still), only to see them being loaded and then immediately unloaded every time X starts
b) some harmless error messages?

Of course your answer will be b, but that is some special form of OCD, I must say.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4151

PostPosted: Thu Nov 10, 2011 5:36 pm    Post subject: Reply with quote

Wonder if you have fix all the warnings throw by gcc while building X too ? :P
Back to top
View user's profile Send private message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Fri Nov 11, 2011 4:24 am    Post subject: Reply with quote

OK, If I give up this form of OCD, how can I go on tinkering with my Gentoo box.
I am not the kind of person who want just his work done, and I don't have any computer related work to do. For me, Gentoo is a toy, all my concern is to make my Gentoo box perfect.
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Fri Nov 11, 2011 11:10 am    Post subject: Reply with quote

fangwen wrote:
OK, If I give up this form of OCD, how can I go on tinkering with my Gentoo box.

You ask on the forums, where people tell you if the errors are serious or if you can ignore them. It's interesting though, until now I've seen it as a form of OCD and have been quite amused by this phenomenon. But you gave a good point that it might not be just about OCD. So full explanation about the errors:

First the touchpad. It's being initialized twice - if you'd look at the full log, you'd clearly see it, the error is because X wants to initialize an already initialized device. The reason? Your touchpad is duplicated in /dev/input - it's there as mouseX and as eventX.
There are two "fixes" for this. One is to remove the mouse interface from your kernel (CONFIG_INPUT_MOUSEDEV). Don't worry, it's safe, your touchpad and mice will still be available as event devices. The other is to copy /usr/share/X11/xorg.conf.d/50-synaptics.conf into /etc/X11/xorg.conf.d (create the dir if you don't already have it), and add this to the InputClass section in there:
Code:
   MatchDevicePath "/dev/input/event*"
Should be obvious what this does, it makes X only look at event devices. If you want to know further about X input configuration, see here.

Then we come to vesa and fbdev. X is configured to use them as fallback, so that if for some reason the main driver doesn't load, you still get X. On the one hand it seems like a good strategy, but on the other hand it makes debugging more difficult. If you were to install the vesa and fbdev drivers, and your main driver loads correctly, what would happen is vesa and fbdev would get loaded only to then be unloaded shortly after. A waste if you ask me.
Back to top
View user's profile Send private message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Tue Dec 13, 2011 2:36 pm    Post subject: Reply with quote

Gusar wrote:
The other is to copy /usr/share/X11/xorg.conf.d/50-synaptics.conf into /etc/X11/xorg.conf.d (create the dir if you don't already have it), and add this to the InputClass section in there:
Code:
   MatchDevicePath "/dev/input/event*"
Thank you, Gusar.
If you are still here, I need your further help. I tried your suggestions above and it didn't work. But if I edit the 50-synaptics.conf file directly in /usr/share/X11/xorg.conf.d/, it did solve my problem. This is somehow rather strange. Why?
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Sat Dec 17, 2011 1:45 pm    Post subject: Reply with quote

Because it had no click with the touchpad, I added this line to my 50-synaptics.conf file in /etc/X11/xorg.conf.d/,
Code:
Option "TapButton1" "1"
It did take effect. But it seems that this line,
Code:
MathDevicePath "/dev/input/event*"
should always be put in /usr/share/X11/xorg.conf.d/. I guess this has something to do with root permission (I ran startx as a normal user).
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Sat Dec 17, 2011 2:45 pm    Post subject: Reply with quote

Ah, now I get what's going on. No matter what you do /etc, the file in /usr/share will still apply synaptics to all devices, including mouseX ones. Don't know why I didn't think of this sooner.
It has nothing do to with permissions, it has to do with scanning order: X will scan all files in /usr/share/X11/xorg.conf.d, then it'll scan all files in /etc/X11/xorg.conf.d, and then it'll scan xorg.conf

However, now it's time for me to have fun again :D. Even after you knew exactly what the error means and that it's harmless (and that there's another way to handle it), it still didn't give you pause until you got rid of it. Now tell me that's not OCD :P
Back to top
View user's profile Send private message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Sun Dec 18, 2011 4:41 am    Post subject: Reply with quote

Gusar wrote:
Now tell me that's not OCD :P
Well, I surrender. :P Thanks you again, Gusar.
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
user
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2004
Posts: 131

PostPosted: Wed Dec 28, 2011 8:41 pm    Post subject: Re: Xorg Errors and Warnings Reply with quote

Hi fangwen,

Quote:
[ 5295.136] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 5295.136] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 5295.136] (WW) The directory "/usr/share/fonts/Type1/" does not exist.

Install fonts for these directories or live with these messages.
Code:
[  5295.136] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  5295.137] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".

Do a font cache update.
Code:
# fc-cache -v -f

Quote:
[ 5295.138] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

Start your X server with noacpi option.
Code:
# exec /usr/bin/startx -- -noacpi

Quote:
[ 5295.143] (WW) Warning, couldn't open module vesa
[ 5295.210] (WW) Warning, couldn't open module fbdev
[ 5295.482] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

I dont know any solution.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2278
Location: UK

PostPosted: Wed Dec 28, 2011 9:47 pm    Post subject: Reply with quote

You should fix the acpi warning by installing acpid. It makes the power button on your PC work properly, among other things.
Back to top
View user's profile Send private message
fangwen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2011
Posts: 128
Location: Shanghai, China

PostPosted: Thu Dec 29, 2011 10:39 am    Post subject: Reply with quote

Thank you, I have never expected that there will still be replies to my post after such a long time.

To user
thanks, I am working with my fonts these days.
Quote:
[ 5295.143] (WW) Warning, couldn't open module vesa
[ 5295.210] (WW) Warning, couldn't open module fbdev
[ 5295.482] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
vesa and fbdev are fallback mode for X, Gusar had told me that. And the third line is about multi-card support in kernel (my laptop has hybrid graphics).

To Ant P.
I just installed acpid one or two weeks ago, it took care of the acpi warning. Thank you anyway.
_________________
All operating systems suck. This one just sucks less.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum