Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz + ATi fglrx - AIGLX działa, a compiz nie?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
Syster
n00b
n00b


Joined: 26 Jun 2007
Posts: 60
Location: ŁódŸ

PostPosted: Sat Nov 05, 2011 2:30 pm    Post subject: Compiz + ATi fglrx - AIGLX działa, a compiz nie? Reply with quote

Witajcie!
Mam problem ze startem compiza. Posiadam kartę zintegrowaną Radeon HD4700 oraz zainstalowane najnowsze ati-drivers.
Podczas startu X'a, po logach wygląda na to, że AIGLX wstaje:

Quote:
[ 1341.891] (II) AIGLX: Loaded and initialized OpenGL driver(II) GLX: Initialized DRI GL provider for screen 0

W logach X'a nie widzę błędów.

glxinfo również podaje, że sterowniki działają:

Quote:
direct rendering: Yes
GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,


Mimo to, compiz nie wstaje:

Quote:
neox@Syster-Gentoo ~ $ compiz-manager
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
No whitelisted driver found
SKIP_CHECKS is yes, so continuing despite problems.
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (8192): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald

(process:4236): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.


Podam może swoją konfigurację X'a ;)
Quote:
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
Option "AIGLX" "true"
EndSection

Section "Module"
# Disable "dri"
# Disable "dri2"
Load "dbe"
Load "dri"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:5:0"
Option "DRI" "true"
Option "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"

Option "Composite" "Enable"

EndSection

Section "ServerFlags"

Option "AIGLX" "On"

EndSection


Podejrzewam, że błąd jest jakiś błachy, ale nie jestem pewien. Może ktoś na to rzucić okiem?
Aha, jestem na platformie amd64.

Quote:
Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.12.2-r0, 3.0.6-gentoo x86_64)
=================================================================
System uname: Linux-3.0.6-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.0.3
Timestamp of tree: Sat, 05 Nov 2011 12:00:01 +0000
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.2-r3, 3.1.4-r3
dev-util/cmake: 2.8.4-r1
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.0.3
sys-apps/openrc: 0.8.3-r1
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.9.6-r3, 1.11.1
sys-devel/binutils: 2.21.1-r1
sys-devel/gcc: 4.5.3-r1
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc: 2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64 -fomit-frame-pointer -mmmx -msse -msse2 -m3dnow"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon64 -fomit-frame-pointer -mmmx -msse -msse2 -m3dnow"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.utf8@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aalib acl acpi alsa amd64 amr apm berkdb bzip2 cli consolekit cracklib crypt cups cxx dbus device-mapper dri emerald extensions extras fortran gdbm gdu gif gnome gpm hal iconv icu ipv6 java jpeg libkms libxml lm_sensors md5sum mmx mmxext modules mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre png policykit pppd python qt4 readline samba session sse sse2 ssl sysfs syslog tcpd tiff udev unicode vboxwebsrv vnc x xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sat Nov 05, 2011 2:39 pm    Post subject: Reply with quote

Zainstaluj to:
Code:
x11-apps/fusion-icon


Mi się normalnie też nigdy compiza nie udało odpalić, a dzięki temu ustrojstwu wstaje bez problemu.
Back to top
View user's profile Send private message
Syster
n00b
n00b


Joined: 26 Jun 2007
Posts: 60
Location: ŁódŸ

PostPosted: Sat Nov 05, 2011 2:43 pm    Post subject: Reply with quote

Też próbowałem, ale nie pomogło ;/
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 357
Location: Kraków

PostPosted: Sat Nov 05, 2011 4:15 pm    Post subject: Reply with quote

Primo, sekcję "DRI" z xorga wywal na sam koniec.
Secundo,
Code:
eselect opengl set ati

Tertio, pokaż
Code:
glxinfo | grep OpenGL

_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sat Nov 05, 2011 7:04 pm    Post subject: Reply with quote

Ja tam nigdy nie wywalałem DRI i mi wszystko działało, tyle że mam NVIDIA

BTW. eselect opengl set ati nie jest jakoś specjalnie potrzebne, po każdej instalacji sterowników samo się to robi.

Ale to tak na marginesie.
Back to top
View user's profile Send private message
Syster
n00b
n00b


Joined: 26 Jun 2007
Posts: 60
Location: ŁódŸ

PostPosted: Sat Nov 05, 2011 8:54 pm    Post subject: Reply with quote

1. no okej

2. Zrobiłem to już wcześniej, ale tak jak powiedział @Pryka, to i tak wykonuje się automatycznie po instalacji sterowników

3.
Pisałem o tym w pierwszym postcie:
Quote:
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4200
OpenGL version string: 3.3.11005 Compatibility Profile Context
OpenGL shading language version string: 3.30
OpenGL extensions:
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 493

PostPosted: Sun Nov 06, 2011 1:31 am    Post subject: Reply with quote

ATI robi diabelnie "dobre" sterowniki do Linuxa, problem w tym, że Compiz przeważnie nic nie wie, o tym doniosłym fakcie.

Radziłbym poszukać lub poczekać na inną. - najlepiej nowszą wersję sterownika do karty.

Pryka wrote:
Ja tam nigdy nie wywalałem DRI i mi wszystko działało, tyle że mam NVIDIA

To jest właśnie podstawowa różnica między własnościowymi sterami Nvidii i ATI.
Nividia zazwyczaj działa zawsze w miarę prawidłowo , ATI często działa względnie prawidłowo.
Co prawda podobno jest coraz lepiej z tymi sterami, ale o Nvidii nikt nigdy takiego wątku chyba nie zakładał...
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sun Nov 06, 2011 8:08 am    Post subject: Reply with quote

Jacekalex wrote:
To jest właśnie podstawowa różnica między własnościowymi sterami Nvidii i ATI.
Nividia zazwyczaj działa zawsze w miarę prawidłowo , ATI często działa względnie prawidłowo.
Co prawda podobno jest coraz lepiej z tymi sterami, ale o Nvidii nikt nigdy takiego wątku chyba nie zakładał...


W sumie trudno się z Tobą nie zgodzić.
Back to top
View user's profile Send private message
Syster
n00b
n00b


Joined: 26 Jun 2007
Posts: 60
Location: ŁódŸ

PostPosted: Sun Nov 06, 2011 8:47 am    Post subject: Reply with quote

kurczę no nie powiem szkoda;/

A nie wie ktoś jak działają i czy działają otwarte sterowniki dla radeona dla kart z serii HD?

Musze chyba podpatrzeć jak rozwiązali compiza w ubuntu, tam w końcu compiz działa.
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 357
Location: Kraków

PostPosted: Sun Nov 06, 2011 9:56 am    Post subject: Reply with quote

Heh, śmiszne.
Ja mam Radeon HD5450, z zamkniętymi sterami. O ile kiedyś były dość kiepskawe, o tyle teraz są naprawdę dobre. Stabilne i mają dobry panel konfiguracyjny. Nigdy mi się nie zdarzyło, żeby compiz mi nie działał (dopóki miałem Gnome'a).
A
Code:
aticonfig --initial -f
próbowałeś?
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
Syster
n00b
n00b


Joined: 26 Jun 2007
Posts: 60
Location: ŁódŸ

PostPosted: Sun Nov 06, 2011 5:17 pm    Post subject: Reply with quote

Tak, zaraz jak zainstalowałem stery
Back to top
View user's profile Send private message
Syster
n00b
n00b


Joined: 26 Jun 2007
Posts: 60
Location: ŁódŸ

PostPosted: Thu Feb 02, 2012 7:42 pm    Post subject: Reply with quote

LoL, nie powiem, strasznie się zdziwiłem, ale rozwiązanie było przebanalne :-D
Po prostu wystarczylo włączyć w CompizConfig Settings Manager:
Gnome Compatibility
Animations
Window Decoration
Workarounds
Move Window
Resize Window
i działa:)
Back to top
View user's profile Send private message
Bastian82
n00b
n00b


Joined: 07 Feb 2011
Posts: 45
Location: Poznań

PostPosted: Sat Feb 04, 2012 8:09 am    Post subject: Reply with quote

Sorki, ale muszę to napisać: L O L :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum