Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
need 32 bit version of libtermcap.so.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
jharvell
n00b
n00b


Joined: 16 May 2006
Posts: 16

PostPosted: Thu Nov 19, 2009 12:34 am    Post subject: need 32 bit version of libtermcap.so.2 Reply with quote

Is there any package that produces a 32 bit version of libtermcap.so on an amd64 machine? I have to run an 32-bit executable linked against it. It seems like sys-libs/libtermcap-compat should, but it only produces the 64-bit version.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3892
Location: USA

PostPosted: Thu Nov 19, 2009 1:09 am    Post subject: Reply with quote

Which emul-linux-x86-* ebuilds do you have installed? I'd be surprised it's not in one of them... (My ia64 box is off right now so I can't check if I already have it, then find out what package...)

Otherwise you'd have to go crossdev and build one...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
jharvell
n00b
n00b


Joined: 16 May 2006
Posts: 16

PostPosted: Thu Nov 19, 2009 7:17 pm    Post subject: Reply with quote

emerge -s emul-linux-x86 shows the following installed:

app-emulation/emul-linux-x86-baselibs
app-emulation/emul-linux-x86-compat
app-emulation/emul-linux-x86-gtklibs
app-emulation/emul-linux-x86-medialibs
app-emulation/emul-linux-x86-qtlibs
app-emulation/emul-linux-x86-sdl
app-emulation/emul-linux-x86-soundlibs
app-emulation/emul-linux-x86-xlibs

The following two are masked and thus not installed:

app-emulation/emul-linux-x86-glibc-errno-compat
app-emulation/emul-linux-x86-java

I'll check out crossdev....thanks.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3731

PostPosted: Fri Nov 20, 2009 8:36 am    Post subject: Reply with quote

maybe you want to have a look to the multilib overlay, it allows you to build packages for 64bit or 32bit by setting an use flag, but i don´t know if it also covers the package you are looking for.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
jorgeinglessis
n00b
n00b


Joined: 04 Nov 2006
Posts: 52
Location: Merida, Venezuela

PostPosted: Sat Oct 29, 2011 12:43 pm    Post subject: Reply with quote

Hi there, I'm having the same problem, how did you solve it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum