Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wine and CounterStrike 1.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Sun Oct 23, 2011 9:57 am    Post subject: wine and CounterStrike 1.6 Reply with quote

Hello guys.

I've a little problem with wine and CounterStrike 1.6.
I've installed steam via wine and then I've installed CS 1.6 over Steam.
My problem is that I've an ATI Mobility Radeon HD 5650 Graphic card and
I found a few (definitely old) bug reports that CS 1.6 crashes randomly with this graphic card.
And this is my problem. The game runs fine but after 2-3 minutes the complete system crashes.
I have to shutdown the pc via hard reset after that occurs.
I have tried a lot like running the game on a virtual desktop and on a virtual Windows 98 emulation.
But nothing seems to work...
Also I tried to change the graphic card drivers from ati-drivers (11.9) to the open source drivers.
But after that no games were playable...

So anyone of you have an idea what I could do?

Thanks
Back to top
View user's profile Send private message
Mistwolf
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2007
Posts: 107
Location: Edmonton, AB

PostPosted: Mon Oct 24, 2011 5:17 am    Post subject: Reply with quote

Did you check the Wine bug?

http://bugs.winehq.org/show_bug.cgi?id=8025

It has some suggestions, but no real solution since nobody knows if it is a driver issue or a wine issue.
Back to top
View user's profile Send private message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Tue Oct 25, 2011 6:23 am    Post subject: Reply with quote

I think I found a solution to fix this bug. I have executed this lines:

Code:

aticonfig --sb=off
aticonfig --tls=off
aticonfig --sync-video=off


and added to winecfg the rule that hl.exe should be started on a windows 98 environment.
Actually I have no freezes for 5 hours playing.
But at least I have one more problem.
Sometimes the ping increases highly and I get disconnected from the server.
This comes definitely not from the server or my Internet connection because this occurs
when I run a second PC with CS 1.6 and on the same Internet connection as well and there is
the ping default.
I try to fix this with reducing the nice priority...
Back to top
View user's profile Send private message
MichelleJanson7
n00b
n00b


Joined: 23 Nov 2011
Posts: 1

PostPosted: Wed Nov 23, 2011 5:20 pm    Post subject: Reply with quote

Thank you for the help with this! I had the same question!

www.alittlebi tadrift.blogspot.com
_________________
Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum