Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
trouble emergin wxhaskell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
lum-X
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2011
Posts: 99
Location: Thessaloniki, Greece || Prishtina Kosovo

PostPosted: Thu Oct 20, 2011 9:51 pm    Post subject: trouble emergin wxhaskell Reply with quote

i have this problem and i have to go and read soon the guide how te read emerge logs and try to fix these by my self.

by the way i followed this guide to instal haskell

http://www.haskell.org/haskellwiki/Gentoo/HaskellPlatform

Code:
lumx lumx # emerge -vpt wxhaskell

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N    ~] dev-haskell/wxhaskell-0.12.1.6  USE="-doc -profile" 46 kB
[ebuild  N    ~]  dev-haskell/wxcore-0.12.1.6  USE="-doc -profile" 541 kB
[ebuild  N     ]   x11-libs/wxGTK-2.8.11.0  USE="X gnome gstreamer opengl sdl tiff -debug -doc -odbc -pch" 29,888 kB
[ebuild  N     ]    gnome-base/libgnomeprintui-2.18.6  USE="-doc" 666 kB
[ebuild  N     ]     gnome-base/libgnomeprint-2.18.8  USE="cups -doc" 0 kB
[ebuild  N     ]      net-print/libgnomecups-0.2.3-r1  USE="-debug" 0 kB
[ebuild  N     ]    app-admin/eselect-wxwidgets-1.4  0 kB
[ebuild  N    ~]   dev-haskell/wxdirect-0.12.1.3  USE="-doc -profile" 0 kB

Total: 8 packages (8 new), Size of downloads: 31,138 kB

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

lumx lumx # emerge wxhaskell

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 8) dev-haskell/wxdirect-0.12.1.3
 * wxdirect-0.12.1.3.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                  [ ok ]
>>> Unpacking source...
>>> Unpacking wxdirect-0.12.1.3.tar.gz to /var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work
>>> Source unpacked in /var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work
>>> Compiling source in /var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work/wxdirect-0.12.1.3 ...
 * Using cabal-1.10.2.0.
[1 of 1] Compiling Main             ( /var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work/wxdirect-0.12.1.3/Setup.hs, /var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work/wxdirect-0.12.1.3/Setup.o )
Linking setup ...
Configuring wxdirect-0.12.1.3...
setup: At least the following dependencies are missing:
time >=1.0 && <1.2
 * ERROR: dev-haskell/wxdirect-0.12.1.3 failed (compile phase):
 *   setup configure failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3050:  Called haskell-cabal_src_compile
 *   environment, line 2377:  Called cabal_src_compile
 *   environment, line  701:  Called haskell-cabal_src_configure
 *   environment, line 2385:  Called cabal-configure
 *   environment, line  597:  Called die
 * The specific snippet of code:
 *       ./setup configure --ghc --prefix="${EPREFIX}"/usr --with-compiler="$(ghc-getghc)" --with-hc-pkg="$(ghc-getghcpkg)" --prefix="${EPREFIX}"/usr --libdir="${EPREFIX}"/usr/$(get_libdir) --libsubdir=${P}/ghc-$(ghc-version) --datadir="${EPREFIX}"/usr/share/ --datasubdir=${P}/ghc-$(ghc-version) ${cabalconf} ${CABAL_CONFIGURE_FLAGS} ${CABAL_EXTRA_CONFIGURE_FLAGS} "$@" || die "setup configure failed"
 *
 * If you need support, post the output of 'emerge --info =dev-haskell/wxdirect-0.12.1.3',
 * the complete build log and the output of 'emerge -pqv =dev-haskell/wxdirect-0.12.1.3'.
 * The complete build log is located at '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/temp/environment'.
 * S: '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work/wxdirect-0.12.1.3'

>>> Failed to emerge dev-haskell/wxdirect-0.12.1.3, Log file:

>>>  '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/temp/build.log'

 * Messages for package dev-haskell/wxdirect-0.12.1.3:

 * ERROR: dev-haskell/wxdirect-0.12.1.3 failed (compile phase):
 *   setup configure failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3050:  Called haskell-cabal_src_compile
 *   environment, line 2377:  Called cabal_src_compile
 *   environment, line  701:  Called haskell-cabal_src_configure
 *   environment, line 2385:  Called cabal-configure
 *   environment, line  597:  Called die
 * The specific snippet of code:
 *       ./setup configure --ghc --prefix="${EPREFIX}"/usr --with-compiler="$(ghc-getghc)" --with-hc-pkg="$(ghc-getghcpkg)" --prefix="${EPREFIX}"/usr --libdir="${EPREFIX}"/usr/$(get_libdir) --libsubdir=${P}/ghc-$(ghc-version) --datadir="${EPREFIX}"/usr/share/ --datasubdir=${P}/ghc-$(ghc-version) ${cabalconf} ${CABAL_CONFIGURE_FLAGS} ${CABAL_EXTRA_CONFIGURE_FLAGS} "$@" || die "setup configure failed"
 *
 * If you need support, post the output of 'emerge --info =dev-haskell/wxdirect-0.12.1.3',
 * the complete build log and the output of 'emerge -pqv =dev-haskell/wxdirect-0.12.1.3'.
 * The complete build log is located at '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/temp/environment'.
 * S: '/var/tmp/portage/dev-haskell/wxdirect-0.12.1.3/work/wxdirect-0.12.1.3'

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

lumx lumx #
Back to top
View user's profile Send private message
mahdi1234
Guru
Guru


Joined: 19 Feb 2005
Posts: 496
Location: far from new world orderia

PostPosted: Thu Oct 20, 2011 10:20 pm    Post subject: Re: trouble emergin wxhaskell Reply with quote

lum-X wrote:
Code:
Configuring wxdirect-0.12.1.3...
setup: At least the following dependencies are missing:
time >=1.0 && <1.2
 * ERROR: dev-haskell/wxdirect-0.12.1.3 failed (compile phase):
 *   setup configure failed
 *

Looks like issue with dev-haskell/time what is your version, does it fit the condition of higher or equal of 1.0 and lower than 1.2 ?
Back to top
View user's profile Send private message
lum-X
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2011
Posts: 99
Location: Thessaloniki, Greece || Prishtina Kosovo

PostPosted: Thu Oct 20, 2011 10:28 pm    Post subject: Reply with quote

Code:
lumx lumx # emerge -vp time

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] dev-haskell/time-1.2.0.3  USE="-doc -hscolour -profile" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


nope i will mask and will give it a try now :D
learned another thing tonight 8)

EDIT

this is my portage.mask and the last 2 lines are about dev-haskell/time
Code:

  GNU nano 2.2.5                                         File: /etc/portage/package.mask                                                                                         

>x11-drivers/nvidia-drivers-270.41.19


#required by gnome-base/gnome-2.32.1, required by @selected, required by @world (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (29 Jul 2011)
# GNOME 3.0 mask for upgrade packages, don't add new packages to this list
# unless they pull in one of the masked packages
# The "Better late than never!" release
#
# Libraries
# Core Applications
# Extra Applications
#>=www-client/epiphany-3.0.4

#haskell mask
=dev-lang/ghc-6.12.3
=app-admin/haskell-updater-1.1.3.0
=dev-haskell/stm-2.1.2.2
=dev-haskell/haddock-2.6.1

<dev-haskell/time-1.2.0.0
>=dev-haskell/time-1.0.0.0


and this is what i get now but i will try to recompile Haskell-platrofm again to see if it will fix

Code:
lumx lumx # emerge -vp time

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   #] dev-haskell/time-1.2.0.3  USE="-doc -hscolour -profile" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

The following mask changes are necessary to proceed:
#required by time (argument)
# /etc/portage/package.mask:
>=dev-haskell/time-1.2.0.3

NOTE: This --autounmask behavior can be disabled by setting
      EMERGE_DEFAULT_OPTS="--autounmask=n" in make.conf.

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

lumx lumx # emerge  time

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild   R   #] dev-haskell/time-1.2.0.3

The following mask changes are necessary to proceed:
#required by time (argument)
# /etc/portage/package.mask:
>=dev-haskell/time-1.2.0.3

NOTE: This --autounmask behavior can be disabled by setting
      EMERGE_DEFAULT_OPTS="--autounmask=n" in make.conf.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
lum-X
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2011
Posts: 99
Location: Thessaloniki, Greece || Prishtina Kosovo

PostPosted: Thu Oct 20, 2011 10:53 pm    Post subject: Reply with quote

sorry for double posting but this is the package.accept_keywords

Code:
#required by skype (argument)
>=net-im/skype-2.2.0.35-r1 ~amd64

#required by nero (argument)
>=app-cdr/nero-4.0.0.0-r1 ~amd64

#>www-client/firefox-3.6.22
>=www-client/firefox-7.0.1-r1

#required by www-client/firefox-6.0, required by firefox (argument)
>=dev-libs/nss-3.12.10 ~amd64

#required by www-client/firefox-6.0, required by firefox (argument)
>=dev-libs/nspr-4.8.8 ~amd64

#required by codeblocks (argument)
=dev-util/codeblocks-10.05 ~amd64


#flash test 11.xx
>www-plugins/adobe-flash-10.3.183.10

#required by driftnet (argument)
>=net-analyzer/driftnet-0.1.6_p20090401 ~amd64

#required by mysql-workbench (argument)
>=dev-db/mysql-workbench-5.2.34 ~amd64

#required by dev-db/mysql-workbench-5.2.34, required by mysql-workbench (argument)
>=dev-cpp/ctemplate-1.0 ~amd64

#required by gnome-extra/nautilus-dropbox-0.6.9, required by nautilus-dropbox (argument)
>=net-misc/dropbox-1.2.24 ~amd64

#required by nautilus-dropbox (argument)
>=gnome-extra/nautilus-dropbox-0.6.9 ~amd64


#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/glut-2.1.1.2 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/happy-1.18.6 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
=dev-haskell/regex-posix-0.72.0.3 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/cabal-install-0.10.2-r1 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/http-4000.1.1 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/fgl-5.4.2.3 ~amd64
#required by dev-haskell/cgi-3001.1.7.1, required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/cabal-1.10.2.0 ~amd64
#required by dev-haskell/cgi-3001.1.7.1, required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
=dev-lang/ghc-6.10.4-r1 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/parallel-1.1.0.1 ~amd64
#required by dev-lang/ghc-6.10.4-r1[-ghcbootstrap], required by dev-haskell/cgi-3001.1.7.1, required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
=app-admin/haskell-updater-0.9.1.0 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
=dev-haskell/regex-base-0.72.0.2 ~amd64
#required by haskell-platform (argument)
>=dev-haskell/haskell-platform-2009.2.0.2 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/quickcheck-1.2.0.0:1 ~amd64


#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
#>=dev-haskell/time-1.2.0.3 ~amd64
<dev-haskell/time-1.2.0.0 ~amd64
>=dev-haskell/time-1.1.2.0 ~amd64


#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/xhtml-3000.2.0.1 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/editline-0.2.1.0 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
>=dev-haskell/cgi-3001.1.7.1 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
=dev-haskell/haddock-2.4.2 ~amd64
#required by dev-haskell/haskell-platform-2009.2.0.2, required by haskell-platform (argument)
=dev-haskell/stm-2.1.1.2 ~amd64
#required by wxhaskell (argument)
>=dev-haskell/wxhaskell-0.12.1.6 ~amd64
#required by dev-haskell/wxcore-0.12.1.6, required by dev-haskell/wxhaskell-0.12.1.6, required by wxhaskell (argument)
>=dev-haskell/wxdirect-0.12.1.3 ~amd64
#required by dev-haskell/wxhaskell-0.12.1.6, required by wxhaskell (argument)
>=dev-haskell/wxcore-0.12.1.6 ~amd64



i just dont know what to do, i will be back tomorrow cause here its 2 AM and i woke up at 6AM today and now my head really hurts :S

i just unmerged dev-haskell/time and then i got this but i cant thing of how to make portage install a verson >1 and <1.2
Code:
umx lumx # emerge --depclean   

 * Depclean may break link level dependencies. Thus, it is
 * recommended to use a tool such as `revdep-rebuild` (from
 * app-portage/gentoolkit) in order to detect such breakage.
 *
 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=dev-haskell/time-1.1.2.4 pulled in by:
 *     dev-haskell/haskell-platform-2009.2.0.2
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
 *
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 *
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the portage tree, since it may
 * not be possible to satisfy their dependencies.

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


and as i can see i dont need a version above 1.2 according to this.

Code:
lumx lumx # equery depends  dev-haskell/time
 * These packages depend on dev-haskell/time:
dev-haskell/cabal-install-0.10.2-r1 (>=dev-haskell/time-1.1)
dev-haskell/haskell-platform-2009.2.0.2 (>=dev-haskell/time-1.1.2.4)


i have no idea what to do more to fix this for tonight

goodnight to all you up there
Back to top
View user's profile Send private message
mahdi1234
Guru
Guru


Joined: 19 Feb 2005
Posts: 496
Location: far from new world orderia

PostPosted: Fri Oct 21, 2011 8:47 am    Post subject: Reply with quote

Since dev-haskell/haskell-platform-2009.2.0.2 requires >=dev-haskell/time-1.1.2.4 you shall put into package.keywords exactly this version and remove others from mask. At least you will see what happens, I guess it currently pulls 1.2.0.3 since it's highest ~ version in the portage and that's the way portage works.
Back to top
View user's profile Send private message
archenroot
n00b
n00b


Joined: 13 Dec 2011
Posts: 32

PostPosted: Thu Jan 10, 2013 1:56 pm    Post subject: layman -> dev-vcs/darcs-2.8.0 > random > time Reply with quote

This is quite interesting, layman package is standard package in default gentoo tree. After last world update I was not able to update whole system due to dependency of layman on hard masked package:
layman -> dev-vcs/darcs-2.8.0 > random > time

Should I report bug, or what am I doing wrong?

Ladislav
_________________
Emperor wants to control outer space Yoda wants to explore inner space that's the fundamental difference between good and bad sides of the Force
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum