Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-office/libreoffice compilation error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Thu Sep 29, 2011 4:04 pm    Post subject: app-office/libreoffice compilation error Reply with quote

Can anyone using ~arch reproduce this?
Code:
Entering /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper

Compiling: sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
Compiling: sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
Compiling: sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
In file included from /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:32:0:
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx:198:34: error: 'Link' has not been declared
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx: In function 'void pdfi::writeJpeg_(OutputBuffer&, Stream*, bool)':
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:153:13: error: 'DCTStream' was not declared in this scope
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:153:24: error: expected primary-expression before ')' token
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:153:25: error: expected ')' before 'str'
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx: At global scope:
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:492:29: error: variable or field 'processLink' declared void
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:492:29: error: 'Link' was not declared in this scope
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:492:48: error: expected primary-expression before '*' token
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:492:49: error: expected primary-expression before ')' token
/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:929:1: error: expected '}' at end of input
/usr/include/poppler/UTF8.h:59:12: warning: 'int mapUCS2(Unicode, char*, int)' defined but not used
dmake:  Error code 1, while making '../../../unxlngx6.pro/obj/pdfioutdev_gpl.obj'


USE flags:
Code:
[ebuild   R    ] app-office/libreoffice-3.4.3.2-r1  USE="branding dbus gstreamer java kde ldap nsplugin opengl templates (-aqua) -bash-completion -binfilter -custom-cflags -debug -eds -gnome -graphite -gtk (-kdeenablefinal) -mysql -odk -python -test -vba -webdav" LINGUAS="-de -en_GB -en_ZA -es -fr -hu -it" 0 kB
Back to top
View user's profile Send private message
djhyland
n00b
n00b


Joined: 26 Nov 2008
Posts: 43
Location: St. Paul MN

PostPosted: Fri Sep 30, 2011 8:54 am    Post subject: Reply with quote

Code:
------------------------------
Entering /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/scripting/util

Compiling: scripting/unxlngx6.pro/misc/scriptframe_version.c
: &&     LD_LIBRARY_PATH=/var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/solver/340/unxlngx6.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}} xsltproc --nonet --stringparam uri \
        'vnd.sun.star.expand:$OOO_BASE_DIR/program/libscriptframe.so' -o ../unxlngx6.pro/misc/scriptframe.component \
        /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/solenv/bin/createcomponent.xslt scriptframe.component
Making:    scriptframe.lib
Making:    libscriptframe.so
scripting deliver
deliver -- version: 275594
Module 'scripting' delivered successfully. 35 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/source/pdfimport/xpdfwrapper

 it seems that the error is inside 'sdext', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

rm -Rf /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/sdext/unxlngx6.pro # optional module 'clean'
/bin/sh
cd /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2
source ./LinuxX86-64Env.Set.sh
cd sdext
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
make: *** [all] Error 1


It looks as if my build is failing in the same place. I'm rebuilding my libreoffice as part of a revdep-rebuild, which is pulling in the packages app-text/xpdf-3.02-r4 and gnome-base/libgnomeprintui-2.18.6. I don't know if libgnomeprintui is part of the same issue as libreoffice and xpdf since it's broken dependency is different, but all three are failing to build. For libreoffice and xpdf, the issue seems to be with poppler:

Code:
 
 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 26% ]  *   broken /usr/bin/xpdf (requires libpoppler.so.13)
[ 67% ]  *   broken /usr/lib64/libgnomeprintui-2-2.la (requires -lpng14)
[ 73% ]  *   broken /usr/lib64/libreoffice/share/extensions/pdfimport/xpdfimport (requires libpoppler.so.13)
[ 100% ]     
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/xpdf -> app-text/xpdf
 *   /usr/lib64/libgnomeprintui-2-2.la -> gnome-base/libgnomeprintui
 *   /usr/lib64/libreoffice/share/extensions/pdfimport/xpdfimport -> app-office/libreoffice
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot   app-office/libreoffice:0 app-text/xpdf:0 gnome-base/libgnomeprintui:2.2
..........
Calculating dependencies... done!


I'll see what I can do to fix the problem in the morning. (My daughter's finally agreed to go back to bed, so I will too!)
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5535
Location: ~Brussels - Belgique

PostPosted: Fri Sep 30, 2011 1:10 pm    Post subject: Reply with quote

Hello,

I have the same problem.

app-text/poppler-0.18.0 seems to break many things that depend on it, including libreoffice.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Fri Sep 30, 2011 5:55 pm    Post subject: Reply with quote

OK, thanks. I've filed a bug report :wink:
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5535
Location: ~Brussels - Belgique

PostPosted: Fri Sep 30, 2011 6:05 pm    Post subject: Reply with quote

Hello,

The bug is already fixed, please sync.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 758
Location: Stuttgart, Germany

PostPosted: Sat Oct 01, 2011 10:45 am    Post subject: Reply with quote

I just re-synced, and I don't see a new version of poppler in the tree. Should I just wait a bit?

*fidget fidget*

Thanks,

EE
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5535
Location: ~Brussels - Belgique

PostPosted: Sat Oct 01, 2011 3:41 pm    Post subject: Reply with quote

No, there is only new patches for libreoffice, giimp and other packages, so that they can compile with any version of poppler
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 758
Location: Stuttgart, Germany

PostPosted: Sat Oct 01, 2011 4:33 pm    Post subject: Reply with quote

for all new packages? Because luatex fails against the new poppler, and there's no patched ebuild for it just yet. According to revdep-rebuild, the following packages on my system are linked against poppler:

Code:
[ebuild   R    ] dev-tex/luatex-0.70.1
[ebuild   R    ] app-text/evince-2.32.0-r3
[ebuild   R    ] media-gfx/gimp-2.6.11-r5
[ebuild   R    ] app-office/libreoffice-3.4.3.2-r1
[ebuild   R    ] app-text/texlive-core-2011-r4
I just synced, and I don't see new versions for any of them. Should I file bug reports?

Cheers,

EE
Back to top
View user's profile Send private message
ihadzic
n00b
n00b


Joined: 02 Oct 2011
Posts: 1

PostPosted: Sun Oct 02, 2011 12:44 am    Post subject: Reply with quote

I also have a problem with xpdf and poppler. it won't compile with poppler 0.18.0.
According to revdep-rebuild, it wants libpoppler.so.13 rather than .18.

I have just tried to emerge -sync and it still doesn't work. the xpdf version
is 3.02-r4.
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 758
Location: Stuttgart, Germany

PostPosted: Sun Oct 02, 2011 9:24 am    Post subject: Reply with quote

okay, apparently luatex has a patch on its bug report against poppler 0.18.0 which has to be applied to an overlay, and the other ebuilds (including libreoffice) recompiled fine. So I'm good here. I wish some ebuilds with a lot of dependencies (libpng comes to mind, since the same thing happened with it recently) would break functionality a bit more cautiously, but I suppose that's what I get for using ~arch.

Cheers,

EE
Back to top
View user's profile Send private message
rickythesk8r
n00b
n00b


Joined: 10 Aug 2003
Posts: 62

PostPosted: Sun Oct 02, 2011 11:47 am    Post subject: Reply with quote

ExecutorElassus wrote:
<snip>

I suppose that's what I get for using ~arch.



I still haven't learned my lesson. When I see "poppler" in my dependency list, I just cringe. But, two days ago, I charged ahead anyway and have paid the price.
_________________
I never met a closure I didn't like.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5535
Location: ~Brussels - Belgique

PostPosted: Mon Oct 03, 2011 9:02 am    Post subject: Reply with quote

Since the problem is a compilation problem, there are no new revision of ebuilds, just some more patches that are applied during the compilation.

In my case, Gimp and libreoffice are OK with poppler-0.18.0
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum