Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz funziona solo con utente root
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
angOS
n00b
n00b


Joined: 17 Aug 2011
Posts: 2

PostPosted: Wed Aug 17, 2011 4:49 pm    Post subject: Compiz funziona solo con utente root Reply with quote

Ciao a tutti in questi giorni sto sbattendo la testa su un problema che trovo alquanto "insolito"...

ho installato Gentoo come guest su virtualbox senza problemi, ho installato LXDE e anche fin qui nessun problema funziona tutto alla perfezione, l'altro giorno ho provato ad aggiungere compiz

ho seguito la guida che ho trovato nella documentazione e dando il comando "emerge -av compiz-fusion" non ci sono state noie.

ora arriva la parte interessante: se faccio il login come root direttamente da lxdm mi trovo compiz ed emerald perfettamente funzionanti, se invece entro come utente normale compiz non funziona, emerald idem e non funziona l'input da tastiera...

la cosa strana è che sia root che l'utente normale hanno la sessione di lxde configurata nello stesso modo quindi non capisco proprio perchè in uno funzioni tutto e nell'altro no...

qualcuno ha qualche idea a riguardo? :mrgreen:
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Thu Aug 18, 2011 7:18 am    Post subject: Reply with quote

in che "gruppi" si trovano i due utenti? (root e quello normale)

per saperlo digita il comando "groups" da entrambi gli utenti.
posta qui il risultato.

già che ci sei, posta anche "/etc/group"
_________________
Darkman
Back to top
View user's profile Send private message
angOS
n00b
n00b


Joined: 17 Aug 2011
Posts: 2

PostPosted: Thu Aug 18, 2011 8:17 am    Post subject: Reply with quote

dunque i gruppi sono i seguenti:

per utente root = root bin daemon sys adm disk wheel floppy tape video

per utente io = wheel audio usb cdrom video io

e questo è il risultato di: cat /etc/group

root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon
tty:x:5:
disk:x:6:root,adm
lp:x:7:lp
mem:x:8:
kmem:x:9:
wheel:x:10:root,io
floppy:x:11:root
news:x:13:news
uucp:x:14:uucp
console:x:17:
audio:x:18:io
cdrom:x:19:io
tape:x:26:root
video:x:27:root,io
cdrw:x:80:
usb:x:85:io
users:x:100:
portage:x:250:portage
utmp:x:406:
nogroup:x:65533:
nobody:x:65534:
man:x:15:
sshd:x:22:
cron:x:16:
mail:x:12:
postmaster:x:249:
ssmtp:x:248:
locate:x:247:
ldap:x:439:
messagebus:x:246:
lpadmin:x:106:
vboxguest:x:105:
io:x:1000:

probabile che non funzioni per via di qualche permesso in meno?
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 777
Location: san leonardo del friuli

PostPosted: Thu Aug 25, 2011 7:44 pm    Post subject: Reply with quote

dai un compiz --replace da terminale dopo aver fatto il login col tuo utente
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum